
ON-AIR Designer
User Guide

Version: 6.6.0/2

To obtain the latest documentation and software downloads, please visit:

Edition: Tuesday, March 9, 2021

www.lawo.com/lawo-downloads

https://www.lawo.com/lawo-downloads/


Copyright

All rights reserved. Permission to reprint or electronically reproduce any document or graphic in whole
or in part for any reason is expressly prohibited, unless prior written consent is obtained from the Lawo

AG.

All trademarks and registered trademarks belong to their respective owners. It cannot be guaranteed that
all product names, products, trademarks, requisitions, regulations, guidelines, specifications and norms

are free from trade mark rights of third parties.

All entries in this document have been thoroughly checked; however no guarantee for correctness can
be given. Lawo AG cannot be held responsible for any misleading or incorrect information provided

throughout this manual.

Lawo AG reserves the right to change specifications at any time without notice.

© Lawo AG, 2021



3/95

Table of Contents

ON-AIR Designer User Guide Version: 6.6.0/2

Table of Contents

1. Introduction ......................................................................................................................................... 4

2. Product Overview ................................................................................................................................ 5

3. Installation & Setup .............................................................................................................................. 7

4. Basic Operations ............................................................................................................................... 12

5. Configuring a Single Unit .................................................................................................................... 38

6. Transferring Configuration Data .......................................................................................................... 71

7. Configuring Multiple Units ................................................................................................................... 78

8. Using the Device Configuration Wizard ............................................................................................... 88

9. Appendices ....................................................................................................................................... 94



ON-AIR Designer User GuideVersion: 6.6.0/24/95

1. Introduction

1.     Introduction

Welcome to the ON-AIR Designer.

About this Manual

This document describes how to install and use the ON-AIR Designer. 

It provides a general guide to the operation of the software, with screenshots taken from different products. You
can find more information about specific configuration options in your product manual.

Look out for the following which indicate:

Notes - points of clarification.

Tips - useful tips and short cuts.

Attention - alert you when an action should always be observed.

Lawo User Registration

For access to the Downloads area and to receive regular product updates, please register at:

www.lawo.com/registration.

http://www.lawo.com/registration/
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2. Product Overview

2.     Product Overview

The ON-AIR Designer is Lawo's software application for configuring radio on-air systems. The configuration
defines key aspects of the system such as the audio mix engine, routing matrix and so on. In each case, the
available resources vary depending on the product and its license. Resources defined by the configuration
include:

· Inputs and Outputs can be named to clearly identify connections to external equipment.

· Sources can be named and defined for mono, stereo, 5.1 or 5.1/2ch operation. Special sources can be
created for DAW control (via the Mackie-HUI™ protocol) and VCA grouping.

· Summing Buses can be named and defined for mono, stereo or 5.1 operation.

· Signal Processing can be applied to sources and/or summing buses. Options include EQ, Dynamics,
Limiter, Delay, De-essing and Automix.

· Control Surface Layout – the configuration defines which sources can be assigned to fader strips, and
whether the console supports a second layer and virtual fader mappings.

· MF Key Functions – the configuration defines the function and color-coding of all MF Keys (on the
control surface, VisTool and any external key panels).

· External Control Functions – the configuration defines how the system responds to external control
functions such as GPI signals and radio automation systems (RAS).

· Conditional Functions can be programmed using logic elements such as OR, AND, NOT, etc.

· Other Functions include customized routing, mixing, metering and networking.

Where is the Configuration Data Stored?

During editing, each project is stored on your computer as a .db3 file. Whenever you transfer a project to the
DSP Core, the .db3 datatbase is first compiled to create a binary .cfg file that can be read by the system. It is
this file which is read by the DSP Core in order to load the configuration. The binary version is non-editable and
cannot be opened by the ON-AIR Designer. Therefore, it is recommended to maintain the .db3 file on your PC
to allow for changes and additions.

Power Core and sapphire/Nova17 allow you to store an editable version of the configuration on the device itself.
All other products store the binary version only.

Once the transfer is complete, the DSP Core will cold start. At the end of the boot-up, the system reads the new
configuration data.

Modifying the Configuration

The simplest way to customize a system is to modify the existing configuration or a standard template. To do this,
you will need a copy of the latest configuration or template as a .db3 file. You can then use the ON-AIR Designer
software to open, edit and save the file; and transfer the modified configuration back to the system.

If you plan to use VisTool with your device, then it is a good idea to edit the VisTool and ON-AIR Designer
configurations in parallel. Please refer to the separate "VisTool MK2 User Guide" for more details on editing
a VisTool project.

Configuring Multiple Systems

Using local and/or global substitutions, it is possible to apply the same configuration parameters to multiple
systems. This makes it easy to maintain the configuration for a large installation as, if something changes, the
change need only be applied once.
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Backwards Compatibility

Configurations designed using the previous configuration tool "zirkon.exe" are compatible with the ON-AIR
Designer, and can be used without restrictions. Hence, the ON-AIR Designer supports two project file types:

· .db3 - is the new file type supported by systems running Version 6.0.0.x or later.

· .mdb - is the previous file type used by "zirkon.exe", and is required for systems < Version 6.0.0.x.

.db3 is recommended, as .mdb files do NOT support substitutions and are slower when loading and saving data. 

If you open a .mdb file, then it will be automatically updated so it can be stored using the new .db3 file format.

Please note that the modification of a configuration for the product Zirkon is no longer supported (as of
Version 6.0.0.x).
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3. Installation & Setup

3.     Installation & Setup

This chapter describes how to install the software and connect the configuration PC to the Lawo system.

Topics include:

· PC Requirements

· Installing the Software

· Uninstall & Updates

· Connecting Your PC to the Lawo Control System
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3. Installation & Setup

3.1 PC Requirements

To install and run the ON-AIR Designer, your PC must meet the following requirements:

· Windows 7, 8 or 10 operating system. Note that Windows 10 LTSB (Long Term Servicing Branch) for
Enterprise installations is not supported.

· Core-I5 (or higher) CPU

· 2GB RAM, minimum

If you are planning to install VisTool MK2 on the same machine, then please also refer to the VisTool MK2
requirements (included in the "VisTool MK2 User Guide").
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3.2 Installing the Software

The latest version of the onair-designer.exe installer is available from the Downloads area at www.lawo.com
(after Login).

1. Copy the installer onto your PC.

2. Double click on the installer icon to start the ‘ON-AIR Designer Setup Wizard’:

3. Follow the Wizard's instructions accepting the default options provided.

4. When you reach the 'Summary' window, check the options and click Install - the software is installed
onto your computer; this may take a few minutes.

By default, files are installed in the location: ‘C:\Program Files\OnAirDesigner’.

5. When the installation is complete, the following window will appear:

It is recommended to leave the default "Run" options selected and click on Finish. You can now use SoP
Explorer to check the firmware revisions of the system, and ON-AIR Designer to transfer a configuration.

If you have any problems with the software installation, please contact your local Lawo representative or email
support@lawo.com.

http://www.lawo.com
mailto:support@lawo.com
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3.3 Uninstall & Updates

ON-AIR Designer can be uninstalled in the usual Windows manner: from the "Uninstall or change a program"
Control Panel, select ON-AIR Designer and click Uninstall.

You can update ON-AIR Designer to a new software version by following the normal installation procedure
described above. There is no need to remove an older version of the application.

To ensure proper functionality, it is mandatory that the software version of the system matches the software
version of the configuration tool. Otherwise the configuration may contain options which are not supported by the
Lawo system (and functionality may be ignored). To make sure everything runs smoothly, first run the installer
(to update ON-AIR Designer) and then use SoP Explorer to check and update the firmware running on the
hardware components.

Once both the system and ON-AIR Designer are running the same release, you can open (and convert) the
configuration project to take advantage of any new options and features.

When you open a project created using an earlier definition, you can choose whether to convert the project
or not. This allows you to maintain configurations for systems running different versions. See Converting
Projects.
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3. Installation & Setup

3.4 Connecting & Configuring the PC

To configure a Lawo device, the PC must have a valid network connection to the device's control system.

1. Start by connecting the PC's LAN port directly to the device's control port (the exact labeling will vary).

For simplicity, it is best to use a direct connection. This can be modified later to connect via a network. Please
refer to your product manual for cabling and network requirements.

2. Configure the network settings for the PC's LAN port as follows. The exact steps vary depending on your
OS version.

The IP Address must be unique, and set within the same range as that of the device's control port. The Subnet
Masks should be identical. 

The default settings for Lawo radio devices are: 

· IP Address = 192.168.101.240

· Subnet Mask = 255.255.255.0

· Gateway = 0.0.0.0

Test the connection by opening a web browser application and typing in the default IP address =
192.168.101.240. If the connection is successful, then the Web UI home page will appear.

If there is a problem opening the page, then first check your web browser. Then check the network cabling and
IP settings of the configuration PC and Lawo device.

If you are connecting via a larger network, you may need to consult your network administrator to gain access to
the Lawo device.
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4. Basic Operations

4.     Basic Operations

This chapter describes the basic operating principles of the software.

Topics include:

· Starting the Application

· File -> New

· File -> Open

· Saving the Project

· The Main Operating Windows

· Arranging the Workspace

· The Main Menus

· Toolbar

· ‘Project’ Window

· Checking the Network Communication

· Options

· Closing the Project & Software
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4. Basic Operations

4.1 Starting the Application

1. Select ON-AIR Designer from the Windows START menu - the application opens with a blank operating
window.

At the top of the page you will find the main menus and toolbar. 

To start working with the software, you can either create a new project or open an existing one.

Multiple projects can be open at the same time.



ON-AIR Designer User GuideVersion: 6.6.0/214/95

4. Basic Operations

4.2 File -> New

To create a new project:

1. Select File -> New from the top menu bar, or click on the  Toolbar icon, or use the keyboard shortcut
(CTRL + N) - the 'New Project Wizard' opens.

2. Select a product and click on Next.

For ruby/Power Core and sapphire/Nova17, skip straight to step 3. 

For crystal, Nova29 and sapphire compact, you have the opportunity to select a template.

crystal - Templates choice

· Choose one of the templates to open a standard configuration (recommended).

· Or, choose option 0 – Frame Selection to configure the "frames" manually (as described in step 3).

Usually it is best to choose a template, as this will automatically configure some of the main system elements:
inputs, outputs, sources and summing buses. If you choose option 0, then all elements must be programed from
scratch.

Note that the Nova29 supports only two templates:

· 1 - nova29, no default names - defines a simple configuration with MADI ports 1 to 16 set for 64-slot
transmission and no redundancy. Sync options are set for internal sync and 48kHz operation.

· 2 - nova29, with default names - as above but with default names for the MADI inputs and outputs.
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4. Basic Operations

3. If you selected option 0, or are configuring a ruby/Power Core or sapphire/Nova17, then the 'Frame'
options must be defined manually.

ruby - Frame selection

The four 'Frame' areas define the System Core, Surface, Panels and Screen functions.

For the System Core, the options are product specific. For ruby, Power Core is available in a choice of
licensed packages; please select the license which has been purchased. For sapphire/Nova17, you can choose
either the 3RU or 6RU DALLIS frame; please select the correct frame size. For crystal and sapphire compact,
there is only one option available: the Compact Engine.

For the Surface, select the maximum control surface size required. Where applicable, the numbers in brackets
indicate the number of Fader Modules + Central Modules (full mode) + Central Modules (monitor mode). For
example, the ruby 16 Fader (4+1) option can be used for a 4-, 8-, 12- or 16-fader surface with a single Central
Module. If more faders are fitted, or you have more than one Central Module, then a larger Surface option must
be used.

Under Panels, select the maximum number of key panels connected to the system.

The Screen option is always set to Screen functions to support VisTool functions.

The specification can be changed later (via Frame -> Change Frame). For example, if you upgrade the
license for ruby/Power Core, you can change the System Core frame to unlock the additional resources.
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4. Once you have selected a template or specified the 'Frame' , click on Finish. 

The software creates the new project. Depending on the product and its specification, a number of windows will
open. In our example, we can see the 'Project' window (on the left), plus the 'System Core' (in the central working
area).

ruby New Project

It may take a few seconds to build the new project. During this time the status is shown in the "progress" bar
(below Console in the 'Project' window).

The next logical step is to define the properties in the 'Project' window.
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4. Basic Operations

4.3 File -> Open

To open an existing project stored on your computer:

1. Select File -> Open from the top menu bar, or click on the  Toolbar icon, or use the keyboard
shortcut (CTRL + O).

2. Select your project file and click on Open.

If you cannot see the file, check the Files of type option at the bottom of the dialog box; you may need to
change this to see the correct file type (.db3 or .mdb).

The project opens, with the same workspace layout and docking options as at the last file save.

If the configuration was created using a different definition version, then you may be asked if you wish to convert
the project. Note that it may take a few seconds to open the project. During this time the status is shown in the
"progress" bar (below Console in the 'Project' window).

If you see an error stating that the project is already open then navigate to the project folder (using Windows
Explorer) and delete any "projectname.txt" files. Then try opening the project again.

On Power Core and Nova17, a copy of the project file is stored on the DSP Core. To download it to your
computer, use Load Project from unit.
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4.3.1 Converting Projects to the Current Release

When you save a configuration, the definition version of the ON-AIR Designer is stored along with the project in
the same folder (in a file named "projectname.def"). This means that when you open a project, the versions can
be compared.

If a project was created using an earlier definition, then you will be asked if you wish to convert the project:

Select Yes to proceed, or No to work with the older version. (You will need to choose No if the system you are
configuring is running an older version of software.)

If you select "don't show this message again" then, in future, this message will not appear, and projects will
automatically convert to the current ON-AIR Designer release. This will speed up all subsequent "File -> Open"
operations. You can re-activate the message later from the software options - use the Show convert message
checkbox (under the General tab):

By leaving the message enabled, you will be able to choose Yes to convert some projects and No for others (to
configure systems running a different software release).

Whenever a project is converted, the software creates a copy of the original file (before conversion) and
stores this in the project folder (using the suffix "_before_convert"). This allows you to re-open the original
project if necessary.
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4. Basic Operations

4.4 Saving the Project

At regular intervals you should save the project, and also use "save as" to keep a copy of the project at different
revision stages. This will allow you to test the configuration and revert to an earlier version if necessary. The
screenshots below are taken from Power Core, but the procedure is identical for all on-air systems.

Ø  File -> Save

Select File -> Save from the top menu bar, or click on the  Toolbar icon, or use the keyboard shortcut (CTRL
+ S).

This overwrites the existing project (as specified in the "File" field in ‘Project’ window).

Ø  File -> Save As

1. Select File -> Save As from the top menu bar, or use the keyboard shortcut (CTRL + SHIFT + S) - the
"Save" dialogue box opens.

2. Choose a new folder location, enter a different file name, or select a different file type (using the Files of
type option at the bottom of the dialog box).

3. Then click on Save to save the project:

The default file type is .db3 unless you specify otherwise. See Backwards Compatibility.

A project containing substitutions cannot be saved as a .mdb file.
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4. Basic Operations

4.5 Closing the Project & Software

1. To close the active project, select File -> Close from the top menu bar, or click on the  Toolbar icon.

2. To close the complete application (and all active projects), select File -> Exit from the top menu bar, or
click on the red cross (at the top right of the headline bar). 

In either case, if you have made a change since the last save, then you will be asked if you wish to save or
ignore the changes:

· Select Save to overwrite the current project.

· Select Ignore to close the project or software without saving.

· Select Cancel to cancel the operation and continue editing.
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4.6 The Main Operating Windows

To edit a project, you will need the following docking panels and windows.

 1   Project

The 'Project' window defines the main properties for the Lawo system such as its IP-Address. It can also be
used to add multiple units to the project (to work with substitutions).

 2   Frames

Each of the four 'Frame' windows defines a system component: the System Core, Control Surface, Key Panels
and Screen (for VisTool functions). In each case, you will see a graphical representation - in our example, of the
System Core. Double-click or right-click on the images to configure the relevant options - for example, to define
a connector's inputs and outputs, or add an expansion card.

 3   Tree Definition

From the 'Tree Definition' you can specify all the elements of the system, from sources and buses to MF Keys
and logical functions. The 'Tree Definition' gets its name from the tree-like structure on the left hand side. Each
of the branches can be opened by double-clicking on a branch name or on the arrows beside the branch. Once
open, you will see all the available parameters for the selected element - in our example, for a Source named
MIC 1. Right-click on a branch to insert a new element.

 4   Resources

The 'Resources' window can be used to check the amount of DSP resource used by the project. The counters
will vary depending on the System Core frame selection.

 5   Substitutions

If you are configuring more than one unit, use the 'Global' and 'Local' substitution windows to individualize
parameters as required. In the other configuration windows, a substituted parameter is indicated by a colored
frame and grey background.

 6   Function Pool (ruby only)

The 'Function Pool' can be used to move a function or prepare MF Keys before positioning them on a Central
Module. This is ideal if you know what functionality is required, but are not yet sure of the MF Key layout.
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Inputs & Outputs

In addition, the Inputs and Outputs windows can be used to view and edit IO parameters in list form.

Transfer Menu

Once editing is complete, the configuration data must be transferred from your computer to the Lawo system. 

Under the Transfer menu, you can choose to transfer the "Setup" data (the project properties) and/or the
"Config" data (the configuration itself).
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4.7 Arranging the Workspace

The workspace includes three docking areas (left, right and bottom) plus a central working area where
configuration windows can be either floating or stacked. Note that when you save a project, you will save the
current layout.

In the example below, the 'Project', 'Substitution' and 'Function Pool' panels are all docked (shown in blue), while
the 'Tree Definition', 'System Core' and 'Resources' windows are floating in the central workspace (shown in
red).

Ø  Click and drag on a boundary edge to increase or decrease the size of a space. In the example below the
height of the bottom docking area has been increased:
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4.7.1 Docking Panels

Each of the following panels can be docked, floating or hidden from view.

Toolbar icon Main Menu Docking Position

The 'Project' window Docks -> Project Left

'Function Pool' Frame -> Function Pool Right

'Jump to' none Docks -> Jump to.. Right

'Used in' none Docks -> Used in.. Right

'Parameter Line' none Docks -> Parameter Line Right

'Local Substitutions' Docks -> Local Substitutions Bottom

'Global Substitutions' Docks -> Global Substitutions Bottom

Where more than one panel can share the same space, the panels can be arranged in any order or combined to
create a stack. To change the current location or behaviour, click and drag on the panel's headline bar to release
it from the docking area, and then do one of the following.

Ø  To create a floating window, release the panel anywhere above the workspace. The panel becomes a floating
window which can be resized and positioned in the usual manner. If you lose a panel from view, click on the

 Toolbar icon to "Dock tools".

Ø  To dock the panel in a new position, release it into a permitted space. Not all panels can be docked in all
positions and so a blue background appears when a valid area is reached. When you release the panel, it will
fill the available space.

Ø  If a panel is released on top of an existing panel, then this creates a stack. In this instance, use the tabs at the
bottom of the area to select the options in the stack.

'Jump to' released on top of 'Used in' to create a stack 
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4.7.2 Tabbed View

Each of the remaining configuration windows appear in the central workspace. They can be opened and closed
using either a toolbar icon or main menu option. Note that the 'Tree Definition' can be opened multiple times (to
access different branches of the system). All open windows can be either stacked (in Tabbed View) or floating
(Tabbed View off).

Ø  Click on the  Toolbar icon, or select Window -> Tabbed View, to change the view.

In Tabbed View, all open windows are stacked. Use the tabs at the top of the workspace to switch between them
- the selected window fills the central workspace.

Central Workspace: Tabbed View

You can click and drag on the tabs themselves to change their order if you wish.
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If Tabbed View is not selected, then all open windows are floating. A floating window can be resized and
positioned anywhere in the central workspace.

Ø  Click and drag on the headline bar (at the top of the window) to move it.

Ø  Click and drag on the left, right or bottom boundary lines to resize.

Ø  Click on the buttons at the top right to minimise, maximize or close a window.

Central Workspace: Floating Windows

If you lose a floating window from view, then select Window -> Cascade or Window -> Tile to re-arrange the
view.
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4.8 The Main Menus

4.8.1 File

Use the File menu to:

· New - create a new project.

· Open - open an existing project.

· Close - close the active project.

· Recently opened Files - lists all the recently saved projects; click to open one.

· Load Project from unit - loads a project stored on the unit (ruby & sapphire only).

· Project History - shows the history of the project file:

o Database - the system definition version.

o Program - the ON-AIR Designer software version used to create the file.

o Changed - the date when the configuration file was last saved.

· Save and Save as - Save a configuration.

· Find - perform a search on the 'Tree Definition' window.

· Exit - quit the ON-AIR Designer software.

4.8.2 Edit

Use the Edit menu to:

· Add unit / Delete Unit - add or delete a unit from the project, see Configuring Multiple Units in a Project.
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4.8.3 View

Use the View menu to:

· Toolbar – show or hide the Toolbar.

· Statusbar – show or hide the status bar at the bottom of the ON-AIR Designer.

· Style – select a display style.

· Refresh – refresh the screen.

· Options – open the options dialogue box.

· Userlevel – select a user level to access different configuration options.

· Units – select a unit (if multiple units have been defined).

· Profile – select a profile (if profiles have been loaded from the Global project). If no Profiles exist, or a
Global project has not been specified, then there is nothing to select.

4.8.4 Frame

Use the Frame menu to:

· Show all Hardware - show or hide unused panels or surfaces for a better overview of the configured
hardware.

· Function Pool - show or hide the Function Pool (ruby only).

· Change Frame - change the frame specification.

· System Core - show or hide the DSP Core.

· Surface - show or hide the control surface modules.

· Panels - show or hide any optional key panels.

· Screen - show or hide any ‘virtual’ panels which will be operated via VisTool.
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4.8.5 Command

Use the Command menu to:

· Parameter – open the parameter window for the selected 'Frame' module (when viewing the Surface,
System Core, etc).

· Resources – open the 'Resources' window.

· Tree Definition – opens a ‘Tree Definition’ window.

· Sort Tree – when ticked, elements within the ‘Tree Definition’ window are sorted alphabetically.

· Find - perform a search on the 'Tree Definition' window.

· Inputs / Outputs – open the Inputs or Outputs list.

· Device Configuration Wizard - open the device configuration wizard.

4.8.6 Transfer

Use the Transfer menu to:

· Config to unit - transfer the active configuration to the unit.

· Setup to unit - transfer the ‘Setup’ parameters to the unit.

· Create Config – create the complied configuration files without performing a transfer.
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4.8.7 Window

Use the Window menu to:

· Dock Tools - reset any floating windows to their last known docking positions.

· Tabbed View - switch between Tabbed View and floating windows.

· Cascade / Tile - control the view when using floating windows.

· 1, 2, ... - all open windows are listed in the lower part of the menu. If a window has been minimized or
hidden, then click on its name to bring it back into view.

4.8.8 Docks

Use the Docks menu to show or hide the docking panels:

· Project

· Jump to..

· etc.

4.8.9 Help

Use the Help menu to select:

· Info - check the release version of the ON-AIR Designer.
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4.9 Toolbar

The toolbar icons provide fast access to a number of functions. If you cannot see the toolbar, then check that is
enabled in the View menu.

The first few icons perform file-based operations:

Exit - close the ON-AIR Designer software.

New - create a new configuration.

Open - open an existing configuration.

Save - save the current configuration to your PC.

Project - show/hide the 'Project' window.

Close - close the current configuration.

The next set of icons define the software's options and views:

Options - open the Options dialogue box.

Tabbed View - switch the view.

Dock Tools - reset all panels to their last known docking positions.

The next series of icons provide fast access to different aspects of the configuration:

System Core - show/hide the 'System Core' window.

Surface - show/hide the 'Surface' window.

Panels - show/hide the 'Panels' window.

Screen - show/hide the 'Screen' window.

Function Pool - show/hide the 'Function Pool' (ruby only).

Show all Hardware - show/hide any unused panels or surfaces for a better overview of the configured
hardware. 

Change Frame - open the 'change frame' window.

Tree Definition - open a new 'Tree Definition' window. If you click on the icon more than once, then
multiple windows will open.
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The remaining icons are:

Inputs - open the Inputs list.

Outputs - open the Outputs list.

User Level - select a user level to access different configuration options.

Device Configuration Wizard - open the device configuration wizard.

Local Substitutions - open the 'Local Substitutions' window.

Units - click to select a unit (if multiple units have been defined); all windows update to show the
parameter values for the selected unit.

Global Substitutions - open the 'Global Substitutions' window.

Profile - click to select a profile (if profiles have been loaded from the Global project). If no Profiles
exist, or a Global project has not been specified, then there is nothing to select.

Create config - click to create the complied configuration.

Config to Unit - click to transfer the active configuration to the unit.
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4.10 ‘Project’ Window

The 'Project' window defines the main properties for the system.  It can also be used to make an Online
connection to the Lawo system, and view the progress of operations such as load, save and transfer.

1. Click on the  Toolbar icon to show or hide the 'Project' window.

The window can be floating or docked. See Arranging the Workspace.

The 'Project' Window
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General Properties

If you have opened an existing configuration, then most of the properties should be complete. If you have
created a new configuration, then many of the fields will be empty.

If you are configuring more than one unit, then any substituted fields are indicated by a grey background.
These cannot be edited directly. Instead use the 'Substitution' windows to individualize the parameters.

'Project' Window - completed 'Project' Window - new

Each of the property fields should be completed as follows:

· Product - this line is completed automatically. It shows the product type (selected when the
configuration was created using File -> New).

· System Core - this line is completed automatically. It shows the DSP Core (selected when the
configuration was created using File -> New).

· File - this line is completed automatically when you save the project. It shows the file path where the
project is stored. Use File -> Save As to change the file name or location.

· Global project (optional) - click to define a Global project (to apply global settings such as metering
schemes).

· Profiles (optional) - this area lists any Profiles stored in the Global project. If no Profiles exist, or a
Global project has not been specified, then the area remains blank.

· Units - multiple units of the same product type can be added to a project. Right-click to Add or Delete a
unit; then use this field to switch between units. By default, all parameters apply equally to all units. If this
is not desirable, then you can individualize parameters using substitutions.
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· Name - enter a project title.

· Deskname - enter a desk name to identify the unit. This name is transferred to the Lawo system when
you use Transfer -> Setup to Unit.

· Author (optional) - enter the name of the configuration author.

· User - this line is completed automatically. It shows the registered user of the configuration PC (for
information purposes).

· PC IP-Address - this line is completed automatically. It shows the IP address of the configuration PC
(useful for avoiding IP conflicts).

· Template - this line is completed automatically. It shows the name of the template (selected when the
configuration was created using File -> New).

· Can speed - enter the CAN bus speed for the system. The default is 500K. This MUST match the CAN
bus speed stored on each control surface module or key panel.

· Coldstart - this line is completed automatically. It shows whether the system will perform a warm start or
cold start after a transfer of configuration data. For crystal, ruby, sapphire compact and
sapphire/Nova17, the option is ticked (i.e. the system will cold start); for Nova29, the option is not
ticked (i.e. the system will warm start).

· Default names - select this checkbox to apply default names whenever you add a new IO card to the
project.

· Online - select this checkbox to open a network connection to the selected unit. The two indicators show
the connection status. Leave the Online box unticked to work offline.

· IP-Address - enter the IP Address of the selected unit. If Online is ticked, the connection status will
update.

· Comment (optional) - use this field to add notes about the project.

Console

The horizontal bar at the bottom of the 'Project' window shows the progress of operations such as open project,
save project, transfer config to unit, etc. 

The text area below shows what is currently occurring and provides confirmation when a operation is complete.
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4.11 Checking the Network Communication

You can check the network connection to the Lawo system by opening a project and ticking the Online
checkbox.

The two indicators show the connection status: green = valid connection; red = not connected; yellow = the
device firmware needs updating.

Network Communication OK No Network Communication

If there is a valid network connection (green indicator), then the 'Console' text area displays the System
version.

If the firmware needs updating (yellow indicator), then use SoP Explorer to update the device firmware.

If there is a problem with the network connection (red indicator), then check the network cabling and IP settings
of both the configuration PC and Lawo system. See Connecting Your PC to the Lawo Control System. If
everything looks correct, try running a Windows PING test.
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4.12 Options

1. Select View -> Options from the top menu bar, or click on the  Toolbar icon to open the 'Options'
dialogue box:

The options are divided into the following categories:

· Colors - define the field color-coding used by ON-AIR Designer.

· Metrics in pixel - define the default sizing of windows such as the Tree Definition.

· General:

o Show convert message - see Converting Projects to the Current Release.

o Font - defines the font and text size used by ON-AIR Designer.

o Enable Docking - enables or disables docking, see Arranging the Workspace.

2. In each case, make a selection and then click on OK to confirm.

3. To restore all options to the factory defaults, click on Restore Defaults.
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5.     Configuring a Single Unit

This chapter describes how to edit the configuration for a single unit. 

It is divided into three sections:

· Hardware Configuration (Part I):

o Surface

o System Core

o Panels

o Screen

o Function Pool

o Change Frame

· Hardware Configuration (Part II):

o The 'Tree Definition'

o Inserting Elements

o Naming Elements

o Editing Parameters

o Working with Control Signals

o Programing an MF Key

o Swapping MF Keys

o Copying Elements

o Deleting Elements

o Grouping Elements

o Searching the 'Tree Definition'

o Changing the User Level

o Editing IO Parameters (in List Form)

o Using Copy/Paste & Swap

o Other Keyboard Shortcuts

· Monitoring Resources:

o The 'Resources' Window

o Jump to...

o Parameter Line
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5.1 Hardware Configuration (Part I)

5.1.1 Surface

The Surface configuration defines the control surface modules and their parameters. The example below
describes a ruby surface. Other surfaces are configured in a similar manner.

1. Click on the  Toolbar icon, or select Frame -> Surface, to open the window:

Surface Configuration Window

The maximum size of the control surface is defined by the 'Frame Selection'. 

For larger frames like the one above, you may need to scroll left or right to see all the modules. To see the

complete surface (as shown above), click on the  Toolbar icon, or select Frame -> Show All Hardware.
This will show (or hide) any unused panels or surfaces.

You can zoom in (or out) on by pressing and holding CTRL while scrolling your mouse-wheel.

Each module position represents a CAN bus address within the frame. This is a unique hexadecimal address
which defines the role of each module.

Can Bus Addresses (ruby)
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2. To add or change a module, right-click on a slot and choose an option from the list.

Fader Module Assignment (ruby)

Note that the Surface configuration will not necessarily look like your physical console, as it is the CAN
bus address assigned to each module which is important.

3. Double-click on a module to open its parameter window.

Fader Module Parameters (ruby)

The same parameters can be accessed by opening the "Surface" branch of the 'Tree Definition'.

MF Key Swap

Return to the 'Surface' configuration window, and notice that on the Central Module you will see the MF Key
labels for all configured functions. 

Drag and drop an MF Key to swap the button functions - an arrow will appear when a valid "drop" position is
reached. 

This operation always swaps the functionality so you will never "lose" any of your existing programing. All
connected logic is included in the swap.

Central Module - before swap Swap in Progress Central Module - after swap
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5.1.2 System Core

The 'System Core' configuration defines the plug-in cards and IO parameters for the DSP Core. The example
below describes Power Core. Other cores are configured in a similar manner.

1. Click on the  Toolbar icon, or select Frame -> System Core, to open the window.

System Core Configuration

You can zoom in (or out) on by pressing and holding CTRL while scrolling your mouse-wheel.

For Power Core, the main license defined by the 'Frame Selection' is printed above the DONGLE icon (e.g.
Radio XL). If any add-on licenses are enabled, then these are highlighted in red (e.g. AddOn GPIO).

Double-click on the text RAVENNA, DMS or GT to open parameter windows for:

· RAVENNA - the RAVENNA inputs and outputs.

· DMS - used for VisTool metering or to create audio loopbacks.

· GT - used to send GPIO-over-audio.

2. To add or change a plug-in card, right-click on a slot and choose an option from the list:

When you have completed the assignments, the on-screen ‘Frame’ should look identical to your DSP
Core.

3. Double-click on an IO card or connector to access the input and output parameters.

The same parameters can be accessed by opening the "Audio Input" and "Audio Output" branches of the 'Tree
Definition', and selecting the appropriate IO card.



ON-AIR Designer User GuideVersion: 6.6.0/242/95

5. Configuring a Single Unit

5.1.3 Panels

The "Panels" configuration defines any key panels connected to the system and their parameters.

1. Click on the  Toolbar icon, or select Frame -> Panels, to open the window:

Panels Configuration Window

If this is a new configuration, then you will see a series of blank 19” frame panels. The maximum number of key
panels is defined by the 'Frame Selection'.

2. Right-click on an empty panel slot to assign a key panel:

3. Repeat to assign all the key panels connected to your system.

Panels Configuration (example)

Each slot position from top to bottom represents a CAN bus address. This is a unique hexadecimal address
which defines the role of each panel within the system. 

You can zoom in (or out) on by pressing and holding CTRL while scrolling your mouse-wheel.

The MF Key labels are shown for all existing functions. Drag and drop an MF Key to swap the button functions -
an arrow will appear when valid "drop" position is reached. This works in the same way as the Central Module
MF Key swap described earlier.

4. Double-click on a panel to open its parameter window.

The same parameters can be accessed by opening the "Panel"  branch of the 'Tree Definition'.
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5.1.4 Screen

The Screen configuration can be used to create virtual control panels which will be operated from VisTool. 

1. Click on the  Toolbar icon, or select Frame -> Screen, to open the window:

Screen Configuration Window

You can zoom in (or out) on by pressing and holding CTRL while scrolling your mouse-wheel.

The MF Key labels are shown for all existing functions. Drag and drop an MF Key to swap the button functions -
an arrow will appear when valid "drop" position is reached. This works in the same way as the Central Module
MF Key swap described earlier.

2. Right-click on an empty panel slot to assign a Screen Panel:

The available options are:

· Matrix 128 * 128 Control - an XY matrix panel of 128 x 128.

· Matrix Control - an XY matrix panel of 90 x 30 (switched in pages).

· Screen Blank Panel – a blank panel (to replace an existing panel).

· Screen Button – 32 MF Key functions.

· Screen Button RGB – 64 MF Key functions with self-labeling, RGB buttons.

3. Scroll down to the lower slots and notice that some additional options become available:

Slot 11: Screen Matrix TB - a talkback switching panel, with 32 buttons:
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Slot 12: Screen Matrix Monitor - a monitor matrix control panel, with 32 buttons:

Slot 13: Network Assign - a network assign control panel, with 32 buttons:

Slot 14: Screen Src Assign - a fader strip assign control panel, with 32 buttons:

Slot 15: Parm Control - a DSP control panel, with 32 buttons:

4. Double-click on a panel to open its parameter window. 

The same parameters can be accessed by opening the relevant branch of the 'Tree Definition':

· "Logic" - for Matrix Control, Network Assign, Screen Src Assign or Parm Control.

· "MF Keys" for Screen Buttons.
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5.1.5 Function Pool

The Function Pool is available only for ruby. It can be used to prepare MF Keys before positioning them on a
Central Module, or to move a function by swapping it to and from the 'Function Pool' panel. This is ideal if you
know what functionality is required, but are not yet sure of the MF Key layout. The same parameters can be
accessed from the 'Tree Definition'.

1. Click on the  Toolbar icon to show or hide the 'Function Pool'.

The window can be floating or docked to one side (left or right). See Arranging the Workspace.

2. Double-click on any MF Key in the window to open the Function Pool parameter window. 

This shows all the dummy MF Keys available. Each one can be programed in the usual manner:

3. Now open the Surface configuration and drag and drop the MF Key from the Function Pool to the
Central Module - an arrow will appear when a valid "drop" position is reached. 

You can use the same drag and drop technique to move functions to and from the Function Pool panel. This
allows you to easily rearrange an existing MF Key layout.
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5.1.6 Change Frame

The 'Change Frame' window can be used to change the maximum specification of the system.

The options vary depending on the product specified when the project was created (via File -> New). All products
supported by the ON-AIR Designer are shown below.

1. Select Frame -> change frame to open the window.

ruby / Power Core crystal sapphire compact

sapphire / Nova17 Nova29

Here you can change the specification of any component: System Core, Surface, Panels or Screen.

2. If you change an option, click on OK - the software now loads the new configuration. 

It may take a few seconds to load the new data. During this time the status is shown in the "progress" bar (below
Console in the 'Project' window).

If the change lowers the specification of an existing configuration, then parameters are loaded to the
available resources.
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5.2 Hardware Configuration (Part II)

5.2.1 The 'Tree Definition'

The 'Tree Definition' is used to define the system's elements and their parameter options.

1. Click on the  Toolbar icon, or select Command -> Tree Definition, to open the window.

The 'Tree Definition' can be opened multiple times to access different branches of the system. The
window(s) can be floating or tabbed. See Arranging the Workspace.

Below is an example from a ruby console.

Tree Definition: Source -> Parameter branch (Power Core)

'Treedefiniton'

The ‘Tree Definition’ gets its name from the tree-like structure on its left hand side. Each of the branches can be
opened by double-clicking on a branch name or on the arrows beside the branch. Once open, you will see all
configured elements.

Some elements are automatically added to the 'Tree Definition'. Others, such as Source, Sum Bus and Logic
elements must be inserted. Right-click on a branch to Insert, Copy or Delete an element. In our example, the
Source branch is open; the sources have been organised into groups named AutoMix, Digital Sources, etc.
Within the Microphone Sources group, 4 mono sources have been added.

Select Command -> Sort Tree to sort the elements alphabetically.

Parameter Area

When you open up a branch of the tree and select an element, its parameter options appear on the right hand
side. In our example, we can see the parameters for the source named SRC_MIC 1.

Some parameters are linked to other elements within the configuration - for example, the source's Audio Input
and control functions such as Fader Toggle. Note that these fields are color-coded to indicate the expected
signal type: pink for an audio input or output; green for a logical function; etc.

For some elements, there will be more than one page of parameters. If so, these are accessed by tabs at the top
of the window - in our example, Parm, PFL, Conf, DownSrc, Aux, Aux Switch and Keys.
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5.2.2 Inserting Elements

To add a new element to the project:

1. Right-click on a branch within the 'Tree Definition' and choose Insert Element.

Note that the selected branch defines the options which appear. So, a right-click on the Connect branch opens
a selection of "Connect" elements; a right-click on the Source branch opens the source elements; and so on.

2. Select the type of element you want to add (e.g. Source).

3. On the right, place the element within a Group, for example Microphone Sources.

Select New if you wish to create a new Group.

4. Enter the number of elements of the same type you wish to create in the Iteration box.

5. Then click on OK - the new element(s) are added to the 'Tree Definition' under your selected Group
category.
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5.2.3 Naming Elements

After adding an element to the ‘Tree Definition’, you must name it. It is this reference name which will be used to
link to other elements within the configuration.

Reference names MUST be unique. Choose your reference names carefully so that you can easily locate
functions as the configuration grows.

For our example:

1. In the Source field, enter a reference name. 

Once entered, the Reference name appears beside the element in the 'Tree Definition':

You can use the copy and paste shortcuts to speed up the naming process for multiple elements.
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5.2.4 Editing Parameters

The parameters for the selected element are edited on the right hand side of the display; the available
parameters depend on the product and user mode:

The parameter entry boxes are color-coded to indicate the expected signal type: white for a text entry, value or
checkbox; green for a logical function; pink for an audio signal; and so on.

1. For white entry boxes, either type in the text or value required, or tick the checkbox to enable the option.
Press Backspace on your PC keyboard to remove any unwanted text.

You can use the copy and paste shortcuts to speed up the data entry.
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2. For colored entry boxes, double-click inside the box to open a 'Tree Selection' window - in our example,
we have double-clicked inside the pink Audio Input box.

3. Open the branches of the 'Tree Selection' to choose an input:

4. Select OK to confirm - the 'Tree Selection' window closes and the parameter box updates to show your
assignment.

5. To remove a linked entry, click anywhere inside the entry box and press DEL on your PC keyboard.

'Tree Definition' Color-Coding

When you double-click on a colored entry box in the 'Tree Definition', different options appear in the ‘Tree
Selection' depending on the parameter you are assigning. For example, you will see only audio signals when
assigning a pink field; only control signals when assigning a green field; and so on. In each case, the color of
the entry box indicates the expected signal type:

· Green = a logical function.

· Pink = an audio input or output.

· Blue = a source.

· Brown = a summing bus.

· Yellow = a level or balance function.

· Orange = a label.

· Turquoise = an Ember+ element.

· Magenta = the state of another element.
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5.2.5 Working with Control Signals

When programing logical functions (green parameter entry boxes), it is important to understand the control
signals available from the 'Tree Selection':

Ø  Control Inputs

Logical functions can be triggered from any input control signal:

· GPI/O – any GPI. 

· MF Key – any MF Key including those on a key panel or VisTool screen display. 

· Logic – a logical element such as an OR gate, AND gate, Toggle Flip Flop.

· Surface – the alarm contact from any module within the Surface. 

· Panel – the alarm contact from any key panel.

· Definition - a pre-defined logical trigger from the "System -> Definition" branch of the 'Tree Definition'.

The following example shows how to configure an MF Key to open and close a fader.

1. Select the Source from the 'Tree Definition' and double-click in its green Fader Toggle box to open the
'Tree Selection' window. 

2. Then select the desired control signal - in our example, the Source's MF 1a Key - and OK:

Once this configuration is transferred to the system, you will be able to open and close the Source from the fader
strip's MF Key 1a.
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Ø  Control Outputs

Most elements offer control outputs. These reflect the status of the element and may be used to configure a
return operation - for example, to light the fader start MF Key when the Source fader is open.

1. With the same Source selected, select the Keys tab to view the Source's MF Key lamps and labels. For
each MF Key, you may define up to 8 key states labeled P1 to P8 – P1 is lowest priority; P8 is highest priority.

2. Double-click on one of the key state Logic boxes to open a ‘Tree Selection’ window.

3. In the 'Tree Selection', open the the Logic -> "Source Group" -> "Source Name" branch and assign the
source's Fader Start control signal:

4. Now select a color for this state by clicking on the drop-down Color menu - we have selected red.

In this example, we have created an MF Key which will open the fader, and turn red when the fader is open. 

Note that the MF Key's P1 state has also been configured so that the key lights in green when the fader is closed
(using nFader start).
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Ø  Logic Elements

Sometimes you may want a function to be triggered from the logical result of a number of other conditions. For
example, to trigger an external red light if any one of a number of Sources is "on-air". 

For this application, you could use the OR8 Logic element as follows:

1. First insert and name an OR8 element under the Logic branch of the 'Tree Definition'.

2. Double-click in the In 1 box to open a ‘Tree Selection’ window.

3. In the 'Tree Selection', open the the Logic -> "Source Group" -> "Source Name" branch and assign the
source's Channel On control signal:

4. Repeat to assign the Channel On control signals from the other microphone Sources.
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5. Assign the output of the Logic -> OR8 to the red light - for example, via a GPIO card:

Once the configuration is transferred to the system, when any of the four MIC Source faders are open, the red
light should illuminate!

Logic elements can be connected together to create exactly the right control signal for a function.

It is a good idea to regularly save, transfer and test your configuration to avoid feedback loops within the
programing. 
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5.2.6 Programing an MF Key

MF Keys are programed in a similar manner to other control signals. In each case, you must name the MF Key,
then program its functionality, and then define how the key will light.

The example below shows how to create a monitor source selector using a TConn64 element. 

First, each of the monitor source selector MF Keys must be named - in our example, the selections are to be
made via VisTool and so the MF Keys can be found under a Screen Button RGB Module element:

Once the MF Keys are named, they can be assigned to a function - in our example, to the input Trigger of a
TConn64:
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The output of the TConn64 can then be assigned to light the MF Key lamp: 

This example will route a pair of audio inputs to the TConn64 output when the corresponding VisTool MF Key is
active, and light the MF Key in red.

In our example, a TRUE.Out control output has been assigned to the MF Key's P1 state.
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5.2.7 Swapping MF Keys

MF Key functions can be swapped by dragging and dropping on the MF Key name fields - an arrow will appear
when a valid "drop" position is reached:

MF Key - swap in progress

Alternatively, you can use the F11 and F12 keyboard shortcuts as follows: select the first MF Key name field
and press F11 (to mark the active MF Key). Then click on another MF Key name field and press F12 - this
swaps the two MF Key functions. 

In both cases, all connected logic is included in the swap.

5.2.8 Copying Elements

If you have a number of elements (e.g. Sources) which require similar parameters, then Copy Element can
save a lot of programing time.

1. First insert, name and configure the element with all the common parameters you wish to copy.

2. Then right-click on the element in the 'Tree Definition' and choose Copy Element:

3. Select a Group for the new elements, for example Studio Mics.

4. Enter the number of copies you wish to make in the Iteration box, for example 3.
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5. Click on OK - the copied elements now appear under your chosen group category.

Note that the copied elements are marked with an * to distinguish them from your original element.

6. Your first task is to change the Reference name for each copy - this updates both the element name and
any referenced fields.

7. You can now make individual changes to the copies. 
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5.2.9 Deleting Elements

Elements can be deleted individually or in multiples.

Ø  To delete an individual element:

1. Right-click on the element in the 'Tree Definition' and choose Delete Element:

2. Confirm by clicking on Yes, or select No to cancel.

Ø  Deleting Multiple Elements

The Clean function can be used to delete multiple elements. It works by deleting all elements within the 'Tree
Definition' which are unnamed.

1. First select each element and clear its Reference name from the parameter area.

2. Repeat for all the elements you wish to delete:

Reference Name cleared Reference Names cleared for multiple Sources

3. Then right-click on any element in the 'Tree Definition' and choose Clean.

4. Confirm the operation by clicking on Yes - the system will now delete all unnamed elements.
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5.2.10 Grouping Elements

Grouping elements will help you find functions quickly and easily once the configuration begins to grow.

Ø  To add a new group:

 1. Right-click on any element in the 'Tree Definition' and choose Insert element - the ‘New element’
window opens.

 2. Select New and enter the new group name:

 3. Select OK to confirm.

Ø  To delete an existing group:

1. Open the ‘New Element’ window as described above.

2. Select the group you wish to delete and click on Delete.

3. Confirm by clicking on Yes or select No to cancel.

If the group already contains elements it is not possible to delete the group.

Ø  To rename an existing group:

1. Right-click on an element in the group you wish to edit and choose Rename Group - a dialogue box
opens.

2. Enter the new name for the group and confirm the change by clicking on OK.

Alternatively, you can open the 'New Element' window as described above and use the Rename function.

Ø  To change the group of an existing element:

1. Right-click on the element in the 'Tree Definition' and choose Change Group - the ‘New element’
window opens.

2. Select the new group and confirm the change by clicking on OK.
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5.2.11 Searching the 'Tree Definition'

The Find function can be used to search the 'Tree Definition' by name. It is very useful for finding elements or
functions within a larger configuration.

1. Right-click on any element in the 'Tree Definition' and choose Find, or select File -> Find from the top
menu bar, or use the keyboard shortcut (CTRL + F) - the 'Find..' dialogue box opens.

The Find function cannot be selected unless there is an open 'Tree Definition' window.

2. Enter the name you wish to search for including the wildcard character (*) - for example: *MF_MON2*:

3. Click on OK - the system now searches and all matches are highlighted in red:

4. You can now select a match to interrogate the element further.

Note that the current search remains active until you re-open the 'Find' dialogue box and clear its contents.
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5.2.12 Changing the User Level

The user level affects what options you see within the ON-AIR Designer. There are four possibilities:

· Basic is the default user level. It allows you to make minor changes to the configuration like renaming a
source label. All other configuration options are locked.

· Advanced provides a higher level of access and unlocks more configuration options.

· Expert provides full access to all configuration options.

· System is used by Lawo engineers to test new configuration options.

1. To check or change the user level, click on the on the  Toolbar icon - a tick is displayed beside the
current mode:

If the user level is set to System or Expert, it is possible to break the system’s functionality. Therefore, your
system warranty may be affected if you choose to use either of these modes.
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5.2.13 Editing IO Parameters (in List Form)

The Command -> Inputs and Command -> Outputs windows can be used to view and edit IO parameters in
list form. This is often easier than using the 'Tree Definition'.

1. Select Command -> Inputs (or Outputs) from the top menu bar, or click on the  (or ) Toolbar
icon.

The 'Inputs' (or 'Outputs') list opens:

Here you will see all inputs (or all outputs) including any loopbacks.

The ID number on the left is fixed and is the unique matrix number for the input (or output).

Any grey boxes are for reference only and cannot be adjusted. White boxes allow you to click and edit a
parameter value.

2.  Click on a white parameter field to edit its value - some options allow text entry; others offer a drop-down
menu or an enable/disable checkbox.

3.  Click into another field, press TAB or press ENTER to confirm the new entry.

The parameter options are identical to those available from the IO branches of the ‘Tree Definition’: "Audio Input"
and "Audio Output".

You can use keyboard shortcuts to speed up the data entry.
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Resizing & Sorting the Lists

1. Click and drag on the column width to resize a column.

2. Click on the column heading to sort the list - when a sort is active, the column heading is color coded. 

Keeping clicking on the column heading to cycle through the options:

· Sort list alphabetically from A to Z

· Sort list in Reverse, alphabetically from Z to A

· Sort list off.

You can click on more than one column heading to sort by multiple fields:

Command -> Inputs (Sorted by Slot AND Name)

3. Click on all colored column headings to turn sorting off - the lists revert to sort by ID.
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5.2.14 Using Copy/Paste & Swap

The copy/paste and swap functions can be used to speed up data entry in the 'Tree Definition' and 'Command ->
Inputs/Outputs' lists.

To view the available functions, right-click on a property field (in the Tree Definition) or cell (in the Inputs/Outputs
lists).

Copy & Paste Cells

The following keyboard shortcuts can be used to copy and paste individual cells:

· F5: Copy active cell (Inputs/Outputs) or field (Tree Definition).

· F6: Paste the copied content to the active cell; you must select the destination cell first. Following the
paste, the next cell of the same type becomes active. Press F6 repeatedly to copy the same content to
multiple cells.

· F7: Like F6, but the last number in the copied string is increased by one. This is useful for entering
incremental names such as MIC01, MIC02, MIC03.

· F8: Like F7, but the last number in the copied string is increased by two. This is useful for dealing with
stereo elements - for example, to incrementally assign the left audio channels of a Priconnect.

Copy & Paste Blocks

The following keyboard shortcuts can be used to copy and paste a block of cells in the Inputs/Outputs lists. Note
that this function is not available in the Tree Definition.

· F9: Copy a marked block of cells (in the Inputs/Outputs list).

· F10: Paste the copied block relative to the active cell (to the right and down).

To mark the block, either click and drag across the block using your mouse. Or, click in the first cell; press and
hold SHIFT, and click in the last cell - the marked block is highlighted. You can select cells across multiple
columns if you wish.

When using F10, the copied block is pasted from the active cell across cells to the right and downwards.
Therefore, take care to select the upper leftmost cell before pressing F10.



ON-AIR Designer User Guide Version: 6.6.0/2 67/95

5. Configuring a Single Unit

5.2.15 Other Keyboard Shortcuts

The following keyboard shortcuts can be used to speed up other operations:

· CTRL + O: Open Project.

· CTRL + SHIFT + O: Open Last Project

· CTRL + N: New Project

· CTRL + F: Find (Tree Definition)

· CTRL + S: Save Project

· CTRL+ SHIFT+ S: Save As

· CTRL + double-click on reference field: Show active reference in 'Tree Selection'.

· SHIFT + double-click on reference field: repeats the last entry.
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5.3 Monitoring Resources

5.3.1 The 'Resources' Window

The 'Resources' window can be used to check the DSP resources used by the project.

1. Select Command -> Resources to open the window.

The counters show how many resources are left out of the maximum available. The maximum numbers vary
depending on the product.

If, during programing, you try to add a resource which exceeds any of the limits above, the software will warn
you with a ‘No resources available’ pop-up.
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5.3.2 Jump to...

The "Jump to.." function can be used in the 'Tree Definition' to find all occurrences of a reference including its
connections.

1. Right-click on a reference field and choose Jump to.. - the 'Jump to' docking panel appears.

The window can be floating or docked in any position. See Arranging the Workspace.

The Jump to.. list shows the origin of the reference (in light green); the selected reference (in dark green);
plus all other usages (in white).

Note that any elements containing the reference are also highlighted in the 'Tree Definition' (in red).

 2. Click on an entry in the list to "jump to" the element containing the reference.

 3. You can use the Automatic update option to update the Jump to.. list as follows:

· Automatic update (on) = the Jump to.. list updates when you select a different reference.

· Automatic update (off) = the Jump to.. list does not update and continues to list all entries for the
initial reference.
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5.3.3 Parameter Line

You can use the Parameter Line function in the 'Tree Definition' to open a single docking panel containing all
available options for a parameter. This is helpful when editing parameters with lots of options such as RAVENNA
outputs.

1. Right-click on the parameter you wish to interrogate and choose Parameter Line - the 'Parameter line'
docking panel appears.

The window can be floating or docked in any position. See Arranging the Workspace.

The docking panel shows all the options for the selected parameter. In our example, this makes the RAVENNA
output options more visible and avoids having to scroll left and right across the parameter line.

 2. You can use the Automatic update option to automatically update the Parameter line docking panel:

· Automatic update (ticked) = the docking panel updates to show the parameter in focus.

· Automatic update (not ticked) = the docking panel does not update and continues to show the initial
selection.
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6.     Transferring Configuration Data

This chapter describes how to transfer the configuration to a unit.

Topics include:

· Preparation

· Transfer -> Setup to unit

· Transfer -> Config to unit

· Load Project from Unit

· Transfer -> Create Config
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6.1 Preparation

To check your programing you will need to transfer the configuration data to the Lawo system. If the System
Core is a Compact Engine, Nova29 or Nova17, you must transfer the setup data first and then the configuration.
For the System Core is a Power Core, the transfer of setup data is optional.

During the transfer, you can choose to save the project file onto the DSP Core (if your system supports this).
This allows you to store the system configuration on the unit, and load it to another computer at a later date.

Please note:

· If the project contains more than one unit, then you must repeat the transfer for each unit.

· At the end of the transfer, the DSP Core will cold start. Therefore, you should make sure that the system
is NOT in use before starting the transfer.

· The transfer will replace the existing configuration stored on the control system. Please make sure you
have a backup of the existing project before proceeding.

· When running with a firewall, it may be necessary to allow Firewall access for the ON-AIR Designer,
before you can transfer data from your computer.

· You must save your project before transferring configuration data (to allow the required binary files to be
created).

In all cases, the first steps are to connect the configuration PC to the Lawo control system and check the
network communication. See Connecting Your PC to the Lawo Control System and Checking the Network
Communication.
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6.2 Transfer -> Setup to unit

This function transfers the setup parameters defined in the 'Project' window to the selected unit. The screenshot
below is taken from crystal, but the procedure is identical for all radio on-air systems.

1. Start by opening the project you wish to transfer.

2. In the 'Project' window, select the unit from the Units field (if multiple units are configured).

3. Then tick the Online checkbox and make sure that you have a valid network connection to the device -
the green Online indicator should be lit.

If the red indicator is lit, then check the IP address of the device and edit the IP-Address field to match - the
Online indicators will update. See Checking the Network Communication.

4. If any changes have been made to the setup parameters, then these must be saved before the transfer.

Use either File -> Save or File -> Save As to save the project. You can use any file name and location, as long
as the file type (.db3) remains unchanged.

5. Select Transfer -> Setup to unit.

If the option is greyed out, then there is no network communication to the device. Go back to step 3 until this is
resolved.

6. A confirmation box appears. Check the details and select Yes to start the transfer.

The software now compiles the necessary files and transfers them to the device. The progress is shown in the
Console status area at the bottom of the 'Project' window. Once the transfer is complete you will see the lines
File loaded to unit and Sending restart. The device will now go offline while it restarts. This is perfectly normal
but may take a few seconds. All systems perform a cold start, except for the Nova29 which warm starts (to keep
all matrix crosspoints in place).

7. At the end of the reboot, the new setup parameters are loaded and the transfer is complete.

If your computer’s firewall prevents the transfer, then change your firewall settings and retry.
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6.2.1 Editing the System IP Address

If the System Core is a Compact Engine, Nova29 or Nova17, you can use the ON-AIR Designer setup data to
change the system IP address. (Note that, for Power Core, the system IP address must be edited using either
the front panel controls or Web UI).

1. Repeat steps 1 to 3 from the Transfer -> Setup to unit topic to establish a valid network connection to the
device - the green Online indicator should be lit.

2. Enter the new value into the IP-Address field and leave your cursor within the field - the field turns red. 

3. Save, close and re-open the project - the IP address field should be white. 

4. Now continue with steps 5 to 7 from Transfer -> Setup to unit - the transfer will include the new IP
address.

Note that once you have changed the system IP address, you may need to edit your PC's TCP/IP settings to re-
establish a connection to the device.
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6.3 Transfer -> Config to unit

This function transfers the configuration parameters to the selected unit. The screenshot below is taken from
Power Core, but the procedure is identical for all radio on-air systems.

1. Start by opening the project you wish to transfer.

2. In the 'Project' window, select the unit from the Units field (if multiple units are configured).

3. Then tick the Online checkbox and make sure that you have a valid network connection to the device -
the green Online indicator should be lit.

If the red indicator is lit, then check the IP address of the device and edit the IP-Address field to match - the
Online indicators will update. See Checking the Network Communication.

4. If any changes have been made to the configuration, then these must be saved before the transfer.

Use either File -> Save or File -> Save As to save the project. You can use any file name and location, as long
as the file type (.db3) remains unchanged.

5. Select Transfer -> Config to unit from the top menu bar, or click on the  Toolbar icon.

If the option is greyed out, then there is no network communication to the device. Go back to step 3 until this is
resolved.

6. A confirmation box appears. Check the details and select Yes to start the transfer.

The software now compiles the necessary files and transfers them to the device. The progress is shown in the
Console status area at the bottom of the 'Project' window. Once the transfer is complete you will see the lines
File loaded to unit and Sending restart. The device will go offline while it restarts. This is perfectly normal but
may take a few seconds. All systems perform a cold start, except for the Nova29 which warm starts (to keep all
matrix crosspoints in place).

7. At the end of the reboot, the new configuration data is loaded and the transfer is complete.

If your computer’s firewall prevents the transfer, then change your firewall settings and retry.
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6.4 Load Project from Unit

For Power Core and Nova17, a copy of the project file is stored on the DSP Core. This allows you to download it
onto your computer at a later time.

1. Select File -> Load Project from unit:

If this option is greyed out, then there is no network communication between your PC and the control system.

2. A pop-up appears - enter the IP Address of the control system, and press the TAB key to establish the
connection.

3. Then select OK - the project file is downloaded from the unit.

4. To save the project, use Save As and enter an appropriate filename in the usual manner.
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6.5 Transfer -> Create Config

This menu option (and Toolbar icon) will compile the necessary configuration files, without performing a transfer
to the system.
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7.     Configuring Multiple Units

This chapter describes how to apply the same configuration parameters to multiple units.

Topics include:

· Introduction

· Adding & Deleting Units

· Navigating Between Units

· Individualizing the Parameters of a Unit

o Adding a New Subtitution

o The Local Substitutions List

o Linking a Substitution to an Existing Parameter

o Deleting a Substitution from a Parameter

o Other Functions

· Using Global Substitutions

o Removing Global Substitutions

o Transferring Global Substitutions

o What to do if the Global Project is Missing



ON-AIR Designer User Guide Version: 6.6.0/2 79/95

7. Configuring Multiple Units

7.1 Introduction

Using local and/or global substitutions, it is possible to apply the same configuration parameters to multiple
systems. This makes it easy to maintain the configuration for a large installation as, if something changes, the
change need only be applied once.

Local Substitutions

Firstly, it is possible to define multiple units in the same project file so that, by default, all configured parameters
apply equally to all units without exceptions. Specific parameters can then be individualized by adding them to
the 'Local Substitutions' list. For example, to define a different IP-Address, Deskname, etc.

Please note that the hardware configuration (Frame -> Surface, Frame -> System Core, etc.) cannot be
individualized, and so local substitutions can only be used for systems of the same product type. As most
parameters are applied equally, this feature is ideal if you have several units requiring a similar feature set.

Global Substitutions

Secondly, it is possible to create a global project and link this to multiple project files. As each linked project can
support a different hardware configuration, this allows you to apply global settings to different product types.

The global project is a normal ".db3" configuration in which multiple units and their parameters can be defined.
Within each linked project, you may then use 'Global Substitutions' instead of local ones. Providing the
substituted parameters are of an equal type, the settings from the global project will be applied.

It is recommended that the global project be built and maintained at the beginning of the configuration process,
and that it stores only the global parameters. Global substitutions are ideal for installation-wide settings such as
color schemes, metering schemes and system levels.

Substitutions are supported from Version 6.0.0.x onwards. A project containing substitutions must be saved
as a .db3 file.
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7.2 Adding & Deleting Units

Multiple units can be added to, or deleted from, the project via the 'Project' window.

Ø  To add a new unit:

1. Right-click anywhere inside the Units field and select Clone unit - the new unit is added to the bottom of
the list.

Note that you may have to scroll down the list to locate its entry.

Units: Right-click New unit added

2. Double-click on the Unit name (New) to enter a more descriptive name - in our example, Studio G:

Ø  To delete an existing unit:

1. Right-click on the unit you wish to delete (e.g. Studio G) and select Delete unit - the unit is removed
from the project.
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7.3 Navigating Between Units

Once multiple units have been defined, there are two ways you can switch to a specific unit: either click on a
name in the 'Project' window Units field (shown below), or select a unit from the Toolbar:

:

Any substituted parameters within the 'Project' or 'Tree Definition' windows will update.

If you have yet to add any substitutions, then you will see no difference when you navigate between units.

If substituted parameters have been defined, then these are indicated by a grey background and a colored
frame. In our example below, the unit's Deskname and IP-Address have been individualized:

Selected Unit = Studio A Selected Unit = Studio C
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7.4 Individualizing the Parameters of a Unit

Within the 'Tree Definition' you can individualize any parameter.

Within the 'Project' window, the following parameters can be individualized: Deskname, IP-Address, Netmask,
Gateway, Nameserver, NTP-Server, Hostname and Domainname.

7.4.1 Adding a New Substitution

1. Right-click on the desired parameter and select Save as substitution:

2. If you open the 'Local Substitutions' docking panel, you will see a new line:

7.4.2 The Local Substitutions List

1. Click on the  Toolbar icon to open the 'Local Substitutions' list.

The window can be floating or docked to one side (top or bottom). See Arranging the Workspace.

The table lists all defined substitutions, where each line equals one substitution. On the right hand side, you will
see a column for each defined unit: EDIT 1, EDIT 2, EDIT 3, EDIT 4.

2. Click in the individual unit fields to individualize the parameter.

You can use keyboard shortcuts such as F5 (copy) and F7 (incremental paste) to speed up the data entry.

The columns on the left (Group 1, Group 2, Sort, etc.) are used by the Device Configuration Wizard. These
are described later.
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7.4.3 Linking a Substitution to an Existing Parameter

Having defined a substitution, it can be linked to an existing parameter as follows: 

· Either, drag and drop the line from the 'Local Substitutions' window onto the parameter field. 

· Or, right-click on the parameter and select Use substitution.

Once linked, the substituted parameter is indicated by a grey background and a colored frame, and the value for
the selected unit is displayed.

From now on, the value cannot be edited from the parameter field, but should be individualized from the 'Local
Substitutions' list as described earlier.

Note that if you switch to a different unit, via the Units list in the 'Project' window, then the displayed value will
update:

7.4.4 Deleting a Substitution from a Parameter

To delete a substitution: right-click on the individualized parameter and select Delete. The parameter is removed
from the 'Local Substitutions' list and returns to its default value. It can now be edited directly from the 'Tree
Defintion' or 'Project' window as a normal field.
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7.4.5 Other Functions

To interrogate a substitution: right-click on the individualized parameter and select Show substitution:

The 'Local Substitutions' list opens and sets a filter to only show the active parameter:

If you right-click on a field, then you can choose:

· New free - adds a new substitution.

· Copy - duplicates the selected substitution.

· Delete - deletes the substitution (as described earlier).

· Used in.. - shows all parameters using the selected substitution in the Jump to.. docking panel. You can
step through the entries to check or modify the configuration.

Used in.. (example)



ON-AIR Designer User Guide Version: 6.6.0/2 85/95

7. Configuring Multiple Units

7.5 Using Global Substitutions

Global substitutions can be used to apply global settings to several linked project files. They are ideal for
installation-wide settings such as color schemes, metering schemes and system levels.

1. Start by creating a normal ".db3" configuration and save all the parameters to be applied globally as
local substitutions (as described earlier).

If you add multiple units, then each unit will appear in the linked project as a separate profile. This can be used
to create different sets of global options. For example, to offer a choice of metering schemes.

2. Save the project using a suitable file name. It is a good idea to add the suffix "Global" to indicate a
global project file.

3. Now open a project you wish to link, and specify the global project in the 'Project' window.

You can either enter the file path into the Global project field, or click on the ... button to open a File Explorer
window.

4. Save, close and re-open the linked project file - the list of Profiles will update to show the units
configured in step 1.
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5. Click on the  Toolbar icon to open the 'Global Substitutions' list.

6. Drag the ID of the global substitution to the matching target value in your linked project file.

Once linked, the substituted parameter is indicated by a grey background and a red frame, and the value from
the selected profile is displayed:

From now on, the value is updated automatically from the global project, and cannot be edited from the
parameter field.

If you choose a different profile (from the Profiles menu), then the substituted values update. In the example
below, the profiles offer a choice of metering schemes: DIN, UK, SMPTE, etc.

7. Repeat steps 3 to 6 for each project file you wish to link.

7.5.1 Removing Global Substitutions

To remove all global substitutions, open the linked project and clear the file path from the Global project field.

7.5.2 Transferring Global Substitutions

If you transfer a configuration with global substitutions to a unit, then the linked parameters will carry their
values. 

The global project itself is not transferred to the DSP Core. And, in the case of Power Core or Nova17, it is not
stored on the unit (if you use Save Project to unit).
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7.5.3 What to do if the Global Project is Missing

When re-opening a configuration that includes a reference to a global project that cannot be found, there are
two choices of behaviour - to use the local data or not:

· If you choose Yes, then the last settings will be used, but the underlying substitutions are still saved.
This means that if the global substitutions are found later (e.g. by altering the Global project path),
they will be applied.

· If you choose No, then the substitutions will be unused and the default values will be applied. You
should choose this option only if you want to erase all existing global substitutions from a configuration.
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8.     Using the Device Configuration Wizard

This chapter describes the Device Configuration Wizard. 

Topics include:

· End-user View

· Configuring the Wizard

· Display if..

· Selections
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8.1 End-user View

The 'Device Configuration Wizard' provides an alternative way to modify the substituted parameters of a single
unit. The wizard is automatically created from the substitution lists. A number of tools allow you to modify the
layout of the wizard. The instructions below describe how to open and use the wizard once it has been
configured.

1. Select Command -> Device Configuration Wizard from the top menu bar, or click on the  Toolbar
icon to open the wizard:

2. Select the unit you wish to configure and click on Next.

The wizard shows all the defined substitutions for the selected unit only, and organizes the parameters into pre-
configured tabs.

3. Use the tabs to navigate around the configuration.

4. Click on a field to edit its contents.

The fields are color-coded and can be edited in a similar manner to the 'Tree Definition'. See Editing
Parameters.
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8.2 Configuring the Wizard

It is intended for an expert user to prepare the tabs and parameter fields in advance using the 'Local
Substitutions' and/or 'Global Substitutions' lists. The graphics below show how our end-user 'Device Configuration
Wizard' corresponds to the 'Local Substitutions' entry for Input 1:

Device Configuration Wizard

'Local Substitutions' - for Input 1

Each of the columns on the left is used to define how the substitution appears in the wizard:

· Group1 - defines the tab; several parameters may be grouped. A number as a prefix will not be shown in
the wizard but may be used to order the Tabs.

· Group2 - defines the headline; several parameters may be grouped. As above, a prefix may be used for
ordering.

· Sort - is used to order parameters within the headline. Parameters are ordered according to their Sort
number (from low to high).

· Linefeed - all parameters are shown on one line, unless you enable the Linefeed checkbox. If ticked,
the substitution will be displayed on a new line.

· Text - defines the parameter name shown in the wizard. By default, the text is the parameter name.

· Display if.. - is used to hide parameters in the wizard which use free substitutions in combination with
logical statements. See Display If...

· Selection - is used to limit the selection to a choice of references. See Selections.
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8.3 Display if..

Display if.. is used to hide parameters in the wizard which use free substitutions. You can define a condition
which controls whether an element is shown in the wizard using <,>, <=, >= or =. Or, define several matches
using a comma-separated list. 

The Selection field of a free substitution reference (ID) is used as the logical input. The number refers to the
element of the drop-down menu shown in the wizard, while 0 is the first element.

'Local Substitutions' - Display if.. (example)

You can also define, whether an element is used in the configuration by adding a Display if.. statement to the
name of the element in combination with the string "cfg". This permits the configuration to use the whole element,
only if the statement is true. Using this feature, you can control which sources are actually used in the runtime
(via the source selection list).

'Local Substitutions' - Display if.. (with logical statements)
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8.4 Selections

In the substitutions lists, the Selection column is used to limit the wizard's selections to a choice of references. It
can be used in conjunction with Free Substitutions or the 'Tree restriction' dialogue box.

8.4.1 Free Substitutions

Free Substitutions are used to control the visibility of other substitutions. 

To create a free substitution, right-click on the substitutions list and select New free:

You can now enter a list of strings, separated by a semicolon in the Selection column, to define the options
available in the Device Configuration Wizard. Other substitutions may then be suppressed if the Display if..
statement is not true. See Display If...

'Local Substitutions' - Free Substitutions

8.4.2 Tree restriction

The 'Tree restriction' dialogue box can be accessed by double-clicking on a Selection field. It is used to add
elements to the selectable references for the parameter. It can be used in two ways: to create selectable
references (for a drop-down list) or to filter the available selections (to limit the options visible in the 'Tree
Selection'. You can see if either of these options are active by looking in the Selection column of the
substitutions list:

· "selection" = the parameter will use selectable references.

· "filter" = the parameter options will be filtered by a Regular Expression.

Note that you may use either filters or selections; but a combination of both is not possible.
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Selectable References

If the 'Tree restriction' list contains elements, then these will be shown as a drop-down menu in the Device
Configuration Wizard.

You can add allowed elements to the list using '+', or remove an element using '-'. You can also change the order
by dragging and dropping the elements in the list. The Text column defines the reference name shown in the
wizard. If no text is defined, the Reference name is shown.

Tree restriction Device Configuration WIzard

Filters

The Filter field can be used to define Regular Expressions (RegExp) to filter the selectable references. The
hierarchical order of the references is maintained, but you can exclude unwanted references from the normal
'Tree Selection'. Both the group/physical name and the configured name can apply to the filters. A help window
can be opened using the Help button.

Tree restriction Tree Selection
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9.     Appendices

This chapter includes further information which you may find useful. 

Topics include:

· Files & Organisation
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9.1 Files & Organization

Configuration Files

The ON-AIR Designer creates configuration files offline and saves them as database files on your computer. A
number of different files are created with different suffixes. All files are saved to the same folder as the main
project (.db3 file).

.db3 – this is the file which you create when you save a project, and it is this file you edit using the ON-AIR
Designer software.

.mdb – this is the format used by the previous configuration tool. It is supported for backwards compatibility.

.prm – this is the binary file which is created when you perform a Transfer -> Setup to unit. The file contains all
the setup parameters for the system and is transferred and stored on the control system.

.cfg – this is the binary file which is created when you perform a Transfer -> Config to unit. The file contains all
the configuration settings for the system.  It is stored in the "unit" folder of the project directory.

__Kpf.mdb – this is the file which stores source and target names for inputs and outputs which are matrix
enabled. It is stored in the "unit" folder of the project directory.

before_convert.mdb – this is a file which is created when the ON-AIR Designer converts an existing file. It
allows you to keep a copy of the original project before conversion.

It is a good idea to create a project folder to store all the files required for a particular system, and to make
backup copies of your work to avoid losing any data.

VisTool Files

If you are using VisTool Editor, then this will create a .vistool file when you save the VisTool project. It is a good
idea to keep the VisTool and ON-AIR Designer projects together, and name the files clearly as you will need both
files to configure a VisTool runtime session.

VisTool also uses a file named Visconfigurations.mdb file to store any snapshots and user rights created by the
VisTool PC. This is created automatically when you install the VisToolMK2 software (in the folder "C:
\ProgramData\DSA\VisToolMK2\database\"). The file path can be changed from VisTool Editor's "Global
Settings" (via the Snapshots field). 

In addition a number of .ini files to store other variable such as the list of Ember+ hosts, V__line devices, etc. By
default, these are stored in the folder "C:/ProgramData/DSA". The file path can be changed from VisTool's
Session Manager (via the 'optional Parameters' .iniPath field).
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