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1. Introduction

1.     Introduction

About this Manual

This document describes the configuration options supported by the ON-AIR Designer, Lawo's configuration tool
for radio on-air systems. 

The resources vary depending on the product and its license. Use the compatibility tables at the beginning of
each chapter to check which options are supported by your product:

· r = ruby / Power Core

· c = crystal

· sc = sapphire compact

· s = sapphire / Nova17

· N29 = Nova29.

You should be familiar with using the software, and in particular the 'Frame' and 'Tree Definition' windows. If not,
please refer to the separate "ON-AIR Designer User Guide".

Look out for the following which indicate:

Notes - points of clarification.

Tips - useful tips and short cuts.

Attention - alert you when an action should always be observed.

Lawo User Registration

For access to the Downloads area and to receive regular product updates, please register at:

www.lawo.com/registration.

http://www.lawo.com/registration/
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2. Frame Options

2.     Frame Options

This chapter describes the options in the 'Frame' menu. 

There are six configuration windows which are used as follows.

Menu Path Application r c sc s N29

Frame -> Surface Define the control surface modules and their parameters.
ü ü ü ü û

Frame -> System Core Define the plug-in IO cards and other core options.
ü ü ü ü ü

Frame -> Panels Define external key panels and their parameters.
ü ü ü ü ü

Frame -> Screen Define virtual control panels for operation from VisTool.
ü ü ü ü ü

Frame -> Change Frame Change the maximum specification of a component (e.g.
upgrade the Power Core license).

ü ü ü ü ü

Frame -> Function Pool Create a temporary pool of MF Key functions.
ü û û û û
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2. Frame Options

2.1 Frame -> Surface

The Surface configuration defines the control surface modules and their parameters. The example below
describes a ruby surface. Other surfaces are configured in a similar manner.

1. Click on the  Toolbar icon, or select Frame -> Surface, to open the window:

Surface Configuration Window

The maximum size of the control surface is defined by the 'Frame Selection'. 

For larger frames like the one above, you may need to scroll left or right to see all the modules. To see the

complete surface (as shown above), click on the  Toolbar icon, or select Frame -> Show All Hardware.
This will show (or hide) any unused panels or surfaces.

You can zoom in (or out) on by pressing and holding CTRL while scrolling your mouse-wheel.

Each module position represents a CAN bus address within the frame. This is a unique hexadecimal address
which defines the role of each module.

Can Bus Addresses (ruby)
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2. Frame Options

2. To add or change a module, right-click on a slot and choose an option from the list.

Fader Module Assignment (ruby)

Note that the Surface configuration will not necessarily look like your physical console, as it is the CAN
bus address assigned to each module which is important.

3. Double-click on a module to open its parameter window.

Fader Module Parameters (ruby)

The same parameters can be accessed by opening the "Surface" branch of the 'Tree Definition'.

MF Key Swap

Return to the 'Surface' configuration window, and notice that on the Central Module you will see the MF Key
labels for all configured functions. 

Drag and drop an MF Key to swap the button functions - an arrow will appear when a valid "drop" position is
reached. 

This operation always swaps the functionality so you will never "lose" any of your existing programing. All
connected logic is included in the swap.

Central Module - before swap Swap in Progress Central Module - after swap
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2. Frame Options

2.2 Frame -> System Core

The 'System Core' configuration defines the plug-in cards and IO parameters for the DSP Core. The example
below describes Power Core. Other cores are configured in a similar manner.

1. Click on the  Toolbar icon, or select Frame -> System Core, to open the window.

System Core Configuration

You can zoom in (or out) on by pressing and holding CTRL while scrolling your mouse-wheel.

For Power Core, the main license defined by the 'Frame Selection' is printed above the DONGLE icon (e.g.
Radio XL). If any add-on licenses are enabled, then these are highlighted in red (e.g. AddOn GPIO).

Double-click on the text RAVENNA, DMS or GT to open parameter windows for:

· RAVENNA - the RAVENNA inputs and outputs.

· DMS - used for VisTool metering or to create audio loopbacks.

· GT - used to send GPIO-over-audio.

2. To add or change a plug-in card, right-click on a slot and choose an option from the list:

When you have completed the assignments, the on-screen ‘Frame’ should look identical to your DSP
Core.

3. Double-click on an IO card or connector to access the input and output parameters.

The same parameters can be accessed by opening the "Audio Input" and "Audio Output" branches of the 'Tree
Definition', and selecting the appropriate IO card.
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2. Frame Options

2.3 Frame -> Panels

The "Panels" configuration defines any key panels connected to the system and their parameters.

1. Click on the  Toolbar icon, or select Frame -> Panels, to open the window:

Panels Configuration Window

If this is a new configuration, then you will see a series of blank 19” frame panels. The maximum number of key
panels is defined by the 'Frame Selection'.

2. Right-click on an empty panel slot to assign a key panel:

3. Repeat to assign all the key panels connected to your system.

Panels Configuration (example)

Each slot position from top to bottom represents a CAN bus address. This is a unique hexadecimal address
which defines the role of each panel within the system. 

You can zoom in (or out) on by pressing and holding CTRL while scrolling your mouse-wheel.

The MF Key labels are shown for all existing functions. Drag and drop an MF Key to swap the button functions -
an arrow will appear when valid "drop" position is reached. This works in the same way as the Central Module
MF Key swap described earlier.

4. Double-click on a panel to open its parameter window.

The same parameters can be accessed by opening the "Panel"  branch of the 'Tree Definition'.
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2. Frame Options

2.4 Frame -> Screen

The Screen configuration can be used to create virtual control panels which will be operated from VisTool. 

1. Click on the  Toolbar icon, or select Frame -> Screen, to open the window:

Screen Configuration Window

You can zoom in (or out) on by pressing and holding CTRL while scrolling your mouse-wheel.

The MF Key labels are shown for all existing functions. Drag and drop an MF Key to swap the button functions -
an arrow will appear when valid "drop" position is reached. This works in the same way as the Central Module
MF Key swap described earlier.

2. Right-click on an empty panel slot to assign a Screen Panel:

The available options are:

· Matrix 128 * 128 Control - an XY matrix panel of 128 x 128.

· Matrix Control - an XY matrix panel of 90 x 30 (switched in pages).

· Screen Blank Panel – a blank panel (to replace an existing panel).

· Screen Button – 32 MF Key functions.

· Screen Button RGB – 64 MF Key functions with self-labeling, RGB buttons.

3. Scroll down to the lower slots and notice that some additional options become available:

Slot 11: Screen Matrix TB - a talkback switching panel, with 32 buttons:
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2. Frame Options

Slot 12: Screen Matrix Monitor - a monitor matrix control panel, with 32 buttons:

Slot 13: Network Assign - a network assign control panel, with 32 buttons:

Slot 14: Screen Src Assign - a fader strip assign control panel, with 32 buttons:

Slot 15: Parm Control - a DSP control panel, with 32 buttons:

4. Double-click on a panel to open its parameter window. 

The same parameters can be accessed by opening the relevant branch of the 'Tree Definition':

· "Logic" - for Matrix Control, Network Assign, Screen Src Assign or Parm Control.

· "MF Keys" for Screen Buttons.
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2. Frame Options

2.5 Change Frame

The 'Change Frame' window can be used to change the maximum specification of the system.

The options vary depending on the product specified when the project was created (via File -> New). All products
supported by the ON-AIR Designer are shown below.

1. Select Frame -> change frame to open the window.

ruby / Power Core crystal sapphire compact

sapphire / Nova17 Nova29

Here you can change the specification of any component: System Core, Surface, Panels or Screen.

2. If you change an option, click on OK - the software now loads the new configuration. 

It may take a few seconds to load the new data. During this time the status is shown in the "progress" bar (below
Console in the 'Project' window).

If the change lowers the specification of an existing configuration, then parameters are loaded to the
available resources.
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2. Frame Options

2.6 Frame -> Function Pool

The Function Pool is available only for ruby. It can be used to prepare MF Keys before positioning them on a
Central Module, or to move a function by swapping it to and from the 'Function Pool' panel. This is ideal if you
know what functionality is required, but are not yet sure of the MF Key layout. The same parameters can be
accessed from the 'Tree Definition'.

1. Click on the  Toolbar icon to show or hide the 'Function Pool'.

The window can be floating or docked to one side (left or right). See Arranging the Workspace.

2. Double-click on any MF Key in the window to open the Function Pool parameter window. 

This shows all the dummy MF Keys available. Each one can be programed in the usual manner:

3. Now open the Surface configuration and drag and drop the MF Key from the Function Pool to the
Central Module - an arrow will appear when a valid "drop" position is reached. 

You can use the same drag and drop technique to move functions to and from the Function Pool panel. This
allows you to easily rearrange an existing MF Key layout.
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3. 'Tree Definition' Elements

3.     'Tree Definition' Elements

This chapter describes the 'Tree Definition' elements.

The table below summarizes all possible elements.

'Tree Definition'
Element

Application r c sc s N29

Audio Input &

Audio Output

Edit parameters for audio IO signals.
ü ü ü ü ü

Audio Out only Define DMS metering (for VisTool) and internal audio loopbacks. 

* In crystal, DMS and loopbacks appear in the "System -> Definition".

ü û* ü ü ü

Conf Bus Create conference buses to generate mix minus/N-1 returns.
ü ü ü ü û

Connect Create audio connection circuits.
ü ü ü ü ü

Ember+ Configure remote control of parameters via Ember+.
ü ü ü ü ü

Ember+ A-stage Configure remote control of an A__stage device via Ember+.
ü û û û û

GP Sum Create “General Purpose” sums for applications such as talkback.
ü ü ü ü û

GPI/O Edit parameters for physical GPIO and GPIO-over-Audio (GT) signals.
ü ü ü ü ü

GPI/O Network Exchange GPIO signals with other systems via the control network.
ü ü ü ü ü

Label Configure dynamic editing of LCD button labels on external key panels.
ü û û ü û

Level Control Define assignable rotary controls (on a Central Module or key panel).
ü ü ü ü û

Logic Create logical functions to customize system behavior.
ü ü ü ü ü

MF Key Define MF Key parameters for Central Modules, Key Panels and Screen
Button Modules.

ü ü ü ü ü

Minimix Create Minimixer circuits, ideal for monitoring.
ü ü ü ü ü

N-1 Create additional N-1 returns to expand the mix minus capabilities.
ü û û û û

Panel Define MF Key and Label parameters for external key panels.
ü ü ü ü ü

Source Create sources and edit their parameters.
ü ü ü ü û

Sum Bus Create summing buses and edit their parameters.
ü ü ü ü û

Surface Edit parameters for the control surface modules.
ü ü ü ü û

System ->
Definition

Edit global options such as the sync reference, line-up signals, etc.
ü ü ü ü ü

Universal Sum In &

Universal Sum Out

Create summing signals in a Nova29.
û û û û ü

Vis Chan Map physical controls on Fader/Channel Modules to VisTool.
ü ü ü ü û
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3. 'Tree Definition' Elements

3.1 Audio Input / Audio Output

The "Audio Input" and "Audio Output" branches of the 'Tree Definition' provide access to parameters for the
audio IO signals:

The same parameters can be accessed by double-clicking on a connector in the 'Frame -> System Core'.
Parameters can also be edited in list form by selecting 'Command -> Inputs' or 'Command -> Outputs'.

The options vary depending on the type of System Core and its IO specification. The topics which follow
describe all possible parameters for each signal type.

Once configured, the inputs and outputs of each physical IO card can be assigned to other elements via the
"Audio Input" and "Audio Output" branches of the 'Tree Selection'. For example, to assign the audio input of a
source:
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3. 'Tree Definition' Elements

3.1.1 MIC/LINE IN

Input Parameters

Input N Use this field to name the input.

For mono inputs, you can enter up to 16 characters.

For stereo or surround inputs, a two character suffix is automatically added (e.g. “.L”). Therefore,
names should be limited to 14 characters.

Type / Stereo Use the Type drop-down menu (on Input 1) to select:

· Mono.

· Stereo – links inputs 1-2 for stereo operation.

· 5.1 – links inputs 1-6 for L, R, C, LFE, Ls, Rs surround.

· 5.1+2 - links inputs 1-6 for L, R, C, LFE, Ls, Rs surround + inputs 7-8 for stereo.

On odd numbered inputs, select the Stereo checkbox to link the odd/even pair for stereo operation.

Offset Gain Here you can enter a fixed analog offset gain for the input.

For Mic inputs, this is separate from the operator-controlled "mic" gain on the surface.

Matrix Enable This option enables matrix control of the input. There are three options in the drop-down menu:

· ON – sets the input for “Matrix Connect” or “Matrix Query” functions, or external matrix control
such as the MtxCon (NovaConnect) software.

· LS - sets the input for control from the optional Line Scheduler (LS) product. Please contact your
local Lawo representative for details.

· OFF – the input is not enabled for external matrix control.

After a cold start, any inputs set to Matrix Enable ON or LS may need to be connected to a matrix
output.

Line Use this checkbox to choose Mic or Line level operation. 

The mode changes the input impedance and also determines which controls become available
when the source is assigned to a control surface:

· For Mic inputs, operators can adjust mic gain, 48V and a high-pass "rumble" filter.

· For Line inputs, these parameters are not available.

48V Select this checkbox to enable 48V phantom power permanently. For example, to apply 48V to a
talkback microphone.

Fixed Mic Gain Here you can choose a fixed microphone input gain that cannot be changed by the operator. For
example, to enter a fixed input gain for a talkback mic.
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3. 'Tree Definition' Elements

3.1.2 LINE IN

Input Parameters

Input N Use this field to name the input (as described earlier).

Type / Stereo Use the Type and Stereo fields to set the format of the input (as described earlier).

Offset Gain Here you can enter a fixed analog offset gain for the input.

Matrix Enable This option enables matrix control of the input (as described earlier).
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3. 'Tree Definition' Elements

3.1.3 LINE OUT

Output Parameters

Output N Use this field to name the output (as described earlier).

Type / Stereo Use the Type and Stereo fields to set the format of the output (as described earlier).

Offset Gain Here you can enter a fixed analog offset gain for the output.

Matrix Enable This option enables matrix control of the output (as described earlier).

If the option is enabled, you cannot use the Default Audio function.

Default Audio Double-click in the Default Audio box to assign a default audio source for the output.

Default Audio assignments are automatically re-instated after a system cold start. This means
that you can force a cold start to return to the Default Audio assignments if they are overridden
during operation of the system.

A Default Audio source cannot be assigned if Matrix Enable is active.
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3. 'Tree Definition' Elements

3.1.4 AES3 IO

Input Parameters

Input N Use this field to name the input (as described earlier).

Type / Stereo Use the Type and Stereo fields to set the format of the input (as described earlier).

Offset Gain Here you can enter a fixed digital offset gain for the input.

Matrix Enable This option enables matrix control of the input (as described earlier).

Output Parameters

Output N Use this field to name the output (as described earlier).

Type / Stereo Use the Type and Stereo fields to set the format of the output (as described earlier).

Offset Gain Here you can enter a fixed digital offset gain for the output.

Matrix Enable This option enables matrix control of the output (as described earlier).

If the option is enabled, you cannot use the Default Audio function.

Default Audio Double-click in the Default Audio box to assign a default audio source for the output (as
described earlier).
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3. 'Tree Definition' Elements

3.1.5 STUDIO IO

Input Parameters

Input N Use this field to name the input (as described earlier).

Stereo On odd numbered inputs, select the Stereo checkbox to link the odd/even pair for stereo
operation.

Offset Gain Here you can enter a fixed analog offset gain for the input.

For Mic inputs, this is separate from the operator-controlled "mic" gain on the surface.

Matrix Enable This option enables matrix control of the input (as described earlier).

Line Use this checkbox to choose Mic or Line level operation (as described earlier).

48V Select this checkbox to enable 48V phantom power.

Fixed Mic Gain Here you can choose a fixed microphone input gain that cannot be changed by the
operator.

Output Parameters

Output N Use this field to name the output (as described earlier).

Stereo On odd numbered outputs, select the Stereo checkbox to link the odd/even pair for
stereo operation.

Offset Gain Here you can enter a fixed analog offset gain for the output.

Matrix Enable This option enables matrix control of the output (as described earlier).

If the option is enabled, you cannot use the Default Audio function.

Default Audio Double-click in the Default Audio box to assign a default audio source for the output (as
described earlier).

Phones Parameters

These parameters are identical to the output parameters described above.
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3. 'Tree Definition' Elements

3.1.6 MADI IO

Input Parameters

Input N Use this field to name the input (as described earlier).

Type / Stereo Use the Type and Stereo fields to set the format of the input (as described earlier).

Dig Offset Gain Here you can enter a fixed digital offset gain for the input.

Matrix Enable This option enables matrix control of the input (as described earlier).

Transparent Select this checkbox to set the input to be “transparent”. The option should be enabled if you are
using the input to route a Dolby E signal.

Output Parameters

Output N Use this field to name the output (as described earlier).

Type / Stereo Use the Type and Stereo fields to set the format of the output (as described earlier).

Offset Gain Here you can enter a fixed digital offset gain for the output.

Matrix Enable This option enables matrix control of the output (as described earlier).

If the option is enabled, you cannot use the Default Audio function.

Transparent Select this checkbox to set the output to be “transparent”. The option should be enabled if you are
using the output to route a Dolby E signal.

Default Audio Double-click in the Default Audio box to assign a default audio source for the output (as described
earlier).
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3. 'Tree Definition' Elements

MADI Settings

On Power Core, the following parameters configure the MADI ports on plug-in IO cards. 

The same settings for other MADI ports can be accessed via the "System -> Definition -> Parameter = MADI"
branch of the 'Tree Definition'.

Parameter Madi – reference name for the element.

Enable 64 Tx Slots When this checkbox is selected, the MADI port transmits 64 slots as opposed to 56. 

Note that the receiver automatically detects whether 56 or 64 slots are supplied. If the port is
configured to transmit 64 slots and only 56 are received, then the last 8 slots are muted.

The option can be selected for each individual MADI port.

P1 Select Input 2 Click to assign a control signal to switch the MADI port from P1 to P2.

Note that if Sync from MADI is enabled, then this will also switch the MADI sync source.

The option can be selected for each odd/even pair of MADI ports.

P2 Tx = P1 Tx When this checkbox is selected, MADI port P2 transmits the same data as port P1. The option can
be used to configure redundant MADI outputs.

The option exists for each odd/even pair of MADI ports.

3.1.7 DANTE IO

The DANTE parameters are identical to those available for a MADI port. See MADI IO.

3.1.8 RAVENNA IO

The RAVENNA IO parameters vary depending on the type of System Core. See Configuring Audio-over-IP.
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3. 'Tree Definition' Elements

3.1.9 Module Parameters

All IO cards in Power Core include a Module tab which can include either one or two options.

Ignore Card This option is available for all plug-in IO cards. 

If enabled, the IO card is ignored by the system alarm (monitored via the Web UI or alarm bus).
This can be useful if a card is missing.

Enable MADI
Loopbacks

This option is available for 8-channel IO cards only. It appears once the Loopbacks add-on license
is enabled.

Configuring the Loopbacks

The "Enable MADI Loopbacks" option appears for 8-channel IO cards once the Loopbacks add-on license is
enabled. It allows you to add 128 audio loopbacks for each IO card, and can be enabled on multiple cards if
you wish. The option is available for physical IO cards only, and not the General I/O dummy card.

1. Start by turning on the "Enable MADI Loopbacks" option:

The loopbacks are presented as MADI input and MADI output signals, where each input is fed back from the
corresponding output. 

2. Use the "MADI Input" and "MADI Output" tabs to configure the loopback parameters.

Loopback Function (Input Parameters)

Loopback Function (Output Parameters)

The parameters are the same as for a MADI IO card. The audio source for each loopback is defined by the
Default Audio field (in the "MADI Output" tab).
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3. 'Tree Definition' Elements

3.2 Audio Out only (DMS & Loopbacks)

All systems provide DMS elements which can be assigned to a VisTool page for metering, or used to create
audio loopbacks to feed signals back into other parts of the system. Mono DMS can be linked to operate in
stereo or surround. Each DMS channel is equipped with silence detect logic.

The number of DMS and the implementation varies depending on the system:

· ruby / Power Core and sapphire MK2 / Nova17 support 256 DMS presented in 4 groups of 64. 

· sapphire compact and Nova29 support 64 DMS. In addition, Nova29 supports 256 loopbacks which
operate as loopbacks only (without metering and silence detection). These are presented in 4 groups of
64.

· crystal supports 48 DMS (in two pages) plus 32 loopbacks which operate as loopbacks only (without
metering and silence detection).

For all systems except crystal, the DMS Input and DMS Loopback / Silence parameters are accessed from
either the "Audio Input" or "Audio Out Only" branches of the 'Tree Definition'. The same parameters can be
accessed by double-clicking on DMS in "Frames -> System Core".

For crystal, the DMS and Loopback parameters are accessed from the “System -> Definition" branch of the
'Tree Definition'.

DMS parameters can also be edited in list form from the "Command -> Inputs" window.
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3. 'Tree Definition' Elements

3.2.1 DMS Input Parameters

Meter n Reference name for the meter.

Type On the 1st input of eight, you can select the following options from the drop down menu:

· Mono.

· Stereo – normal stereo L/R operation.

· 5.1 – this option links 1-6 of the set for L, R, C, LFE, Ls, Rs surround.

· 5.1+2 - this option links 1-8 of the set for 5.1 surround, as above, plus separate stereo
input.

On other odd numbered DMS, you have the option to check the Stereo box to link the
odd/even pair for stereo operation.

Matrix Enable This option enables matrix control of the DMS. There are three options in the drop-down
menu:

· ON – sets the input for “Matrix Connect” or “Matrix Query” functions, or external matrix
control such as the MtxCon (NovaConnect) software.

· LS - sets the input for control from the optional Line Scheduler (LS) product. Please contact
your local Lawo representative for details.

· OFF – the input is not enabled for external matrix control.

After a cold start, any inputs set to Matrix Enable ON or LS may need to be connected to a
matrix output.

Label Enter a label for the DMS.

Audio Assigns the default audio signal.

Note that the audio feeding a DMS may also be configured in reverse - for example, the DMS
may be assigned as the audio input to another configuration element. In this case, the default
audio is overridden.

Color Define the color for each DMS channel. The color is used for PPM bars in VisTool.
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3. 'Tree Definition' Elements

3.2.2 DMS Loopback / Silence Parameters

Loopback n Reference name for the loopback.

Type Select mono, stereo, 5.1 or 5.1+2 for each loopback.

Matrix Enable This option enables matrix control of the loopback, with options for ON, LS and OFF. See
Matrix Enable. 

Silence Thrs low (dBR) Enter the level at which the silence detect will become active.

Thrs high (dBR) Enter the level at which the silence detect will become inactive. Use these two values to set a
range to avoid flicker.

Timeout low (sec) Enter the period of time, for which the level must be below the defined threshold to activate the
silence detect. Use 0 for immediate signalisation.

Timeout high (sec) Enter the period of time, for which the level must be above the defined threshold to deactivate
the silence detect.

Note that the audio inputs to the loopbacks correspond to the DMS Input described on the previous page.
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3. 'Tree Definition' Elements

3.2.3 Loopbacks only (crystal & Nova29)

In crystal and Nova29, the Loopbacks support audio loopbacks only (without metering and silence detection).
The screenshots below are taken from a Nova29 configuration. To access the Loopbacks in a crystal system,
select "System -> Definition" in the 'Tree Definition' and the Loopback tab. In both cases, the parameters are
identical.

Loopback n Reference name for the output.

Type Select mono, stereo, 5.1 or 5.1+2 for each loopback.

Matrix Enable This option enables matrix control of the loopback, with options for ON, LS and OFF. See
Matrix Enable. 

Input n Reference name for the input.

Type On the 1st input of eight, you can select the following options from the drop down menu:

· Mono.

· Stereo – normal stereo L/R operation.

· 5.1 – this option links 1-6 of the set for L, R, C, LFE, Ls, Rs surround.

· 5.1+2 - this option links 1-8 of the set for 5.1 surround, as above, plus separate stereo
input.

On other odd numbered DMS, you have the option to check the Stereo box to link the
odd/even pair for stereo operation.

Matrix Enable This option enables matrix control of the DMS. There are three options in the drop-down
menu:

· ON – sets the input for “Matrix Connect” or “Matrix Query” functions, or external matrix
control such as the MtxCon (NovaConnect) software.

· LS - sets the input for control from the optional Line Scheduler (LS) product. Please contact
your local Lawo representative for details.

· OFF – the input is not enabled for external matrix control.

After a cold start, any inputs set to Matrix Enable ON or LS may need to be connected to a
matrix output.

Default Audio Assigns the default audio signal.
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3. 'Tree Definition' Elements

3.2.4 DMS (crystal)

In crystal, the DMS parameters are simplified. They are accessed by selecting "System -> Definition" in the
'Tree Definition' and the DMS tab. 

In this instance, when Channel Meters are added to a VisTool screen, they can be switched between two pages
using the Select Page 1 and Select Page 2 control signals.

Parameter DMS - reference name for the element.

Select Page N Enter a control signal to switch the VisTool Channel Meters to Page N.

Channel / Page Enter the number of meters you wish to display per page (maximum 24). 

This value should be set to 24 by default. If a lower value is entered, then faders above the
value cannot be addressed.
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3.3 Conf Bus

The conference system is used to generate mix minus/N-1 feeds for particular sources within your
configuration. 

There are two separate conference systems available (Conf 1 and Conf 2).

In each case, the sources within the system receive an automatically switched mix minus feed. i.e. When their
source fader is open (on-air), they hear all summed faders minus themselves. When their source fader is
closed (off-air), they hear only members of the conference system minus themselves. This allows conference
members to hear each other while they are off-air.

3.3.1 Creating Conf Buses

The "Conf Bus" branch of the ‘Tree Definition’ allows you to create conference buses and define their
parameters.

ConfBus Reference name for the conference bus.

Display Display name for the conference bus used on the control surface. Enter 6 characters or less.

Source Color Selects the color used to illuminate the LAWO backlight on the control surface when this source is
assigned to a fader strip. 

Tick the enabled checkbox to enable color coding.

List Enable Select this checkbox if you wish the conf bus to be added to the source selection list when
assigning sources from the control surface.

Conf 2 Select this checkbox if you wish the bus to be part of the second Conference system. Unchecked,
the bus will automatically default to Conference 1.
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3.3.2 Conf Bus Assignments

Select the Conf tab in the "Source" branch of the 'Tree Definition' to assign a conference bus to each source.

All options are repeated for the two separate conference systems – Conf 1 and Conf 2. By using the command
“Conf 1 In disable” or “Conf 2 In disable”, you can form different mix-minus/conference group. i.e. Sources
working on Conf 1 need not be included in Conf 2 and vice versa. 

When working with two conference groups, please note:

· Sources assigned to different conference groups cannot communicate while a conference is active.

· When a source is assigned to both conference groups it is required to configure the switching or
summing of the Conf buses separately.

· Conf buses with the attribute “Conf 2" (see below) must only be set as a Conf 2 bus within the sources.
The same applies to Conf 1.

The source parameters in the 'Tree Definition' are as follows. All options are repeated for Conf 1 and Conf 2.

Conf 1 Bus Assigns a Conf Bus to the source. This sets the relationship between the source and the bus in
order to generate the N-1 mix. 

Conf 1 On Turns on the Conference system with a rising edge.

Conf 1 Off Turns off the Conference system with a rising edge.

Conf 1 Toggle Changes the state of the Conference system with a rising edge.

Conf 1 In disable A rising edge removes the source from all conference buses that are assigned to the Conference 1
system. A falling edge reassigns the source. For example, this might be linked to the presenter’s
cough switch.

Conf 1n If a source is assigned to a Conf Bus 1, then you can use the control input Conf 1n to assign its
own signal to the conference bus. With a rising edge source is added and with a falling edge it is
taken away.
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The following control outputs appear in the ‘Tree Selection’ under “Logic -> GroupName -> SourceName”.

Conf active Active when Conf is switched on for this source, but not any other source, and the fader is closed.
(i.e. there is one conference source off-air).

In this state, the Conference system is disabled and the source receives a sum of all faders minus
themselves.

Conf prepare Active when Conf is switched on and the fader is open.

In this state, the Conference system is disabled and the source receives a sum of all faders minus
themselves.

Conf off Active when Conf is switched off. The fader state is irrelevant.

In this state, the source does not contribute to the Conference system.

Conf Audio Active when Conf is switched on and the fader is closed for this and at least one other source. (i.e.
there is at least one conference source off-air).

In this state, the Conference system is enabled and the source receives a mix of the conference
members minus themselves. This allows Conference members to hear each other while they are
off-air.

Conf in use Active when Conf is switched on.
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3.4 Connect

Connect elements are used to create audio connection circuits.

Several elements are supported for different applications. The table below summarizes all possibilities.

'Connect' Element Application r c sc s N29

Connect A stereo-in-stereo-out audio connect. 
ü ü ü ü ü

The three Intercom elements can be used to create communications setups.

Intercom Local Configure a local intercom system from a single device.
ü û û ü ü

Intercom Net Server Configure an intercom system with multiple consoles and routers.
ü û û ü ü

Intercom Net Client Works in conjunction with the Intercom Net Server.
ü ü ü ü ü

Matrix Connect Control mono or stereo matrix crosspoints.
ü ü ü ü ü

Matrix MultiConnect Similar to the 'Matrix Connect' but for multiple crosspoints.
ü ü ü ü ü

Matrix Query Monitor the status of a “Matrix Connect”.
ü ü ü ü ü

Mix remote A special connect used to route sources to GP Sums.  
ü ü ü ü û

Priconnect An 8-into-1 mono connect with prioritized switching. 
ü ü ü ü ü

RAVENNA Connect 8 Connect streams available on the network to RAVENNA inputs.
ü û û û û

RAVENNA Query 8 Monitor the status of a 'RAVENNA Connect'.
ü û û û û

TConn64 A 64-into-1 stereo connect.
ü ü ü ü ü

UDP Matrix Transmit audio over Ethernet using the UDP protocol.
ü û û ü û
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3.4.1 Connect

"Connect -> Connect"

This element is a stereo-in-stereo-out audio connect which can feed other elements such as a Minimixer or
DMS Loopback. By defining two elements, one for the on and one for the off state, you can create a simple
A/B input switch.

Connect Reference name for the element.

In Assigns an input control signal to switch the connect on.

Audio In 1 

Audio In 2

Selects the left and right input sources.

Audio Out 1

Audio Out 2

Selects the left and right output destinations.
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3.4.2 Intercom Local, Net Server & Net Client

The three Intercom elements can be used to create communications setups. They work in conjunction with the
InterCom software and are described later.

3.4.3 Matrix Connect

"Connect -> Matrix Connect"

This element allows you to control matrix cross points via MF keys, GPIs or logical functions. 

Every “Matrix Connect” can control an internal or external matrix address. Note that the input and output you
use must have their Matrix Enable option set.

Matrix Connect Reference name for the element.

Condition Assigns the control signal which will make the matrix connection.

Matrix Input Enter the address of the matrix input (see Matrix Numbers; 0 = silence).

Type: Stereo Select this checkbox if the matrix input is stereo. Note that the address in the ‘Matrix Input’ field
is that of the left channel.

Matrix Output Enter the address of the matrix output (see Matrix Numbers).

Type: Stereo Select this checkbox if the matrix output is stereo. Note that if the matrix input is mono, it will
be routed to both left and right outputs.

External Select this checkbox if the matrix to be controlled is external (i.e. not within the system frame).

External Protocol Type If External is ticked, select the communication protocol type:

· CAN over TCP/IP - for sapphire, crystal, Nova29 or Power Core.

· MNOPL - for mc2/Nova73.

· EmBER+ - for supporting EmBER+ devices.

EmBER+ Matrix Nr When using Ember+, you must enter an Ember+ Matrix number (from 1 to 5). This
references the Ember+ Matrix element (which defines the local consumer number, external
matrix type, matrix name, etc.)

Protect When checked, the Matrix Connect cannot be removed by any other system. For example, if
the matrix cross point is visible to other controllers such as the NovaConnect software, setting
Protect will prevent these controllers from changing their status.
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3.4.4 Matrix Multi Connect

"Connect -> Matrix Multi Connect"

This element is very similar to a “Matrix Connect”, but it allows you to control multiple cross points from a single
MF key, GPI or logic function.

The cross points are made to and from a range of sequential inputs and outputs. In the example below we have
defined a single input (address 0 = silence) to connect to 64 outputs starting from matrix address 129. Therefore,
this example will mute all 64 channels of a MADI port.

Other applications include re-routing MADI connections or performing multiple stereo connects. Note that if you
define a larger number of outputs than inputs, the inputs wrap around – for example, two inputs would be routed
to outputs 1/2, 3/4, 5/6 and so on within the sequence. 

Matrix Multi Connect Reference name for the element.

Condition Assigns the control signal which will make the matrix connections.

Matrix Input Enter the address of the first matrix input you wish to connect (see Matrix Numbers; address
0 = silence).

Number of Inputs Enter the number of inputs in the connection range.

Matrix Output Enter the address of the first matrix output you wish to connect (see Matrix Numbers).

Number of Outputs Enter the number of outputs in the connection range.

External Select this checkbox if the matrix to be controlled is external (i.e. not within the system
frame).

External Protocol Type If External is ticked, select the communication protocol type:

· CAN over TCP/IP - for sapphire, crystal, Nova29 or Power Core.

· MNOPL - for mc2/Nova73.

· EmBER+ - for supporting EmBER+ devices.

EmBER+ Matrix Nr When using Ember+, you must enter an Ember+ Matrix number (from 1 to 5). This
references the Ember+ Matrix element (which defines the local consumer number, external
matrix type, matrix name, etc.)

Protect When checked, the Matrix Multi Connects cannot be removed by any other system. For
example, if the cross points are visible to other controllers such as the NovaConnect
software, setting Protect will prevent these controllers from changing their status.
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3.4.5 Matrix Query

"Connect -> Matrix Query"

This element provides the ability to monitor the status of a matrix connect, and produce a "logical 1" control
signal if the connect is removed. For example, to trigger an alarm if a specific crosspoint is removed. 

Every “Matrix Query” can monitor an internal or external matrix address. Note that the input and output you use
must have their Matrix Enable option set.

Matrix Query Reference name for the element.

Matrix Input Enter the address of the matrix input to be monitored (see Matrix Numbers).

Matrix Output Enter the address of the matrix output to be monitored (see Matrix Numbers).

External Select this checkbox if the matrix to be controlled is external (i.e. not within the system
frame).

External Protocol Type If External is ticked, select the communication protocol type:

· CAN over TCP/IP - for sapphire, crystal, Nova29 or Power Core.

· MNOPL - for mc2/Nova73.

· EmBER+ - for supporting EmBER+ devices.

Ember+ Matrix Nr When using Ember+, you must enter an Ember+ Matrix number (from 1 to 5). This
references the Ember+ Matrix element (which defines the local consumer number, external
matrix type, matrix name, etc.)
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3.4.6 Mix Remote

"Connect -> Mix Remote"

A Mix Remote can be used to route a source to a summing bus when the summing bus is a GP Sum. In each
case, insert the element under the "Connect" branch of the 'Tree Definition'. Then define its parameters as
follows.

Mix Remote Reference name for the element.

Mix On Assigns an input control signal to turn on the source-to-bus assignment.

Mix Off Assigns an input control signal to turn off the source-to-bus assignment.

Mix Toggle Assigns an input control signal to toggle the state of the source-to-bus assignment.

Mix AF Assigns an input control signal to switch the source-to-bus assignment post fader. If not defined,
the assignment will be pre fade.

Source Selects the source to be assigned.

GP Sum Selects the GP Sum to assign to.

Level Assigns a VCA control to control the level of the source to bus assignment.

Default Level Sets the default level at which the source will be assigned to the bus.



ON-AIR Designer Configuration OptionsVersion: 6.6.0_138/325

3. 'Tree Definition' Elements

3.4.7 Priconnect

"Connect -> Priconnect"

The Priconnect combines the logic function Prio with the routing function Connect. Each element provides an
8-into-1 mono connect with prioritized switching. It is ideal for applications such as talkback insertion over a
monitor chain.

Priconnect Reference name for the element.

Audio Out Assigns the audio output.

Default Audio In Assigns the audio source which you will normally hear when no input control signals are
active.

In N Assigns an input control signal to switch the Priconnect to the corresponding Audio In.

Audio In N Assigns the audio source for each input.

Input 7 takes highest priority. For example, if both input 4 and input 7 triggers are active, then input 7 is the
audio source routed to the output of the Priconnect.
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3.4.8 RAVENNA Connect 8

"Connect -> RAVENNA Connect 8"

This element can be used to connect incoming streams from the network to RAVENNA inputs. It is supported by
Power Core systems.

Each element supports up to 8 connections each with its own logical trigger.

RAVENNA Connect 8 Reference name for the element.

Input (RAV Core Out) 01-08 Enter the input that will subscribe to a stream from the network.

Stream Name Enter the name of the stream exactly as it is defined in the network. Examples could be
MSTR:Stream1, R3LAY01, etc.

Trigger Assign the logic element that will initiate the connect.
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3.4.9 RAVENNA Query 8

"Connect -> RAVENNA Query 8"

This element works in conjunction with the RAVENNA Connect 8. It can be used to monitor the status of the
stream connection.

RAVENNA Query 8 Reference name for the element.

Input (RAV Core Out) 01..08 Enter the input that will be queried regarding whether a stream from the network is subscribed.

Stream Name Enter the name of the stream exactly as it appears in the network. 

The outputs appear under the "Logic" branch of the ‘Tree Selection’ window:

RAVENNA Query 8 Reference name for the element.

Connected 01..08 True if the configured stream is connected.

nConnected 01..08 True if the configured stream is not connected.
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3.4.10 TConn64

"Connect -> TConn64"

The TConn64 is a 64-into-1 stereo connect, ideal for larger monitoring signal selectors. Each TConn64 may
be assigned up to 64 stereo audio inputs which are switched to a single stereo output by 64 trigger inputs. 

Switch between parameters using the Global and In 1-16, In 17-32, etc. menu tabs at the top of the parameter
area.

In 1-64 Parameters

Trigger In N Assigns an input control signal which connects:

· Audio In N.1 to Audio Out 1

· Audio In N.2 to Audio Out 2

Audio In N.1 Assigns the left audio input source.

Audio In N.2 Assigns the right audio input source.
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Global Parameters

TConn64 Reference name for the element.

Audio In PO 1 Assigns the left Push Out audio input.

If the Pushout option is active and no Trigger In signal is true, then this audio source is
routed to Audio Out 1. This can be used to define a default audio connection for the TConn64.

Audio In PO 2 Assigns the right Push Out audio input.

As above, but routes to Audio Out 2.

Audio Out 1 Assigns the left output, routed from Audio In N.1 when the Trigger N signal is active.

Audio Out 2 Assigns the right output,  routed from Audio In N.2 when the Trigger N signal is active.

In State Can be assigned to the OutState of another TConn64, a Button16 or Button64 in order to
cascade elements (see below).

Or, to the Save Out state from a System Defintion -> Parameter = ElementState snapshot in
order to respond to snapshot recalls.

Pushout When checked, Pushout is active.

Disable Inhibits the setting of another trigger.

Reset This control signal resets the TConn64. It can be used to define a default connection which is
activated by the Reset control signal.

If Pushout is active, and the Reset control signal is triggered then Audio In PO 1 and 2 are
assigned to Audio Out 1 and 2.

If Pushout is not active, and the Reset control signal is triggered then the Preset inputs
(below) are assigned to Audio Out 1 and 2.

Preset Enter the number of the audio input which you wish the TConn64 to reset to when Reset is
actioned. This is also the state which the TConn64 will reset to after a cold start.

Control Outputs

The individual control outputs of the TConn64 appear under the “Logic -> <GroupName> -> TConn64” of the
'Tree Selection' window. In addition, you will find the element's Out State under “Element State -> GroupName
-> TConn64”.

The Global -> In State of a TConn64 can be assigned to the Out State of another TConn64, Button16 or
 Button64 in order to cascade elements. The Out State of the master element should be assigned to the In
State of the slave. The slave will then follow all switch changes which occur in the master.
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3.4.11 UDP Matrix

"Connect -> UDP Matrix"

The UDP Matrix element allows you to configure matrix inputs and outputs for UDP network traffic. This allows
an external matrix to control the connections and, hence, the flow of network traffic.

Incoming UDP traffic can be routed from any input port to any IP Address/Port:
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Outgoing UDP-stream

192.168.101.199:43020

192.168.101.201:43021

192.168.101.201:21023
192.168.101.240

The matrix numbers for UDP inputs and outputs begin from 769. See Matrix Numbers.

First, add a UDP Matrix element to the "Connect" branch of the 'Tree Definition' and then defines its
parameters.

Global Parameters

UDP Matrix Reference name for the element.
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Input Parameters

UDP Input 1 to 24  Names each input.

UDP Port Number Assigns the Ethernet port number for the input.

Matrix Enable Selects whether the input is matrix enabled. See Matrix Enable.

Output Parameters

UDP Output 1 to 24 Names each output.

UDP IP Address Assigns the Ethernet IP Address for the output.

UDP Port Number Assigns the Ethernet port number for the output.

Matrix Enable Selects whether the output is matrix enabled. See Matrix Enable.
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3.5 Ember+

Ember+ is a non-proprietary TCP/IP control protocol which allows the system to remotely control, or be
controlled by, an external device. More details about the Ember+ protocol can be found at
https://github.com/Lawo/ember-plus/wiki.

All devices should be connected to the Lawo control network in the usual manner. 

An Ember+ provider "publishes" parameters so that they may be controlled, or responded to, by an external
consuming device. Please see the Ember+ Tree for a guide to all parameter paths and values.

Up to 5 Ember+ providers and 15 Ember+ consumers are defined in the "System -> Definition" branch of the
'Tree Definition'. This allows you to change what is published to each external device, and how parameters are
consumed.

Several elements are supported for different applications. The table below summarizes all possibilities.

'Ember+' Element Application r c sc s N29

Ember+ GPIO Exchange GPIO signals with another Ember+ device.
ü ü ü ü ü

The three Ember+ Internal elements trigger source or summing bus parameter values and report back their status.

Ember+ Internal
FuncCall

Trigger an Ember+ Function Call.
ü ü ü ü û

Ember+ Internal Src
Control

Trigger up to 8 source or summing bus parameters.
ü ü ü ü û

Ember+ Internal Src
Query

Query the value of a specific Ember+ parameter path.
ü ü ü ü û

Ember+ Matrix Allow remote control of matrix crosspoints via Ember+.
ü ü ü ü ü

Ember+ Orban
CODEC

Control simple call operations within an Orban CODEC.
ü ü ü ü ü

Ember+ R3LAY (Jade) Control parameters within Lawo's R3LAY software.
ü ü ü ü û

Ember+ RAVENNA Publish RAVENNA parameters to the network

* In Power Core, RAVENNA parameters are published from the
Control Settings in the "System -> Definition".

û* ü ü ü ü

Ember+ SrcRepl Couple a source to another Ember+ device. Once replicated, all
selected parameters operate in parallel.

ü ü ü ü û

Ember+ V_pro8 GPI Control presets within a Lawo V_pro8 via Ember+.
ü ü ü ü ü

https://github.com/Lawo/ember-plus/wiki
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3.5.1 Ember+ GPIO

An EmBER+ GPIO element can be used to exchange GPIO signals with another Ember+ device. Each element
provides 32 GPIs and 32 GPOs plus 8 level inputs and outputs.

To use this element, the system must be configured as an Ember+ Provider, Ember+ Consumer or both (via the
"System -> Definition -> Parameter = Local Providers/Local Consumers" branch of the 'Tree Definition'). 

The Link Mode option then defines how the Ember+ GPIO element behaves in this device:

· An Ember+ provider publishes parameters so that they may be controlled by a consuming device. 

· An Ember+ consumer can control, or respond to, GPIO parameters published by an Ember+ provider.

For bi-directional control you will need to configure one Ember+ GPIO element in this console and a mirroring
element (provider or consumer) in the external device.

Global Parameters

Ember+ GPIO Reference name for the element. This must be identical to the Reference name used by the
corresponding consuming (or providing) device. See Ember+ Naming.

Link Mode Sets whether the element is a Local Provider or Local Consumer.

Behaviour on Connection
Lost

If the Link Mode = Local Provider, then this option determines what happens if the network
connection to the consuming device is lost:

· Choose Keep input values to keep parameters in their current state (recommended).

· Choose Set Input Values to 0 to reset parameters to their default state.

Note that the provider has a time out of 1 minute before determining that the connection is
lost. The consumer does not recognize a connection loss.

Local Provider Nr. If the Link Mode = Local Provider, enter the number of the Ember+ provider you wish to
use (as defined under "System -> Definition -> Parameter = Local Providers").

Remote Consumer IP
Address

If the Link Mode = Local Provider, enter the IP Address of the Ember+ consumer. Only
this device will be allowed to change the GPI values.

Provider Monitoring
allowed

When ticked, devices other than the one defined by the Remote Consumer IP Address can
"listen" to the provider's GPIOs. Note that this will increase the amount of network traffic.

Local Consumer Nr. If the Link Mode = Local Consumer, enter the number of the Ember+ Consumer you wish
to use (as defined under "System -> Definition -> Parameter = Local Consumers").
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Logic Inputs 1..32

These tabs configure the 32 GP inputs:

GPI x Reference name for the input. This can be any name - e.g. Red Light.

GPIs 1 to 32 will correspond to GPOs 1 to 32 within the mirroring device, providing that the
Ember+ GPIO elements on both sides have an identical Reference Name. See Ember+
Naming.

Logic Outputs 1..32

These tabs configures the 32 GP outputs:

GPO x Reference name for the output. 

GPOs 1 to 32 will correspond to GPIs 1 to 32 within the mirroring device, providing that the
Ember+ GPIO elements on both sides have an identical Reference Name. See Ember+
Naming.

Out Assign an input control signal to trigger the GPO - in our example, the console's Red Light
MF Key.
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Level Inputs 1..8

This tab configures the 8 level inputs:

Level x Reference name for the level input.

Once named, a GP level can be used in a similar manner to other Level Controls (VCAs). If
the Ember+ connection is lost, then the level input is set to off.

Level Outputs 1..8

This tab configures the 8 level outputs:

Level x Reference name for the level output.

Out Assign the Level Control which will adjust the output. When using this function, it is
recommended that the participating Ember+ Providers be assigned a Task Priority =
Highest.
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Ember+ Naming

For Ember+ GPIO elements, the Reference Names used by the provider and consumer must match.

In the example below, both the providing and consuming device have been configured with an Ember+ GPIO
element named EmbGPIO1. This allows the 32 GPIs and GPOs to correspond:

Naming Multiple Elements

If you wish to insert multiple Ember+ GPIO elements (in order to control more than 32 GPIOs), then insert each
element under a different group name. This will allow you to easily distinguish the different sets of GPIOs:

If you do not use different group names, then all the GPIs and GPOs appear in chronological order.
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3.5.2 Ember+ Internal FuncCall

"Ember+ -> Ember+ Internal FuncCall"

This element triggers an Ember+ Function Call. The available functions and their transfer parameters are listed
in the Ember+ Provider Tree -> Function Calls. 

Each Function Call is triggered by a logical control input and runs on a specific Ember+ parameter path
(defined in the Abs. Function Path field). Up to five parameter values can be transferred. The transfer results
can then be displayed in any Label field - for example, using an MF Key label or VisTool box element.

Global Parameters

Internal FuncCall Reference name for the element.

Abs. Function Path Defines the Ember+ Function Call path.

Trigger Assigns an input control signal to trigger the Function Call.

Parameter 1 to 5: Value Enter up to five parameter values to be transferred. All parameter values are taken as strings.
The order of the values must match that of the Ember+ Provider. You can check this using an
Ember+ viewer. In the example above, a Fader ramp for the Source labeled "PC" with a
duration of "5.3" seconds and a target Gain of "0"dB will be triggered.
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The available functions can also be identified using an Ember Viewer or VisTool. In the example below, the
correct Abs. Function Path syntax is indicated in red: 1.5.2 (sapphire.Functions.Ramp Motor Fader). The
available parameter values are indicated in yellow (Source Name), green (Gain) and turquoise (Time). These
must be entered in the correct order in the 'Tree Definition' as Parameter Values 1, 2 and 3.

The results of the function call can be assigned to any Label field in the usual manner - in the example below,
the result for Value 1 has been assigned to the Label ID of MF Key 1. Note that the Label may be used for
debugging purposes in the implementation phase. In normal operation it does not need to be configured:
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3.5.3 Ember+ Internal Src Control

"Ember+ -> Ember+ Internal SrcCtrl"

This element element allows up to 8 source or summing bus Ember+ parameter values to be triggered by a local
control signal such as an MF Key. For example, to change a series of parameters for a single source, or the
same parameter (e.g. fader level) across a range of sources.

Global Parameters

Internal SrcCtrl Reference name for the element.

Trigger Assigns an input control signal to trigger the parameter values.

Param x Assign each source or summing bus you wish to adjust.

Param Path & Value Enter the parameter path and value. The values are set when the Trigger signal is true.

Use an Ember+ Internal Src Query to report back the status of a parameter path.
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The Param Path and Value fields can be identified using an Ember Viewer as shown below. In our example,
the Param Paths for the RVM1 and RVM3 sources are indicated in green and red, and the Value for RVM3 in
orange - for parameters such as frequencies, an integer value specifies the list position (e.g. 14 = 100Hz):
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3.5.4 Ember+ Internal Src Query

"Ember+ -> Ember+ Internal SrcQuery"

This element allows you to query the value of a specific Ember+ parameter path. It can be used to report back
the status of a parameter value to the operator - for example, to light an MF Key or VisTool indicator if a value
exceeds a certain threshold, or is on (or off). 

For each element (parameter path), up to four conditions can be compared using equal to (=), greater than (>)
or lesser than (<). Each active condition produces a true and false output.

Global Parameters

Internal SrcQuery Reference name for the element.

Source/Sum Assign the source or summing bus you wish to interrogate.

Parameter Path Enter the parameter path you wish to interrogate.

Condition 1 to 4:
Parameter Value

Enter the parameter values and logical conditions you wish to interrogate - you may run up to
four individual queries. For each query, select the logic from the drop-down menu (=. >, <),
enter the parameter value and tick the active checkbox. Note that the query must be ticked as
active to produce a 'Tree Selection' output.

In our example, if the Compressor Release Time is less than 4, Condition 1 = true; if the
Release Time = 4, Condition 2 = true, and so on. (In our example, the value of 4 = 200ms
according to the Ember+ Enumerations table.)

The Param Path and Value fields can be identified using an Ember Viewer as shown below. In our example,
the Param Path for the Mic1 source is indicated in green/red, and the Values in orange - for parameters such
as release time, an integer value specifies the list position (e.g. 4 = 200ms):
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The true and false outputs for each active Condition can be found in the "Logic -> Ember+ Internal SrcQuery"
branch of the 'Tree Selection' window. These can be used to trigger another element - for example, to light the
lamp of an MF Key:
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3.5.5 Ember+ Matrix

The Ember+ Matrix element allows an Ember+ consumer to control crosspoints within an Ember+ provider.
The element does not control any crosspoints directly, but is referenced from other elements including a Matrix
Connect, Matrix Multi Connect and Matrix Query.

There are three parts to the configuration. First, define the system to be an Ember+ Consumer (in the "System
-> Definition -> Parameter = Local Consumers"). Then define an Ember+ Matrix element as described below.
Then, on the Ember+ provider, publish the matrix you wish to control.

Ember+ Matrix Parameters (on the Consumer)

On the consuming device, add an Ember+ Matrix element to the "Ember+" branch of the 'Tree Definition':

EmBER+ Matrix Reference name for the element.

Matrix Nr Assign a number to the matrix - this will be referenced from the controlling element (e.g. from a
Matrix Connect).

Local Consumer Nr Assign the Local Consumer number you wish to use (as defined under “System -> Definition -
> Parameter = Local Consumers”).

Matrix Type Select the external matrix type you wish to control: 

· Nova17 - for sapphire, sapphire compact, crystal or Nova17.

· Nova29

· Nova73

· Vpro8

· BFE - for BFE KSC Core Matrix.

Matrix Name The name will reference to the Ember+ Name defined in the "System -> Definition ->
Parameter = Matrix Ember+ element on the providing device (described below).

Ember+ Matrix Parameters (on the Provider)

On the providing device, open the "System -> Definition -> Parameter = Matrix Ember+" branch of the 'Tree
Definition:

Parameter Matrix Ember+ – reference name for the element.

Local Provider Nr Sets the Local Provider number (defined under "System -> Definition -> Parameter = Local
Providers").

Ember+ Name This option allows a local matrix to be controlled by an Ember+ consumer. The name must
match the Matrix Name defined in the "Ember+ Matrix "element on the consuming device
(described above).
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3.5.6 Ember+ Orban CODEC

This element can be used to control simple call operations within an Orban CODEC device. Please visit the
Orban website for more details on the third-party device.

There are two parts to the configuration. First, define the system to be an Ember+ Consumer (in the "System ->
Definition -> Parameter = Local Consumers"). Then define an Ember+ Orban CODEC element as described
below.

Global Parameters

EmBER+ Orban CODEC Reference name for the element.

CODEC No. Assign a number to the CODEC (from 1 to 5). This number must be unique.

Local Consumer Nr Assign the Local Consumer number you wish to use (as defined under “System -> Definition -
> Parameter = Local Consumers”).

Accept Incoming Call Assign an input control signal to accept the incoming call (within the Orban CODEC).

Disconnect Assign an input control signal to disconnect the call (within the Orban CODEC).

http://www.orban.com/audiocodec
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3.5.7 Ember+ R3LAY

This element can be used to control functions within Lawo's R3LAY software (formerly known as JADE). Please
visit the Lawo website for more details on R3LAY.

There are two parts to the configuration. First, define the system to be an Ember+ Consumer (in the "System ->
Definition -> Parameter = Local Consumers"). Then define an Ember+ R3LAY element as described below.

Global Parameters

EmBER+ R3LAY Reference name for the element.

R3LAY No. Assign a number to the R3LAY application (from 1 to 5). This number must be unique.

Local Consumer Nr Assign the Local Consumer number you wish to use (as defined under “System -> Definition -
> Parameter = Local Consumers”).

ClipIn Assign an input control signal to trigger the "ClipIn" function (within R3LAY).

TimeStamp Assign an input control signal to trigger the "TimeStamp" function (within R3LAY).

Stream Parameters

Select x Assign an input control signal to select the corresponding stream (within R3LAY).

http://lawo.com/r3lay/
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3.5.8 Ember+ RAVENNA

In crystal, sapphire compact and sapphire MK2 systems, this element can be used to publish RAVENNA
parameters to the network .

Note that, in Power Core, RAVENNA parameters are published via the Control Settings in the "System ->
Definition".

There are two parts to the configuration. First, define the system to be an Ember+ Consumer (in the "System ->
Definition -> Parameter = Local Consumers"). Then define an Ember+ RAVENNA element as described below

Global Parameters

EmBER+ RAVENNA Reference name for the element.

Element No. Assign a number to the RAVENNA element (from 1 to 6). This number must be unique.

Local Consumer Nr Assign the Local Consumer number you wish to use (as defined under “System -> Definition ->
Parameter = Local Consumers”).

The remaining parameters define the mDNS and SAP channels used for stream announcement:

· mDNS channels use the multicast Domain Name System defined in IETF RFC 6762. 

· SAP channels use the Session Announcement Protocol defined in IETC RFC 2974. 

For each channel, enter the multicast IP Address and Port Number. Use the Enable checkbox to enable or
disable the channel.
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3.5.9 Ember+ Src Repl

The Ember+ Src Repl element can be used to couple a source between an Ember+ provider and consumer.
Once replicated, all selected parameters will operate in parallel. The replication can be either one-way or bi-
directional. If bi-directional, then if a parameter is altered on one side, the same change is applied on the
opposing side. Note that the source types do not have to match. So, for example, a mono source could be
replicated to a stereo or 5.1 source; in this instance only parameters which match will be coupled.

The replication can affect the following source parameters (according to the options selected in the consumer):

· Fader (sapphire, sapphire compact and ruby)

· INP, excluding mic parameters.

· Other DSP modules: EQ, DYN, LIM, DLY.

To use this feature, there are three parts to the configuration. First, on the consuming device, add an Ember+
Src Repl element to the "EmBER+" branch of the 'Tree Definition'. A single element can be used to replicate
several sources from the same consumer. If you wish to replicate sources to more than one provider, then add
one Ember+ Src Repl element for each provider. Next, define the Source parameters on the Ember+
consumer. Finally, define the Source parameters on the Ember+ provider.

Note that:

· The use of source replication may slow down the system. See Managing the Network Traffic.

· When using Source Replication, it is recommended that the participating Ember+ providers are
assigned a Task Priority = Highest.

· For bi-directional control you must enable the subscript reports on the Ember+ provider.

· To reduce the volume of network traffic, you can configure uni-directional control by disabling the
subscript reports on the Ember+ provider.

· Take care not to create a coupling loop - for example, by configuring two parallel Consumer/Provider
paths to the same source!
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Ember+ SrcRepl Parameters

on the Ember+ Consumer

Ember+ SrcRepl Reference name for the element.

SrcRepl Element Nr Enter a Source Replication element number (e.g. 1). 

This will be used to identify each source you wish to replicate (described below). The same
number can be used to replicate several sources.

Local Consumer Nr Enter the Local consumer number, as defined in the "System -> Definition -> Parameter =
Local Consumers" branch of the 'Tree Definition'.

Enable Replication Enter a control signal to enable the replication.

Replication Consumer ->
Provider

Replication Provider ->
Consumer

Use these options to determine whether the replication is one-way or bi-directional. Tick both
checkboxes for bi-directional replication.

Initial Replication
Direction

This option determines the initial replication direction. It affects what happens after a system
restart or interruption to the Ember+ connection. There are three possibilities: Provider ->
Consumer, Consumer -> Provider and By Negotiation. 

If By Negotiation is selected, then the provider and consumer negotiate over who has the
most current data. This information is then used to determine the initial replication direction.
The negotiation compares whether the provider or consumer have already been replicated
during runtime as follows.

· If no communication has occurred, then the system which started first replicates its
parameters to the other system.

· If communication has occurred and only one of the systems has exchanged parameters,
then this system replicates its parameters to the other system.

· If communication has occurred and both systems have exchanged parameters, then the
time stamp of the last exchange decides the replication direction.

Fader Included, etc. Use these options to determine which parameters are replicated.
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Source Parameters

Ember+ Consumer Ember+ Provider

Ø  On the Ember+ consumer:

1. Open the Source element you wish to replicate.

2. Enter a Source Replication element number (highlighted in blue). This must match the number defined
for the Ember+ SrcRepl element. The same number can be assigned to several Sources.

3. Enter a Source Replication Name (highlighted in red). This is used to identify the Source in the
provider (as described below).

Ø  On the Ember+ provider:

1. Open the Source element you wish to couple.

2. Set the Display name field so that it matches the SrcRepl Name entered on the Ember+ consumer
(highlighted in red).

3. Enter the Local provider number (highlighted in green), as defined in the "System -> Definition ->
Parameter = Local Providers" branch of the 'Tree Definition'.
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3.5.10 Ember+ V_pro8 GPI

The Ember+ V_pro8 GPI element can be used to control presets within a Lawo V__pro8. Any one of four
V_pro8 presets (A to D) can be triggered from 8 GPIs. Note that the V__pro8 must be running Version 1.1.7.24
software or later.

There are two parts to the configuration. First, define the system to be an Ember+ Consumer (in the "System ->
Definition -> Parameter = Local Consumers"). Then define an Ember+ V_pro8 GPI element as described
below.

Global Parameters

EmBER+ V_pro8 GPI Reference name for the element.

V_pro8 Nr Assign a number to the V_pro8 unit (from 1 to 5). This number must be unique.

Local Consumer Nr Assign the Local Consumer number you wish to use (as defined under “System -> Definition -
> Parameter = Local Consumers”).

GPI Parameters

Select this tab to define the GPIs and presets:

GPI x Setting Defines which preset (A to D) will be recalled when the GPI Trigger signal is true.

GPI x Trigger Assigns an input control signal to trigger the GPI.
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The result of an active trigger (e.g. GPI 8) can be viewed in the V_pro8 browser interface:

The parameter paths and values triggered by the GPIs can also be identified using an Ember+ Viewer:
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3.6 Ember+ A-stage

An Ember+ A-stage element allows microphone and GPIO parameters within an A__stage device to be
remotely controlled via Ember+. It is supported by Power Core only.

Each element must be assigned to a Local Consumer and, therefore, up to 15 devices can be configured. Each
A__stage device supports up to 32 mic inputs, plus 8 GPIs and 8 GPOs.

The A__stage device must be connected to the Lawo control network and configured separately (via its
own interface) to allow Ember+ control.

To configure the Power Core side:

1. Create an Ember+ A-stage element for each A__stage device, and assign it to a Local Consumer:

2. Enter the parameters for the Local Consumer in the usual manner.

3. To configure the remote mic amp control:

· Insert a new Source for the mic input in the usual manner, see Creating Sources.

· Double-click on the EmBER+ A-stage field to assign the element created in step 1. 

· Use the Channel No. to enter the A__stage mic input number you wish to control (from 1 to 32).

Once the configuration is in place, the operator can remotely adjust mic input parameters within the A__stage
device by assigning this source to the surface.

4. To configure the remote GPIO control, return to the Ember+ A-stage element and define the fields in
the GPO and GPI tabs (as described below).
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Global Parameters

Ember+ A-stage Enter a Reference name for the element/device

Local Consumer No. Enter the number of the Ember+ Consumer you wish to use (as defined under "System ->
Definition -> Parameter = Local Consumers").

Initial Replication Direction This option determines the initial replication direction following a restart. The default direction
(Consumer -> Provider) will read the values from the A__stage device.

GPI

These tabs configure the 8 GP inputs:

GPI x Reference name for the input. This can be any name - e.g. Red Light.

GPIs 1 to 8 will correspond to GPOs 1 to 8 within the mirroring device, providing that both
sides have an identical Reference Name.
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GPO

These tabs configures the 8 GP outputs:

GPO x Reference name for the output. 

GPOs 1 to 8 will correspond to GPIs 1 to 8 within the mirroring device, providing that both
sides have an identical Reference Name.

Out Assign an input control signal to trigger the GPO - in our example, the console's Red Light
MF Key.
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3.7 GP Sum

A GP Sum (General Purpose Summing bus) is a summing bus which cannot be allocated DSP or fader strip
control. They are ideal for applications such as a talkback or AFL.

A source assigned to the control surface can be connected or disconnected from the sum, either pre or post
fader, via control signals created using the Connect -> Mix Remote element. The level from the source to the bus
can also be controlled or preconfigured.

3.7.1 Creating GP Sum Buses

A GP Sum can be inserted under the "GP Sum" branch of the 'Tree Definition'. Once named, the bus can be
linked to other elements in the configuration.
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3.8 GPI/O

The "GPI/O" branch of the 'Tree Definition' provides access to the physical GPIO and GPIO-over-Audio (GT)
signals.

The same parameters can be accessed by double-clicking on a connector in the 'Frame -> System Core'.
Parameters can also be edited in list form by selecting 'Command -> Inputs' or 'Command -> Outputs'.

3.8.1 GPI & GPO

GPI Parameters GPO Parameters

GPI Parameters

GPI N Reference name for the GPI input.

Neg Select this checkbox if you wish the GPI input to be negated (inverted).

GPO Parameters

GPO N Reference name for the GPI output.

Pulsetime (1/10 sec) Enter the duration of the output pulse in steps of 1/10 second. For example, enter 2 for an
approximate pulse length of 0.2 seconds.

Pulse Enable Select this checkbox to enable output pulse switching.

Select Logic The output pulse will be triggered by the rising edge of the control signal entered in this field.

Each input and output can be assigned to other elements within the configuration via the "GPI/O" branch of the
'Tree Selection'.
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3.8.2 GPIO over Audio channels (GT In/Out)

GPIO-over-Audio, also known as GT In/Out, works by exchanging GPIO signals across a Digital Audio link.
The physical audio link must be either MADI or AES3, and must not use sample rate conversion (otherwise the
GPIO data will get scrambled). Inputs and outputs assigned to GT signals must be set to Transparent mode.
Also, due to the processing required, changes of logical states must not be faster than 100ms.

GT In/Out elements can be added to the "GPI/O" branch of the 'Tree Definition'. Each element supports 64 GT
channels, each of which can transmit 8 GPIO-bits. 

GT In 1 to 64 Parameters

GT In N Reference name for the GT input.

Audio Assigns the audio input to be used to receive GPIO data.

Matrix Enable This checkbox enables matrix control of the GT input. See Matrix Enable.
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GT Out 1 to 64 Parameters

GT Out N Reference name for the GT output.

Out 1 to 8 Assigns the 8 GPIO-bits which will be transmitted on the GT output.

Matrix Enable This checkbox enables matrix control of the GT output. See Matrix Enable.

Once named, the 8 GPIO-bits from each GT Input appear under the “Logic -> GTn” branch of the ‘Tree
Selection’ window:

In 1 to 8 Correspond to the Out 1 to Out 8 logical functions as defined within the sending device
configuration.

nIn 1 to 8 The negated In 1 to In 8.



ON-AIR Designer Configuration OptionsVersion: 6.6.0_172/325

3. 'Tree Definition' Elements

3.9 GPI/O Network

GNET elements, also known as GPI/O Network, can be used to exchange GPIO signals with other radio on-air
systems via the control network. The GPI/O Network works on the principle of ports in order to manage the
network traffic effectively. In the sending device, each element is assigned a port number. This must match the
port number defined in the receiving device. The same element/port can be used to send and receive signals if
you wish.

Power Core supports two possible protocols for the GPI/O Network, either TCP or UDP. All other systems
support TCP only. The protocol is selected when you insert the GPI/O Network element.

To use UDP, both the sending and receiving device must be a Power Core. The advantages of using UDP
are that the exchange uses less bandwidth, reduces the CPU usage, and is simpler and faster.

In each case, there are two parts to the configuration. First, define the TCP/IP connections in both the sending
and receiving systems (via the “System -> Definition -> Param = TCPLink” branch of the 'Tree Definition'). Then,
add a GPI/O Network element to both the sending and receiving systems.
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3.9.1 Using TCP

Each GPIO Net TCP element can handle 32 GPIO signals and 10 level controls. 

In the sending device, use the General tab to define the port number, options and the signal parameters which
will be transmitted via the GNET port.

GPIO Net TCP Reference name for the element.

Port The port number (from 1 to 255).

Port + 1 Assigns an input control signal (e.g. logic “true”) to modify the port number. Use this when
working with multiple consoles so that each console can communicate with the router via
different GNET ports.

Port + 2 See above.

IP Address 3rd/4th Byte If the third and/or fourth byte of the destination IP address are defined, only messages
concerning this address/area are sent out. For example, when transmitting from a system
with the default IP address (192.168.101.241), you might set the 3rd Byte = 101 and 4th Byte
= 241.

This can reduce the network overhead and improve speed in large configurations. Note that
received messaged are not affected by these fields.

Mic Arb Offset This field applies an offset to mic arbitration numbers. Apply this to each GNET port within the
central router so that the mic arbitration numbers for different consoles are discrete.

GPO 1 to 32 Assigns the control functions which will be transmitted.

Level Send 1 to 10 Assigns the level controls which will be transmitted.
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In the receiving device, be sure to enter the matching Port number in the General tab. 

Then assign the element's control signals to other functions. There are two sets of signals which appear in the
"Logic" and "Level Control" branches of the 'Tree Selection' window:

Net GPI 1 to 32 Correspond to the GPO 1 to 32 functions set within the sending device.

Net Level 1 to 10 Correspond to the Send Levels 1 to 10 set within the sending device.
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3.9.2 Using UDP

Each GPIO Net UDP element can handle 128 GPIO signals, 10 level controls and 32 text labels.

In this instance, each device can be configured for Tx/Rx, Tx only or Rx only. Use the Global tab to define the
UDP IP Addresses and Port numbers. If you wish to configure Tx only or Rx only, then leave the corresponding
fields empty.

GPIO Net UDP Reference name for the element.

UDP IP Address Enter the IP Address for the UDP connection.

UDP Tx Port Enter the Tx Port number or leave this field empty for Rx only.

UDP Rx Port Enter the Rx Port number or leave this field empty for Tx only.

GPI Values / Level Values /
Text Labels on Connection
Loss

These fields determine what happens if there is a loss of connection.

Then use the GPO, Level Out and Text Out tabs to define the signal parameters which will be transmitted via
the GNET port.
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In the receiving device, use the Global tab to define the UDP IP Addresses and matching Rx Port number.

Then assign the element's control signals to other functions. There are three sets of signals which appear in the
"Logic", "Level Control" and "Label" branches of the 'Tree Selection' window:

GPI 1 to 128 Correspond to the GPO 1 to 128 functions set within the sending device.

Level In 1 to 10 Correspond to the Send Levels 1 to 10 set within the sending device.

Text In 1 to 32 Correspond to the Text Out 1 to 32 set within the sending device.
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3.10 Label

This element applies to key panels with LCD buttons. It allows dynamic editing of the LCD buttons using the
separate software application zirkonlabel. It is supported by Power Core and sapphireMK2 / Nova17 systems.

From V3.4 software onwards, LCD buttons may also be dynamically re-labeled using the Logic -> Text Prio
function.

Label 1 to 32 Enter a reference name for each auto label.

Once named, the auto label Text outputs appear within the ‘Tree Selection’ under “Label -> C_AUTO_LABEL ->
Label N”. Assign the Text control output to the Label ID of a key panel LCD button:

The button can now be labeled using the zirkonlabel software.
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3.11 Level Control

Under the "Level Control" branch of the ‘Tree Definition’ you will find all of the system's assignable rotary
controls, known as VCAs. These can be used to control any level such as the output level of a Minimixer.

The number of physical controls, and their parameters, vary depending on the system. They can be found on:

· The Central (or Monitor) Modules defined in Frames -> Surface.

· Some of the key panels defined in Frames -> Panels.

· Some DALLIS IO cards, such as the 945/61 DALLIS Headphone Output card or 945/05 GPIO card.

For each control, the most important parameter is its Reference name. The other parameters vary depending
on the type of module. An example is included later.

Once named, the control can be used to control the level of another element by clicking on any yellow "Level"
parameter field and selecting the control 's Gain Out in the 'Tree Selection':
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3.11.1 Balance Control

If the control supports a secondary function (push down and turn), then this can be assigned to any yellow
"Balance" parameter:

Note that you may need to enable the "Balance" option in the "Level Control" parameters before the
secondary function can be assigned. Note also that Balance Controls take their name from the "Level Control"
Reference name, and so do not appear separately under the "Balance Control" branch of the 'Tree Definition'.
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3.12 Logic

Logic elements create logical functions which can be used to customize system behaviour.

Logic elements can be connected together to create exactly the right control signal.

It is a good idea to regularly save, transfer and test your configuration to avoid feedback loops within the
programing. 

Several elements are supported for different applications. The table below summarizes all possibilities.

'Logic' Element Application r c sc s N29

ALARM Supports the external Alarm Log Server option.
ü ü ü ü ü

AND8 A logical AND gate with 8 inputs.
ü ü ü ü ü

ASSIGN Assign a source to a fader strip using a logical control signal.
ü ü ü ü û

Blender Create a crossfade between two levels. The output can control
another variable level parameter.

ü ü ü ü ü

Blink Convert a static signal such as a GPI into a dynamic toggling signal. 
ü ü ü ü ü

Button 16 A 1-out-of-16 function for inter-canceling button groups.
ü ü ü ü ü

Button 64 Identical to the 'Button 16' but with 64 inputs and 64 outputs.
ü ü ü ü ü

DEL A logical DELAY.
ü ü ü ü ü

DFF A Data Flip Flop. Evaluates inputs with a rising clock signal.
ü ü ü ü ü

Enable Func A set of eight enable functions with global unlock and feedback
signalisation. Used to create a signal selector.

ü ü ü ü ü

Feedback Arbiter A 1-out-of-16 selector switch with arbitration. 
ü ü ü ü ü

Gate A logical GATE. Swaps two groups of signals (A to B).
ü ü ü ü ü

IMP An impulse. Converts a static signal to a single pulse. 
ü ü ü ü ü

Level Prio A prioritised 1-out-of-16 level control.
ü û û û û

LS Command Supports the Line scheduler Server option.
ü ü ü ü ü

Macro Works in conjunction with the Macro Editor software to action a
series of functions or interchange functions between systems.

ü û û ü û

MFF A Mono Flip Flop.  Generates an output pulse from a static input.  
ü ü ü ü ü

Mic Arbitration Manage the control of shared microphone sources.
ü ü ü ü û

MOM LAT Create a key that latches on (when you press quickly) or is
momentary (when you press and hold). 

ü ü ü ü ü

Mon Desk Supports a custom panel for crosspoint monitoring.
ü û û ü ü

MTX Src Pool Create a pool of audio inputs that can be assigned to a source
directly from the control surface.

ü ü ü ü û

MUX/DEMUX 8 Create a 1-to-8 de-multiplexer and four 8-to-1 multiplexers.
ü ü ü ü ü

NOT A logical NOT gate to invert a control signal.
ü ü ü ü ü

On Air Arbiter A 1-out-of-8 selector switch with arbitration and protection.
ü û ü ü ü

OR32 A logical OR gate with 32 inputs.
ü ü ü ü ü

OR8 A logical OR gate with 8 inputs.
ü ü ü ü ü



ON-AIR Designer Configuration Options Version: 6.6.0_1 81/325

3. 'Tree Definition' Elements

'Logic' Element Application r c sc s N29

PRIO A 1-out-of-16 function similar to a 'Button 16', but with prioritised
switching.

ü ü ü ü ü

RAVENNA Src Pool Create a pool of RAVENNA streams that can be assigned to a
source directly from the control surface.

ü û û û û

RAVENNA Static
Stream

Configure a RAVENNA stream using stream parameters or RTSP
URL.

ü û û û û

RAVENNA Stream
Control

Configure redundancy for specific RAVENNA inputs.
ü û û û û

Server based Timer Create a VisTool timer that can be synchronized across multiple
instances.

ü û û û û

ShiftReg 16 A logical SHIFT REGISTER with 16 outputs.
ü ü ü ü ü

Static Network Route Configure a static network route for control or streaming.
ü û û û û

TB State Provide signalisation to show when talkback is active.
ü ü ü ü ü

Text Prio Dynamically change the LCD button labels on a key panel.
ü ü ü ü ü

TFF A Toggle Flip Flop. Creates a latching control signal.
ü ü ü ü ü

VispageSwitch Define VisTool functions such as page switching, snapshot
management and user rights access.

ü ü ü ü ü

The following elements appear if the corresponding module is added to the 'Frame -> Screen' configuration. 

Matrix Control Operate matrix crosspoints from VisTool.
ü ü ü ü ü

Network Assign Manage multi-system network connections from VisTool.
ü ü ü ü ü

PARM Control Module Adjust signal processing parameters from VisTool.
ü ü ü ü ü

Screen Matrix Monitor Operate a monitor matrix from VisTool.
ü ü ü ü ü

Screen Matrix TB Operate talkback switching from VisTool.
ü ü ü ü ü

Screen Src Assign
Module

Assign sources to fader strips from VisTool.
ü ü ü ü ü
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3.12.1 ALARM

"Logic -> ALARM"

To support an external Alarm Log Server, you will need to define an Alarm element to the "Logic" branch of the
'Tree Definition'.

ALARM Reference name for the element.

Trigger Assigns the input control signal which will transmit the Text Rising and Text Falling Edge
messages at each status change. 

Invert When checked, the input control signal is inverted.

Text Rising Edge Enter the text which will be transmitted to the external Alarm Log Server system at the rising
edge of the Trigger signal.

Text Falling Edge Enter the text which will be transmitted to the external Alarm Log Server system at the falling
edge of the Trigger signal.

Info When checked, this output is treated as an ‘Info’ message within the Alarm Log Server
system, as opposed to an ‘Alarm’ message.

Alarm Number Enter a specific error code which you wish to be transmitted to the external messaging
system.

Unit The unit number is transferred to the Alarm Log Server. For example, you may set Studio 1
as Unit 1, etc.

Address This is an Address transferred to the Alarm Log Server. For example, you may use this to
identify different system addresses.
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3.12.2 AND8

"Logic -> AND8"

An AND8 element is a logical AND gate with 8 inputs. It can be used to ‘AND’ several control signals.

in 1

in 2

in 3

in 4
in 5

in 6

in 7

in 8

out

nout
&

Truth Table

in 1 in 2 in 3 in 4 in 5 in 6 in 7 in 8 out nout

1 1 1 1 1 1 1 1 1 0

0 x x x x x x x 0 1

x 0 x x x x x x 0 1

x x 0 x x x x x 0 1

x x x 0 x x x x 0 1

x x x x 0 x x x 0 1

x x x x x 0 x x 0 1

x x x x x x 0 x 0 1

x x x x x x x 0 0 1
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General Parameters

AND8 Reference name for the element.

In 1 to 8 Assigns input signals to each of the 8 inputs which are to be AND. Inputs which are not
assigned are set to logical “1” or “TRUE”.

Neg When checked, the input is inverted before being processed by the AND gate.

The control outputs appear under the “Logic -> <GroupName> -> AND8” branch of the 'Tree Selection' window:

Out The AND output.

nOut Negated AND.

3.12.3 ASSIGN

"Logic -> ASSIGN"

An ASSIGN element can be used to assign a source to a fader strip under the control of a logical signal such
as an MF Key. By programing several ASSIGN elements which use the same In control signal, you can assign
several fader strips from a single button press, or create a Clear button which would remove sources from fader
strips.

General Parameters

ASSIGN Reference name for the element.

In Assigns the input control signal to action the fader strip assignment. 

Source This is the source which will be assigned to the fader strip. To assign silence leave this entry
blank.

Fader No. This is the fader number where the source will be assigned when the Input condition is true.
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3.12.4 Blender

"Logic -> Blender"

A Blender element can be used to blend (crossfade) between two levels. The output can be used to control
another variable level parameter (e.g. the Level of a Minimixer).

The "Max" and "Min" levels define the maximum range of the element; the difference should be greater than
30dB for proper operation.

Up to eight additional input channels may be defined to action different blend times and levels within the
Max/Min range. Every channel has a trigger and logic outputs: "Active" and "At Level". "Active" shows the last
triggered channel. "At level" shows the reached destination level. A blend may be overridden by a different
trigger.

General Parameters

Blender Reference name for the element.

Trigger Max/Min Assign the input control signal which will action the fade up to maximum and fade down to
minimum level.

Time Max/Min

 (1/10 sec)

Enter the duration of the fade up (to max.) and fade down (to min.).

Level Max/Min (dB) Enter the maximum and minimum levels for the fade up/down; the difference should be
greater than 30dB for proper operation.

Init Value Determines the state of the blender after a cold start, either Level Max or Level Min.

Trigger 1 to 8 Assign the input control signal which will action the interim fade(s).

Time 1 to 8 Enter the duration of each interim fade.

Level 1 to 8 Enter the level for the fade. Note that all levels must be within the Level Max/Level Min
range.

The blender outputs appear in the "Level Control" branch of the ‘Tree Selection’ window when assigning a
variable level parameter. You can use the Blend Level and Inverse Blend Level to crossfade between two
signals.

Blend Level The output of the blender.

Inverse Blend Level The inverted output of the blender.
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3.12.5 Blink

"Logic -> Blink"

A Blink element converts a static signal such as a GPI into a dynamic toggling signal (on/off/on/etc). For
example, to create a blinking MF Key to signal an incoming telephone call. 

The Blink element uses a lot of resources and may slow down the real time operation of the system. 

General Parameters

Blink Reference name for the element.

Data This control signal switches on the blink function.

On time (1/10 sec) Enter the duration of the on time.

Off time (1/10 sec) Enter the duration of the off time.

The control outputs appear under the “Logic -> <GroupName> -> BLINK” branch of the 'Tree Selection'
window:

Out The BLINK output.

nOut Negated BLINK.

3.12.6 Button 16

"Logic -> Button 16"

A Button 16 element is a 1-out-of-16 function, which is typically used to create an inter-cancelling button
group. For example, to create a set of inter-canceling signal buttons to indicate the on-air status of a range of
studios.

The function has 16 inputs and 16 outputs. A rising edge at one of the inputs sets the output of the same
number to a logical “1”. It remains set until a rising edge is received at another input. When this occurs the first
output is reset to “0”, and the new output is set to “1”. In other words, only one output is ever active.

The Button 64 logic element is identical to the Button 16 but offers more inputs and outputs.

To configure prioritised switching, use a Logic -> Prio element.
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General Parameters

Button 16 Reference name for the element.

In 1 to 16 A rising edge at an input sets the corresponding control output to logical “1”, and any other
active control output to logical “0”.

In State Can be assigned to the OutState of another Button16, a Button64 or TConn64 in order to
cascade elements (see below).

Or, to the Save Out state from a "System Defintion -> Parameter = ElementState" snapshot
in order to respond to snapshot recalls.

Pushout After power on, the control output defined in Preset is set to logical “1” as a default and there
is always one active output, if you switch inputs. If you force the Pushout input to be active,
the default is all outputs set to logical "0" and inputs may be cancelled without activating a
different output.

Disable When this input control signal is active, all control inputs are locked. This freezes the current
state of all control outputs until the Disable signal is turned off.

Reset This input control signal resets the status of the 16 control outputs to the default. If no Preset
is entered, the default is Out 1 = a  logical “1”. Otherwise the input entered in Preset is set to
logical "1".

Preset Enter the number of the input which you wish the Button 16 to reset to when Reset is
actioned. This is also the state which the Button 16 will reset to after a cold start. If no value is
entered, Button 16 resets to Out 1 if Pushout is inactive, or none, if Pushout is active

The control outputs appear under the “Logic -> <GroupName> -> Button 16” branch of the 'Tree Selection'
window. You will also find the element's Out State under “Element State -> <GroupName> -> Button 16”.

The default state after power on is Out 1 = logical “1”; all other outputs are logical “0”.

The Global -> In State of a Button16 can be assigned to the Out State of another Button16, Button64
or TConn64 in order to cascade elements. The Out State of the master element should be assigned to the
In State of the slave. The slave will then follow all switch changes which occur in the master.

3.12.7 Button 64

"Logic -> Button 64"

This element is identical in operation to a Button 16 but with 64 inputs and 64 outputs.
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3.12.8 DEL

"Logic -> DEL"

A DELAY element can be used to delay a control signal. For example, to issue a record signal following by a
delayed Play or Pause command to an external recording device (to commence recording).

General Parameters

DEL Reference name for the element.

In Assigns the control signal you wish to delay.

Delay TIme (1/30 sec) Enter the delay time in degrees of 1/30 second. Note that this time is approximate.

The control outputs appear under the “Logic -> <GroupName> -> DEL”:

Out The delayed output.
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3.12.9 DFF (Data Flip Flop)

"Logic -> DFF"

A DFF element is a Data Flip Flop. It can be used to evaluate inputs with a rising clock signal.

General Parameters

DFF Reference name for the element.

Data Assigns the data input which you wish to process.

Clock Assigns the clock source. If you leave this field empty, then the system clock will be used
(approximately 60Hz).

Reset Static Sets the output to be false as long as Reset Static is active.

Reset Pos Edge Resets the output with a rising positive edge.

The control outputs appear under the “Logic -> <GroupName> -> DFF” branch of the 'Tree Selection' window:

Out The DFF output.

nOut Negated DFF.

3.12.10 Enable Func

"Logic -> Enable Func"

The Enable Function element includes a set of eight independent enable functions with global unlock and
feedback signalisation. It can be used to create a selector, such as a studio to transmitter switch, which
requires feedback from a matrix as to which transmission lines are available/active.

Up to 8 input (Key) signals can be defined each with its own Enabled, Prepared, Active and Key.out output.
Each input also has an Active and Enabled input signal. For our example, the operation is as follows:

1. Transmission lines which are available are signaled from the matrix via the Enabled control input. 

The Enabled output is True when the Enabled input is True and can be used to signal that the line is available –
for example to illuminate the green lamp of an MF Key.

2. Transmission lines which are active are signaled from the matrix via the Active control input. 

The Active output is True when the Active input is True and can be used to signal that the line is active - for
example to illuminate the red lamp of an MF Key.

3. An operator must press and hold the global Unlock button and then press the Key button to prepare a
new assignment.
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If the Unlock AND Enabled AND Key inputs are all true, then the Prepared output is set to True. The
Prepared output can be used to switch the assignment within the matrix and signal the selection – for example,
make the MF Key blink.

4. Assuming the matrix then returns a True signal to the Active input, the Active output would signalise the
assignment - illuminate the red lamp of the MF Key.

This element controls the logic of the selector only and not the audio crosspoints.

Alternative elements are the On Air Arbiter and Feedback Arbiter which add arbitration to the logic.

General Parameters

Enable Func Reference name for the element.

X – Key Assigns the Key control input which will be used to prepare the assignment.

Active Assigns the control input used to signalise that the line is active.

Enabled Assigns the control input used to signalise that the line is enabled (available).

The control outputs appear under the “Logic -> <GroupName> -> Enable Func” branch of the 'Tree Selection'
window:

x Enabled True if the Enabled input is True.

x Prepared True if the Enabled AND Unlock AND Key inputs are true.

x Active True if the Active input is True.

x Key.out True if the Key input is True.
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3.12.11 Feedback Arbiter

"Logic -> Feedback Arbiter"

The Feedback Arbiter element is a 1-out-of-16 selector switch with arbitration. It is ideal for applications such
as a telephone hybrid selector.

If an output is active, then a different output can ONLY be activated by triggering both the Force Enable and
Input x control signals - for example, if MF Keys are used for the control signals, then the operator needs to
press both Force Enable plus the Input x MF Key to change the active output. The Enabled and Active control
outputs can be used to signal the state of the arbiter by illuminating MF Keys.

This element controls the logic of the selector only and not the audio crosspoints.

Alternative elements are the On Air Arbiter which offers more protection, and the Enable Func which
provides signalisation but not arbitration.

General Parameters

Feedback Arbiter Reference name for the element.

X – Input Assigns the MF Key (or control input) which will activate the corresponding output if no other
output is True.

Force enable Assigns the MF Key (or control input) which will force the corresponding output to active and
set all other outputs to False.

Note that both the Force enable and X - Input control signals must be true to change the
active output.  

The control outputs appear under “Logic -> <GroupName> -> Feedback Arbiter” in the 'Tree Selection' window:

None active True if all inputs are False.

x Active True if the corresponding input is True.

x Enabled True if either all inputs are False or the corresponding Force enable is True.

X Force Enabled True if the corresponding Force enable is True.
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3.12.12 Gate

"Logic -> Gate"

A Gate element is a logical GATE. It can be used to swap two groups of signals (A to B), where each group
has 8 inputs and 8 outputs. For example, to switch the output of a monitoring source selector between
Loudspeakers and Phones.

General Parameters

GATE Reference name for the element.

Reverse A/B Assigns the input control signal which will action the A to B switch. 

When the input control signal is a logical “0” then In A.1 to In A.8 are routed to Out A.1 to Out
A.8, and In B.1 to In B.8 are routed to Out B.1 to Out B.8. 

When the input control signal is a logical “1” then In A.1 to In A.8 are routed to Out B.1 to Out
B.8, and In B.1 to In B.8 are routed to Out A.1 to Out A.8. 

In A.1 to A.8 Assign the 8 group A input signals.

In A.1 to A.8 Assign the 8 group B input signals.

The control outputs appear under the “Logic -> <GroupName> -> Gate” branch of the 'Tree Selection' window:

Out A.1 to Out A.8 Group A outputs.

Out B.1 to Out B.8 Group B outputs.
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3.12.13 IMP

"Logic -> IMP"

An Impulse element can be used to convert a static signal such as a GPI into a single pulse:

General Parameters

IMP Reference name for the element.

In The input control signal.

Pulsetime On (1/10 sec) Enter the pulse time in degrees of 1/10 second. Note that this time is approximate.

Pulsetime Off (1/10 sec) Enter the delay time in degrees of 1/10 second. Note that this time is approximate.

Re-trigger If enabled, the IMP may be re-triggered during the "on" cycle, leading to a longer "on" period.

The seven control signals appear in the “Logic -> <GroupName> -> IMP” branch of the 'Tree Selection' window:

Switch On Out Becomes active when a rising edge is supplied to the input. The status remains set for the
duration of the Pulsetime On.

Neg Switch On Out Negative output of the Switch On Out.

Switch Off Out Becomes active once Pulsetime On is finished. The falling edge of Switch On Out triggers
the rising edge of Switch Off Out. The status remains set for the duration of the Pulsetime
Off.

Neg Switch Off Out Negative output of the Switch Off Out.

Switch OR (On/Off) Out Becomes active if the Switch On Out is true OR the Switch Off Out is true.

Neg Switch OR (On/Off)
Out

Negative output of the Switch OR (On/Off) Out.

Switch OR (In/On/Off) Out Becomes active if the input is true OR the Switch On Out is true OR the Switch Off Out is
true.



ON-AIR Designer Configuration OptionsVersion: 6.6.0_194/325

3. 'Tree Definition' Elements

3.12.14 Level Prio

"Logic -> Level Prio"

A Level Prio element can be used to create a prioritised level control. The function has 16 inputs and one
output. 

If no control inputs are active, then the output is set to the Prio 0 Level. 

If one or more control inputs are active, then the control signals are prioritised from 1 (highest) to 16 (lowest).
The output is set to the winning Default value or Level control (if one is defined).

General Parameters

Level Prio Enter a reference name for the element.

Prio 0 Level Enter the level (in dB) to be applied when no control inputs are active.

In 1 to In 16 Assigns input control signals 1 to 16. If more than one input is active, then the control signals
are prioritised from 1 (highest) to 16 (lowest).

Default Enter the level (in dB) to be applied when the control input is active. The Default value is
applied when nothing is assigned to the Level field.

Level Assign the level control to be used when the control input is active. For example, a source
fader or Central Module VCA. If this field is left empty, then the Default value will be used.
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Once named, the Level Prio output (Level Out) appears within the ‘Tree Selection’ when assigning a Level
parameter. This allows it to be assigned to any other Level field. For example, to control the output level of a
minimixer:
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3.12.15 LS Command

"Logic -> LS Command"

A LS Command element can be used to change and monitor Triggers on a Line Scheduler (LS).

To use this feature there must be an active TCP/IP connection to a matrix server (single or redundant)
using the TCP Link mode AIF1/2 (defined under “System -> Definition -> Param = TCPLink”).

General Parameters

LS Command Reference name for the element.

Action Select the action which will happen when the In control input becomes true.

Macro/Template No Enter the Line Scheduler's Trigger number (usually found under Administration / Trigger
names).

In Assign an input control signal to trigger the Action.

Macro active in You can assign an input control signal to display the active state.

The control outputs appear under the “Logic -> <GroupName> -> LS Command” branch of the 'Tree Selection'
window:

Macro defined True when the specified Macro/ Template No is used by any macro or template in the LS.

Macro active True is the macro or template is active.

3.12.16 Macro

"Logic -> Macro"

Macro elements are described later together with the Macro Editor software.
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3.12.17 MFF (Mono Flip Flop)

"Logic -> MFF"

A MFF element is a Mono Flip Flop. It can be used to generate an output pulse from a static input.  

General Parameters

MFF Reference name for the element.

Trigger With a positive edge at this input, the control output is set to logical “1” for the Time set below.

Toggle Assigns the input control signal to be toggled.

Reset Assigns a control input to set the control output to logical “0”.

Time (1/10 sec) Enter the time for which you wish the control output to be set to logical “1”. The time is set in
approximately 1/10 second steps.

The control outputs appear under the “Logic -> <GroupName> -> MFF” branch of the 'Tree Selection' window:

Out The MFF output.
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3.12.18 Mic Arbitration

"Logic -> Mic Arbitration"

In a situation where a microphone source is shared between multiple studios, the “Mic Arbitration” function can
be used to manage which system has control of the remote microphone amplifier settings (gain, 48V, etc.).

In the example above, a microphone connected to the Nova17 from the announcer's booth is to be controlled
from either of the two crystal Studio consoles. In this example, the Nova17 is the server and the two crystal
consoles are clients.

Network Control

The system works by defining a Mic Arbitration Logic element for the microphone. You can define up to 8
sources which may take control of the microphone. When the Condition signal for a source is true, then the
source takes control of the mic input parameters.

Audio Distribution

To distribute the microphone signal from the Nova17, you can use either of the following methods:

· A direct MADI to MADI connection – where the microphone signal is available to both crystal Studios
simultaneously. The advantage and disadvantage of this method is that one studio may have access to
the mic signal without control. 

· Alternatively, configure an audio switch within the Nova17 (e.g. using a Priconnect) which is controlled
by the same condition signal as the Mic Arbitration. The advantage of this method is that when control
is switched so is the audio so that you can be sure you will never have audio without control.
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TCP/IP Configuration

The first step is to configure the TCP/IP links within the server and client system configurations as follows.

1. Within the server's configuration, set the “System -> Definition -> Parameter = TCP Link” modes to
GNET for the links to the clients:

2. Within each client's configuration, set the “System -> Definition -> Parameter = TCP Link” mode to
GNET (or GKPF):

For more details on TCP/IP link types, please see Preparing the TCP/IP Connections.

If the microphone to be controlled is connected locally to one of the consoles, then you will need to
configure a special TCP/IP Link mode for the server - in Step 1, set the “System -> Definition ->
Parameter = TCP Link” mode to GLOC (GNET Local), and enter the IP Address for the Active TCP
Connection to 127.0.0.1 or localhost.



ON-AIR Designer Configuration OptionsVersion: 6.6.0_1100/325

3. 'Tree Definition' Elements

GPI/O Network Configuration

Next, to transfer the “Mic Arbitration” control data, you must configure a GPI/O Network port between the server
and each of the client systems. Note that the “Mic Arbitration” data is transmitted transparently. In other words,
it does not use up any of the 32 configurable GPIOs or 10 level controls.

1. Within the first client, select the GPI/O Network branch of the 'Tree Definition' and Insert a Net
element in the usual manner.

2. Name the GPI/O Network Port in the Net box (e.g. Studio 1<->Nova17) and enter the Port number (1):

If Port 1 is already in use (for a different application), you should choose the next available port number.

3. Repeat for the second client, this time entering a different Port number (2):

4. Now open the server's configuration and add two GPI/O Network Net elements. 

5. Enter Port number 1 for the connection to Studio 1 and Port number 2 for the connection to Studio 2:

You can use the Mic Arb Offset field to apply an offset to the Mic Arbitration Input numbers (used by each
client). Apply this to each GNET port within the server so that the mic arbitration input numbers for different
consoles are discrete.
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Server - Mic Arbitration

Within the server's configuration, you now need to define a Mic Arbitration element (under the "Logic" branch
of the 'Tree Definition').

Each element arbitrates the control of a single mic input between 8 different sources.

Mic Arbitration Reference name for the element.

Mic Input Enter the physical mic input you wish to be controlled via arbitration.

Mic Input Nr 1 to 8 Enter a reference number which will be used to identify the microphone later within the client
configurations.

The Mic Input Nr can be any number but it must be unique. 

Condition When the condition is true, the source with the corresponding Mic Input Nr takes control of
the mic input parameters. 

Server - Audio Distribution

Still within the server configuration, the next step is to distribute the microphone signal to all of the client
systems. In our example, we have used two direct MADI to MADI connections:

1. From the System Core configuration, open the IO parameters for the MADI port feeding the first client
console, and assign the microphone input (Mic 01) as its Default Audio output.

2. Repeat for the MADI port feeding the second client console.



ON-AIR Designer Configuration OptionsVersion: 6.6.0_1102/325

3. 'Tree Definition' Elements

Client - Source Configuration

The final step is to add and configure the sources within each client configuration. This is done by opening the
Source element you wish to configure: 

1. Assign the Audio Input which will receive the incoming microphone signal – in our example, via the
MADI link from the server.

2. In the Matrix Mic Nr box, enter the reference number you defined earlier within the server's
configuration – in our example, 101.

If a Mic Arb Offset was entered within the server's GPI/O Network configuration, then the offset is applied
here.

3. In the Matrix Gnet Port box, enter the GPI/O Network port number which connects to the Nova17 – in
our example, port 1.

4. Repeat these steps for the second client, this time entering 102 for the Matrix Mic Nr, and port 2 for
the Matrix Gnet Port.

5. Save and download all of the server and client configurations.

You can now switch control of the microphone settings between clients by triggering the corresponding control
signals - i.e. the Condition signals for Mic Input Nr x (defined in the servier's Mic Arbitration element). 
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3.12.19 MOM LAT (Momentary Latch)

"Logic -> MOM LAT"

A MOM LAT element can be used to create a key that latches on (when you press quickly) or is momentary
(when you press and hold). For example, to operate talkback. 

General Parameters

MOM LAT Reference name for the element.

Toggle Assign the control signal which you wish to modify (in our example, a talkback key).

Reset Static This input will force a reset (i.e. set the control output to “0”). The reset is active as long as
the input control signal = logical “1”.

Set Static As above, but this time the control output is set to “1”.

Reset Pos Edge This input will force a reset (i.e. set the control output to “0”). The reset is triggered from the
rising edge of the input control signal.

Set Pos Edge As above, but this time the control output is set to “1”.

Delay Time (1/10) Enter the time between which the function will change from ‘short press’ to ‘long press’. In our
example, 10 is entered: pressing the TB key for more than 1 second will action a long press
and for less than one second a short press.

The control outputs appear under the “Logic -> <GroupName> -> MOM LAT” branch of the 'Tree Selection'
window:

Out The control output (latching after a short press and momentary after a long press).

nOut The negated Out.

OutShort TFF Active when the Toggle input control signal is shorter than the Delay Time. It becomes
inactive the next time the Toggle input control signal is shorter than the Delay Time.

OutLong Active when the Toggle input control signal is longer than the Delay Time. It becomes
inactive when the Toggle input control signal becomes active.

OutShort Pulse This output is pulsed when the Toggle input control signal is active below the Delay Time.

To program a Talkback key so that you press and hold to momentarily talk to a destination, use the
OutLong control output to trigger the talkback function.

3.12.20 Mon Desk

"Logic -> Mon Desk"

The Mon Desk element supports a custom panel which monitors crosspoints within a large matrix. This is a
project-specific feature. Please contact your local Lawo representative for further details.
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3.12.21 MTX Src Pool

This feature allows operators to change the audio input assigned to a source directly from the control surface.
The audio inputs must come from a remote matrix which can be a Nova73, Nova17, Nova29 or Matrix server.

A typical application would be to create 16 tie-line sources from a Nova73, where each "matrix source" can
access one of the Nova73's input signals.

To use this feature, the TCP Link between the remote matrix and console must be configured in both
systems under “System -> Definition -> Param = TCPLink” (as KPF, GKPF or DKPF).

This feature is available for stereo sources only.

There are two parts to the configuration: the source parameters and Matrix Src Pool Logic element.

Signal Naming & Organization

To support this feature, inputs within the remote matrix must be named using the the following naming
convention: "Group:Signal". When using dynamic input switching, this provides a two-step navigation process:
first select the Group, and then browse through all available Signals within that Group. Both the Group and
Signal labels can be up to 8 characters.

By default, the signal labels are retrieved automatically from the networked router (if using NetCom or Remote
MNOPL protocols).



ON-AIR Designer Configuration Options Version: 6.6.0_1 105/325

3. 'Tree Definition' Elements

Pool Source Parameters

Start by adding some normal sources to the configuration.

1. Select the first source you wish to configure in the 'Tree Definition' and open the Parm tab.

2. Check that the Audio Input is assigned from the remote matrix (e.g. tie-line 1).

3. Configure the Nova17/MTx Server option.

Turn the option On if the remote matrix is a Nova17, Nova29 or Matrix Server.

Turn the option Off if the remote matrix is a Nova73 (for communication via Remote MNOPL).

 4. Then assign a Class/Pool number.

When using a Nova17, Nova29 or Matrix Server, the number must match the Pool ID defined in the MTx Source
Pool logic element. The pools can be used to divide signals within the matrix into different subsets. Each pool
can be accessed from several sources by assigning the same Pool number. 

When using a Nova73, enter the Class defined in the Nova73 map (as described in the "ext_router_control_en"
pdf).

5. Use the Matrix Out 1 and 2 fields to enter the matrix output number connected to the source's audio
input (in step 2).

This allows the Group and Signal labels for the output to be transferred from the remote matrix. Thus, the
operator can browse through and select the correct signal from the console surface, see Selecting a Matrix
Pool Signal.

6. Repeat steps 1 to 5 for each matrix source you wish to configure.

Note that you can leave the Class/Pool field empty if you wish to "hard-wire" an input from the remote matrix.
In this case, the label of the connected input (defined by the Matrix Out 1 number) appears in the fader strip
label display.




zirkon External Router Control via RMNOPL


Global settings in AdminHD (Nova73)
and in the zirkon-configuration


Definition of the (MADI)-Output to the zirkon
with corresponding Mapping-No.


Selection of an audio input in an external router (Nova73) to a zirkon
source, with audiorouting, label inhertiance and control of the
microphone parameters through the RMNOPL protocol.


Idea:


Concept:


01.08.2005 / Str., Ueb.


Restrictions:


Zirkon.exe         >= 2.5.24
Ticker.bin           >= 2.5.1133
Pathfinder.exe   >=  v1.11


Versions:


The inputs of the Nova73 that should be accessible by the zirkon need
to be configured with “Label” and a special “Mapping-No” in Admin-HD.
The Mapping table no that is used in Admin-HD corresponds to the “Map”
entry in the zirkon configuration. The audio tieline to the zirkon has to be
defined as a “Mapping-No”. The same number has to be used in the zirkon
source configuration as “Matrix-Input”.
In addition you have to define which class (”class”) of Nova73 inputs may
be used by a zirkon source. The mic- and mono/stereo settings of the
selected Nova73 input are transfered to the zirkon by RMNOPL.


Zirkon


Dallis-I/O Nova73


Ethernet-Switch


Remote MNOPL-Protocol


MADI


MADI including Mic-Control


Source-Definition in the zirkon with Reference to:


the zirkon (MADI)-Input,
the (MADI)-Output of the Nova73 connected to thez irkon, and
the signal class, from whitch the Nova73 Inputs


can be selected.


Definition of the Nova73 inputs with label and
corresponding Mapping-No.


Setting of Mapping-Table-No.
(Only 1 Mapping-Table entry per zirkon!!!
Multiple zirkons can access the same
Mapping-Table)


Functionof the mapping-No. (0x cc gg ss tt ):


cc  = class      (e.g. "01") -> defined in the zirkon-configuration
gg  = group   (e.g. "03") -> selection in the channel
ss  = signalno. (e.g. "01") -> selection in the channel
tt    = type         (e.g. "00") -> left or mono ("01"=right)


“Class”, “group” and “signal” numbers have to start at “01” and must
not have gaps in numbering,.





ext_router_control_en.pdf
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Matrix Source Pool Logic Element

"Logic -> MTx Src Pool"

The MTx Src Pool element defines the functionality of the Matrix Source Pools. Each pool can contain up to 64
signals. The element is defined under the "Logic" branch of the 'Tree Definition':

MTx Src Pool Reference name for the element.

Pool ID Enter the number for the matrix source pool. This must be a unique reference number. This
links the element to sources with a matching Class/Pool number.

Src 01, Src 02. etc. Enter the matrix address numbers for each remote input you wish to add to the source pool.
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Selecting a Signal from the Surface

Group & Signal Select Fader Label Display

1. Press down on the fader strip rotary control to step through the input parameters until you reach the
signal selection menu.

The display shows either the current Group and Signal name, or the text "not in pool".

2. Turn the rotary control to scroll through the available signal Groups and press down to make a
selection.

3. Turn the rotary control again to scroll through all available Signals with the Group.

4. Once you are happy with the selection, press the Take button to assign the signal - the fader label
display updates accordingly.

In our example, the three lines of text show the following information:

· MADI = the Group name (defined in the remote matrix).

· In 3 = the Signal name (defined in the remote matrix).

· Nova17 = the source Display Name (defined in the configuration).

3.12.22 MUX/DEMUX 8

"Logic -> MUX/DEMUX 8"

The Mux/Demux8 element creates a 1-to-8 de-multiplexer and four 8-to-1 multiplexers. This is a project-specific
feature. Please contact your local Lawo representative for further details.
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3.12.23 NOT

"Logic -> NOT"

A NOT element is a simple logical gate for inverting a control signal:

outin

Truth Table

in out

0 1

1 0

You can create a logical function whose result will always equal logical “1” by creating a NOT logic element
with no input. The result of this will always be true, and therefore can be applied to parameters which need
to be forced to true (logical “1”) as a default.

General Parameters

NOT Reference name for the element.

In Assigns the input signal to be inverted.

The control output appears under the “Logic -> <GroupName> -> NOT” branch of the 'Tree Selection' window:

Out The NOT output.
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3.12.24 On Air Arbiter

"Logic -> On Air Arbiter"

The On Air Arbiter element is a 1-out-of-8 selector switch designed for transmission line arbitration. 

Up to 8 input (Key) signals can be defined, each with its own Enabled, Prepared, Blink and Active output.
The operation is as follows:

1. Before an output can be made active, the corresponding Enable input signal must be True. 

This allows you to protect the entire selector or individual outputs.

2. Once the Enable input is true, an operator can press and hold the corresponding Unlock button and
press the Key button in order to prepare an output. 

3. The operator must then press the Key button again to activate the output.

The output can only be activated if no other outputs are already active. 

4. The output is deactivated if the Enable input signal becomes False.

This element controls the logic of the selector only and not the audio crosspoints.

Alternative elements are the Feedback Arbiter which is simpler in operation, and the Enable Func which
provides signalisation but not arbitration.

General Parameters

On Air Arbiter Reference name for the element.

X – Unlock Assigns the Unlock MF Key (or control input).

Key Assigns the MF Key (or control input) which will prepare output x. The Key can only be
selected if the Enable AND Unlock signals are true.

Enable Assigns the Enable control signal. Unless this signal is true (static) the corresponding output
cannot be prepared or activated.

The outputs appear under the “Logic -> <GroupName> -> OnAir Arbiter” branch of the ‘Tree Selection’
window:

x Enabled True if the Enable input if True

x Prepared True if the Enable AND Unlock AND Key inputs are true

x Active True if the Prepared output AND Enabled AND Key inputs are True

x Blink  True if the Prepared output AND any other Active output are True.

nActive True if no output is active.

3.12.25 OR32

"Logic -> OR32"

The OR32 element is identical to the OR8 but offers 32 inputs.
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3.12.26 OR8

"Logic -> OR8"

An OR8 element is a logical OR gate which offers 8 inputs. It can be used to ‘OR’ several signals:

in 1

in 2

in 3

in 4
in 5

in 6

in 7

in 8

out

nout in 3 Pulse

in 1

in 4 Neg

out

t

in 2

Truth Table

in 1 in 2 in 3 in 4 in 5 in 6 in 7 in 8 out nout

0 0 0 0 0 0 0 0 0 1

1 x x x x x x x 1 0

x 1 x x x x x x 1 0

x x 1 x x x x x 1 0

x x x 1 x x x x 1 0

x x x x 1 x x x 1 0

x x x x x 1 x x 1 0

x x x x x x 1 x 1 0

x x x x x x x 1 1 0

General Parameters

OR8 Reference name for the element.

In 1 to 8 Assigns input signals to each of the 8 inputs which are to be OR’d. Inputs which are not
assigned are set to logical “0” or “FALSE”.

Neg When checked, the input is inverted before being processed by the OR gate.

Pulse When checked, the input generates a pulse (of 32.5ms duration) before being processed by
the OR gate. Use this option to convert a static signal to a pulse.

The control outputs appear under the “Logic -> <GroupName> -> OR8” branch of the 'Tree Selection' window:

Out The OR output.

nOut Negated OR.
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3.12.27 PRIO

"Logic -> PRIO"

The PRIO element is similar to a Button 16 but with prioritised switching. It can be be used to create inter-
cancelling button groups, where signal prioritisation is required. The element includes 16 inputs and 16 outputs,
where In 1 has lowest priority and In 16 highest priority. 

For example: If In 1 is set to a logical “1”, and all other inputs set to “0”, then Out 1 is active and all other
outputs are set to “0”. If In 3 then becomes set to a logical “1”, Out 3 becomes active and Out 1 is set back to
logical “0”. If In 1 and In 3 are both set to logical “1”, then In 3 has higher priority so Out 3 is the active output.

General Parameters

PRIO Reference name for the element.

In 1 to 16 A rising edge at an input sets the corresponding control output to logical “1”, and any other
active control output to logical “0” providing it is of a lower priority. 

In 16 has highest priority.

The control outputs appear under the “Logic -> <GroupName> -> PRIO” branch of the 'Tree Selection' window.

The default state after power on is logical “0” on all outputs.

3.12.28 RAVENNA Src Pool

This feature allows operators to change the stream assigned to a RAVENNA source directly from the control
surface. There are two parts to the configuration: the RAVENNA Source parameters and RAVENNA Src Pool
Logic element.
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Stream Naming & Organization

To support this feature, streams must be announced to the network using the following naming convention:
"Group:Stream". When using dynamic input switching, this provides a two-step navigation process: first select
the Group, and then browse through all available Streams within that Group. Both the Group and Stream labels
can be up to 8 characters.

By default, the labels are retrieved automatically from the network. Streams with the same Group name are
combined into a single Group even if they are provided by different devices. The list presented to the operator
is updated automatically so that newly discovered streams are added, and streams which can no longer be
detected are erased. To prevent access to certain streams, filters can be applied in the configuration.

In cases where streams cannot be named using the above convention, it is possible to map specific streams to
pre-configured labels. In this instance, the list of streams presented to the operator is fixed and is independent
of stream availability.

RAVENNA Source Parameters

Start by adding some RAVENNA Sources to the configuration.

1. Select the first source you wish to configure in the 'Tree Definition' and open the Parm tab.

2. Check that the Audio Input is assigned from a RAVENNA streaming input.

3. Turn the RAVENNA option ON to enable the RAVENNA Pool stream selector. 

4. Then assign a RAVENNA Pool No. from 1 to 6. This must match the Pool No. defined in the
RAVENNA Src Pool Logic element.

The pools can be used to divide streams into different subsets. Each pool can be accessed from several
RAVENNA sources by assigning the same RAVENNA Pool No. To present the operator with a single pool of
streams, you can use the None option.

5. Repeat steps 1 to 4 for each RAVENNA source.
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RAVENNA Src Pool Logic Element

"Logic -> RAVENNA Src Pool"

The RAVENNA Src Pool element defines the functionality of the RAVENNA Source Pools, whether they be
static or dynamic and the application of filters. Up to 6 independent pools can be defined. The element is
defined under the "Logic" branch of the 'Tree Definition':

RAVENNA Src Pool Reference name for the element.

Pool No. Enter the RAVENNA Source Pool number: None or 1 to 6. This links the element to
RAVENNA Sources with a matching RAVENNA Pool No.

Pool Type Static or Dynamic:

· Dynamic is the more typical choice (shown above). It allows the pool to adjust dynamically
to a changing stream structure.

· When Static is selected, two additional tabs appear where you can define fixed labels for
up to 64 streams.

Node Name Filter Enter a node name filter to limit access to streams from a certain node, or enter the wildcard
(*) to display streams from all nodes.

Node names can be seen in the Web UI. 

Stream Group/Name Filter Enter the filter ":" to use the recommended stream naming convention
"StreamGroup:StreamName". 

Other filters are possible.

Stream Size Filter Apply a stream size filter to limit access to streams of a certain channel size: None (all
formats), 1 (mono), 2 (stereo) or 8 (multi-channel).

Reload Pool Enter a control signal to reload (refresh) the streams in the pool from the network.
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If the Pool Type is set to Static, then the "Static Source List" pages appear. These can be used to define a
fixed Group and Name label for up to 64 streams on the network. If the pool works in this mode, then the list of
streams presented to the operator is fixed (static), and is independent of stream availability.

Local Group Enter a Group label for the stream.

Local Name Enter a Name label for the stream.

RAVENNA Source Label Enter the name of the stream (as it is announced to the network).

Selecting a Stream from the Surface

Group & Stream Select Fader Label Display

1. Press down on the fader strip rotary control to step through the input parameters until you reach the
stream selection menu.

The display shows either the current Group and Stream name, or the text "not in pool".

2. Turn the rotary control to scroll through the available Groups and press down to make a selection.

3. Turn the rotary control again to scroll through all available Streams with that Group. 

If your network supports dynamic stream detection, then the list of available streams updates automatically.

4. Once you are happy with the selection, press the Take button to start the subscription process.

There will be a brief pause in the audio while the streaming connection is configured. During this time, the
connection status is shown in the fader label display. The display updates to show the stream name once the
subscription is successful.

In our example, the three lines of text show the following information:

· REWORK = the Group name (detected from the network).

· CODEC 3 =  the Stream name (detected from the network).

· RAV 01 = the source Display Name (defined in the configuration).
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Stream Subscription: Status Messages

Whenever you subscribe to a stream, the fader strip label display reports back on the status of the connection.

Under normal circumstances, the expected sequence of messages is as follows:

"Mute" -> select a stream and press Take -> ("Pending") -> "Tuning" -> ("Unstable") -> "<Stream-Name>"

Note that messages shown in () may or may not appear. The table below explains the meaning of each
message in more detail.

Status Message Meaning

"Mute" No stream is connected to the source's RAVENNA input.

ACTION: select a stream via the rotary control and press TAKE.

("Pending") Appears IF the connected stream is not yet available. In this instance, the console will wait for the
stream announcement to appear on the network, and then automatically initiate the subscription
process. 

Typically, this message does not appear when selecting a stream from a RAVENNA source pool,
as the list presented to the operator is constantly updated (in the background). 

The message can appear if the source has been configured using a default subscription, if a
stream is connected via VSM, or following a warmstart while restoring the last known connection.

"Tuning" Appears while the console measures the streaming quality, and sets its stream receiving
parameters to ensure correct audio playback. 

During the tuning cycle the audio input is muted, and then unmuted once the task is complete.

If a stream is being received for the first time, then the tuning process can take a couple of
seconds. This initial tuning information is stored in a permanent memory. It is then used whenever
you select the same stream, thereby speeding up all subsequent connections.

("Unstable") Appears IF the stream jitter is extremely high and cannot be dealt with; IF the stream stops for
some reason; or IF the PTP clock information is missing. You can open the RAVENNA pages (in
the Web UI) to view additional information on specifics.

In this instance, the console will attempt to heal itself, and mute the audio input until the stream
reaches stable conditions.

Typically, it is very rare to see this message during the subscription phase.

If an unstable stream is due to a PTP problem, then console will start a new “Tuning” cycle before
the audio input is unmuted.

"<Stream-Name>" Once the subscription is successful, the name of the connected stream is displayed.

On rare occasions, the following error messages may also appear:

Status Message Meaning

"PoolErr" Appears IF there is a problem connecting to the stream. 

This can occur if the selected stream is not available on the network any longer, but is still
presented in the console's list of streams. Since this list is updated cyclically, the problem should
not persist. 

If you see this error, please repeat the subscription process. If the issue persists, check your
network settings.

The audio input will be muted while the error message is displayed.

"RavErr" Appears IF there is an invalid combination of status flags for the RAVENNA stream.

Since the flags are updated cyclically, the error should heal itself. If the issue persists, then check
the RAVENNA pages (in the Web UI).

The audio input will be muted while the error message is displayed.
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3.12.29 RAVENNA Static Stream

"Logic -> RAVENNA Static Stream"

This element can be used to configure a RAVENNA static stream. It is supported by Power Core systems only. 

General Parameters

The parameters vary depending on the Connection Mode, which can be set to either RTSP URL or Stream
Parameters.

Connection Mode = RTSP URL

RAVENNA Static Stream Reference name for the element.

Disabled Disables the transmission of the stream.

Connection Mode Sets the connection mode.

RTSP IP Address 1, 2 Enter the IP address for the RTSP URL.

RTSP Port No. Enter the port number for the RTSP URL.

Stream Name Enter the stream name. The maximum length is 8 characters. 

If the stream is to be displayed on another ruby surface in a channel list, then the stream
name must use the format [GroupName]:[SignalName], where each label field is a maximum
of 8 characters. See RAVENNA Pool Sources.
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Connection Mode = Stream Parameter

RAVENNA Static Stream Reference name for the element.

Disabled Disables the transmission of the stream.

Connection Mode Sets the connection mode.

Stream Name Enter the stream name. The maximum length is 8 characters. 

If the stream is to be displayed on another ruby surface in a channel list, then the stream
name must use the format [GroupName]:[SignalName], where each label field is a maximum
of 8 characters. See RAVENNA Pool Sources.

Stream Size Defines the number of audio channels used by the stream.

Samples per Frame Sets the number of samples included in each Ethernet Frame. A frame is the payload being
carried over the Ethernet link. The default value is 32.

Codec Selects the type of codec used for the stream: Linear 16, 24 or 32 bits; or AM824 (a
packetized AES signal that includes all user and status bits).

Multicast IP Address Enter the multicast address. If the field is left blank, then a default multicast address is
assigned. These fields provide your network architect with the ability to implement a specific
IP multicast schema for your facility.

Multicast Src IP Address Enter the multicast source address.

Multicast UDP Port No. Reserved for Unicast. The default value is 5004.

RTP Payload Type Defines the RTP payload. The default value is 98.

FIxed Jitter Reserve
(Samples)

Can be used to define a fixed Time Offset for the stream (applied by the receiver during
stream tuning).

By default, the value is set to 0 (none) so that the stream is tuned as normal: either
automatically or manually via the Power Core Web UI. See Stream Tuning.

If a non-zero value is entered, then a fixed Time Offset is applied. See Defining a Fixed Time
Offset.
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3.12.30 RAVENNA Stream Control

"Logic -> RAVENNA Stream Control"

This element can be used to configure redundancy for specific RAVENNA inputs. It is supported by Power
Core systems only.

Primary and backup streams are specified such that if the primary stream is lost or becomes unknown, then
the backup stream will be connected.

For example, if the Main Stream Name (MSTR:Stream01) is lost, then within 30 seconds the Backup Stream
Name (BKUP:Stream02) will be subscribed. In addition, you can use the Auto Connect control signal to
ensure that the Main Stream (or Backup Stream) is always subscribed.

RAVENNA Stream Control Reference name for the element.

Input (RAV Core Out) Enter the input that will be used to subscribe to the streams from the network.

Main Stream Name Enter the name of the Primary or Main stream exactly as it appears in the network. 

Backup Stream Name Enter the name of the Backup or Alternate stream exactly as it appears in the network. 

Stream Connect Timeout
in seconds

Enter a value from 1 to 300.

Alarm Logging Enabled Enable whether these connections shall be logged via the Alarm Log Server.

Auto Connect Use this input to ensure that no other undefined streams may be subscribed to this Input. Any
attempt to subscribe to a different stream will cause the Main Stream to be subscribed
instead.

Force Main Stream
Connect

Forces the Main stream to be connected.

Force Backup Stream
Connect

Forces the Backup stream to be connected.
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The outputs appear under the "Logic" branch of the ‘Tree Selection’ window:

RAVENNA Stream Control Reference name for the element.

Waiting for Stream Waiting for the stream to connect.

Stream Unstable The stream connection is unstable.

Main Stream connected The Main stream is connected.

Backup Stream connected The Backup stream is connected.

Auto Connect active Auto Connect active is true.

Force Main Stream active Force Main Stream active logic is true.

Force Backup Stream
active

Force Backup Stream active logic is true.
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3.12.31 Server based Timer

"Logic -> Server based Timer"

Server-based timers can be used to synchronize the operation across multiple VisTools. If a parameter such as
the timer direction, preset or alarm time is changed from one VisTool, then this is displayed in the other
instances. The displayed time is also synchronized. 

Up to 32 independent server-based timers can be configured.

1. Start by adding a Server based Timer element to the Logic branch of the 'Tree Definition', and enter a
Timer ID number from 1 to 32. 

You can use the remaining fields to define how the timer is triggered.

ON-AIR Designer Server-based Timer (ID 32)

2. Then open VisTool Editor and insert a Server based Timer element in the usual manner.

Edit the Timer ID in the 'Properties' panel to match the one entered in the ON-AIR Designer:

VisTool Editor Server-based Timer (linked to Timer 32)
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3.12.32 ShiftReg 16

"Logic -> ShiftReg 16"

A ShiftReg16 element is a logical shift register with 16 outputs. It operates as a series of flip flops with 16
parallel outputs, where the output of one flip-flop is connected to the input of the next. They share a single clock
signal which causes the data to shift from one flip-flop to the next. By connecting the last flip-flop back to the
first, using Ring Mode, the data can cycle for extended periods.

General Parameters

ShiftReg 16 Enter a reference name for the element.

Input (static) Assigns the data input which you wish to process.

Clock (pos. edge) Assigns the clock source. If you leave this field empty, then the system clock will be used
(approximately 60Hz).

Reset (static) Sets all outputs to be false as long as Reset Static is active.

Ring Mode Enable this option to connect the output of the last flip-flop back to the first (to cycle the data).

The control outputs appear under the “Logic -> <GroupName> -> ShiftReg 16” branch of the 'Tree Selection'
window:

Output 1 to 16 The positive outputs 1 to 16.

nOutput 1 to 16 The negated outputs 1 to 16.
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3.12.33 Static Network Route

"Logic -> Static Network Route"

This element can be used to configure a static network route for the streaming ports (ra0 & ra1) or control ports
(dwc0 & dwc1). It is supported by Power Core systems only.

General Parameters

Static Network Route Enter a reference name for the element.

Disabled Use this checkbox to disable the route.

Device Group Select the network interfaces which will be affected. You can choose either the streaming
ports (ra0 & ra1) or control ports (dwc0 & dwc1).

Route Type Select the type of route: either Host or Subnet.

Host Name / IP Address Enter the host name and IP address.

Gateway Name / IP
Address

Enter the gateway name and IP address.
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3.12.34 TB State

"Logic -> TB State"

The TB State element can be used for talkback state signalisation. For example, to illuminate a TB key when
another studio is calling.

General Parameters

TB State Reference name for the element.

Key Assigns the MF Key you wish to use to signalise the talkback state.

In Assigns the logic control signal for the incoming call.

Afterglow (sec) Enter the time in seconds before the key light will extinguish after the incoming call has
ceased. Note that this time is approximate.

The control outputs appear under the “Logic -> <GroupName> -> TB State” branch of the 'Tree Selection'
window:

out.active True when the Key is active (i.e. the TB button is pressed). 

in.active True when the incoming call (In control signal) or Afterglow are active.

enable True when the Key is not is use (i.e. TB is not in use.)
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3.12.35 Text Prio

"Logic -> Text Prio"

The Text Prio element can be used to dynamically change the labels on any key panel with LCD buttons.

LCD buttons may also be dynamically re-labeled using the zirkonlabel software.

Each label can display two lines of text (Text A and Text B), or displays a source/sum Label, and be switched
between 16 text strings using logical control inputs.

General Parameters

Text Prio Enter a reference name for the element.

In 1 to In 16 Assigns input control signals for the text strings 1 to 16. The control signals are prioritised
from 1 (highest) to 16 (lowest) if more than one input is active. 

Text A Enter the text which will appear in Line 1 of the LCD button label when its control input is
active. Up to 6 characters. 

Text B Enter the text which will appear in Line 2 of the LCD button label when its control input is
active. Up to 6 characters.

Label Assigns the source or sum label which will appear on the LCD button when its control input is
active.This field replaces Text A and Text B if assigned.
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Once named, the Text Prio output (Text Out) appears within the ‘Tree Selection’ when assigning a Label
parameter. This allows it to be assigned to the Label ID of a key panel LCD button. The button label will then
follow the definitions made within the Text Prio logic element:



ON-AIR Designer Configuration OptionsVersion: 6.6.0_1126/325

3. 'Tree Definition' Elements

3.12.36 TFF (Toggle Flip Flop)

"Logic -> TFF"

A TFF element is a Toggle Flip Flop. When a positive edge arrives at the input signal, this triggers a change of
state at the output. A common application is to create a latching MF Key.

General Parameters

TFF Reference name for the element.

Toggle Assigns the input control signal to be toggled.

Reset Static This input control signal will force a reset (i.e. set the control output to “0”). The reset is active
as long as the input control signal = logical “1”.

Set Static As above, but this time the control output is set to “1”.

Reset Pos Edge This input control signal will force a reset (i.e. set the control output to “0”). The reset is
triggered from the rising edge of the input control signal.

Set Pos Edge As above, but this time the control output is set to “1”.

The control outputs appear under the “Logic -> <GroupName> -> TFF” branch of the 'Tree Selection' window:

Out The TFF output.

nOut Negated TFF.
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3.12.37 VispageSwitch

"Logic -> VispageSwitch"

A VispageSwitch element can be used to configure MF Keys, or other control signals, to action VisTool logical
functions. For example, to create page switching buttons, snapshot save/load/delete and User Access Rights. 

VispageSwitch elements are added to the "Logic" branch of the 'Tree Definition'. You should define an element
for each VisTool screen, and set the Station ID to match the Station ID defined in VisTool's Session
Management window. Any VisTool screen set to a matching Station ID will then respond to the VispageSwitch
functions.

To enable VisTool page switching and snapshot functions you must tick the EnablePageKey and
EnableLoadSave checkboxes within the VisTool Editor "Global Settings" window.

VisTool page switching and snapshot functions can also be configured using the “System -> Definition ->
Parameter = Screen” and "System -> Definition -> Parameter = Snapshot" elements. These methods
switch all VisTool screens regardless of their Station ID.

The Nova29 does not support snapshots.

Each VispageSwitch element supports four sets of parameters: Logic, Snapshots, Rights and Labels.

VispageSwitch -> Logic Parameters

Vispage

Switch

Reference name for the element.

Station ID Assigns an ID number to the element. Any VisTool screen set to a matching Station ID (in
VisTool Sessions) will respond to the VispageSwitch functions.
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Access Group This option assigns an Access Group to the element. Access Groups are supported by Power
Core Max to link the control surface ACCESS keys to different VisTool instances. Any Fader
Modules set to a matching Access Group will respond to the corresponding VispageSwitch
functions.

Default Page This page appears on the VisTool screen following a cold start of the remote system. 

You should enter the number which corresponds to the page index within the VisTool Editor
configuration.

Clear Rights on Start If checked, defined user rights are reset after a warm start (e.g. a power cycle). If not checked,
user rights will remain intact.

Note that you must be using VisTool MK2 to support the user rights system.

Load PC Snap When this control signal is active, a window opens on the VisTool screen to load a snapshot.

Save PC Snap As above, but to save a snapshot.

Delete PC Snap As above, but to delete a snapshot.

Save PC Source Snap As above, but to save a source snapshot.

PC Log-In When this control signal is active, the user log in window opens on the VisTool screen. You
must activate this function to provide access to the user rights supported by VisTool MK2.

The function should only be active on a single VisTool screen - i.e. for one VispageSwitch
element mapped to one Station Id.

PC Log-Out As above, but the control signal logouts the current user.

Edit PC Labels When this control signal is active, the user label edit window opens on the VisTool screen.

Application Full Screen Sets the application to full screen view. 

Application WindowPos Toggles the application between full screen and minimized. 

Application Minimize Minimizes the application. 

Application Close Closes the application.

Mute RFID Tag Reader Mutes the RFID Tag Reader.

The RFID Tag Reader is an optional Add On for VisTool MK2 which permits user login via an
RFID tag. This control signal can be used to mute the reader.

Disable RFID Tag Reader As above, but the control signal disables the RFID Tag Reader.

Select 1 to 32 When the Select 1 control signal is active, the VisTool screen is switched to page 1, where
page 1 is the page index within the VisTool Editor configuration.

When the Select 2 control signal is active, the VisTool screen is switched to page 2.

And so on up to page 32.

The following control outputs appear under “Logic -> <GroupName> -> VispageSwitch” in the 'Tree Selection'
window:

Selected 1 True when Page 1 is selected.

Selected 2 True when Page 2 is selected.

etc. Etc. up to 32.

Use the Selected 1 to 32 outputs as feedback to the control signal (for example, to light the MF Key which
switched the page).
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VispageSwitch -> Snapshot Parameters

These parameters assign control signals to the nine Global/Channel snapshot buttons:

Global Snapshot 

1 to 9

When this control signal is active, the corresponding global snapshot is loaded. 

The 9 Global Snapshot buttons can load any Full snapshot. The assignment of snapshots to
buttons is made in the Edit Snaps window.

Channel Snapshot 

1 to 9

As above, but Channel snapshot buttons can load any Src snapshot with a matching Class
field.

The control outputs appear under “Logic -> <GroupName> -> VispageSwitch” in the 'Tree Selection' window:

GlbSnap n defined True when global Snapshot n is defined within the user rights system supported by VisTool
MK2.

ChanSnap n defined True when channel Snapshot n is defined within the user rights system supported by VisTool
MK2.
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VispageSwitch -> Rights Parameters

These parameters name each of the user access rights supported by VisTool MK2.

You should only name Rights for the same VispageSwitch element which opens the user log-in window (via
PC Log-In). Otherwise you will not be able to access the rights from the user management Admin pages!

The name in the 'Tree Definition' is a reference name only; up to 32 Rights may be defined:

Once named, the control outputs appear under “Logic -> <GroupName> -> Right” in the 'Tree Selection' window.
For each right, there are two states: granted and denied:

Right 1 Granted True when user permission is granted (defined by the User Group Rights administrator).

Right 1 Denied True when user permission is denied.

etc. etc. up to 32.
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Example of "Rights" Configuration

The naming of the user "Right" simply makes it appear in the User Group Rights Admin pages. To define what
each "Right" does, you must configure the appropriate 'Tree Definition' functions. 

In our example, Right 3 (named Access Enable) allows permitted users to select the ACCESS button. If users
are denied access to this right, then they cannot select ACCESS and the source cannot be assigned to the
center section.

To configure this example, assign the Denied control output for user Right 3 to the Access User Off function. If
you wish to apply this to every source and sum bus, then repeat for every source and sum in the configuration:
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VispageSwitch -> Labels Parameters

These parameters can be used to label the 32 user Rights described earlier.
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3.12.38 Screen Matrix TB

VisTool runtime (example)

Using a VisTool Talkback Matrix, up to 256 keys can be defined, each feeding up to two mono or stereo
destinations. Each key has a default audio source which can be interrupted momentarily by mono talkback
(from any VisTool station 1 to 4).

ON-Air Designer Configuration

1. Add a Screen Matrix TB module to slot 11 of the Frame -> Screen configuration.

2. Double-click on the module and name the panel from its General tab. 

3. Enter the matrix address of the talkback source for your VisTool stations. Up to four talkback sources
can be assigned, corresponding to VisTool Station ID 1 to 4:

4. Using the remaining tabs (TB 001..064, etc.) enter the matrix address of each default Source (mono)
and its Destinations. 

If the Stereo box is checked, then both Destinations are stereo; enter the address of the left destination, the
right destination is always + 1.

You can define up to 256 talkback keys, each with a default mono source and two stereo destinations.

The matrix addresses can refer to either an internal or external address. To address an external matrix, the TCP
Link under “System -> Definition -> Param = TCPLink” must be set for KPF, GKPF or DKPF.
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VisTool Editor Configuration

1. Add some Box elements to a page. 

2. Right-click on the element, and open up the MF Key -> Screen Matrix TB branch. Select the talkback
key you wish to assign to the VisTool button:

3. Remember to save the project, and switch to Test mode to test the talkback switching.

When creating the VisTool session, the Station ID must be set to 1 to 4.
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3.12.39 Screen Matrix Monitor

VisTool runtime (example)

Using a VisTool Monitor Matrix, mono or stereo sources can be switched to stereo sinks (destinations).

ON-Air Designer Configuration

1. Add a Screen Matrix Monitor module to slot 12 of the Frame -> Screen configuration.

2. Double-click on the module and name the panel from its General tab:

3. Using the remaining tabs (Sources Mono, Sources Stereo 1, etc.) enter the matrix address of each
Source and Sink.

The matrix addresses can refer to either an internal or external address. To address an external matrix, the TCP
Link under “System -> Definition -> Param = TCPLink” must be set for KPF, GKPF or DKPF.
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VisTool Editor Configuration

1. Add some Box elements to a page. 

2. Right-click on the element, open the MF Key -> Screen Matrix Monitor branch, and select the source
or sink you wish to assign to the VisTool button:

3. Remember to save the project and switch to Test mode to test the monitor matrix.

When creating the VisTool session, the Station ID must be set to 1 to 4.
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3.12.40 Matrix Control 128 * 128

"Logic -> Matrix Control 128*128"

This element provides an XY matrix with 128 x 128 crosspoints which can be operated from VisTool MF Keys.
To use this feature you will need to add a Matrix Control 128*128 module to the Screen configuration. Then
define the module's parameters as follows.

Global Parameters

Matrix Reference name for the element.

External Select this checkbox if the matrix to be controlled is external (i.e. not within the system frame).

External Protocol Type If External is ticked, select the communication protocol type:

· CAN over TCP/IP - for sapphire, crystal, Nova29 or Power Core.

· MNOPL - for mc2/Nova73.

· EmBER+ - for supporting EmBER+ devices.

Ember+ Matrix Nr When using Ember+, you must enter an Ember+ Matrix number (from 1 to 5). This
references the Ember+ Matrix element (which defines the local consumer number, external
matrix type, matrix name, etc.)

Feedback Mode When selected, the operator only needs to select the destination and action Take. A
connection is made automatically from the corresponding source. For example, Src Page 1
Matrix Nr 01 to Dest Page 1 Matrix Nr 01.

Src always green When this option is off, the source MF Key on VisTool changes color to indicate the
connection status: red = connected; green = disconnected.

Turn the option on to override the color-coding so that the source MF Key always lights in
green.

Take Use this field to assign the ‘TAKE’ control signal. This makes the connection once a source
and destination are prepared.

Reset Selection This control signal cancels any pre-selections made.

Select Reset Time This is the amount of time for which selected sources remain in pre-selection before they are
canceled. The time resets after each selection. 

For example, if the Select Reset Time is set to 5 seconds, the operator has 5 seconds in
which to select the next source before the first selection is canceled. They then have another
5 seconds to select the next source, and so on. 
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Src and Dest Parameters

Matrix No xx Enter the address of the matrix input or output (see Matrix Numbers; 0 = silence).

Type: Stereo Select this checkbox if the source or destination is stereo.

Active Select this checkbox to see the source or destination labels on the VisTool MF Key. 
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3.12.41 Matrix Control

"Logic -> Matrix Control"

This element is similar to the Matrix 128 * 128 but supports 90 x 30 crosspoints and adds protection for specific
or connected crosspoints. 

Most of the parameters are identical to the Matrix Control 128*128, with the following exceptions:

Global Parameters

Auto Protect When selected, any destinations which are connected are automatically protected so that they
cannot be changed by another system. 

Protect Dst01 to Dst30 Use these fields to protect specific crosspoints so that they cannot be changed by another
system. 
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3.12.42 Network Assign

"Logic -> Network Assign"

The Network Assign system is designed to manage the assignment of matrix signals to different Network
transmission feeds within a networked installation. In the example below, three studios can be assigned to up to
three Local Lines within three Networks:

The system can support up to 13 studios divided into 12 Networks and 9 Local lines. The assignments are then
controlled from VisTool screen buttons.

To use this feature you will need to add a Network Assign Module to slot 13 of the Screen configuration on
each of the networked systems. Then define the module's parameters as follows.

General Parameters

Network Assign Enter a reference name for the Matrix Module.
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Kpf Parameters

External Select this checkbox if the matrix input address is external (i.e. not within the System Core.)

MNOPL Select this checkbox if the module is to be controlled via the MNOPL protocol.

Matrix Input This is the matrix input number within the Nova73 where the studio is connected. See Matrix
Numbers.

NW 1-1, 1-2, 1-3, etc. These addresses set the matrix output numbers for the connection to each Nova17.

Network & Local Parameters

NW Timeout Enter the time (in seconds) after which the preselected network will be cancelled.

NW-1 Text, NW-2 Text,
etc. 

Enter the text which will appear on the VisTool Network selection buttons during operation.

L Timeout Enter the time (in seconds) after which the preselected local line will be cancelled.

L-1 Text, L-2 Text, etc. Enter the text which will appear on the VisTool Local Line selection buttons during operation.
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3.12.43 Screen Src Assign

The buttons on a Screen Source Assign module can be used to perform fader strip assignments from a
VisTool runtime GUI.

The assignment always works on the fader in access, and so you may wish to add some ACCESS keys to the
VisTool page (as described later). The configuration requires two stages: first use the ON-AIR Designer to
prepare the system configuration, and then use VisTool Editor to edit the VisTool project.

ON-Air Designer Configuration

1. Add a Screen Src Control panel to slot 14 of the Screen configuration.

2. Name the panel from its General parameters tab:

If the Swap Colors option is enabled, then the on-screen "Assign Src" button in VisTool will use more colors to
indicate the fader strip assign status. These are described later.

3. Select the Screen Src Control module from the "Logic" branch of the 'Tree Definition' and assign the
sources you wish to make available for VisTool assignment from the Src Page parameter tabs.

You can define up to 192 sources.
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Then assign the signal which will be used for the signalisation of the VisTool element - the "Source.Assigned"
output is normally used:
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VisTool Editor Configuration

1. Add some Box elements to a page.

2. Right-click on a button, and open up the MF Key -> Screen Src Assign branch. Note that any
functions which have already been used are highlighted in green.

First, add the three buttons which will action the "fader assign" mode:

· Assign Src - mimics a double-press of the console's ACCESS key. This puts the current fader in
access into "fader assign" mode. Once active, you can choose a source using a source select button
(see below), press Cancel to cancel the operation, or press Remove Src to remove the current
source.

· Cancel - cancels an active Assign Src operation.

· Remove Src - removes the source from the fader in access and leaves it unassigned. 

Then, add the source select buttons (Src001, Src002, etc.). Each of these relates to the Screen sources
defined earlier by the ON-AIR Designer - in our example, Src002 corresponds to our MIC_2 source:

As you assign each button, it updates to show the assigned function. Edit the User Text property to define the
name displayed on the VisTool screen.

3. Remember to save the project and switch to Test mode to test the fader strip assignments.

If the Swap Colors option is enabled in the ON-AIR Designer, then the on-screen "Assign Src" button shows
four states:

· Red (P4) = fader result start (i.e. fader open).

· Yellow (P3) = configured signal active.

· Green (P2) = source assigned to fader.

· Black (P1) = true.

If the Swap Colors option is disabled, then only the last two states are shown:

· Green (P2) = source assigned to fader.

· Black (P1) = true.
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3.12.44 PARM Control Module

The buttons on a PARM Control module can be used to adjust signal processing parameters from a VisTool
runtime GUI.

The controls always work on the fader in access, and so you may wish to add some ACCESS keys to the
VisTool page (as described later). PARM MF Keys are usually combined with Access Source Information to
provide feedback on the source and its parameter values. The configuration requires two stages: first use the
ON-AIR Designer to prepare the system configuration, and then use VisTool Editor to edit the VisTool project.

ON-Air Designer Configuration

1. Add a PARM Control panel to slot 15 of the Screen configuration.

2. Name the panel from its General tab:

VisTool Editor Configuration

1. Add some Box elements to a page.

2. Right-click on a button, and open up the MF Key -> Parm Control branch. Select the parameter you
wish to assign to the VisTool button - there are many options including Aux on/off and +/- for most DSP
parameters:

As you assign each button, it updates to show the name of the function.

The Access 01 to Access 40 options are for backwards compatibility only. To assign the Access key for a
fader strip to a VisTool button use the method described below.

3. Remember to save the project and switch to Test mode to test your parameter control.
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3.13 MF Key

The "MF Key" branch of the ‘Tree Definition’ provides access to MF Key parameters for the:

· Central and Monitor Modules (including Extensions)

· Key Panels 

· Screen Button Modules

The same parameters can be accessed by double-clicking on the module in the Frame -> Surface or Frame ->
Panels configuration.

MF Keys on Fader Modules do not appear here as they are defined in the Source configuration.
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Keys Parameters

The MF Key parameters for a Screen Button RGB Module are shown below. Other MF Keys are programmed in
a similar manner. In each case, you must name the MF Key, then program its functionality, and then define
how the key will light.

MF 1 Reference name for the MF Key.

Default Label Line 1 This is a static label for the MF Key (Line 1). Use 6 characters or less. 

Default Label Line 2 This is a static label for the MF Key (Line 2). Use 6 characters or less. 

Label ID This field enables dynamic labeling of the MF Key. You can link this field to:

· The output of a Text Prio logic element - to switch between 16 pre-prepared text strings. The
text strings are defined by the Text Prio.

· An output from the Label logic element - this allows the zirkonlabel program to edit the label.

· The Kpf label of any source or sum - this is the Display Name of the source or sum.

P1 Color Selects the color for the priority 1 lamp state - lowest priority.

P1 Low The lamp will be dimmed.

P1 Color Selects the color for the priority 1 lamp state - lowest priority.

P1  Blink The lamp will blink.

P1 Logic This input triggers the P1 lamp state – lowest priority.

The Color, Low, Blink and Logic options are repeated for the different MF Key states labeled P1 to P4 – P1 is
lowest priority; P4 is highest priority. If more than one control signal is provided, then the lamps illuminate in
priority – for example, P4 will win over P1. You can use the Blink options in combination with any of the colors.
All options are repeated for each MF Key.

Once MF Keys have been named, their control outputs can be assigned to other functions via the 'Tree
Selection' window. The control outputs are:

MF Key Active when the key is pressed.

MF nKey Active when the key is not pressed.
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3.14 Minimix

A Minimixer is a 2-in-2-out mixer with controls for level, dim, mute, balance, and talkback insertion. It is aimed
principally at monitoring, but can be used anywhere where you wish to assign level control or other functions to
the signal flow. 

The signal flow is shown below. Note that the left and right channels are treated independently, and the talkback
inputs differ (depending on the Minimixer type).
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3.14.1 Minimixer Types

On Power Core, two types of Minimixer are available: "Minimixer Sys TB" (included) and "Minimixer TB
Input" (available via the Minimixer add-on license). On other products, you will find one option "Minimixer Sys
TB", except for the Nova29 which supports the "Minimixer TB Input" as standard.

The two types are identical except for the talkback insertion:

· Minimixer Sys TB - up to two talkback inputs can be selected from eight system-wide talkback
sources.

· Minimixer TB Input - the talkback source can be freely selected from any audio input.

3.14.2 Creating a Minimixer

Each Minimixer should be inserted under the "Minimix" branch of the 'Tree Definition'.

On Power Core, the "Minimixer TB Input" option appears once the Minimixer add-on license is enabled.

If the add-on license is not enabled, then you will see only the "Minimixer Sys TB" type.

3.14.3 Audio Parameters

The audio parameters (in the Global, Dim and Mute tabs) are identical for all Minimixer types.
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Global Parameters

Minimixer Reference name for the element.

In L

In R

Assigns the audio sources for the left and right inputs to the Minimixer.

Mono Assigns an input control signal to mono the left and right channels of the Minimixer; the two
channels are mixed and an attenuation of 3dB applied.

If you wish to use the Minimixer as a 2-into-1 mono mixer, assign a Logical function whose
result is always true (e.g. a NOT logic element with no input) to force the Minimixer into Mono
mode.

Phase Assigns an input control signal to phase reverse the right channel of the Minimixer.

Side Assigns an input control signal to route the right input to the left output and vice versa.

Level Assigns a level control to adjust the main level of the Minimixer.

The Default Level is applied when nothing is assigned to the Level function. 

Level Left 

Level Right

Assigns a level control to exclusively adjust the main left and right channels of the Minimixer; the
overall Level is then superimposed. This function permits level balancing.

The Default Level(s) are applied when nothing is assigned to Level Left or Level Right.

Balance Pot Assigns a level control to adjust the left/right balance of the Minimixer.
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Dim Parameters

In Dim L/R Assigns input control signals to dim the left and right input channels to the minimixer (before the
main level). 

The amount of dim can be assigned to a level control - see In Dim Level L/R - or set to a fixed
level - see In Dim Level (init).

Out Dim 1 L/R

Out Dim 2 L/R

Assigns input control signals to dim the left and right output channels of the Minimixer (after the
main level, before TB insertion).

Two different control signals (Out Dim 1 and Out Dim 2) can be applied to each channel; the
control signals are OR’d - output dim will be applied if either control input is true.

The amount of dim can be assigned to a level control - see Out Dim Level L/R - or set to a
fixed level - see Out Dim Level (init).

In Dim Level L/R Assigns level controls to adjust the input Dim level for left/right channels. If blank, then the In
Dim Level will be applied.

Out Dim Level L/R Assigns level controls to adjust the output Dim level for left/right channels. If blank, then the Out
Dim Level will be applied.

In Dim Level (init) This is the level applied to the left and right input channels of the minimixer when the In Dim L
and In Dim R control signals are active. Level is set in dB.

Out Dim Level (init) This is the level applied to the left and right output channels of the minimixer when the Out Dim
1 L or Out Dim 2 L, and Out Dim 1 R or Out Dim 2 R control signals are active. Level is set in
dB.
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Mute Parameters

In Mute L/R Assigns input control signal to mute the left and right input channels of the Minimixer.

Out Mute L/R Assigns input control signals to mute the left and right output channels of the Minimixer (after
main level, before TB insertion).

Out TB Mute L/R Assigns input control signals to mute the left and right output channels of the Minimixer after TB
(talkback) insertion.
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3.14.4 Talkback (for Minimixer Sys TB)

For a "Minimixer Sys TB" element, two talkback sources can be inserted into each Minimixer chain: Sys TB 1
and Sys TB 2. 

On crystal, these are dedicated sources.

On sapphire, sapphire compact and Power Core, they can be selected from the eight system-wide talkback
sources (defined in the “System -> Definition -> Audio = Internal” branch of the 'Tree Definition'). This allows
you to use different talkback inputs for each Minimixer.

In each case, there are two parts to the configuration: first, define the system-wide talkback source(s) and,
second, define the talkback parameters for each individual Minimixer.

Minimixer - Sys TB Parameters

Now select the "Minimixer Sys TB" element you wish to edit and open the Sys TB tab. 

Each source can be summed with both left and right channels of the minimixer using a single control signal
(Sys TB 1 and Sys TB 2). Or, each source can be summed independently with the left or right channels (e.g.
Sys TB 1L and Sys TB 1 R). This second option allows talkback to be inserted on only one side of the
minimixer.

Level for each talkback source can be assigned to a level control - see Sys TB 1/2 Level - or set to a fixed
value - see Sys TB Level (init).

Sys TB 1 Select

Sys TB 2 Select

Use these fields to set Sys TB 1 and Sys TB 2 to one of the eight pre-defined talkback signals
(in “System -> Definition -> Audio = Internal”).

These fields are not visible for crystal (as only two talkback sources are supported).

Sys TB 1

Sys TB 2

Assign an input control signal to sum each talkback source with both the left and right
channels of the Minimixer.

Sys TB 1 L/R

Sys TB 2 L/R

Assign an input control signal to sum each talkback source with either the left or the right
channel of the Minimixer.

Note that the Sys TB 1 and Sys TB 1L control signals are OR’d – this means that audio
source 1 will be inserted to the left channel if either control input is true.

Sys TB 1/2 Level Assign a level control to adjust the level of the talkback source. If left blank, then the SysTB
Level (init) is applied.

Sys TB Level (init) This is the level applied if the Sys TB 1 Level or Sys TB 2 Level are not assigned. The level
is set in dB.
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3.14.5 Talkback (for Minimixer TB Input)

For a "Minimixer TB Input" element, the talkback source can be freely selected from any audio input.

Select the "Minimixer TB" element you wish to edit, and open the TB tab to edit the talkback parameters.

The talkback source can be summed with both left and right channels of the minimixer using a single control
signal (TB). Or, talkback can be summed independently with the left or right channels (TB L and TB R). This
second option allows talkback to be inserted on only one side of the minimixer.

The talkback source level can be assigned to a level control using TB Level, or set to a fixed value using TB
Level (init).

TB In Assign the audio input to be used as the talkback source.

TB Assign an input control signal to sum the talkback source with both the left and right channels
of the Minimixer.

TB L

TB R

Assign input control signals to sum the talkback source with either the left or the right channel
of the Minimixer.

TB Level Assign a level control to adjust the level of the talkback source. If left blank, then the TB Level
 (init) is applied.

TB Level (init) This is the level applied if the TB Level field is not assigned. The level is set in dB.
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3.15 N-1

This option allows you to configure 64 dedicated N-1 returns to expand the mix minus capabilities of the system.
It can be used once the N-1 add-on license is enabled.

If the add-on license is not enabled, then you will see the "N-1" branch in the 'Tree Definition', but cannot
insert any elements.

3.15.1 N-1 Anatomy

Each N-1 can subtract an individual source from a summing bus. 

The summing bus can be either mono or stereo, and can be any Sum Bus or GP Sum. This allows you to create
N-1 returns from existing buses such as PGM. Or, define new buses specifically for the purpose.

3.15.2 Creating N-1s

Use the "N-1" branch of the ‘Tree Definition’ to insert an N-1 element in the usual manner. Then define the
parameters as follows.

Note that to create an N-1 for a stereo source, the Type and Sum Bus must be stereo.

In the example below, four stereo N-1 returns have been created for the four MIC sources using the existing
PGM bus.

N-1 Enter a reference name for the N-1 element.

Type Set the type to either Mono or Stereo, depending on the format of the summing bus you wish to
use.

Source Select the source you wish to subtract. 

If the Type = Mono, then you can choose any mono source.

If the Type = Stereo, then you can choose any mono or stereo source.

Sum Bus Select the summing bus you wish to use. 

If the Type = Mono, then you can choose any mono bus (Sum Bus or GP Sum). 

If the Type = Stereo, then you can select any stereo bus (Sum Bus or GP Sum). 
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3.16 Panel

This branch appears in the 'Tree Definition' once one or more Key Panels have been added to the Frame ->
Panels configuration:

The parameters vary slightly depending on the panel type. The next few pages show some examples. In each
case, the buttons are treated as MF Keys.

3.16.1 KSC-LCD Panels

The LCD panels support dynamic labels and up to four pages of MF Keys (switchable in two layers). Use the
Keys Page tabs to define the MF Key parameters (name, label and lamp color/state), and the Module tab to
define the page and layer switching.

Keys Parameters

Page x Key y Enter a reference name for the MF Key.

Name Line 1 This is a static label for the MF Key (Line 1). Use 6 characters or less. 

Name Line 2 This is a static label for the MF Key (Line 2). Use 6 characters or less. 

Label ID This field enables dynamic labeling of the MF Key. You can link this field to:

· The output of a Text Prio logic element - to switch between 16 pre-prepared text strings. The text
strings are defined by the Text Prio.

· An output from the Label logic element - this allows the zirkonlabel program to edit the label.

· The Kpf label of any source or sum - this is the Display Name of the source or sum.

P1 Color Selects the color for the priority 1 lamp state - lowest priority.

P1  Blink The lamp will blink.

P1 Logic This input triggers the P1 lamp state – lowest priority.

The Color, Blink and Logic options are repeated for the different MF Key states labeled P1 to P4 – P1 is lowest
priority; P4 is highest priority. If more than one control signal is provided, then the lamps illuminate in priority –
for example, P4 will win over P1. You can use the Blink options in combination with any of the colors. All options
are repeated for each MF Key.

Once MF Keys have been named, their control outputs can be assigned to other functions via the 'Tree
Selection' window. The control outputs are:

MF Key Active when the key is pressed.

MF nKey Active when the key is not pressed.
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Module Parameters

Module Reference name for the panel.

Once named, the alarm status for the panel can be assigned to another function (via the "Panel"
branch of the 'Tree Selection'). The "failed" output is active when the alarm is active.

Select Page x Reference name for the Page select function.

Select Logic This input control signal makes Page x active.  It can be any control signal but is usually an MF Key
on the same key panel.

Shift Reference name for the SHIFT select function.

Shift Select Logic This input control signal makes the SHIFT layer active.  It can be any control signal but is usually an
MF Key on the same key panel.

3.16.2 KSC-T20 Key Panel

Some key panels have simpler MF Key lamp color/state parameters, for example:

MF 1 Reference name for the MF Key.

Red Lights the Red lamp – highest priority.

White Lights the White lamp.

Yellow Lights the Yellow lamp.

Green Lights the Green lamp – lowest priority.

Low The lamp will be dimmed.

Blink The lamp will blink.

3.16.3 GPIO & VCA Parameters

Some key panels provide GP inputs and outputs which can be configured in the same way as a GPIO card.

Some key panels provide VCAs which can be configured in the same way as other Level Controls.
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3.17 Source

The "Source" branch of the ‘Tree Definition’ allows you to insert and configure sources.

Each source can support several sets of parameters. Switch between them using the menu tabs at the top of
the parameter area.

The most important fields are the source Name and Type (defined in the Parm tab):

A source must be named before it can be referenced to other elements via the 'Tree Selection'.

For Power Core, the Type defines whether this is a normal audio source (mono, stereo or surround) or a
special source such as a VCA Group, Minimix, R3LAY or Protools. For crystal,  sapphire compact and
sapphire MK2, the source type is defined when you insert the source element. This topic covers normal audio
sources. The other source types are described later.
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3.17.1 Source -> Parm

Select the source you wish to edit in the 'Tree Definition' and open the Parm tab to access its main parameters:

Source Name Reference name for the source element.

Type This field defines the type of source.

Display Display name for the source. This is the name which appears in the fader label display when the
source is assigned to the control surface. Enter 6 characters or less so that the name can appear in
full on the control surface displays.

It is strongly recommended that you use unique Display names wherever possible!

Alias This name can be used to distinguish between sources which have the same ‘Display’ name. For
example, if you have two sources named CD, you will need to enter different Alias names in order to
save and load snapshots. If an Alias name is not entered then snapshot data is referenced to the
‘Display’ name. 
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Class This field applied to VisTool Snapshots. It can be used to permit Src snapshots saved on one source
to be recalled on another.

If the Class field is left empty, then Src snapshots stored from the source can only be recalled to
itself.

If the Class field is set to the same text string as other sources (e.g. Default), then Src snapshots
stored from another Default source may be recalled. This is useful if, for example, you wish to able
to recall microphone parameters stored on one input to another.

Ember+ Local
Provider Nr

This field can be used to publish all source parameters to an Ember+ provider - enter the provider
number from 1 to 5, or select None if you do not wish to publish the source.

Sources can be published using either their Display name or Alias name depending on the status of
the Sources/Sums Naming option (defined under "System -> Definition -> Params = Ember+
Settings"). In either case, the name must be unique to ensure correct operation.

Src Repl Element Nr

Src Repl Name

These fields are used to couple the source to an external source in an Ember+ consumer. The Src
Repl Element Nr should match that defined in the Ember+ SrcRepl element. The Src Repl Name
should match the name (either Display or Alias) configured in the Ember+ consumer.

EmBER+ A-stage Available when the System Core = Power Core. This field can be used to assign an Ember+ A-
stage element so that the source can control microphone parameters within an A__stage device via
Ember+. Having assigned a device (via its Ember+ A-stage Element Name), enter a Channel No.
(from 1 to 32) to select the mic input.

List Enable Enable this checkbox to add the source to the source selection list. This allows operators to assign
the source to a fader strip from the control surface.

Enable Access Group
1 to 4

Available when the System Core = Power Core Max. See Configuring Power Core Max Sources.

Audio Input Selects the audio input for the source.

Limiter

Compressor

Equaliser

Delay

DeEsser/AutoMix

Available when the System Core = Compact Engine. Enable the checkboxes to assign signal
processing to the source. The Compressor represents the complete dynamics section: Gate,
Expander and Compressor. The DeEsser/Automix shares the same DSP module and is available
for mono and stereo sources only.

Lim Disable

Dyn Disable

Eq Disable

Dly Disable

DeEsser/AutoMix
Disable

Available when the System Core = Power Core or Nova17. In this instance, the DSP blocks are
automatically enabled for each source. Use the checkboxes to disable the signal processing. For
example, if you wish to minimize the latency. The Dyn represents the complete dynamics section:
Gate, Expander and Compressor. The DeEsser/Automix shares the same DSP module and is
available for mono and stereo sources only.

Nova17/MTx Server Available on stereo sources only. If the audio input to the source is assigned from a remote matrix,
then this option selects the method of communication:

· Turn the option On if the remote matrix is a Nova17, Nova29 or Matrix Server.

· Turn the option Off if the remote matrix is a Nova73 (for communication via Remote MNOPL).

Once communication is established, you can use the Matrix Out 1 field to support the transfer of
labels from the remote matrix (to the fader label display on the console).

And/or use the Class/Pool field (and Mtx Src Pool logic element) to provide operator-controlled
selection of audio inputs from the remote matrix. See Configuring a Matrix Source Pool.

Matrix Out 1 Available on stereo sources only. This option allows the labels from a remote matrix (as described
above) to appear in the fader strip displays and source's Kpf label.

Enter the matrix number of the remote matrix output which is connected to the source's audio input.

Class/Pool Available on stereo sources only. This option will allow an operator to select audio inputs from a
remote matrix directly from the fader strip. See Configuring a Matrix Source Pool.

When using a Nova17, Nova29 or Matrix Server, enter the Pool ID defined in the corresponding MTx
Src Pool element. 

When using a Nova73, enter the class configured in the Nova73 map (as described in the
"ext_router_control_en" pdf).
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RAVENNA

RAVENNA Pool No.

Available when the System Core = Power Core. When set to ON, the source becomes a RAVENNA
source that can subscribe to streams available on the network. Up to 6 pools can be defined to
shape the availability of streams, and whether a particular stream can be selected by this source. A
RAVENNA Src Pool element must be defined to support this feature. See Configuring RAVENNA
Pool Sources.

Fader Level Sync Available when the System Core = Power Core. This feature works in the same way as "Fader
Level Sync" in a Minimix Source (described later). It allows the source fader level to be controlled
from another gain element (e.g. Source, VCA, GNET UDP). Similarly, the Fader Level Out (in the
'Tree Selection') can be used to control gain in another element (e.g. Source, Minimixer, GNET
UDP).

When using this feature to sync different control types, note that there may be differences in the
value ranges: e.g. Faders = infinity to +9dB; VCAs = infinity to 0dB. In this instance, the effective gain
value is applied.

Fader Open Tick this box if you wish the level of the source to be set to 0dB rather than - infinity. This is
particularly useful for sources which are not to be assigned to the control surface.

Input Mute Selects an input control signal to mute the audio input. 

This mute occurs at the point before the signal is distributed in the matrix, therefore will affect routes
to other destinations as well as to the selected source. (To mute the source within the ‘channel’, see
Channel Mute.) 

The mute is active until the input control signal = Logical “1”.

Fader Up

Fader Down

Fader Toggle

Fader Up to Last
Value

Fader Toggle to Last
Value

Opens the source fader (see also Hold Mode below).

Closes the source fader (see also Hold Mode below).

Changes the state of the source fader: open to closed, or vice versa (see also Hold Mode below).

Opens the source fader to its last known position.

Toggles the source fader to its last known state.

These 5 functions can be used to program a fader start and are triggered by the rising edge of the
input control signal.

Hold Mode When this input is active, the last position is stored when the fader is closed by Fader
Down/Toggle. Opening the fader using logic sets the fader to the last stored position. If Hold Mode
is activated while the fader is closed, then the Default Position set below is used. 

Default Pos (dB) Used in conjunction with Hold Mode. Sets the default level, in dB, to which the fader will open if
Hold Mode is activated while the fader is closed.

DMS Color The value entered here selects the color for DMS meters within VisTool. The value shown is
represented by 0xRRGGBB where RRGGBB denote the amounts of Red, Green and Blue
respectively. Click on the color selector box to choose from the color palette.

Source Color Default Selects the color used to illuminate the fader strip backlight when the Mode is set to either:

· Source Color Enabled

· Mix Mode

If you select Black, then the backlight is unlit.

Source Color Mode Select the mode of operation for the fader strip backlight:

· Source Color Enabled - always indicates the type of source.

· Source Color Disabled - always indicates signal present.

· Mix Mode - combines the options above; signal present takes priority.

Signal present parameters are defined under "System -> Definition -> Parameter = Signal Present".

Channel On Edge

Channel Off

Edge

Ch On/Off Toggle

Channel Mute

When a positive edge is supplied to this input, the source is unmuted. 

When a positive edge is supplied to this input, the source is muted.

This input toggles the status of the channel mute on each rising edge of the control signal.

This input mutes the source as long as it is supplied with an active control signal. 

These 4 control inputs allow the audio signal of a source to be switched on and off.

Access User Off This input locks out the Access Key so that the source cannot be assigned to the center section.
You may use this to limit operator access to source parameters.

Parm Page User Off This input locks out all DSP modules for the source. You may use this to prevent parameters such
as a presenter’s mic EQ and Compression from being altered by the operator.
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Channel Parm off This input locks parameter control from the channel fader strip. You may use this to prevent
parameters such as mic gain and pan from being altered by the operator.

Ref Src Selects the reference source. When a source is assigned to the control surface, a reference source
can be assigned at the same time. For example, on a console with two layers – on-air and record –
you could assign the TEL source to both layers automatically. In this parameter box, assign the
reference source (e.g. TEL). 

To determine where the reference source appears on the control surface, use the Ref Src Fader
Offset option set within the “System -> Definition -> Param = Fader”.

Note that changing DSP parameters on one of the sources will affect the other.

Matrix Mic Nr

Matrix Gnet Port

These two fields are used if the audio input to the source is a microphone which requires arbitration.
See Mic Arbitration.

Use the Matrix Mic Nr field to enter the Mic Input Nr referenced within the server's configuration. 

In the Matrix Gnet Port field, enter the GPI/O Network port number which connects to the server.

disable Surr. Pan This control input disables the Surround Pan parameters on the Channel and Central Modules –
LCR, front-rear, Center slope and LFE level. This can be used to simplify operation for a stereo
installation. Note that 5.1 panning is only available if 5.1 or 5.1+2 Sums are configured.

Access This control input will action the fader access key for the source. For example, to action an access
key from a GPI.

Mono Available on stereo sources only. This control input monos the source.

ms -> xy Available on stereo sources only. This control input converts an ms input to xy.

Stereo Available on stereo sources only. This control input resets the source to stereo.

Left -> Both Available on stereo sources only. This control input routes the Left audio input to both sides of the
source.

Right -> Both Available on stereo sources only. This control input routes the Right audio input to both sides of the
source.

Side Swap Available on stereo sources only. This control input reverses the Left and Right audio inputs at the
input to the source.

Phase Available on mono and stereo sources only This control input reverses the phase of the source.

Start Mic AutoGain
Cycle

Available on microphone input sources only. This control input starts the AutoGain measurement
process.

The following control outputs appear in the ‘Tree Selection’ under “Logic -> GroupName -> SourceName”.

Access active Active if the ACCESS Key on the source fader strip is active.

OAC ready On Air Control ready. This control output may be used by an external Radio Automation System.

Channel On Active when the ‘Channel Mute’ is inactive.

Channel Mute Active when the ‘Channel Mute’ is active.

Channel Audio Active when the source is "on air" - this occurs when the fader is open AND the channel is ON. (i.e.
Channel Mute inactive).

Assigned Active when a source is assigned to a fader strip.

Phase Active when the source is phase reversed.

Mono (stereo sources only). Active when the source is in mono.

The remaining source parameter tabs are described later. See Source -> PFL, Conf, DownSrc, Aux, Keys /
Fader Status.
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Fader Status

The fader status outputs are active depending on the status of the source fader. 

Note that each control surface will behave differently depending on whether or not it supports moving faders.
For surfaces with moving faders, there is a choice of two modes: Normal or Hot Fader  (described below). For
surfaces with non-moving faders, there is no choice as the faders always operate in the equivalent of Hot
Fader Mode.

The two modes are shown in the diagram below. 

· Normal Mode – the surface fader position always represents the fader level. This means that if a
source is controlled by RAS or Fader Up/Down/Toggle logic signals, then the surface fader will move in
response to the automation.

· Hot fader Mode – the surface fader position is independent of any automation (RAS or fader logic).
This allows an operator to preset a fader value (e.g. 0dB), before an RAS controller or Fader
Up/Down/Toggle fader start opens or closes the Background fader level. 

Note that in Normal Mode, the Background level is always 0dB and has no action; in Hot Fader Mode, the
operator sets the Surface level, while RAS or fader logic signals control the Background level.
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The following fader status outputs are available for each source. You can use these to trigger other logical
functions via the 'Tree Selection' window.

Fader Start For moving fader systems: 

· In Normal mode the output indicates the status of the RAS/Logic controlled surface fader position.

· In Hot Fader mode, the output indicates the status of the RAS/Logic controlled background fader
position.

For non-moving fader systems, the output is active when the “Background” fader (RAS/Logic) value
is open.

nFader Start The negative result of Fader Start.

Fad. -20dB Becomes active when the “Background” fader value moves above -20dB.

Becomes inactive when the “Background” fader value is off.

Fader Man. Start For moving fader systems:

· In Normal Mode the status is true by default. 

· In Hot Fader Mode, the output reflects the surface fader position.

For non-moving fader systems, the output reflects the status of the physical fader position. It is
active when the “Surface” fader value is open.

Fader Man. nStart The negative result of Fader Man. Start.

Fader Man. 

-20dB

Becomes active when the “Surface” fader value moves above -20dB.

Becomes inactive when the “Surface” fader value is off.

Fader Result Start Active if Fader Start AND Fader Man. Start are both active. If a VCA master is assigned, then this
also needs to be active.

In Normal mode this output is identical to Fader Start. 

In Hot Fader mode, this output flags the status of the combined physical fader and RAS/logic
controlled fader position. In other words, both the physical fader and the automation/logic need to be
open for this output to be true.

Fader Result nStart The negative result of Fader Result Start. 

Fader prepared Active if Fader Start is active AND Fader Man Start is NOT active. 

Use this output in Hot Fader mode, or on non-moving fader systems, to flag when the RAS or logic
has opened a fader position, but the physical surface fader is closed.

Fader Touch active Active if the fader sense is active (the fader is touched).
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Back Gain

The Back Gain is a channel-related level which can be used by any element, such as a Minimixer or Mix
Remote, to adjust the level of a return path for the source such as an Aux. It can be found under the Level
branch of the 'Treeselection':

Once assigned, the Back Gain can be controlled from VisTool (via the Vis Chan BackGain parameter) or from
another console or system (via an Ember+ Internal Src Control element).
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3.17.2 Source -> PFL

For each source defined in the 'Tree Definition', open the PFL tab to edit the source-specific PFL parameters.
These functions are triggered by the rising edge of the input control signal.

PFL On Turns On PFL for the source.

PFL Off Turns Off PFL for the source.

PFL Toggle Changes the state of the source PFL.

The following control outputs appear in the ‘Tree Selection’ under “Logic -> GroupName -> SourceName”.

PFL active Active when the source is routed onto the PFL bus (PFL On).

PFL prepare Active when the source is in ‘PFL Prepare’. This state occurs when you turn on PFL for an open
fader in either PFL R or PFL SUM R mode. Your monitoring does not change but the source is put
into ‘PFL prepare’. When you close the fader, PFL becomes active.

PFL off Active when both PFL active and PFL prepare are off.

PFL in use Active if either PFL active or PFL prepare are active.

PFL assigned Indicates which PFL bus (1 to 5) is assigned as “PFL 1”. 

PFL 1 may be swapped with another PFL bus (from 1 to 5) from “Surface -> Fader Module -> PFL1
Swap”.
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3.17.3 Source -> Conf

Select the Conf tab in the "Source" branch of the 'Tree Definition' to assign a conference bus to each source.

All options are repeated for the two separate conference systems – Conf 1 and Conf 2. By using the command
“Conf 1 In disable” or “Conf 2 In disable”, you can form different mix-minus/conference group. i.e. Sources
working on Conf 1 need not be included in Conf 2 and vice versa. 

When working with two conference groups, please note:

· Sources assigned to different conference groups cannot communicate while a conference is active.

· When a source is assigned to both conference groups it is required to configure the switching or
summing of the Conf buses separately.

· Conf buses with the attribute “Conf 2" (see below) must only be set as a Conf 2 bus within the sources.
The same applies to Conf 1.

The source parameters in the 'Tree Definition' are as follows. All options are repeated for Conf 1 and Conf 2.

Conf 1 Bus Assigns a Conf Bus to the source. This sets the relationship between the source and the bus in
order to generate the N-1 mix. 

Conf 1 On Turns on the Conference system with a rising edge.

Conf 1 Off Turns off the Conference system with a rising edge.

Conf 1 Toggle Changes the state of the Conference system with a rising edge.

Conf 1 In disable A rising edge removes the source from all conference buses that are assigned to the Conference 1
system. A falling edge reassigns the source. For example, this might be linked to the presenter’s
cough switch.

Conf 1n If a source is assigned to a Conf Bus 1, then you can use the control input Conf 1n to assign its
own signal to the conference bus. With a rising edge source is added and with a falling edge it is
taken away.
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The following control outputs appear in the ‘Tree Selection’ under “Logic -> GroupName -> SourceName”.

Conf active Active when Conf is switched on for this source, but not any other source, and the fader is closed.
(i.e. there is one conference source off-air).

In this state, the Conference system is disabled and the source receives a sum of all faders minus
themselves.

Conf prepare Active when Conf is switched on and the fader is open.

In this state, the Conference system is disabled and the source receives a sum of all faders minus
themselves.

Conf off Active when Conf is switched off. The fader state is irrelevant.

In this state, the source does not contribute to the Conference system.

Conf Audio Active when Conf is switched on and the fader is closed for this and at least one other source. (i.e.
there is at least one conference source off-air).

In this state, the Conference system is enabled and the source receives a mix of the conference
members minus themselves. This allows Conference members to hear each other while they are
off-air.

Conf in use Active when Conf is switched on.

3.17.4 Source -> DownSrc

For each source you can assign up to six Down Sources. These are sources which will be removed from the
control surface when the selected source is assigned to a fader strip.



ON-AIR Designer Configuration Options Version: 6.6.0_1 169/325

3. 'Tree Definition' Elements

3.17.5 Source -> Aux / Aux Switch

Having defined Aux 1 to Aux 20 in the "System -> Definition-> Parameter = Aux", there are two ways to
configure the on/off and pre/post status: either statically (if the state is to be forced) or dynamically (if the state
should be toggled). The latter is ideal for operator-controlled bus assignments from a fader strip MF Key.

Static Bus Assignments

Use the Aux Switch source parameters to force a particular state for each bus send. 

In the example below, a Logic -> NOT element has been used to create a "true" control signal. This has then
been applied to the "Aux 1 Post" state to force the source to be assigned to the Aux 1 bus (in our example, this
is PGM).

Aux n Pre This control input will switch the send to Aux n to pre fader.

Aux n Post This control input will switch the send to Aux n to post fader.

Aux n Off This control input will switch the send to Aux n Off.
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Toggled Bus Assignments

Use the Aux source parameters to toggle the state for each bus send.

In the example below, MF Keys 2 and 2b are assigned to the "Toggle Aux 3" and "Toggle Aux 4" states. This
allows the operator to switch the bus to pre, post or off from the surface.

Select Aux n This control input will assign the source to Aux n. The first press assigns the source pre-fader; the
second press is post fader; and the third press is off.

Post Only If this box is checked, then there is no pre-fader option.
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3.17.6 Source -> Keys

Select the Keys tab (in the "Source" branch of the 'Tree Defintion') to name each MF Key and define how it will
illuminate in response to a control signal. Note that, on a fader strip, the MF Keys are defined for the source
rather than the physical fader.

The MF Key reference name is very important as until you name keys, they will not appear in the 'Tree
Selection' window, and therefore cannot be assigned to functions. Each MF Key can light in a variety of colors,
and can be static, blinking or half-lit to indicate different statuses.

MF 1 Mode

(& VoMu Default)

These options are for MF Key 1 only:

· Select Normal for normal MF Key operation.

· Select either Voice/Music or Voice/Music/Off to use the key for automatic switching onto a
Voice or Music bus.

MF 1 Label Display name for MF Key 1. This is the name which will be used on the control surface so use
4 characters or less.

MF 1 P1: Color Selects the color for the priority 1 lamp state - lowest priority.

MF 1 P1: Low The lamp will be dimmed.

MF 1 P1: Blink The lamp will blink.

MF 1 P1: Logic This input triggers the P1 lamp state – lowest priority.

The Color, Low, Blink and Logic options are repeated for up to 8 key states labeled P1 to P8 – P1 is lowest
priority; P8 is highest priority. If more than one control signal is provided, then the lamps illuminate in priority –
for example, P8 will win over P1. You may use the Low or Blink options in combination with any of the colors.
All options (except the MF 1 Mode) are repeated for each MF Key.

Only MF Keys 1, 1b, 2 and 2b have an electronic label.

Once the MF Keys have been named, their control outputs can be assigned to other functions via the 'Tree
Selection' window. The control outputs are:

MF Key Active when the key is pressed.

MF nKey Active when the key is not pressed.

sapphire systems support MF Keys 6 to 9 if sources are assigned to fader strips fitted with the Rotary
Extension Module. 
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Automatic Voice/Music Bus Switching

MF Key 1 can be used to enable or disable automatic switching from a mono, stereo or 5.1 source onto a voice
or music bus. Note that these options exist for MF Key 1 only.

Ø  To Enable Automatic Voice/Bus Switching:

1. Select the source and its MF Keys tab.

2. Set the MF Mode 1 to either Voice/Music or Voice/Music/Off:

· Voice/Music = automatic bus switching is disabled; use MF Key 1 to enable the feature.

· Voice/Music/Off = automatic bus switching is enabled; use MF Key 1 to disable the feature.

3. Set the VoMuDefault option to either Voice or Music to choose which is the default bus.

In our example, the source is set to automatically feed the Voice bus; MF Key 1 is programed to disable the
Voice/Music bus switching:
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The Set to "Voice", Set to "Music" or Set to "Off" triggers can be used to override the current assignment -
in the example below, press MF Key 1b to assign the source to the Voice bus; press MF Key 2 to assign the
source to the Music bus; press MF Key 2b to remove the source from both the Voice and Music bus:

Ø  Programing the Logic:

To define which bus is used for Voice (or Music), use the 6 Logic outputs from the source. In our example,
Aux 1 is Voice, and Aux 2 Music:
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3.18 Sum Bus

The "Sum Bus" branch of the ‘Tree Definition’ is used to insert and configure summing buses.

Each bus can support several sets of parameters. Switch between them using the menu tabs at the top of the
parameter area.

The most important fields are the Name and Type (defined in the Parm tab):

A sum bus must be named before it can be referenced to other elements via the 'Tree Selection'.

For Power Core, the Type defines whether this is a normal summing bus (mono, stereo or surround) or a
special bus such as R3LAY. For crystal,  sapphire compact and sapphire MK2, the type is defined when
you insert the summing bus element.
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3.18.1 Sum Bus Parameters

Select the Sum Bus you wish to edit in the 'Tree Definition' and open the Parm tab to access its main
parameters:

There are identical to the corresponding Source parameters, with the following exceptions/additions:

· DSP must be allocated to each summing bus by ticking the Limiter, Compressor, Equalizer and/or
Delay boxes.

· Post Only – select this checkbox to limit bus assignments to post fader only (e.g. for a PGM or Group
bus).

Note that you cannot assign a summing bus directly to another summing bus. However, this can be achieved by
using an audio loopback and a source. First, assign the sum bus to a loopback output, and then assign the
loopback return to a source. The source may then be assigned to the sum bus in the usual manner. Audio
loopbacks are described later.
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3.19 Surface

3.19.1 Surface -> Fader Module

The "Surface -> Fader Module" branch of the 'Tree Defintion' defines the programmable functions of the Fader
Module. The same parameters can be accessed by double-clicking on the Fader Module in the Frame ->
Surface window.

Each fader strip can control any source or summing bus, and has a number of programmable functions. Note
that these are configured for the source, and not the fader strip, so that when a source is moved to a different
fader position, the functionality follows.

Fader Module -> Source

Open the "Surface -> Fader Module" branch of the 'Tree Definition', and select the Source tab to enable or
disable layering, and configure the default sources for each fader strip.

Module The reference name for the Module.

Disable Layer 2 Not available for crystal. Tick this box to disable Layer 2 switching. This will disable the ACCESS
2 keys on the Fader Module. Once Layer 2 is disabled, the ACCESS 2 key can be reassigned to
another function by defining MF Key 5 for the source, see Source -> Keys.

Default Sources Assigns a default source or sum bus to the fader strip. This source is loaded whenever the
configuration is transferred, or the system is reset using a cold start. You can permanently assign
this source to the fader strip by ticking Only Default.

· Use boxes 1.1, 1.2, 1.3, 1.4 to assign Layer 1, strips 1 to 4

· Use boxes 2.1, 2.2, 2.3, 2.4 to assign Layer 2, strips 1 to 4

Only Default Tick this box if you wish the Default Source to be permanently assigned to the fader strip.
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Fader Module -> Direct Out

Open the "Surface -> Fader Module" branch of the 'Tree Definition', and select the Direct Out tab to enable a
direct out for the fader strip. If two layers are supported, then there are eight entries:

· 1.1, 1.2, 1.3, 1.4 - assigns Layer 1, strips 1 to 4. 

· 2.1, 2.2, 2.3, 2.4 - assigns Layer 2, strips 1 to 4.

Out X.x Assign the audio output for the Direct Out.

Pre Fader Assign a control signal to switch the Direct Out pre fader.

Pre Sig Assign a control signal to switch the Direct Out pre processing.

You can combine the Pre Fader and Pre Sig control signals to configure the following options:

· Pre fader, pre processing.

· Pre fader, post processing.

· Post fader, pre processing.

· Post fader, post processing (default).
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Fader Module -> Module

Open the "Surface -> Fader Module" branch of the 'Tree Definition', and select the Module tab to monitor the
status of a control surface mode.

Alarm Enter the name to be displayed in the Alarm Log Server for the module.

General Enter the general purpose name for the module.

Once the Alarm field is named, the following control outputs appear under the “Surface -> Module” branch of
the 'Tree Selection' window:

Alarm Surface N failed This output is true when the surface alarm for the module is active.
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Fader Module -> PFL1 Swap

The PFL 1 Swap function can be used to swap the PFL 1 bus for another listen bus on each fader strip. You
can use this to configure different PFL outputs for different fader strips. This is particularly useful if the console
supports multiple operating stations.

Open the "Surface -> Fader Module" branch of the 'Tree Definition', and select the PFL1 Swap tab.

Use the ChX.x field to select the PFL bus which will be used by the fader strip. The options are:

· Default = PFL 1 (the predefined PFL bus)

· PFL 2 to PFL 5 – the user-defined buses configured in “System -> Definition -> Parameter = PFL
Mode”.
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Fader Module -> Channel Mapping

Any fader strip can be mapped to a different control surface position using fader mappings. The system works
by giving every fader strip a unique mapping ID. This includes faders on Layer 1 and Layer 2 for all Fader
Modules.

MF Keys, defined by the configuration, can then reassign any fader ID to any control surface position. For
example, a fader can be cloned by assigning the same ID to two positions. Move one of the cloned faders, and
the other follows; select a new source for the fader, and the other follows.

Fader Mapping IDs Fader Clone Example

The mapping numbers identify both layers. Therefore Module 1 contains Faders 1 to 4 and 5 to 8; Module 2
starts at Fader 9 and so on.

There are three main applications for fader mappings:

· To clone a fader - as shown above.

· To move fader strips – for example, to rearrange the layout for different types of production.

· To map invisible fader strips onto physical faders – to create additional "layers".

The first two applications are particularly useful for multi-operator layouts, as faders can be cloned at different
operator stations, or the control surface can be re-configured from single to multi-user.
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>> Channel Mapping Parameters

1. Select the Fader Module you wish to edit from the "Surface" branch of the 'Tree Definition'.

2. Select the Channel Mapping menu tab:

Default Map

Activate

Assigns a control signal to activate the default fader mapping.

Map n

Activate

Assigns a control signal to activate.fader mapping 1 to 12.

Map n

1.1, 1.2, 1.3, 1.4, etc.

Enter the fader ID numbers which will be mapped to the Fader Module when the Map n
Activate control signal is true.

· Use 1.1 to 1.4 to map Layer 1, strips 1 to 4.

· Use 2.1 to 2.4 to map Layer 2, strips 1 to 4.

You must enter the absolute fader ID, which is counted from 1 through to 8 for each Module
(faders 1 to 4 on Layer 1, and faders 5 to 8 on Layer 2). For example, to map the third fader on
the second layer of Module 2, you would enter 15 (as the second layer of Module 2 is counted as
faders 9 to 16).
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Fader Module -> Snapshots

Open the "Surface -> Fader Module" branch of the 'Tree Definition', and select the Snapshots tab to isolate
fader strips from snapshot loads. For example, if there is more than one operator, you may wish to use
snapshots to reset some faders and not others. 

When the SnapLoad disable (Default Map) option is active, all Source, Sum and Assign parameters remain
unchanged if a snapshot is loaded. 

· Use Ch 1.1 to 1.4 to isolate Layer 1, strips 1 to 4.

· Use Ch 2.1 to 2.4 to isolate Layer 2, strips 1 to 4.

The Default Map positions determine which channels are isolated.

This option applies to all types of snapshot: internal memories and Vistool full/source snapshots. It has no affect
when snapshots are saved. Generally, all channels are included when saving.
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Fader Module -> MF Key Mappings

MF Key mappings can be used to swap the functions of MF Keys according to the production or user
requirements.

Note that the mappings affect all MF Keys on the Fader Module. So, to change the function of MF Keys globally
across the console, remember to modify the MF Key Mappings for all Fader Modules. MF Key mappings are
stored as a "one-shot" setup in the configuration. This means that you will need to upload a new configuration to
change from one set of MF Key mappings to another.

Open the "Surface -> Fader Module" branch of the 'Tree Definition', and select the MF Key Mapping tab to
configure MF Key mappings.

In each case, use the drop-down menu to assign a logical MF Key to the physical MF Key. Note that MF 1 to 9
correspond to the MF Keys on a sapphire with a Key Extension module.

Once the configuration is uploaded, the MF Keys on the selected Fader Module will update accordingly.

Fader Module -> VisChan

These parameters are identical to the ones accessed via the "VisChan" branch of the 'Tree Definition'.
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3.19.2 Surface -> Central Module

The "Surface -> Central Module" branch of the 'Tree Defintion' defines the programmable functions of the
Central Module. The same parameters can be accessed by double-clicking on the Central Module in the Frame -
> Surface window.

Central Module -> Keys

Open the "Surface -> Central Module" branch of the 'Tree Definition', and select the Keys tab to define the MF
Key name and its lamp color/state. These parameters are identical to those on a fader strip (described earlier).

To configure the MF Key functions, assign the MF Key to the required function from the 'Tree Selection' window.
For example, the MF Key below will switch the output of a TConn64 monitor source selector to PGM:
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Central Module -> VCA

These parameters configure the rotary 'VCA' controls on the Central Module:

Control n Enter a reference name for the control on the Central Module.

Name Enter the name which will appear on the OLED display beside the control. You can enter up to 6
characters. 

Default Gain (dB) Enter a default value in dB. Note that -60dB corresponds to - infinity.

This gain is applied after a cold start and whenever the Set Default Gain control signal (see
below) is active.

Gain Step Width Select an option from the drop-down menu. This sets the gain to change in steps of 1dB, 2dB,
3dB or 5dB.

Set Default Gain Assign a control signal to activate the Default Gain value. For example, you could assign the
warm start control signal if you wish the level to be reset after a restart.

Gain Sync Input Assign the output of another Level Control. You can use this parameter to link controls. For
example, to have the headphone level follow the studio monitor level or vice versa.

Balance Enable Tick this box to enable balance control. When enabled, operators can push down and turn the
control to adjust balance.

Balance Sync Input Assign the output of another Balance control. You can use this parameter to link controls. For
example, to have the headphone balance follow the studio monitor or vice versa.

Central Module -> Module

These parameters are configured in a similar manner to the Module Parameters on a Fader Module.
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3.20 System -> Definition

This branch of the ‘Tree Definition’ defines the system's global options. 

The tables below list all possible elements according to their order in the menu tabs: Audio, Logic, Madi, etc.

Audio

'System -> Definition' Application r c sc s N29

Parameter = Aux Define the 20 summing buses which can be assigned from the
control surface.

ü ü ü ü û

Audio = Internal Define the frequency switching for the internal LineUp signals and
the system-wide talkback sources (Sys TB). 

ü ü ü ü û

Parameter = Sync Define the sync reference parameters.
ü ü ü ü ü

Parameter = Meter Set the reference levels and metering options for the control surface
and VisTool.

ü ü ü ü ü

Parameter = Insert Configure external insert devices.
ü û ü ü û

Parameter = TieLine
Stereo

Configure 32 Stereo Tie Lines (for dynamic assignment of signals
to/from a MADI link).

ü ü ü ü û

Parameter = Signal
Present

Define the signal present indicator on the fader strips.
ü ü ü ü û

Parameter = Surround
Downmix 

Define the downmix parameters (used when a surround source is
routed to a stereo summing bus).

ü ü ü ü û

Parameter = PFL Mode Configure the PFL modes for each listen bus.
ü ü ü ü û

Parameter = Mic
AutoGain

Sets the AutoGain target level (used during the AutoGain
measurement process for microphone sources).

ü ü ü ü û

Logic

'System -> Definition' Application r c sc s N29

Parameter = Settings Define options for the console surface.
ü ü ü ü û

Parameter = Faders Define options for the faders.
ü ü ü ü û

Parameter = Timers Define options for the six standard timers.
ü ü ü ü ü

Parameter = Screen Define general settings for VisTool functions.
ü ü ü ü ü

Parameter = PowerUp Define actions to occur after power-up.
ü ü ü ü ü

Madi, OAC, TCP, Alarm, Protools

'System -> Definition' Application r c sc s N29

Parameter = MADI Define parameters for the MADI ports.
ü ü ü ü ü

Parameter =
OnAirControl

Configure inputs and outputs to control or respond to functions
within an external Radio Automation System (RAS).

ü ü ü ü û

Parameter = TCP Link Define the TCP/IP connections to other systems within the control
network.

ü ü ü ü ü

Parameter = Alarm Define options for the Global Alarm and external Alarm Log Server.
ü ü ü ü ü

Protools Assign central control functions from the Mackie-HUI™ protocol.
ü û û ü û



ON-AIR Designer Configuration Options Version: 6.6.0_1 187/325

3. 'Tree Definition' Elements

Ember+

'System -> Definition' Application r c sc s N29

Parameter = Local
Consumers

Define the TCP/IP configuration required for the system to act as an
Ember+ consuming device. 

ü ü ü ü ü

Parameter = Local
Providers

Define the TCP/IP configuration required for the system to act as an
Ember+ providing device. 

ü ü ü ü ü

Ravenna

'System -> Definition' Application r c sc s N29

Parameter = Stream
Announcement

Define the mDNS and SAP channels used for stream
announcement.

ü û û û û

Parameter = PTP
Settings

Define the PTP settings for Power Core.
ü û û û û

Parameter = Control
Settings

Define the control settings applicable to RAVENNA.
ü û û û û

Parameter = Stream
Settings

Define the global settings for transmit (Tx) and receive (Rx)
streams.

ü û û û û

Parameter = Jitter
Classes

Define the Jitter Classes supported by Power Core, and their Time
Offset Additions (applied during stream tuning).

ü û û û û

Project

'System -> Definition' Application r c sc s N29

Parameter =
Description

Define text fields which are displayed in the Web UI (to describe the
project and system).

ü ü ü ü ü

Access Grp, Matrix AccGrp

'System -> Definition' Application r c sc s N29

Parameter = Settings 1 Define options for the surface (applicable to Access Group 1).
ü ü ü ü û

Parameter = Faders 1 Define options for the faders (applicable to Access Group 1).
ü ü ü ü û

Parameter =
Snapshots

Define options for snapshots.
ü ü ü ü û

Parameter = Logic
Snapshots

Define up to 32 logical states to be saved with every snapshot.
ü ü ü ü û

Parameter = Element
States Snapshots

Define up to 8 element states to be saved with every snapshot.
ü ü ü ü û

Parameter = Central
Menu

Configure control of the DSP pages on the surface: INP, DYN, EQ,
etc.

ü ü ü ü û

Parameter = Bus Menu Configure control of the BUS assign pages 1 to 5.
ü ü ü ü û

Parameter = VCA
Group Menu

Configure control of the VCA assign pages 1 and 2.
ü ü ü ü û

Parameter = Extension
Menu

Configure control of the page buttons on the Key Extension panel.
ü û û ü û

Parameter = Matrix
Snapshot

Define up to 128 matrix connections to be saved with every
snapshot.

ü û ü ü û
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3.20.1 Parameter = Aux

"System -> Definition -> Parameter = Aux"

This branch of the 'Tree Definition' defines the 20 summing buses which can be assigned from the control
surface. Note that the bus locations are called Aux 1 to Aux 20, although they may be used for any type of bus:
PGM, REC, AUX, etc.

Once a bus is assigned to an "Aux n" location, it will become available to the operator via the BUS assign buttons
on the Central Module (unless the Hide option is active). Up to five pages can be configured, where Aux 1 to 4
will appear on page one; Aux 5 to 8 on page two; and so on.

Select "System -> Definition" in 'Tree Definition' and the Audio tab to access the "Parameter = Aux" options:

Parameter Aux – reference name for the element.

Screen Button Text Defines the text displayed on VisTool "bus assign" buttons. Select Aux Text if you wish to inherit the
aux bus Display name.

Aux Mode Sequence Defines the order in which bus assignments are made; you can select between:

· Pre - post -off

· Post - pre - off

"Off", "Pre", "Post"
Colors

Defines the MF Key colors used for aux assignments. 

The default colors are Aux Off = green; Aux Pre = red; Aux Post = Yellow.

Aux 1 to 20 Assigns the summing bus defined as “Aux n”.

Hide Tick this box if you do not want the bus to be displayed on the Fader Module OLEDs when in ‘Bus
Assign’ mode.

Use this option to prevent operators from adjusting assignments onto a bus (e.g. PGM).

Fader Enable Assigns the control trigger which will switch the bus send levels onto the faders (globally across the
console). 
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3.20.2 Audio = Internal

"System -> Definition -> Audio = Internal"

This branch of the 'Tree Definition' defines the frequency switching for the internal LineUp signals and the
system-wide talkback sources. 

Start by selecting "System -> Definition" in 'Tree Definition' and the Audio tab. Scroll down to access the
"Audio = Internal" options:

Audio Internal – reference name for the element.

Line Up set f = n Hz Assigns input control signals to set the frequency of the Line Up signal. If no input signal is
assigned or true, then the generator defaults to 1kHz.

The number of LineUp signals is determined by the product, or for Power Core the active
license:

· Power Core Edge, SAN and Radio L = 1 LineUp signal

· Power Core Radio XL = 2 LineUp signals

· Power Core Max = 4 LineUp signals

Sys TB Assigns the audio signals to be used for system-wide talkback. These can be inserted into a
"Minmixer Sys TB" (via the Sys TB tab).

On crystal, two signals can be assigned: Sys TB 1 and Sys TB 2.

On sapphire, sapphire compact and Power Core, up to eight signals can be assigned: Sys
TB 1 to 8. Any two can be used in each Minimixer Sys TB.
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3.20.3 Parameter = Sync

"System -> Definition -> Parameter = Sync"

This branch of the 'Tree Definition' configures the system's sync reference parameters. See Synchronisation
for more about the sync reference options and how to use the Web UI to check the sync status.

Start by selecting "System -> Definition" in 'Tree Definition' and the Audio tab. Scroll down to access the
"Parameter = Sync" options:

Parameter Sync – reference name for the element.

Enable Sync from
PTP, MADI, etc.

When no boxes are ticked, the system is synchronised to internal system clock (either 48kHz or
44.1kHz, see Enable Samplerate Switch below.)

To sync to an external reference, select the relevant tick boxes.

Sync Prio If more than one sync source is enabled, then this menu sets the prioritization order.

Enable Samplerate
Switch

Select this tick box to enable the 44.1kHz sample rate switch (described below).

Samplerate 44.1kHz Selects a logic control signal to switch the system sample rate from 48kHz (default) to 44.1kHz. To
switch the sample rate you must check the Enable Samplerate Switch box AND apply a logic
control signal.
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3.20.4 Parameter = Meter

"System -> Definition -> Parameter = Meter"

This branch of the 'Tree Definition' sets the reference levels and metering options for the control surface and
VisTool.

Start by selecting "System -> Definition" in 'Tree Definition' and the Audio tab. Scroll down to access the
"Parameter = Meter" options:

Parameter Meter – reference name for the element.

Relative System Level
(dBFs)

Sets the relative system level in dBFS, see System Reference Levels.

Overload Thrs (dBR) Sets the overload metering point. Set the Overload Threshold to 3dB above the working
point to encourage good operating practice.

Analog Ref Level (dBu) Sets the analog reference level in dBu, see System Reference Levels.

Silence Thrs low (dBR) Enter the level at which the silence detect will become active for crystal meter channels.

Silence Thrs high (dBR) Enter the level at which the silence detect will become inactive. Use these two values to set a
range to avoid flicker.

Silence Timeout low (sec) Enter the period of time, for which the level must be below the defined threshold to activate the
silence detect. Use 0 for immediate signalisation.

Silence Timeout high (sec) Enter the period of time, for which the level must be above the defined threshold to deactivate
the silence detect.

The Meter A, Meter B and Meter 1 to 4 entries define the six stereo meters which can be displayed within
VisTool. For each stereo meter you can define:

Meter Name Enter a reference name for the meter.

Meter L, Meter R Assign a source to the left and right meter inputs.
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System Reference Levels

DIN SMPTE

Relative System Level - 27 - 38

Analog Reference Level 15 24

Operating Level (analog) +6 dBu + 4 dBu

Operating Level (digital) - 9 dBFS -20dBFS

The Relative System Level and Analog Reference Level are options defined in the configuration. They
combine to set the operating levels (analog and digital) for the system.

With Relative System Level (dBFS) you define the relative working point internally within the system. This
value can be calculated with the formula "RSL = - digital headroom - 18" or "RSL = working point -18dB".

For example, the working point (0 dBr) for the ARD (German Broadcasters’ Network) is at -9 dBFS. From this
follows a Relative System Level (dBFS) of -27. Note that the working point is important as dynamics and
limiter modules refer to this value. When the threshold value is set to 0 dB, the absolute level equals the working
point.

If required, the Relative System Level and Analog Reference Level can be edited using the ON-AIR
Designer. Start by opening the existing configuration, and then edit the Relative System Level (dBFS) and
Analog Ref Level (dBu) options in the 'Tree Definition' (shown below).

ON-AIR Designer Tree Definition: "System -> Definition -> Parameter = Meter"

Then save and transfer the edited configuration to the DSP Core. For more information about the configuration
tool, please see the "ON-AIR Designer User Guide". This is available from the Downloads area at
www.lawo.com (after Login).

http://www.lawo.com
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Phase Correlation

The following control outputs can be found in the 'Tree Selection', under the branch “Logic -> Definition ->
Parameter Meter”. These can be used to signal when a stereo meter signal is out of phase.
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3.20.5 Parameter = Insert

"System -> Definition -> Parameter = Insert"

This branch of the 'Tree Definition' configures the insert devices. You can use any audio inputs and outputs for
the connections to a mono or stereo insert device.

Start by selecting "System -> Definition" in 'Tree Definition' and the Audio tab. Scroll down to access the
"Parameter = Insert" options: 

Parameter Insert – reference name for the element.

Insert N Enter a name for the insert. This is both the reference name and the name which will be displayed
on the control surface, so use 6 characters or less.

Type: Stereo When checked the insert device is treated as a stereo device, and when unchecked a mono device
– see the notes above.

Output L

Output R

Assign the outputs (sends) to the insert device.

Input L

Input R

Assign the inputs (returns) from the insert device.
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3.20.6 Parameter = TieLine Stereo

"System -> Definition -> Parameter = TieLine Stereo"

This branch of the 'Tree Definition' supports 32 Stereo Tie Lines which can be used to dynamically assign
signals onto a MADI link between two compatible systems. This is useful if the number of inputs and outputs you
wish to share exceeds that of the available MADI links.

To use this feature you must configure the TCP Link under “System -> Definition -> Param = TCPLink”,
and Stereo Tie Line options for sending and receiving systems.

Start by selecting "System -> Definition" in 'Tree Definition' and the Audio tab. Scroll down to access the
"Parameter = TieLine Stereo" parameters:

Parameter TieLine Stereo – reference name for the element.

Desk Input 01 to 32 Enter the physical input used for the incoming Tie Line.

Matrix Output Nr Enter the matrix address of the output from the external system.

MNOPL Select this checkbox to enable the MNOPL protocol to use stereo tie lines with a Nova73.



ON-AIR Designer Configuration OptionsVersion: 6.6.0_1196/325

3. 'Tree Definition' Elements

3.20.7 Parameter = Signal Present

"System -> Definition -> Parameter = Signal Present"

This branch of the 'Tree Definition' defines the signal present indicator on the fader strips.

The fader strip backlight can be configured to show signal present, source color or to run in mix mode for
each source configured in the "Source" branch of the 'Tree Definition', see Source Color.

Start by selecting "System -> Definition" in 'Tree Definition' and the Audio tab. Scroll down to access the
"Parameter = Signal Present" options:

Parameter Signal Present – reference name for the element.

State 1 to 8 Thrs Enter the threshold level (dBR) at which you wish the indicator to illuminate. Please see
System Reference Levels to see how the dBr values equate to your system's operating levels.

Low Tick this box for half lit.

Blink Tick this box for flashing.

Color Select the color for the illumination.

In our example, the signal present indicator will illuminate as follows:

· Signals > 6dBR – fully-lit red.

· Signals > -1dBR – fully-lit yellow.

· Signals > -30dBR – fully-lit green.

· Signals < -30dBR – half-lit black (off).
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3.20.8 Parameter = Surround Downmix

"System -> Definition -> Parameter = Surround Downmix"

This branch of the 'Tree Definition' defines the downmix parameters to be used when a surround source is
routed to a stereo summing bus.

You may set up 5 sets of downmix parameters so that the operator may change the downmix according to
their requirements. Once selected, the downmix parameters are applied globally to all surround to stereo
assignments.

If a surround source is assigned to a mono bus, then the stereo downmix is converted to mono by
subtracting 3dB from, and then summing, the L and R channels.

Start by selecting "System -> Definition" in 'Tree Definition' and the Audio tab. Scroll down to access the
"Parameter = Surround Downmix" options:

Parameter Surround Downmix – reference name for the element.

Lf -> L This is the amount of signal applied from Left Front to the Stereo Left output. Levels are entered in
dB. 

Rf -> L As above for Right Front.

C -> L As above for Center.

LFE -> L As above for LFE (Low Frequency Effect/Sub)

Ls -> L As above for Left Surround.

Rs -> L As above for Right Surround.

Lf -> R, etc. Repeat as above but for levels to the Stereo Right output.

Select Enter a control signal to make the downmix parameters active. If nothing is entered, then the first
set of parameters is applied.
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3.20.9 Parameter = PFL Mode

"System -> Definition -> Parameter = PFL Mode"

This branch of the 'Tree Definition' configures the PFL modes for each listen bus. To use PFL 2 to 5, you must
first create a user-defined bus for each additional listen bus required. This is done using Sum Buses in the
usual manner. Note that PFL 3, 4 and 5 are not supported by crystal. 

Start by selecting "System -> Definition" in 'Tree Definition' and the Audio tab. Scroll down to access the
"Parameter = PFL Mode" options:

Parameter PFL Mode – reference name for the element.

PFL Mode x Assigns a control signal to activate the corresponding PFL mode.

PFL Off Assigns a control signal to reset any active PFL buttons to off.

PFL Swap to Used in conjunction with the “Fader Module -> PFL1 Swap parameter” options.

PFL Sum Assigns a sum bus to PFL 2 (and PFL 3, 4 & 5 on sapphire, sapphire compact and Power
Core).

No PFL when
Hotfader closed

When checked, PFL ignores the hot fader position. So, if you are working in hot fader mode, PFL
responds to the actual channel level and not the physical fader position.
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3.20.10 Parameter = Mic AutoGain

"System -> Definition -> Parameter = Mic AutoGain"

This branch of the 'Tree Definition' defines the AutoGain target level.

Start by selecting "System -> Definition" in 'Tree Definition' and the Audio tab. Scroll down to access the
"Parameter = Mic AutoGain" options:

Parameter Mic AutoGain – reference name for the element.

Target Level (dBr) Enter the AutoGain target level in dBr. The default value is 0.
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3.20.11 Parameter = Settings

Within the "System -> Definition" branch of the 'Tree Definition', there are two sets of global options:
"Parameter = Settings" and "Parameter = Settings 1 (2, 3, 4)", where 2, 3, 4 appear only for Power Core Max.

For a standard System Core, both sets of options are applied globally (as there is only one Access Group). For
Power Core Max, the "Parameter = Settings" options are applied globally, while the "Settings x" options apply to
a specific Access Group (to allow a different configuration for each surface).

"System -> Definition -> Parameter = Settings"

Select "System -> Definition" in 'Tree Definition' and the Logic tab to access the "Parameter = Settings"
options:

Parameter Settings – reference name for the element.

Pan/Bal first This setting defines the default function of the fader strip's rotary encoder.

When there is no check in the box, the encoder controls GAIN/MIC settings first. The operator
must then tap down on the control to access PAN/BAL.  

Check the box if you wish to reverse the priority and control PAN/BAL first. 

Sort by LCD Text When checked, sources within the source list are sorted by their Display name. If unchecked,
the sources are sorted by their Reference name. The Display and Reference names are
defined in Source -> Parm.

NTSC When checked, Delay times set in the Delay module are calculated using NTSC frames.
Unchecked, the system uses PAL frames.

DMS Integration Mode This setting defines the time constant for all PPM meters within VisTool. The options are|:
Ultrafast, Fast, Normal or Slow.

Correction Key-LED Sets an offset for the LED brightness of console keys.

Correction Display Sets an offset for the OLED brightness.

Gain Reset Off If an input is used as a matrix input and as an input to a source:

Check this box so that the source gain is unaffected if the matrix input is disconnected.

Uncheck the box and the source gain is reset to 0dB IF the matrix input disconnects.

Conf'd Panels always
green

When this option is off, the Conference MF Key on VisTool changes color to indicate the
conference status: red = active; green = off.

Turn the option on to override the color-coding so that the conference MF Key always lights in
green.

Can Bus Speed Available when the System Core = Power Core.  Defines the CAN bus speed for the surface.
This option can also be set from the 'Project' window.

VCA encoder max value Available when the System Core = Power Core. This setting adjusts the maximum possible
value for rotary encoders. The default is 0dB.

If you wish to use rotary encoders and faders to adjust the same settings in parallel, then you
should change the value to +9dB (so that VCAs have the same maximum value as faders).
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"System -> Definition -> Parameter = Settings 1"

Select the AccessGrp 1 tab to adjust the "Parameter = Settings 1" options:

Parameter Settings 1 – reference name for the element.

Disable Ambient Light
Sensor

Assigns a control input which will disable the ambient light sensor(s). 

Assign the TRUE.Out control output from a NOT gate to disable the sensor. Or, assign an MF
Key to provide operators with an enable/disable button.

Disable System Menu Available for ruby, sapphire compact and sapphire. Assigns a control input to disable the
SYS button on the Central Module. This prevents operator access to the system options.

Disable Bus Menu Available for ruby. Assigns a control input to disable the BUS button on the Central Module.
This prevents operator access to bus assign pages.
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3.20.12 Parameter = Faders

Within the "System -> Definition" branch of the 'Tree Definition', there are two sets of options for the console
faders: "Parameter = Faders" and "Parameter = Faders 1 (2, 3, 4)", where 2, 3, 4 appear only for Power Core
Max.

For a standard System Core, both sets of options are applied globally (as there is only one Access Group). For
Power Core Max, the "Parameter = Faders" options are applied globally, while the "Faders x" options apply to a
specific Access Group (to allow a different configuration for each surface).

"System -> Definition -> Parameter = Faders"

Select "System -> Definition" in 'Tree Definition' and the Logic tab to access the "Parameter = Faders"
options.

Parameter Faders – reference name for the element.

Use Scale +9dB

Use Scale 0dB

Assigns input control signals to switch between fader scales.

The default fader scale, with nothing entered in either box, is to +9dB.

To permanently set the console to a fader scale, assign a logic element which will always be
true – for example, a NOT gate with no input. 

Ref Source Fader Offset Available when the Surface = ruby or sapphire MK2. 

When a source is assigned to the control surface, a reference source can be assigned at the
same time. This value defines the position at which the reference source will be assigned, as
an offset from the current source position. For example, on a control surface with 20 fader
strips and 2 layers, if you wish the reference source to be assigned on the alternate layer, you
would enter a fader offset of 20. 

Production Mode (Save
Value)

This option is recommended for production systems, but not for on-air.

When ticked, fader levels are recalled by snapshots. When unticked, fader levels are ignored
(to avoid accidental reset of an on-air source).

Show Group Fader Values

Group Fader Values
Fallback

Group Fader Value Hold
Time (sec)

The next three options are available when the Surface = ruby, sapphire compact or sapphire
MK2. 

Enable the Show Group Fader Values option to show the resulting fader values applied to
VCA slaves in the fader strip displays. The value shown is the combined result of the VCA and
source fader. If the Group Fader Values Fallback option is also enabled, then the displays will
revert to their default mode (e.g. source name) after a certain time period. The time period is
set by the Group Fader Value Hold Time (in seconds).
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The next four options are available when the Surface = crystal. 

Freeze all Channels Assigns a control input which will disable controls on the Channel Module. You might activate
this mode to dust the console!

Motor Fader Open Initially sets the "Background fader" to open (after coldstart). The Background fader may be
used for RAS control or the Fader Up/Down/Toggle logic. If you do not use any of these, you
should set the fader to open (as the fader is always in the signal path).

Manual Fader Open Initially sets the "Surface fader" to open. If you do not have a surface attached and use logic,
RAS or any other protocol for fader control, you may set the fader to open (as the fader is
always in the signal path).

Vistool Fader is Choose the fader which is shown and controlled in Vistool. Motor Fader represents the
"Background fader", while Hot Fader represents the "Surface fader". See Fader Status.
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"System -> Definition -> Parameter = Faders 1"

Then select the AccessGrp 1 tab and scroll down to access the "Parameter = Faders 1" options:

Parameter Faders 1 – reference name for the element.

Dim Source Colors Sets defined source colors to dim.

User Labels On

User Labels Off

User Labels Toggle

These control inputs switch User Labels on or off, or toggle their state.  They can be used to
configure how operators view User Labels on the surface.

Enable Large User Labels This control input switches User Labels on the surface to large display mode.

Global switch to Layer 1 Assigns a control input to switch all Fader Modules enabled for layering to Layer 1.

Global switch to Layer 2 Assigns a control input to switch all Fader Modules enabled for layering to Layer 2.

Swap ACCESS Keys Swaps the function of the Fader Module ACCESS keys 1 and 2. If Layer 2 is disabled in a
Fader Module, then ACCESS 1 and MF 5 are swapped.

Save Channel On/Off If ticked, the Channel On/Off parameter of sums and sources is stored and recalled by
snapshots and memories.

Fader Notch (initial)

Enable/Disable Fader
Notch

Sets the initial value (active after a cold start) for the SYS menu Fader Notch option.

Assigns a control input to enable or disable the Fader Notch.

Hot Fader Mode (initial)

Enable/Disable Hot Fader
Mode

Sets the initial value (active after a cold start) for the System menu's Hot Fader Mode.

Assigns a control input to enable or disable Hot Fader mode.
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The following control outputs appear in the 'Tree Selection'. They can be used to signal when a state is active. 

Scale +9dB active True when the +9dB fader scale is active.

Scale 0dB active True when the 0dB fader scale is active.

User Labels active True when User Labels are active.

Global Layer 1 active True when the Global Layer 1 switch is active.

Global Layer 2 active True when the Global Layer 2 switch is active.

Fader Notch active/not
active

True when the Fader Notch is active (or not active).

Hot Fader Mode active/not
active

True when Hot Fader Mode is active (or not active).



ON-AIR Designer Configuration OptionsVersion: 6.6.0_1206/325

3. 'Tree Definition' Elements

3.20.13 Parameter = Timers

"System -> Definition -> Parameter = Timers"

This branch of the ON-AIR Designer 'Tree Definition' sets the options for the six standard timers included in
every configuration. Choose a standard timer if you do not need synchronized operation.

1. Start by selecting "System -> Definition" in 'Tree Definition' and the Logic tab. Scroll down to access
the timer parameters.

ON-AIR Designer Standard Timers

The fields can be used to name each timer and define how it is triggered:

Parameter Timer – reference name for the element.

Time N Name Enter a reference name for the timer.

Timer N Start Assigns a control signal to start the timer. The timer will start from its current position. 

If you want a key to always start the timer from 00:00:00:00, assign the same key to both the
Timer N Start and Timer N Reset functions.

Timer NStop Assigns a control signal to stop the timer.

Timer N Reset Assigns a control input signal to reset the timer to 00:00:00:00.

Timer N Restart Assigns a control input signal to restart the timer from its current position.

In the 'Tree Selection' window, the following outputs appear under “Logic -> Definition -> Parameter Timer”.
These can be used to illuminate the trigger keys and/or signal the timer alarm status:

Timer N Run Active when the timer is running. Can be used to illuminate the MF Key controlling the timer.

Timer N Alarm Active when the timer alarm is active.
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2. Then open VisTool Editor and insert a Timer element in the usual manner.

Edit the Timer ID in the 'Properties' panel to link the element to an ON-AIR Designer timer. For standard timers,
the ID numbers are fixed: Timer 1 = ID 1; Timer 2 = ID 2; and so on.

VisTool Editor Standard Timer (linked to Timer 1)
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3.20.14 Parameter = Screen

"System -> Definition -> Parameter = Screen"

This branch of the 'Tree Definition' defines general settings for VisTool functions. The options apply globally to
all VisTool instances.

Start by selecting "System -> Definition" in 'Tree Definition' and the Logic tab. Scroll down to access the
"Parameter = Screen" options:

Parameter Screen – reference name for the element.

Enable Fader Messages When ticked, messages concerning fader levels are exchanged via DMS. When unticked,
fader messages via DMS are disabled. 

The option must be ticked in order to exchange fader values with VisTool (e.g. to/from VisTool
Fader elements). When enabled, there will be an increase in the amount of network traffic.

If fader messages are not required (to/from other DMS devices), then the option should be
disabled to reduce the volume of network traffic.

VisPage 1 to 10 Available for crystal, sapphire and sapphire compact.

Assigns a control signal (for example, an MF Key) to switch VisTool to a particular page. You
can configure switching for the first 10 VisTool pages – page index 1 to 10. Pages are
switched across all VisTool instances. Thus, if you are connecting more than one VisTool and
wish to configure independent page switching, please use the "Logic -> VispageSwitch"
element instead.

ASSIGN State Key Pressed
Transition

Available for ruby.

Defines whether the console ASSIGN state triggers ACCESS functions in VisTool. There are
two possible states: ASSIGN triggers ACCESS or ASSIGN triggers the normal state.
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3.20.15 Parameter = PowerUp

"System -> Definition -> Parameter = PowerUp"

This element has no parameters in the 'Tree Definition' but adds some logical states to the ‘Tree Selection’
window. The states can be used to action other functions – for example, to load a default snapshot on power-
up.

The control outputs appear in the 'Tree Selection' window under “Logic -> Definition -> Parameter PowerUp”:

ColdStart Active for one second after a cold start.

WarmStart Active for one second after a warm start.

Audio to Backplane This output is true if the associated master board is active. If the master board is not active,
the logic signal is false.

M1 or M2 active These outputs are true if the master card in Slot 1 or Slot 2 is active. They can be used in
sapphire systems to trigger functions when the redundant master card becomes active.

In the example below, the state “WarmStart” has been configured to Load Snapshot 1:
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3.20.16 Parameter = Madi

"System -> Definition -> Parameter = Madi"

This branch of the 'Tree Definition' defines parameters for the MADI ports.

Select "System -> Definition" in 'Tree Definition' and the Madi tab to access the options:

Parameter Madi – reference name for the element.

P1, 2, 3, 4 External
Matrix Port

This is a project-specific feature.

Server 1 active 

Server 2 active

These options support a redundant matrix server.

Assign a control signal to switch to server 1 or server 2.

P1 Enable 64 Tx Slots When this checkbox is selected, the MADI port transmits 64 slots as opposed to 56. 

Note that the receiver automatically detects whether 56 or 64 slots are supplied. If the port is
configured to transmit 64 slots and only 56 are received, then the last 8 slots are muted.

The option can be selected for each individual MADI port.

P1 Select Input 2 Click to assign a control signal to switch the MADI port from P1 to P2.

Note that if Sync from MADI is enabled, then this will also switch the MADI sync source.

The option can be selected for each odd/even pair of MADI ports.

P2 Tx = P1 Tx When this checkbox is selected, MADI port P2 transmits the same data as port P1. The option can
be used to configure redundant MADI outputs.

The option exists for each odd/even pair of MADI ports.
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3.20.17 Parameter = OnAirControl

"System -> Definition -> Parameter = OnAirControl"

This branch of the 'Tree Definition' provides 64 inputs and outputs to control or respond to functions within an
external Radio Automation System (RAS).

Select "System -> Definition" in 'Tree Definition' and the OAC tab to access the options:

Parameter OnAirControl – reference name for the element.

TCP-Mode Check this box to enable RAS (Radio Automation System) control over TCP/IP.

OAC GPO 1 to 64 Assign a control signal (e.g. MF Key) to each of the OAC GPOs. 

This allows functions within the system to remotely control functions within the Radio
Automation System.

Aux No. Musik Enter the aux bus number dedicated to the Music signal (for RAS control).

Aux No. Speech Enter the aux bus number dedicated to the Speech signal (for RAS control).

The following control outputs appear in the 'Tree Selection', under “Logic -> Definition -> Parameter
OnAirControl”. They can be used to signal when a RAS function is active.

OAC GPI 1 to 64 Active when the allocated RAS function is active. 
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3.20.18 Parameter = TCP Link

"System -> Definition -> Parameter = TCP Link"

This branch of the 'Tree Definition' defines the TCP/IP connections to other systems within the control network.
To establish communication, you must enter the IP address of each connected system. Then assign a TCP/IP
link mode to manage the network traffic. The following data exchange modes are supported:

· GNET –  for GPI/O Network data only.

· KPF – for matrix control data only (via a Matrix Connect or Matrix Query).

· GKPF – allows both GPI/O Network and matrix control data.

· DKPF – for use with an external matrix server. This is a project-specific feature.

· GLOC – for a GNET Local connection (used with Mic Arbitration).

· AIF1, AIF2 – for use with the Alarm Log Server and Line Schedulers.

Start by selecting "System -> Definition" in 'Tree Definition' and the TCP tab to access the parameters:

Parameter TCP Link – reference name for the element.

Active TCP Connection Enter the TCP/IP address for each connected system. 

Mode Then enter the Mode using the syntax listed above. From each system, only one link can be
KPF or GKPF, except for connections to a main and redundant Master Board (sapphire).

Send Context Tick the Send Context option to send the mode to the receiver. For some functions like
Intercom Clients, this option must be activated.

External Router 1, 2

Map

These options are used with a Nova73. Start by entering the TCP/IP address of the Nova 73
control system into the External Router 1 field. This enables communication via the
MNOPL protocol. External Router 2 should be used if there is a redundant connection to
the Nova 73.  

Then enter the number of the Nova73 mapping table into the Map field (from 1 to 16).

MNOPL Server Tick this option to enable the remote MNOPL server when interfacing to a z4 system.

LS Doublestar This is a project-specific feature.

Surface over TCP Tick this option to enable "surface" messages to be transmitted via Ethernet (KS-ETH). This
affects the transmission of "surface" messages to/from key panels using the firmware KS16.
It can be used to prevent CAN bus buffer overflows.
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3.20.19 Parameter = Alarm

"System -> Definition -> Parameter = Alarm"

This branch of the 'Tree Definition' defines the options for the Global Alarm.

Select "System -> Definition" in 'Tree Definition' and the Alarm tab to access the options:

Parameter Alarm – reference name for the element.

Alarm Contact This field is supported by DALLIS only. It assigns a control signal to activate the Global Alarm
contact. Note that when this signal is active, no other error need be active to trigger the alarm.

Temp Level OK The value entered here sets the temperature in ° C at which the Global Alarm is reset after it
has been active.

Temp Level Max The value entered here sets the temperature in ° C at which the Global Alarm will be activated.

Note that the maximum temperature varies depending on the product. If you attempt to enter a
value outside of the permitted temperature range, then the entry box turns red.

DB Alarm Act x These fields can be used to display the alarm states (active and inactive) of an external Alarm
Log Server.

The following control outputs appear in the “Logic -> Definition -> Parameter Alarm” branch of the 'Tree
Selection' window:

Pwr Supply OK Active when the power supply is operating correctly.

Pwr Supply Failed Active when the power supply has failed.

Temperature OK Active when the temperature is below the value set under Temp Level OK in the ‘Tree
Definition’.

Temperature Over Active when the temperature exceeds either the value set under Max Temp Level in the
‘Tree Definition’, or the critical system temperature.
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3.20.20 Protools

The Mackie-HUI™ protocol offers many central control functions such as transport control, automation modes,
etc. These can be assigned to MF Keys or other control signals. Please see MACKIE HUI Parameters for a full
list of elements and their assignable functions.

Assigning DAW Parameters

"System -> Definition -> Protools"

Each function is listed as a separate element within the “System -> Definition” branch of the ‘Tree Definition’. 

To assign a function to an MF Key:

1. Start by selecting "System -> Definition" in 'Tree Definition' and the Protools tab. 

2. Select the function you wish to configure - for example, ProTools = V Pot Assign:

3. Double-click in a parameter box to assign the MF Key.

The corresponding control output can be found under the "Logic" branch of the ‘Tree Selection’ window. This
can be used to light the MF Key.
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3.20.21 Parameter = Local Consumers

"System -> Definition -> Parameter = Local Consumers"

An Ember+ Consumer can control, or respond to, parameters published by an Ember+ providing device.

Up to 15 Ember+ consumers can be defined in the "System -> Definition -> Parameter = Local Consumers"
branch of the 'Tree Definition' window. The Consumer number (1 to 15) will be referenced by other elements.
For example, from an Ember+ GPIO.

Select "System -> Definition" in 'Tree Definition' and the Ember+ tab to access the "Local Consumers"
options:

Parameter Local Consumers – reference name for the element.

Remote IP Address Enter the TCP/IP Address of the Ember+ providing device. You can enter either "127.0.0.1" or
"localhost" to configure the local host.

Remote Port Number Enter a port number. This must match the Port Number of the Ember+ provider:

· If the provider is configured using the ON-AIR Designer, then enter the Local Port Number
defined in the provider's configuration.

· If the providing device is another system type (A__stage, V_pro8, Orban, etc.), then you will
need to find out the Ember+ control port number from the relevant documentation.

Task Priorities This option can be used to raise the priority of the Ember+ Provider, when compared to DMS
and network communications (such as GNET). The default setting of normal is
recommended, as changing the priorities may affect the overall system performance. The
options are:

· normal = the Ember+ provider has low priority. Interference of different functions is
minimal. When executed, Ember+ functions may be delayed.

· high = the Ember+ provider is prioritised above DMS. Ember+ functions are executed
faster. There may be delays to DMS functions like VisTool metering updates or VisTool
control.

· highest = the Ember+ provider is prioritised above DMS and TCP/IP link communication:
AIF, KPF, GNET, etc. In addition to the effects described above (for high), the setting of
crosspoints via GNET may be delayed.
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3.20.22 Parameter = Local Providers

"System -> Definition -> Parameter = Local Providers"

An Ember+ Provider publishes parameters so that they may be controlled by an external consuming device. 

Up to five Ember+ providers can be defined in the "System -> Definition -> Parameter = Local Providers"
branch of the 'Tree Definition' window. The Provider number (1 to 5) will be referenced by other elements. For
example, from an Ember+ GPIO or Source element. This allows you to change what can be accessed from
each external device.

Select "System -> Definition" in 'Tree Definition' and the Ember+ tab to access the "Local Providers"
options:

Parameter Local Providers – reference name for the element.

Local Port Number Enter a port number. This must match the Port Number of the Ember+ consumer:

· If the consumer is configured using the ON-AIR Designer, then enter the Remote Port
Number defined in the consumer's configuration.

· If the consuming device is another system type (V_pro8, Orban, etc.), then you will need to
find out the Ember+ control port number from the relevant documentation.

Task Priorities This option can be used to raise the priority of the Ember+ Provider, when compared to DMS
and network communications (such as GNET). The default setting of normal is
recommended, as changing the priorities may affect the overall system performance. The
options are:

· normal = the Ember+ provider has low priority. Interference of different functions is
minimal. When executed, Ember+ functions may be delayed.

· high = the Ember+ provider is prioritised above DMS. Ember+ functions are executed
faster. There may be delays to DMS functions like VisTool metering updates or VisTool
control.

· highest = the Ember+ provider is prioritised above DMS and TCP/IP link communication:
AIF, KPF, GNET, etc. In addition to the effects described above (for high), the setting of
crosspoints via GNET may be delayed.

Enable Subscript Reports This option determines whether the Ember+ Provider will announce value changes to
connected consumers. When ticked, values are announced (required for bi-idirectional
Ember+ Source Replication). When not ticked, values are not announced; this can be used to
reduce the volume of network traffic.
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In addition, the following options affect all Ember+ providers.

Available for All Products

Parameter Matrix – reference name for the element.

Internal Matrix This field is used to publish the device's internal matrix to an Ember+ provider - enter the
provider number from 1 to 5, or select None if you do not wish to publish the matrix.

Ember+ Name The matrix name appears in the Ember+ tree. It is good idea to edit the name if you are
publishing matrices from multiple devices.

Available for Power Core

Parameter Providers Client Whitelist – reference name for the element.

Client xx IP Address This list can be used to restrict the access to the Ember+ providers so that only devices with
a defined IP can talk to Power Core (via Ember+). Up to 16 IP addresses (or host names) can
be configured. If at least one IP address / host name is entered, then the whitelist becomes
active. If all fields are empty, then the whitelist is disabled and access is permitted from
consumers with any IP address.

For convenience, the whitelist can be temporarily disabled from the Power Core Web UI (via
the System -> Control tab).

Parameter Settings – reference name for the element.

Sources/Sums Naming This option determines whether sources are published using their Display name (System
name) or Alias name. In either case, the name must be unique to ensure correct operation.

3.20.23 Parameter = Stream Announcement, PTP Settings, etc.

Please see Global RAVENNA Settings.

3.20.24 Parameter = Description

"System -> Definition -> Parameter = Description"

This branch of the 'Tree Definition' allows you to define text fields which are displayed in the Web UI (to
describe the project and system).

Parameter Description - reference name for the element.

Project Name Free text (up to 21 characters).

Version Free text (up to 21 characters).

Project Description 1
to 4

Free text (up to 21 characters).

3.20.25 Parameter = Settings 1

See Parameter = Settings.

3.20.26 Parameter = Faders 1

See Parameter = Faders.
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3.20.27 Parameter = Snapshots

"System -> Definition -> Parameter = Snapshots"

This branch of the 'Tree Definition' configures the global options for snapshots. The same parameters are
repeated four times in a Power Core Max system (to allow a different configuration for each Access Group).

Select "System -> Definition" in 'Tree Definition' and the AccessGrp tab. Scroll down to access the
"Parameter = Snapshots" options:

Parameter Snapshots – reference name for the element.

Load max. Fader No. Enter the maximum fader number which will be reset by a snapshot load. Any fader above this
number will not be affected. Leave the field blank to apply snapshot loads to all faders.

This option applies to both the internal snapshot memories and VisTool snapshots.

Load Audio always If ticked, audio-related parameters are loaded for all faders regardless of the Load max. Fader No.
You can use this option to load audio-related parameters to all faders, while loading fader strip
assignments up to the Load max. Fader No. 

Audio-related parameters include User Labels, DSP Settings, Fader level (if Production Mode is
enabled) and Bus assignments.

This option applies to both the internal snapshot memories and VisTool snapshots.

Enable Load Groups
Logic

Available when the System Core = Power Core. 

If ticked, a number of additional logic inputs become available - FC: Disable... and FO: Enable...
The inputs can be used to change which source parameters load depending on the fader status.
See Selective Loading of Source Parameters.

If unticked, the default behaviour applies: all parameters load if source faders are closed, and do not
load if source faders are open.

This option applies to both the internal snapshot memories and VisTool snapshots.

Load Snapshot 1 to 5 Assigns input control signals which will load internal snapshot memories 1 to 5 when supplied with
a rising edge.

For example, you may wish to program an MF Key which will ‘zero’ the desk from the press of a
button.  

Save Snapshot 1 to 5 Assigns input control signals which will save internal snapshot memories 1 to 5 when supplied with
a rising edge.

Load Src Clipboard When activated, this control signal loads DSP parameters in the internal clipboard to the source “in
access”.

Save Src Clipboard When activated, this control signal saves DSP parameters from the source “in access” to the
internal clipboard.

Delete Src Clipboard When activated, this control signal clears the internal clipboard.
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Reset Channel Parameters When activated, this control signal resets DSP parameters for the source "in access" to their
default values.

Unlock Save & Load Use these options to protect the SAVE and LOAD buttons on the Central Module.

When nothing is assigned, or the Enable box is unticked, the function is always available to
the operator. 

To protect the function, assign an input control signal and tick the Enable checkbox.

The following control outputs appear in the 'Tree Selection' window under “Logic -> Definition -> Parameter =
Snapshots”:

Snapx.set Active when data is stored to the internal snapshot memory. This can be used to signal to the
operator which memories contain settings and which memories are empty.

Snapx.load This output is pulsed when the snapshot is loaded.

Src Clipboard.set Active when data is stored to the internal clipboard.

Glb Snap loaded pulse This output is pulsed when a Full snapshot is loaded.

Src Snap loaded pulse This output is pulsed when a Src snapshot is loaded.

3.20.28 Parameter = Logic Snapshots

"System -> Definition -> Parameter = Logic Snapshots"

This branch of the 'Tree Definition' can be used to save and recall up to 32 logical states with every snapshot.
The same parameters are repeated four times in a Power Core Max system (to allow a different configuration
for each Access Group).

Select "System -> Definition" in 'Tree Definition' and the AccessGrp tab. Scroll down to access the
"Parameter = Logic Snapshots" options:

Parameter Logical Snapshots – reference name for the element.

State 1 Enter the first logical state you wish to save.

State 2 Enter the second logical state you wish to save.

etc. Continue as above. You can enter up to 32 logical states.
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3.20.29 Parameter = Element States Snapshots

"System -> Definition -> Parameter = Element State Snapshots"

This branch of the 'Tree Definition' can be used to save and recall up to eight element states with every
snapshot. The same parameters are repeated four times in a Power Core Max system (to allow a different
configuration for each Access Group).

Elements which support this functionality include the Connect -> TConn64, Logic -> Button16 and Logic ->
Button64. 

Select "System -> Definition" in 'Tree Definition' and the AccessGrp tab. Scroll down to access the
"Parameter = Element States Snapshot" options.

Parameter Element States Snapshot – reference name for the element.

Element State 1 Enter the first element Out State you wish to save.

Element State 2 Enter the second element Out State you wish to save.

etc. Continue as above. You can enter up to 8 element Out States.

To determine which elements will be saved, enter the element's Out State control signal into the Element State
field as shown below:
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Then enter the corresponding Element State Save control signal into an element's In State field to define the
element for snapshot recall. In our example, the Out State from the Button16 will switch the In State of a
TConn64 element:
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3.20.30 Parameter = Central Menu

"System -> Definition -> Parameter = Central Menu"

This branch provides external control of the Central Module's DSP pages: INP, DYN, EQ, etc.

Parameter Central Menu – reference name for the element.

ACCESS/ASSIGN Reset Assign an input control signal to reset any active ACCESS buttons to off. This will cancel any
open menus: INP, DYN, EQ, etc.

The following control outputs appear in the 'Tree Selection'. They can be used to signal when a menu or state is
active. 

During a fader strip assignment a source may be in access. Thus, it is possible for both the ACCESS active
and ASSIGN active outputs to be true at the same time.
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3.20.31 Parameter = Bus Menu

"System -> Definition -> Parameter = Bus Menu"

This branch provides external control of the BUS assign pages 1 to 5 (known as the Aux Bus menus).

Parameter Bus Menu – reference name for the element.

Select Menu Page n Assign an input control signal to select an aux bus menu.

Reset Assign an input control signal to reset (cancel out of) the aux bus menus.

The corresponding control outputs appear in the 'Tree Selection'. They can be used to signal when a menu is
active.

3.20.32 Parameter = VCA Group Menu

"System -> Definition -> Parameter = VCA Group Menu"

This branch provides external control of the VCA Group assign pages 1 and 2.

Parameter VCA Group Menu – reference name for the element.

Select Menu Page n Assign an input control signal to select VCA Group assign page n.

The corresponding control outputs appear in the 'Tree Selection'. They can be used to signal when a menu is
active.
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3.20.33 Parameter = Extension Menu

"System -> Definition -> Parameter = Extension Menu"

This branch of the 'Tree Definition' provides external control of the page buttons on a Key Extension panel
(optional on sapphire and ruby).

Parameter Extension Menu – reference name for the element.

Menu Assign an input control signal to select a page: Input, Surround Panning, etc.

Reset Assign an input control signal to reset (cancel) the Key Extension page.

An "Out" control signal for each menu appears in the 'Tree Selection'. They can be used to signal when a menu
is active.
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3.20.34 Parameter = Matrix Snapshot

"System -> Definition -> Parameter = Matrix Snapshot"

This branch of the 'Tree Definition' can be used to save and load up to 128 matrix connections with every
snapshot. The same parameters are repeated four times in a Power Core Max system (to allow snapshots to be
handled separately for each Access Group).

Each channel of a stereo or multi-channel output has to be defined individually.

Start by selecting "System -> Definition" in 'Tree Definition' and the Matrix AccGrp tab. Scroll down to access
the "Parameter = Matrix Snapshot" options

Parameter Matrix Snapshot 1 – reference name for the element.

Entries 1...8 Enter the matrix numbers for the first 8 outputs whose connections you wish to save.

etc. Continue as above. You can define up to 128 matrix connections.
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3.21 Universal Sums

The Universal Sum In and Universal Sum Out elements can be used to sum signals within a Nova29 system.

3.21.1 Universal Sum In

Up to 128 mono (or 64 stereo) Universal Sum Ins may be defined, each with its own audio input. Each Universal
Sum In is then routed to any or all Universal Sum Outs (up to a maximum of 7, mono or stereo, at a time).
Control signals can be configured to provide on/off, pre/post and variable level control for each summing point.

First, insert and name the elements in the usual manner. Then define the summing parameters from the ‘Tree
Definition’.

Universal Sum Input Reference name for the element.

In Selects the audio input for the Universal Sum In.

Universal Sum 1 Assigns the input to a summing output. You can choose any named Universal Sum Out (mono
or stereo) element.

Note: if you have not named your Universal Sum Out, then you will not see it as an option in
the 'Treeselection'. 

Pre 1 Assigns a control signal to switch the summing input send to pre VCA level.

Post 1 Assigns a control signal to switch the summing input send to post VCA level.

Off 1 Assigns a control signal to switch the summing input send to off.

Level 1 Assigns a level control to adjust the summing input send level.

Default Level 1 (init) This level is applied when nothing is assigned to the Level x function.

etc. The Universal Sum, Pre, Post, Off, Level and Default Level parameters are repeated seven
times, allowing you to assign each Universal Sum In to up to 7 Universal Sum Outs.



ON-AIR Designer Configuration Options Version: 6.6.0_1 227/325

3. 'Tree Definition' Elements

3.21.2 Universal Sum Out

Up to 14 mono or 7 stereo Universal Sum Outs may be defined. Each Universal Sum In can then route to a
maximum of 7 Universal Sum Outs (mono or stereo) at a time.

This branch of the 'Tree Definition' names the Universal Sum Out elements.

Universal Sum Out Reference name for the element.
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3.22 VisChan

The "Vis Chan" branch of the ON-AIR Designer's 'Tree Definition' names the physical controls on Fader/Channel
Modules so that they can be mapped to VisTool elements. This allows physical MF Keys and displays such as
signal present to be mirrored on a VisTool runtime GUI.

You must enter a unique reference name for each control you wish to access. Then save the configuration, and
link it to VisTool Editor (using the Project Properties). Within VisTool Editor, you will find all named functions
under the corresponding drop-down menus when you define an element's function - for example, named MF
Keys appear under the MF Key branch when defining a VisTool Button or Box element.

The following controls can be named in the ‘Tree Definition’. Note that you will need to repeat the procedure for
each Fader/Channel Module you wish to access.

VisChan Parameters

MF 1.1a, MF 1.1b, etc. Reference name for Fader 1 MF Key 1a, 1b, and so on.

SigP 1 Reference name for Fader 1 Signal Present indicator.

Access 1 Reference name for Fader 1 ACCESS key (to put the source into access).

Assign 1 Reference name for Fader 1 ACCESS key (to activate fader strip assign).

LayerSelect 1 Reference name for Fader 1 ACCESS key (to operate layer switching and provide access to
the ACCESS function for sources on layer 2.

LCD-Text 1 Reference name for Fader 1 Display Name.

Label 1.1 Reference name for Fader 1 User Label Line 1.

Label 1.2 Reference name for Fader 1 User Label Line 2.

MicGain 1 Reference name for Fader 1 mic gain (analog input gain).

Gain 1 Reference name for Fader 1 gain (channel DSP gain).

BackGain 1 Reference name for Fader 1 BackGain.



ON-AIR Designer Configuration Options Version: 6.6.0_1 229/325

4. Configuring Audio-over-IP

4.     Configuring Audio-over-IP

This chapter describes the options for Audio-over-IP.

The RAVENNA setup varies depending on the type of System Core. For Power Core, all of the configuration is
handled by the ON-AIR Designer. For the Compact Engine, two different tools are required: the ON-AIR
Designer and RAVENNA Web UI. This document describes the ON-AIR Designer parameters.

All streams are fully compatible with the SMPTE ST2110-30/31, AES67 and RAVENNA standards. To achieve
redundant streaming, compatible with SMPTE ST2022-7, you must use both interfaces: primary and secondary.
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4.1 RAVENNA in Power Core

4.1.1 RAVENNA Out

Audio is streamed from Power Core to the network according to the RAVENNA audio output settings defined in
the system configuration. This means that once a suitable configuration is loaded to the system, audio will be
streamed automatically whenever Power Core is connected to the network and powered.

To prepare some output streams, edit the system configuration as follows:

1. Open the "Audio Output" branch of the 'Tree Definition', and select one of the RAVENNA Out tabs.

Note that the number of channels available is dependent on the Power Core license. At maximum capacity, up
to 256 channels of audio can be broadcast on 128 streams.

Note that streams can be transmitted from either or both front panel ports (ra0 and ra1).

'Tree Definition': Audio Output -> RAVENNA 1-64

2. All outputs that have a name entered into the Name field will be transmitted automatically as streams,
while the other parameters configure the output's audio options and stream setup. 

The first few fields: Name, Type, Dig Offset Gain, Matrix enable, Transparent and Default Audio are
handled in an identical manner to other outputs. See MADI IO for details. 

The RAVENNA parameters: Stream Size, Codec, SampPerFrm, Devices, IP Addresses, mDNS, SAP, TTL,
etc. define the stream setup.

The important fields are:

· Name - a name must be entered in order to publish the output stream to the network. The maximum
length is 8 characters. If the stream is to be displayed on another ruby surface in a channel list, then the
stream name must use the format [GroupName]:[SignalName], where each label field is a maximum of 8
characters. See RAVENNA Pool Sources for details.

· Type - defines the format of the output: mono, stereo, etc. This should match the Stream Size.

· Matrix enable - by turning ON the Matrix Enable option, the output can be controlled by a matrix.

· Default Audio - alternatively, if Matrix Enable is OFF, a permanent audio source can be assigned to
the output. Note that the Default Audio setting is ignored when Matrix Enable is ON.

· Stream Size - defines the number of audio channels used by the stream. This should match the audio
output format (Type).

· Codec - selects the type of codec used for the stream: Linear 16, 24 or 32 bits; or AM824 (a packetized
AES signal that includes all user and status bits).

· SampPerFrm - sets the number of samples included in each Ethernet Frame. A frame is the payload
being carried over the Ethernet link. This is typically set to 32.

· Devices - selects which port to send the stream out on: ra0, ra1 or both ra0 + ra1 (Hitless Merge
SMTPE 2022-7).
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· IP Address 0, 1 - enter the multicast address for the streams being transmitted on ra0 and ra1. Note that
if this field is left blank, then a default multicast address is assigned. These fields provide your network
architect with the ability to implement a specific IP multicast schema for your facility.

· UDP Port No. - reserved for Unicast.

· mDNS - multicast DNS is a way to enable stream discovery on a Layer 2 network. Up to four mDNS
"Announcement Rings” can be established per Power Core. These can be used to shape the stream
availability between Power Core and other RAVENNA devices.

· SAP - Session Announcement Protocol, is a variant on mDNS and expands the Announcement Ring
capability to eight.

· TTL - Time To Live defines how many hops the stream may navigate. Each time a stream traverses a
switch, the TTL is reduced by one. 

· Enable / Disable - ability via Logic to control whether a stream is to be transmitted or not.

In our example, the network will receive 10 stereo streams (named R1601s, R1603s, etc): the first 8 are
controlled by an external matrix, while the last two have been assigned some Default Audio (from the Program
and Record sums). 

3. Repeat these steps to configure the remaining RAVENNA output streams as needed.

Once the configuration has been transferred to the system, you can use the Web UI RAVENNA -> Inputs page
to check the streaming setup.
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4.1.2 RAVENNA In

Audio from streams on the network can be connected to Power Core either statically (by assigning a source
from a RAVENNA streaming input) or dynamically (by configuring RAVENNA Pool Sources).

In both cases, you will need to define the streaming inputs as follows:

1. Open the "Audio Input" branch of the 'Tree Definition', and select one of the RAVENNA In tabs.

Note that the number of channels available is dependent on the Power Core license. At maximum capacity, up
to 256 channels of audio can be received via 128 streams.

Note that streams are received on either or both front panel ports (ra0 and ra1) depending on the external
network topology.

'Tree Definition': Audio Input -> RAVENNA 1-64

2. All inputs which are named can be used by other elements within the configuration; for example, as the
audio input to a source. The other parameters configure the input's audio options and stream setup. 

The first few fields: Name, Type, Dig Offset Gain, Matrix enable and Transparent are handled in an identical
manner to other audio inputs. See MADI Signal Parameters for details.

The RAVENNA parameters: Stream Size, UDP Port No, etc. define the stream setup.

The important fields are:

· Name - a name must be entered in order to use the input.

· Type - defines the format of the input: mono, stereo, etc. This should match the Stream Size.

· Matrix enable - by turning ON the Matrix Enable option, the input can be controlled by a matrix.

· Stream Size - defines the number of audio channels used from the stream. This should match the audio
input format (Type) to maintain conformity. However, this is not a requirement. If the stream size does
not match the type, then the audio inputs will still be assigned when a stream is subscribed to, with
consecutive channels being allocated on a one-to-one basis.

· UDP Port No. - reserved for Unicast operation.

· Default Stream (optional) - defines the name of the stream you wish subscribe to. It can be used to
permanently link the receiver to a stream. You can enter a stream name of up to 28 characters. The
console will then search the network using mDNS or SAP announcement protocols. If a matching stream
name is found, the receiver will automatically subscribe to it. If a Default Stream name is not entered,
then an automatic subscription will not occur. In this instance, a stream subscription can be established
by selecting a pool source on the surface, with internal logic or via Ember+.

· Matrix No. - when the system is used in conjunction with an external routing controller, such as Matrix
Server, this number corresponds to the entry in the Matrix Server configuration. 

3. Repeat these steps to configure the inputs for each RAVENNA stream.
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4.1.3 Global RAVENNA Settings

The following branches of the 'Tree Definition' define the global RAVENNA settings.

Start by selecting "System -> Definition" in 'Tree Definition' and the Ravenna tab. Scroll down to access the
parameter sets.

Stream Announcement

"System -> Definition -> Parameter = Stream Announcement"

These parameters define the mDNS and SAP channels used for stream announcement:

· mDNS channels use the multicast Domain Name System defined in IETF RFC 6762. 

· SAP channels use the Session Announcement Protocol defined in IETC RFC 2974. 

For each channel, enter the multicast IP Address, Port Number and TTL value (in seconds). Use the Enable
checkbox to enable or disable the channel.

For convenience, temporary changes to the channel settings can be made from the Power Core Web UI (via
the RAVENNA -> Global tab).
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PTP Settings

"System -> Definition -> Parameter = PTP Settings"

These parameters define the PTP settings for Power Core. 

Two global PTP modes are supported: slave only and master-slave.

If Slave Only is enabled, then Power Core is forced to operate as a PTP slave at all times. In this mode, the
device looks for an incoming PTP signal from an external GrandMaster (GM). The other PTP settings must be
the same as the PTP GM so as to sync successfully.

If Slave Only is disabled, then Power Core will operate in PTP master-slave mode. In this mode, the PTP
priorities set within the device itself and all other streaming nodes determine the current PTP master (as
described below).

Parameter PTP Settings - reference name for the element.

Slave Only Defines the global PTP mode: slave only or master-slave.

Prio 1, Prio 2 Set the PTP priorities for Power Core. 

If Power Core is operating in master-slave mode, all master-capable devices on the network elect
the PTP master according to a common algorithm known as the "Best Master Clock Algorithm".
The algorithm compares the following parameters in turn:

· Prio 1 - the lower the number, the higher the priority of the device.

· Clock Class

· Prio 2 - as for Prio 1.

· MAC Address

Note that the Clock Class is not available in Power Core but may be used by a third-party
GrandMaster if one is installed.

DSCP This field assigns a DSCP value to the PTP clock stream. The default value is 56.

Domain The remaining settings vary depending on the network architecture and PTP profile in use. Please
refer to the Lawo IP Networking Guide.

The default values are shown above.
Master Announce
Interval

Master Sync Interval

Master TTL

Slave WAN Mode

For convenience, temporary changes to the PTP settings can be made from the Power Core Web UI (via the
RAVENNA -> PTP tab).

http://www.lawo.com/ip-networking-guide/
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Control Settings

"System -> Definition -> Parameter = Control Settings"

These parameters define the control settings applicable to RAVENNA.

Parameter Control Settings - reference name for the element.

Matrix Offset Applies a global offset to any matrix-enabled inputs and outputs defined in the "Audio Input ->
RAVENNA" and "Audio Output -> RAVENNA" branches of the 'Tree Definition'. 

EmBER+ Local
Provider

This field can be used to publish all available RAVENNA parameters to an Ember+ provider - enter
the provider number from 1 to 5, or select None to disable publishing via Ember+.

The next three options affect what happens when streams are announced to the network.

mDNS/SAP Startup
Delay After Join

Delays mDNS/SAP announcements (in seconds).

mDNS Redundant
Queries Respond
Behaviour

Defines how Power Core responds to mDNS queries. There are two possibilities:

· respond each instantly (default) - every query is answered immediately. If there are many
enquirers and many streams, this can lead to a large flood of announcements.

· collect and respond once (optimized operation) - after receiving a query, Power Core waits 10
seconds before a response is sent. If queries are received within this period, the timer is reset (to
10 seconds). The responses are sent either once the timer has expired or after 45 seconds
(whichever is the soonest). In this way, several enquiries are answered collectively and a flood of
announcements is avoided. There are separate timers for general queries and per stream.

Please note: Collect and respond is recommended for SDP announments in mDNS. To use it,
make sure that all Power Cores in your network are using version 6.6_PL-002 (ON-AIR Designer
6.6.0.20) or higher.

SDP Announcing via
mDNS enabled

Enable this option to include the SDP in mDNS announcements.

Nodes List TTLs This value is applied if the "Update: Data + TTL" option is enabled in the RAVENNA -> Nodes tab of
the Power Core Web UI.

The default value is 300 (seconds). Possible values are 60 to 3600.

Streams List TTLs As above, but applies to the RAVENNA -> Streams tab.
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Stream Settings

"System -> Definition -> Parameter = Stream Settings"

These parameters define the global settings for transmit (Tx) and receive (Rx) streams.

Parameter Stream Settings - reference name for the element.

Tx RTP Payload Type This field defines the RTP payload for TX streams. The default value is 98.

Tx DSCP This field assigns a DSCP value to TX streams. The default value is 46.

SSM Enable (IGMP v3
only)

Select this checkbox to enable IGMP v3.

IGMP v1/2 Disable Select this checkbox to disable IGMP v1/2. The possible combinations with SSM Enable are
described later.

IGMP Router Alert
option

IGMP Legacy
Suppression

The next two options can be used to configure the IGMP behaviour (described later). If in doubt,
leave both options enabled.

EmBER+ SDP Stream
Names with Suffix

Select this checkbox to automatically apply a suffix to Ember+ Stream Names.

The suffix is required if the same stream name is used by different senders.

The suffix must be deactivated when streams are sent both by logic elements and by Ember+.

RX Make-before-
Break Enable

Select this checkbox to enable make-before-break in the receiver.

RX Syntonous Mode
Enable

Select this checkbox to enable syntonous mode in the receiver.

RX Re-Tuning Disable Select this checkbox to disable the automatic retuning of streams by permanent late packets. 

If enabled, the tuning of streams must be triggered manually, via the Web UI, if this is desired. See
Retuning Streams. 

There is one exception which is when a new stream is connected and there is no Time Offset value
stored in NVRAM. In this case, an automatic tuning of the stream is performed.

RX Re-Tuning only on
both Channels fail

Select this checkbox to change the automatic tuning of redundant streams in the receiver. When
enabled, re-tuning only occurs if both channels fail.

RX Time-Offset Base
Margin

Sets the Time Offset Base Margin (in samples). The value contributes to the overall Time Offset
applied during stream tuning. The default value is 5.
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IGMP

The Internet Group Management Protocol (IGMP) is used in IPv4 networks to establish multicast group
memberships. 

There are three versions of IGMP: v2 improves upon v1 by adding the ability for a host to leave a multicast
group; v3 improves upon v2 by supporting Source Specific Multicast (SSM). SSM is a method of delivering
multicast packets in which the only packets delivered to a receiver originate from a specific source address.
Thus, SSM reduces demands on the network and improves security.

Ø  Setting the IGMP Scheme

The SSM Enable (IGMP v3 only) and IGMP v1/2 Disable options determine how IGMP Joins are transmitted.
There are two possibilities: Any Source Multicast (ASM) or Source Specific Multicast (SSM). The table below
describes what happens when the options are combined.

IGMP 

v1/2 Disable

SSM Enable 

(IGMP v3 only)

Result

OFF OFF IGMP Joins are sent as IGMP v2 (Any Source Multicast).

OFF ON IGMP Joins are sent, by default, as IGMP v3 (Source Specific Multicast). 

If Power Core receives queries in v2, it reverts to v2 and keeps sending in v2.

ON OFF IGMP Joins are sent as IGMP v2 (Any Source Multicast).

ON ON IGMP Joins are sent as IGMP v3 (Source Specific Multicast).

There is no fallback to v2 and so Power Core keeps sending IGMP v3 only.

Ø  Configuring the IGMP Behavior

The following options are active by default and can be deactivated as required. This is sometimes necessary,
depending on the type of network switch in use. If in doubt, leave both options enabled. 

· IGMP Legacy Suppression (sysctl: net.inet.igmp.legacysupp)

If this variable is non-zero, then IGMP v1 and v2 membership reports received on a link are allowed to suppress
the IGMP v3 state-change reports which would otherwise be issued.

· IGMP Router Alert option (sysctl: net.inet.igmp.sendra)

If this variable is non-zero, then IGMP v2 and v3 reports contain the IP Router Alert option.

Ø  Receiving single streams as ASM in a SSM environment

It is also possible to connect individual streams as ASM in a SSM environment if:

· The SDP received via Ember+ has the source IP address omitted from the source-filter field.

· A RAVENNA Static Stream is configured where the multicast source IP address field is left blank.

Example SDP (with source IP Address omitted)



ON-AIR Designer Configuration OptionsVersion: 6.6.0_1238/325

4. Configuring Audio-over-IP

Jitter Classes

"System -> Definition -> Parameter = Jitter Classes"

These parameters define the five Jitter Classes supported by Power Core, and their Time Offset Additions
which are applied during stream tuning. 

In each case, you should enter a Jitter Max value (to define the Jitter Classes) and a corresponding Time
Offset Addition (applied when streams are tuned). Stream tuning occurs automatically when you first connect
a stream to a RAVENNA receiver. It can also be performed manually from the Power Core Web UI (via the
RAVENNA -> Stream Destinations tab).

The 'Tree Definition' parameters are as follows:

Parameter Jitter Classes - reference name for the element.

Jitter Max These fields define the maximum value for each jitter class (in samples). The default values are
shown above.

Time Offset Addition These fields define the Time Offset Addition applied to each Jitter Class (in samples). The default
values are shown above.

Jitter Class Select
Mode

This option defines which measurement is used to place streams in a particular Jitter Class. There
are two possibilities: Peak Jitter (the default) or Jitter StdDev (the standard deviation).

Since peak jitter is usually greater than the standard deviation, this mode will result in higher Time
Offset values. Thus, to keep latency to a minimum, you should switch to the standard deviation
(Jitter StdDev) mode.

Path Delay Classes

"System -> Definition -> Parameter = Path Delay Classes"

These parameters define the five Path Delay Classes supported by Power Core, and their Time Offset
Additions which are applied during stream tuning.

In each case, you should enter a Path Delay Max value (to define the Path Delay Classes) and a
corresponding Time Offset Addition (applied when streams are tuned). Stream tuning occurs automatically
when you first connect a stream to a RAVENNA receiver. It can also be performed manually from the Power
Core Web UI (via the RAVENNA -> Stream Destinations tab).

The 'Tree Definition' parameters are as follows:

Parameter Path Delay Classes - reference name for the element.

Path Delay Max These fields define the maximum value for each path delay class (in samples). The default values
are shown above.

Time Offset Addition These fields define the Time Offset Addition applied to each Path Delay Class (in samples). The
default values are shown above.
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4.2 RAVENNA in the Compact Engine

Audio can be streamed to and from the Compact Engine if a RAVENNA IO card is fitted to one of the front
expansion slots. Only the left-hand slot can support the internal MADI bridge option and be used as a master
clock source.

On its own, the IO card provides 8 inputs and 8 outputs from the RAVENNA streaming port to and from the
system (via the TDM backplane). However, the RAVENNA interface itself is capable of streaming 64 bi-
directional channels. You can gain access to the additional channels by utilising the spare internal MADI port
(which exists on systems fitted with either 0 or 2 external MADI ports). To support this option, an internal MADI
bridge connector must be fitted. Note that a Compact Engine fitted with 4 external MADI ports cannot support this
feature (as there is no spare internal MADI port).

The ON-AIR Designer defines whether the internal MADI to RAVENNA bridge option is enabled and the name,
label and other parameters for each RAVENNA input and output. Once the configuration is in place, the
RAVENNA Web UI must be used to map the RAVENNA signals to the Tx and Rx streams.

4.2.1 Enable MADI over RAVENNA

To use the RAVENNA IO card as a 64-channel interface, the internal MADI to RAVENNA bridge option must be
enabled.

1. Start by checking that the System Core is configured with either a 0-port or 2-port MADI card and a
RAVENNA IO card (in expansion slot 1):

2. Then open the "Audio Input" branch of the 'Tree Definition', select the Compact Engine Madi card and
the RAVENNA tab:

3. The Enable MADI over RAVENNA options should be set to On for MADI 1 and Off for all other ports.
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4.2.2 RAVENNA IO Parameters

Once the Enable MADI over RAVENNA option is turned on, you can edit the name and other parameters for
the 64 signals.

1. Use the Madi 1 (RAVENNA intern) Input and Output tabs to access the parameters.

Madi 1 (RAVENNA intern) Outputs

Madi 1 (RAVENNA intern) Inputs

Note that the MADI ports are numbered from right to left in the configuration. Therefore, MADI 4 and MADI 3
relate to the two external MADI ports (on a 2-port MADI card), while MADI 2 and MADI 1 are the spare internal
ports. MADI 1 is always reserved internally for RAVENNA.

Most of the parameters are handled in an identical manner to other signals. See MADI IO for details. 

When defining the names, every input can generate a RAVENNA Destination label, and every output a
RAVENNA Source Label. The labels can be used to define a default source stream for a RAVENNA input or
group of inputs. To implement this feature, the Name field must use the format [GroupName]:[SignalName],
where each label field is a maximum of 8 characters. Every label must be unique within the system network.

Output Parameters

· Name - defines the signal name. Use the format [GroupName]:[SignalName] to generate a RAVENNA
Source Label.

· Type - defines the format of the output: mono, stereo, etc. This should match the Stream Size.

· Matrix enable - by turning ON the Matrix Enable option, the output can be controlled by a matrix.

· Default Audio - alternatively, if Matrix Enable is OFF, a permanent audio source can be assigned to
the output. Note that the Default Audio setting is ignored when Matrix Enable is ON.

· Transparent - select this checkbox to set the output to be “transparent”.

· RAVENNA Stream Size - defines the number of audio channels used by the stream. This should
match the audio output format (Type).

Input Parameters

· Name - defines the signal name. Use the format [GroupName]:[SignalName] to generate a RAVENNA
Destination Label.

· Type - defines the format of the input: mono, stereo, etc. This should match the Stream Size.

· Matrix enable - by turning ON the Matrix Enable option, the input can be controlled by a matrix.

· Transparent - select this checkbox to set the output to be “transparent”.

· Default RAVENNA Source Label (optional) - defines the stream you wish subscribe to by entering its
RAVENNA Source Label. This option can be used to permanently link the receiver to a stream. To use
this feature, you must follow the [GroupName]:[SignalName] labeling convention described above.
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5.     Intercom

This chapter describes the InterCom system.
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5.1 Introduction

Intercom elements are supported by crystal, sapphire, sapphire compact, Nova29 and ruby / Power Core.
They provide easy programing for communications setups, and work in conjunction with the separate software
application called InterCom.

Within the system configuration, an InterCom element is defined for each communications station (e.g. Studio
1, Studio 2, Announcer's Booth, etc.) The element defines the talkback send and return, and the call and
response buttons. The talkback buttons can be console MF Keys, external key panels, VisTool touch-screens or
external control signals.

Each InterCom element uses a summing bus resource. This means that the limit on InterCom elements
varies depending on the product.

The InterCom software is then used to program the talkback buttons for each communications station. Each
button can talk to a single InterCom station, answer an incoming call or talk to a group of stations. At any time,
you can transfer the Intercom configuration to any system within your studio network, where it is stored
separately from the system configuration and loads on boot up.

You can transfer a new InterCom configuration without restarting the system. This allows you to modify
InterCom functions while the system is running online.

The InterCom configuration is referenced to elements within the system configuration. Thus, InterCom functions
can only be executed when loaded to a console with the corresponding system configuration.
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5.2 InterCom Local vs InterCom Net

Within the system configuration (defined by the ON-AIR Designer), three different elements are supported:
Intercom Local, Intercom Net Server and Intercom Net Client.

Intercom Local elements should be used when the Intercom Stations are connected to a single Lawo system
(e.g. MF Keys, key panels and/or VisTools connected to a Nova29 router).

The Intercom Net Server and Intercom Net Client elements allow you to create a single intercom system
using Intercom Stations connected to different Lawo systems. This reduces the need for separate cabling, as
the CAN bus is used for data transfer and MADI tielines can be used to transfer audio signals. With this type of
setup, the basic intercom configuration is done on the server, while clients can connect to the server for control
signals. Key assignments are also configured on the client side.

Note that every Intercom station needs an Intercom Net Client element on the local unit, and an Intercom Net
Server element on the remote server unit.

crystal and sapphire compact systems support Intercom Net Client elements only. This means that they
can communicate with an Intercom Net Server system, but cannot "host" a stand-alone Intercom system.

Our example below shows how all three elements can be combined:

Once the elements have been configured on all of the participating systems, you can then use the Intercom
Software to transfer an InterCom configuration to the server.
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5.3 System Configuration

Before you can use the InterCom software, you must program and transfer a a system configuration using the
ON-AIR Designer software. 

For our example, eight steps are required:

1. Name the audio inputs where each talkback microphone is connected

2. Add an Intercom element for each communications station.

3. Define the Intercom global parameters - to name the element, assign the talkback audio input, and so on.

4. Configure the talkback outputs - name and set the default audio path for each talkback return.

5. Define the control signals you wish to use as talkback buttons for each communications station (in our
example, we are using MF Keys). 

6. Define the Intercom key events - to reference the MF Keys defined in step 5.

7. Configure the MF Key Lamps and Labels - to define how the talkback buttons will respond to incoming
calls and how they light when pressed.

8. Save and transfer the system configuration.

5.3.1 Naming the Talkback Inputs

Start by naming the audio inputs where each talkback microphone is connected – in our example, we have three
mics connected to different MADI inputs of a Nova29 router:
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5.3.2 Adding the Intercom Elements

Add an Intercom Local element for each communications station to the "Connect" branch of the ‘Tree
Definition’:

Or, to create an Intercom system using more than one console/router, add an Intercom Net Server element to
the server and Intercom Net Client element to the client.
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5.3.3 Defining the Intercom Global Parameters

Select each Intercom element to define its Global parameters.

Intercom Local

Intercom Enter a unique reference name.

Identifier Enter a unique reference number. This number is used to identify the element within the
InterCom software, see Adding an InterCom station. 

The nova29 support an Identifier range up to 96. The Identifier range for sapphire and crystal
is limited to 48; these systems will ignore numbers higher than 48.

LED Time (1/10sec) Enter the timeout for the signalisation of an incoming call. The button lamp/LED will stop
blinking after this time.

Audio Input Assign the audio input to be used as the talkback source. For our example, this should be the
talkback mic named earlier.

Group In Signal Select this checkbox to enable group key blinking. When enabled, and the group is active, all
group keys to which the caller is assigned blink.
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Intercom Net Server

As for Intercom Local, but with the following exceptions and additions:

Identifier This number will identify the element within the InterCom software AND within the Intercom
Net Client.

IP Addr[3]

IP Addr[4]

Enter the third and fourth byte of the Intercom Net Client's IP address. This is used to identify
the client to the server, in conjunction with the Identifier number.

Intercom Net Client

As for Intercom Local, but with the following exceptions and additions:

Identifier 1 to 4

activate 2, 3, 4

Enter the same Identifier number as configured on the Intercom Net Server. 

You can enter up to four different Identifiers (Identifiers 2, 3 and 4 are enabled by the activate
control signals). This allows the client to connect and work with different Intercom Net Server
elements (these may be on different systems).
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5.3.4 Configuring the Talkback Outputs

Next, name and set the default audio path for each talkback return – in our example, we have three talkback
speakers connected to different MADI outputs of the Nova29 router. The Default Audio field is set to the output
of the InterCom elements we defined earlier:
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5.3.5 Defining the MF Keys

Next, name the control signals you wish to use as talkback buttons for each communications station. 

You may use any type of control signal. This includes console MF Keys, MF Keys on an external key panel,
VisTool screen buttons or external control signals.

In our example, we have a KSC-LCD14P2 panel for each of the 3 studios.

1. Add the key panels to the Frames -> Panels configuration: 

2. Double-click to open the key panel parameters, and name each MF Key:

Name Line 1 and 2 are only supported by key panels with self-labeling buttons.
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5.3.6 Defining the Intercom Element Key Events

Now return to each Intercom element to define the Key Events parameters. For our example, assign each of the
MF Keys defined earlier to a key number.

Key 1 to n Assigns a control signal to trigger each Key. The Keys are referenced within the InterCom
software, see Adding the InterCom Stations. Note that a Key cannot talk to its own Intercom
Station. 

The number of Keys varies depending on the product. If both the Intercom Client and Server
are a Power Core, then you can have up to 48 Keys (per InterCom element). In all other
instances, up to 32 Keys are supported.

Disable 1 to n Assigns a control signal to disable the Key. For example, to override the InterCom system.

Repeat this process for each Intercom element in the configuration.
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5.3.7 Configuring the MF Key Lamps and Labels

You can now define how your talkback buttons will respond to incoming calls and how they light when you press
them. The example below shows the definition of the MF Key lamps and labels for a KSC-LCD14P2 panel. If you
are using a VisTool touch-screen button or an external control signal, then you will need to define their signaling
parameters accordingly.

Each Intercom element provides the following logic control signals:

incoming active Active if any incoming call button is active.

outgoing active Active if any outgoing call button is active.

n defined Active when the specified button is configured within the InterCom software.

n incoming Active when the specified incoming call button is active.

n outgoing Active when the specified outgoing call button is active.

n blink Active when the specified incoming call button is active (Alias of incoming).

n Label The Name given to the InterCom station within the InterCom software.

MF Key Lamp configuration
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MF Key Label configuration

5.3.8 Saving and Transferring the System Configuration

Having completed the configuration, you should now save and transfer your configuration to the system.

You must transfer the Intercom elements to the system before you can access the features of the InterCom
software.
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5.4 InterCom Software

The InterCom software is used to program the talkback buttons and then transfer the InterCom configuration to
each system. Four steps are required:

1. Create a new configuration.

2. Add the InterCom stations. This step names each station and defines the number of talkback buttons.

3. Define the InterCom content. Each button can call another InterCom station, answer any incoming call,
call a group of InterCom stations or perform no function.

4. Save and transfer the InterCom configuration to the system.

crystal and sapphire compact systems support Intercom Net Client elements only. This means that they
do not require a separate InterCom configuration; the InterCom configuration must be stored on the server's
system.

5.4.1 System Requirements

InterCom PC

To install and run InterCom, your computer MUST meet or exceed the following requirements:

· Operating System: Windows XP Professional SP3 or Windows 7 Ultimate. Note that Windows 10 LTSB
(Long Term Servicing Branch) for Enterprise installations is not supported.

· Processor: Intel™ Core i3 530 (or higher equivalent processor).

· Random access memory (RAM): 2GB

· Ethernet interface: 100MBit/s

· CAN over Ethernet service running (see Checking the CAN service).

Lawo OnAir System

The Lawo OnAir system MUST be running OS Version 3.2 software or higher.

You can check the OS version using the Web UI.

If the OS-Version is lower than 3.2, please contact your local Lawo representative or email support@lawo.com.

crystal and sapphire compact systems support Intercom Net Client elements only and therefore do not
require a separate InterCom configuration.

Network

You should connect the InterCom PC to the Master Board’s Ethernet port either directly or via a network switch.
Do NOT use an Ethernet hub as this will interrupt the data stream. See Wiring: CONTROL Network.

mailto:support@lawo.com
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5.4.2 Installing the Software

The DSA InterCom.exe setup application, included with your system, performs an automatic install of the
InterCom software.

1. Copy the DSA InterCom.exe application onto your computer.

2. Double click on the DSA InterCom.exe application icon:

This starts the 'Setup Wizard’:

3. Follow the Wizard's instructions accepting the default options provided.

4. When you reach the 'Summary' window, check the options and click Install.

The software is installed onto your computer; this may take a few minutes. By default, files are installed in the
location: ‘C:\Program Files\Lawo’.

5. When the installation is complete, a confirmation window appears.

6. Click on Finish to exit the ‘Setup Wizard’.

If you have any problems with the software installation, please contact your local Lawo representative or email
support@lawo.com.

mailto:support@lawo.com
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5.4.3 Checking the CAN Service

The InterCom software talks to the system by running a CAN service over the Ethernet connection. To check or
enable this service, use the MtxConAdmin application as follows.

MtxCon (also known as NovaConnect) is the software used to control a Nova17 or Nova29 stand alone
matrix. You can download and install this software from www.lawo.com.

Having installed MtxCon:

1. Open the MtxConAdmin application on your computer:

2. Enter the IP address of the system and select Next:

 If you have a redundant Master Board, you should also tick the second entry box and enter the IP address
of the redundant board.

http://www.lawo.com
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3. Next select the ports you wish to use for the CAN service:

4. Select the configuration database for MtxCon; the default location is shown below:
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If the CAN service is already running, then you will see the following window. 

5. Tick the Restart box and click Finish if you wish to restart the service.

Once the CAN service is running, you will see the following confirmation box:

6. Click OK and Cancel to exit the MtxConAdmin application.

Running CAN over Ethernet can affect the performance of your PC. Therefore, you should cancel the
service once you have finished running the InterCom software.
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5.4.4 Operating Principles

1. Start the InterCom software, by selecting START -> Program Files -> Zirkon -> InterCom.

If this is the first time you have run the software, then you will be asked for the location of the InterCom database
file. The default location is in the C:\Program Files\InterCom folder. If you have already been using the InterCom
software, then the last file you saved from the software is automatically opened for you.

In either case, the InterCom operating window appears. It is divided into the following areas:

 1   Menus

File, View and Help main menus.

 2   Toolbar

Quick access to common functions such as Open, Print and Help. 

 3   InterCom

This area defines each InterCom station. Each entry is given a number (Nr), a Name (up to 6 characters) and
Type.

The Nr must match the InterCom Identifier set within the system configuration. The Typ defines how many keys
are available at the station.

 4   InterCom Content

Double-click on an entry from the InterCom list (3) and the InterCom Content (4) updates to show the button
definitions for the station.

Each button can call another InterCom station, ANSWER any call or perform no function (OFF). Having set the
functions from the Nr field, the Name automatically updates.

If you check the Gr box, then the button can talk to a group of stations as defined below.

 5   Group

In this area you can define a group of InterCom stations. For example, if you group all InterCom stations
together, then a single button can talk to All.

Each group is given a unique number (Nr) and a Name (up to 6 characters).
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 6   Group Content

Double-click on an entry from the Group list (5) and the Group Content (6) updates to show the group definitions.

Each group can contain any number of InterCom stations from the InterCom list (3).

Having defined a group, return to the InterCom Content area (4), tick the Gr checkbox, and then select the group
number from the Nr field.

 7   Status Bar

Status messages appear here.

5.4.5 The Main Menus

File

· New – creates a new InterCom configuration.

· Open… – opens an existing InterCom configuration. This file is saved as a .mdb file.

· Print – prints a list of the InterCom setup.

· Save as.. – use this option to save the database under a different file name.

· Send Configuration – transfers the InterCom configuration to an online system.

· Exit – quits the InterCom application.

View

From the View menu, you can select to display, or not display, the toolbar and/or status bar.

Help

The Help menu provides information about the InterCom software release, and your computer (System-Info).
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5.4.6 Creating a New Configuration

1. Select File -> New from the main menus to create a new configuration.

You are asked to choose a location for the InterCom database file:

2. Enter a file name and select Save.

The database is saved and a blank operating window appears:
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5.4.7 Adding the InterCom Stations

1. In the InterCom area (top left), double-click on the first empty Nr field to enter a new InterCom station -
the cursor flashes.

2. Enter a number.

The Nr must match the unique Identifier which you defined earlier within the system configuration for the
InterCom element. In our example, 1 is Studio 1, 2 is Studio 2 and so on.

3. Then click on the Name field and type in a name for the InterCom station.

This name is used within the other areas of the InterCom operating window to help identify the InterCom station.
You can enter up to 6 characters:

4. Next click on the Typ field and make a selection from the drop-down menu:

This selection determines how many buttons can be defined within the InterCom Content area. The options are
predefined by the software. If both the Intercom Client and Server are a Power Core, then you can have up to 48
Keys. In all other instances, up to 32 Keys are supported.

5. Repeat steps 1 to 4 for each InterCom station:
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5.4.8 Defining the InterCom Content

1. Double-click on an InterCom station (top left) to view its button definitions (top right).

The name of the selected station is shown at the top of the InterCom Content area (in green). The number of
buttons which may be defined is governed by the Typ which you selected earlier – in our example, T16:

Each button can call another InterCom station, answer any incoming call, call a group of InterCom stations or
perform no function. First let’s define a button to call a specific station. See Using Groups, for more details on
groups.

2. Click on the Nr field for the button you wish to define, and select a function from the drop-down menu -
the options are:

· -1 (OFF) – performs no function.

· 0 (ANSWER) –  answers any incoming call.

· 1, 2, 3, etc. – calls another InterCom station.

Once selected, the Name field updates automatically.

You can also drag and drop an InterCom station (from the left tab) onto a button (on the right tab).
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3. Repeat for each button of each InterCom station – for example:

Define St 1:

Define St 2:

Define St 3:

5.4.9 Saving and Transferring the InterCom Configuration

The InterCom configuration is automatically saved into the file path you entered earlier when you close the
application. If you wish to create different InterCom setups, you can use File -> Save As to save the database
under a different file name.

To make the InterCom configuration active, it must be transferred to the system via TCP/IP. The configuration is
then stored on the control system and loaded whenever the system powers on.

You can transfer a new InterCom configuration without restarting the system. This allows you to modify
InterCom functions while the system is running online.

1. First make sure that your InterCom PC is connected and communicating with the system you wish to
transfer to.

2. Then check that you have transferred the system configuration which supports your InterCom setup.

3. Select File -> Send Configuration to transfer the current InterCom configuration to the system.

4. Once the transfer is complete, test your InterCom setup.
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5.4.10 Using Groups

Any number of InterCom stations can be grouped together, allowing a single button to call more than one station.

Ø  To Create a Group

1. In the Group area (bottom left), double-click on the first empty Nr field to enter a new Group number -
the cursor flashes.

2. Enter a unique number.

This number will be used to reference the group within the InterCom operating window.

3. Then click on the Name field and type in a name for the InterCom station.

You can enter up to 6 characters.

Ø  Defining the Group

1. Double-click on the Group (bottom left) to view its definition (bottom right).

2. Click on the first empty Nr field and select the first InterCom station you wish to group:

Once selected, the Name field updates automatically.

3. Repeat to select all the stations for the group. Our example shows a group named ALL which contains
Studio 1, Studio 2 and Studio 3.
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Ø  Configuring the Group Button

1. Return to the InterCom Content area and tick the Gr checkbox beside the button you wish to use to call
the group.

2. Click on the Nr field, and the drop-down menu now lists all available groups – select the group (e.g. ALL)
from the list:

The group definition is now complete. In our example, we have modified the Studio 1 InterCom station so that it
has 4 active buttons:

· 1 – call Studio 1.

· 2 – call Studio 2.

· ALL – call the group ALL (Studios 1, 2 and 3).

· ANSWER – answers any incoming call.

3. Transfer the InterCom configuration to the system using File -> Send Configuration to make the groups
active.
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6.     Macros

This chapter describes the Macros system.
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6.1 Introduction

Macros are supported by sapphire MK2 and Power Core systems. They can be used to action a series of
complex functions, or to interchange functions between systems.

Each macro can operate any element defined within the system configuration; up to 32 macros may be operated
from each console at any one time. To trigger a macro, it is assigned to a logic element such as an MF Key,
GPI, etc. Thus, it is possible to execute multiple operations at the push of a button.

Macros are assembled using the Macro Editor. The program allows you to define "macro sets", each consisting
of 32 macro definitions. You may create different macro sets for different types of work - for example On Air,
Recording, etc. At any time, you can transfer a macro set to any system within your studio network, where it is
stored separately from the system configuration and loads on boot up.

In sapphire MK2 systems with a redundant Master Board, then the macro definitions must be transferred to
both Master Boards.

You can transfer a new macro set without restarting the system. This allows you to modify macros while the
system is running online.

The Macro Editor serves exclusively for the definition of macros; it does not provide the actual functions. Each
macro is referenced to elements within the system configuration. Thus, macros can only be executed when
loaded to a console with the corresponding system configuration.
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6.2 System Configuration

Before you can use the Macro Editor software, you must edit the system's configuration. There are two parts to
the configuration. First, define a Macro element to assign the triggering logic for the 32 macros. Then, configure
the functions which will be assembled into each macro.

6.2.1 Defining the Macro Logic

Each system supports a single Macro element which must be added to the "Logic" branch of the 'Tree
Definition'. 

For each of the 32 macros, you can assign two control inputs: one for the rising and one for the falling edge.
The control inputs can be any logical signal – for example, an MF Key on the control surface, an MF Key within
VisTool, a GPI, etc.

General Parameters

Macro Reference name for the element.

X Rising Edge Assign the control input which will trigger the macro's rising edge.

X Falling Edge Assign the control input which will trigger the macro's falling edge.



ON-AIR Designer Configuration Options Version: 6.6.0_1 269/325

6. Macros

For each of the 32 macros, there are four logic outputs: red, green, yellow and blink. These can be found
under the “Logic -> <GroupName> -> Macro” branch of the 'Tree Selection' window. They can be used to
signal the status of the macro - for example, to illuminate the MACRO MF Key:

The logic control outputs can trigger any configuration element, not just MF Key lamps.

6.2.2 Configuring the Macro Functions

The next step is to insert and name all of the elements which will be executed as part of each macro definition.
The elements can then be assembled into macros later using the Macro Editor software.

The Macro Editor references the configuration elements by their name and type. Therefore, you should give
each element a unique name - for example:

Elements can be controlled from macros and other control signals if required.

Some elements cannot be renamed. For example, the Central Module within the ‘Surface’ branch of the
‘Tree Definition’ window. See Configuring Elements without a Name for more details.
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6.2.3 Transferring the System Configuration

Having configured the logical control inputs for your macros (via the Logic -> Macro element) and the functions
themselves, you should now save and transfer the configuration to the Lawo system.
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6.3 Installing the Macro Editor

6.3.1 System Requirements

Macro Editor PC

To install and run the Macro Editor, your computer MUST meet or exceed the following requirements:

· Operating System: Windows XP Professional SP3 or Windows 7 Ultimate. Note that Windows 10 LTSB
(Long Term Servicing Branch) for Enterprise installations is not supported.

· Processor: Intel™ Core i3 530 (or higher equivalent processor).

· Random access memory (RAM): 2GB

· Ethernet interface: 100MBit/s

The Macro Editor software serves exclusively for the definition of macros and their transfer to consoles; it
does not provide the actual functions and it is not required for operation.

Lawo System

The Lawo system MUST be running OS Version 2.7 software or higher.

You can check the OS version using the Web UI.

If the OS-Version is lower than 2.7, please contact your local Lawo representative or email support@lawo.com.

crystal and Nova29 systems do not support Macros.

Network

You should connect the Macro Editor PC to the Lawo control system either directly or via a network switch. Do
NOT use an Ethernet hub as this will interrupt the data stream. See Wiring: CONTROL Network.

mailto:support@lawo.com
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6.3.2 Installation Procedure

The ZirkonMacros.exe setup application, included with your system, performs an automatic install of the Macro
Editor software:

1. Copy the ZirkonMacros.exe application onto your computer.

2. Double click on the ZirkonMacros.exe application icon:

This starts the ‘ZirkonMacros Setup Wizard’:

3. Follow the Wizard's instructions accepting the default options provided.

4. When you reach the 'Summary' window, check the options and click Install.

The software is installed onto your computer; this may take a few minutes. By default, files are installed in the
location: ‘C:\Program Files\Zirkon’.

5. When the installation is complete, a confirmation window appears.

6. Click on Finish to exit the ‘Setup Wizard’.

If you have any problems with the software installation, please contact your local Lawo representative or email
support@lawo.com.

mailto:support@lawo.com
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6.4 Using the Macro Editor

The Macro Editor is used to assemble the macro definitions and then transfer them to each system. Five steps
are required:

1. Configure the Lawo system(s) so that the Macro Editor can communicate via the TCP/IP network.

2. Add the elements you wish to include within your macro definitions. The element type and name must
match those created within the system configuration earlier.

3. Create the "macro sets". 

Each macro set consists of up to 32 macro definitions. You can create multiple macro sets if you wish – for
example, you may have one set of macros suitable for live work, a different set for offline recording, etc.

4. Within each macro set, define the macros 1 to 32.

5. Transfer the macro set to the system(s) you configured in step 1.

6.4.1 Operating Principles

1. Start the Macro Editor, by selecting START -> Program Files -> Zirkon -> Zirkon Macros:

If this is the first time you have run the software, then you will open a new file. If you have already been using the
Macro Editor, then the last file you saved from the software is automatically opened for you.

In either case, the Macro Editor window consists of four operating areas:

 1   Main Menus

File, Edit and Help main menus.

 2  Toolbar

Quick access to common functions such as Save, Transfer, Delete, Move Up and Move Down. 

 3   Selection Area

This area operates very much like the ‘Tree Definition’ window within the system configuration. 

Each of the tree’s branches may be opened to select a component. Double-click on the tree branch, or click on
the + sign, to open up a branch. Click on the – sign to close the branch and return to the top navigation level.

The Selection Area contains three types of component:

· Units - open this branch to view or add units to your network.

· Elements - open this branch to view or add the system configuration elements which may be included
within a macro definition.

· Macrosets - open this branch to view or add a macro set, and the individual macros.

 4  Data Entry Area

When you open up a branch of the tree and select a component - for example the unit called AMP_Studio_5 -
the data entry area comes to life. This is where you can program the parameters for the selected component. In
our example, the TCP/IP address and description of the unit.
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6.4.2 The Main Menus

File

Use the File menu options to create a New macro file, Open an existing configuration, Save a configuration or
Exit (Quit) the Macro Editor software.

Edit

Use the Edit menu to access the following functions:

· Cut, Copy and Paste - you can copy and paste units, elements and/or macro sets to help speed up
your programing.

· Create – adds a Unit, Element or Macroset to the configuration.

· Rename – renames your current selection.

Help

The Help menu provides information on the current release version of the Macro Editor software.
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6.4.3 Configuring the Units

The Macro Editor transfers macro definitions to each system via TCP/IP network. Therefore, the first step when
creating a new configuration is to define the name, IP address and description of each unit:

1. Open up the Units branch within the Selection Area on the left of the display to view the units.

If this is a new configuration you will see a single unit called Zirkon with the default IP Address and a default
Description.

2. To change the name of the unit, right-click on the existing name and select Rename:

3. You can now type a new name and press Enter.

4. Edit the IP Address to match that of your unit within the Parameter Area, and change the Description if
you wish. 

5. After making changes with the Parameter Area click on Apply to adopt the new settings.
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6. If you wish to add more units, then right-click anywhere within the Selection Area, and select Create
and Unit:

A New Unit is added to the Units branch. You can now edit its name, IP Address and Description as above:

7. Repeat for all the units on your network.
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6.4.4 Configuring the Elements

Each macro definition actions the elements you programed earlier within the system configuration. Therefore,
the next step is to create a list of these under the Elements branch within the Macro Editor.

All elements to be used within macros MUST be entered here. If not, they cannot be referenced to the
system configuration.

1. Open up the Elements branch within the Selection Area on the left of the display to view the elements:

If this is a new configuration, as in our example, you will see a dummy entry called KeyXY. You will need to
create a new entry for every element which you wish to be controlled by a macro.

2. To add a new element right-click anywhere within the Selection Area, and select Create and Element.

A New Element is added to the Elements branch:
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3. To name the element, right-click on the existing name and select Rename.

4. Type the name of the element and press Enter.

5. Within the Parameter Area, tick the checkbox which describes the type of the element - e.g. TFF.

The Macro Editor references each element by name and type. Therefore, these MUST match those given
within the system configuration, see Configuring the Macro Functions.

6. Enter a Description for the element if you wish.

7. Having made changes within the Parameter Area, click on Apply to adopt the changes:

8. Repeat steps 2 to 7 for every element you wish to include within a macro definition.

9. You can delete unwanted elements, such as the dummy KeyXY entry by right-clicking and selecting
Delete:
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6.4.5 Creating a Macro set

The next step is to create a macro set. Each macro set can be named and consists of 32 macro definitions. For
example, you may create different macrosets for different types of application such as Live or Recording work.
This provides the ability to transfer different macro sets to different studios for any given production.

1. Open up the Macrosets branch within the Selection Area to view the macro sets:

If this is a new configuration you will see one Macro set named My Macroset.

2. Double-click on the name or click on the + sign to view the 32 individual Macros.

There are a few options for each macro set:

· To change the name of the macro set, right-click the name and select Rename.

· Then type in the new name – for example, Live Macros – and press Enter.

· You can enter a Description in the Parameter Area, if you wish, and also click the Set Default button.
This makes this macro set the default selection when transferring macros later. 

· Having made changes in the Parameter Area, click on Apply to adopt the changes.
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6.4.6 Defining the Macros

Having configured your macro set and added all the elements you need to the Macro Editor, you are now ready
to define your macros.

The example below shows a programed macro – Macro 1 – which will execute 4 functions on the Rising edge of
the triggering logic:

Within the Macro data area you can see the 4 element functions which will be triggered:

· Mix 1 Balance set to -9

· Mix 1 Dim Level set to -20

· Source 1 routed to Aux Pre 1

· Input 1 of the OR8 gate turned ON. 

The Edge selector shows that these elements will occur on the Rising Edge of the macro.

The Data entry mask area can be used to edit any of the individual entries within the Macro data list. For each
function, you can set the:

· Type – this is the element type, in our example a Minimix. Click on this field to view all the element types
which can be included within a macro.

· Element – this is the element name, in our example the Minimix called Mix 1. The options here come
from the Elements branch of the Macro Editor.

· Function – this is the function within the element, in our example, the Dim Level within the Minimix. The
options available here depend on the type of element.

· Parameter – this is the parameter value which will be actioned, in our example, the level will change to -
20dB. The parameter options also depend on the type of element.
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Ø  To program a new macro from scratch:

1. Open up your macro set within the Selection Area to view the 32 individual Macros.

2. Select a macro – e.g. 1 Macro:

3. Select Rising Edge from the Edge Selector to define what will happen when the macro’s rising edge is
triggered. 

4. Highlight the first row within the Macro Data area. This will be marked with an *.

The Function fields within the Data Entry Mask area now become active for you to define your macro.

5. First select the type of element – for example, Source:
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6. Then the name of the element – for example, Source 1:

7. Now select a Function within the Source 1 element – for example, Fader Up/Down:
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8. Finally, select the Parameter value which you wish to occur. In our example, we want the fader to open
(turn ON) on the rising edge of the macro:

9. When you have made your selections, click on Append to add the function to the macro definition.

The function is automatically entered in the next available position – in our example, position 1:

10. Now click on Falling Edge within the Edge Selector to define what will happen when the macro’s falling
edge is triggered.
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11. Repeat steps 4 to 10 for every function you wish to be actioned from this macro.

When you finish, you should have a list of functions programed for the macro – for example:

The functions will be actioned in the order in which they appear.

Ø  To reorder the list:

1. Select the macro function – e.g. Mix 1 Dim Level.

2. Click on the Move Up or Move Down buttons on the Macro Editor Toolbar to change its position within
the list.

Ø  To delete a function:

1. Select the macro function – e.g. Mix 1 Dim Level.

2. Right-click and select Delete.

3. Or, select Delete all to delete all functions from the macro.

When using either of these operations, remember to change both the Rising Edge and Falling Edge if
applicable.
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6.4.7 Configuring Elements without a Name

The system configuration includes some elements which cannot be renamed. For example, the Central Module
within the ‘Surface’ branch of the ‘Tree Definition’ window. These element functions must be added to the Macro
Editor under the universal name of *. 

1. First, create a new element and rename it as *.

2. Select the types of element you wish to add – in our example, the XL Module and Definition types:

3. Now when you come to configure your macros, you will find a range of functions for these elements
under the XL and Definition Function types:
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6.4.8 Transferring a Macro set

You can transfer any of your macro sets to any system configured within the Units branch of the Macro Editor.
Macro definitions are transferred via TCP/IP. They are then stored on the control system and are loaded
whenever the system powers on.

In systems with a redundant Master Board, then the macro definitions must be transferred to both Master
Boards.

You can transfer a new macro set without restarting the system. This allows you to modify macros while the
system is running online.

First make sure that your Macro Editor PC is connected and communicating with the system you wish to
transfer to. Then make sure that you have transferred the system configuration that supports the Macro setup.

1. Select the macro set you wish to transfer, and click the Set Default button.

2. Select the unit you wish to transfer to, and check the IP Address.

3. To start the transfer, either click on the Transfer button from the Toolbar, or right-click and select
Transfer:

A confirmation pop-up automatically appears showing the name of the macroset and unit you will transfer to:

5. Click on OK to proceed.

Your PC will now connect to the system and transfer the macro data. 

All 32 macros within the macro set are transferred; you cannot transfer a subset.



ON-AIR Designer Configuration Options Version: 6.6.0_1 287/325

6. Macros

6.4.9 Saving the Macro Editor Configuration

The Macro Editor configuration, including all of the macro sets, elements and TCP/IP configuration, may be
saved as a .zmc file on your PC. This allows you to open the file at a later date for editing or to perform a new
transfer.

1. Either click on the Save button from the Macro Editor Toolbar or select File -> Save.

2. You will asked to enter a name and directory location for your configuration. Enter a name – e.g.
ZirkonMacros - and then click Save.

The name and file path appears in the blue bar at the top of the Macro Editor, and the file name also appears in
the top folder within the Selection Area:

From hereon, you can simply click on Save to save changes to this file. Or, use Save As to save changes to a
different filename or path.
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6.4.10 Trouble-shooting

To verify if all functions of all macro elements have been successfully assigned, the system offers a Telnet shell
command. Once the session is open:

1. Type macro and press Enter for an overview of Macros 1 to 32 - for example:

pty0 [/] # macro

macro

macro definitions for macro 1 to macro 32

dumping macro definitions

=========================================

Elements defined in MACRO  1

---------------------------------------------------

seq: <rising edge> |  seq: <falling edge>

---------------------------------------------------

   1: <*>     |    2: <Master_B_active >

   2: <*>

no unresolved element found

---------------------------------------------------

A (u) behind a macro line signifies an element which could not be assigned. Elements that are not assigned are
either not included in the console configuration or the element was spelt incorrectly.

2. To view other functions which can be executed from the Telnet session, type macro –h and press Enter:

-d <macro_number> - print the macro number only

-d <all>          - print all macros

-u                - print unresolved only

-e                - erase macro definitions



ON-AIR Designer Configuration Options Version: 6.6.0_1 289/325

7. Appendices

7.     Appendices

This chapter includes further information which you may find useful. 
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7.1 Special Source Types

When configuring a source, the following special source types are supported.

Source Type Application r c sc s N29

Source VCA Group Create a VCA Group master.
ü û ü ü û

Source MiniMix Control the level of another element such as a Minimixer.
ü ü ü ü û

Source R3LAY
(Jade)

Remotely control source parameters within Lawo's R3LAY (formerly
known as Jade).

ü ü ü ü û

Source Protools Remotely control channel functions within an external DAW.
ü û û ü û

7.1.1 Source Type = VCA Group

VCA grouping can be used to control several sources or summing buses from a single master fader.

Up to 8 VCA masters can be defined in the configuration, and you can assign any number of fader strips to
each VCA master.

Please note:

· A fader strip can only ever be assigned to a single VCA. 

· A VCA master cannot be slaved to another VCA.

· For your console to support VCA grouping, at least one VCA master must be defined in the
configuration.

Creating a VCA Group

VCA masters are a special type of source, and so they must be added to the "Source" branch of the 'Tree
Definition'.

1. Insert a new Source in the usual manner, see Creating Sources.

2. Set the source Type to VCA Group:
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VCA Parameters

1. Select the VCA Group you wish to edit (from the "Source" branch of the 'Tree Definition') and open the
Parm tab to adjust its main parameters.

These are a subset of the Source parameters described earlier. Most important is the Source name which
must be unique (e.g. VCA 1), and the VCA Group No (described below).

Use the Display name and Source Color options to define the label and color coding of the VCA master.

The VCA Group No can be used to define a fixed order for the VCA groups 1 to 8. It affects how the groups
appear in the VCA menu; how they are stored in snapshots; and what happens if changes are made to the
configuration.

To maintain compatibility with older ON-AIR Designer projects (< 6.6.0.24), the default setting is "Auto".
However, it is recommended to use a specific number, so that if a VCA Group is later added or deleted, this will
have no affect on the existing groups. 

To define a fixed order, you must assign a unique number to every VCA Group source. Alternatively, the option
can be left at "Auto" (to order the VCA Group sources automatically).

Please note:

· Each VCA Group No. must be used only once within the same configuration.

· You must not mix the "Auto" and fixed group numbers within the same configuration.

In snapshots, all settings are stored according to the VCA Group No. Thus, if you change from "Auto" to
fixed numbering and wish to use existing snapshots, it is important that the fixed numbering matches that of
the automatic sequence.
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2. Open the "System -> Definition -> Param = Fader" branch of the 'Tree Definition'.

There are three relevant options: Show Group Fader Values, Group Fader Values Fallback and Group
Fader Value Hold Time (in seconds).

Working with VCAs

VCA groups use non-moving slave faders. This means that when you move the master fader, the slave faders
remain stationary even though their level is changing. This allows you to see and update slave fader positions
even if the VCA master is closed.

If the Show Group Fader Values option is enabled (in the "System -> Definition -> Param = Fader" branch of
the 'Tree Definition'), then you will see the resulting fader values applied to VCA slaves in the fader strip
displays. In our example, both slave faders are at 0dB, but the master VCA has been moved to +5 and
therefore the combined level is +5dB:

Combined level shown in slave fader displays

If the Group Fader Values Fallback option is also enabled, then the displays will revert to their default mode
(e.g. source name) after a certain time period. The time period is set by the Group Fader Value Hold Time (in
seconds).
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7.1.2 Source Type = Minimix

The special source type (Source -> Minimix) creates a fader-controlled gain element which can be assigned to
any level control. This allows you to control any level, such as the output of a Minimixer, from a fader. Using a
VisTool Fader element, level can also be adjusted from an on-screen fader.

1. Insert a new Source in the usual manner, see Creating Sources.

2. Set the source Type to Minimix.

3. Name and edit the source parameters.

These are a subset of the Source parameters described earlier. Most important is the Reference name which
must be unique - in our example, HP Level:

The Fader Level Sync input can be used to set the gain from an external controller. Note that this is a one-
way gain sync only, and so any changes made by the fader will not be sent back to the external controller.

4. Now locate the element you wish to control from the source - in our example, a Minimixer. And, assign
the source's Fader Level Out control to the desired parameter field (Level):

5. Once the configuration is saved and transferred, assign the source named HP Level to a fader strip.
You can now remotely control the Minimixer level from its fader.
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7.1.3 Source Type = R3LAY (Jade)

This special source can be used to remotely control a fader strip within Lawo's R3LAY (formerly known as Jade).
The control data is exchanged via the Lawo control network using Ember+.

The parameters are a subset of the Source parameters described earlier. Most important are:

· the Reference name which must be unique (e.g. R3LAY 1).

· the Ember+ Local Provider No - defined in the "System -> Definition".

· the R3LAY No. and Ember+ Name fields which select the R3LAY application and its source fader. The
R3LAY No must be unique (within the configuration of this device).

Once the configuration has been transferred to the system, you can assign the R3LAY source to a fader strip in
the usual manner. The console fader will remotely control the designated R3LAY fader.



ON-AIR Designer Configuration Options Version: 6.6.0_1 295/325

7. Appendices

7.1.4 Source Type = Protools

Using a serial to MIDI interface, you can connect Power Core or sapphire MK2 systems to any DAW
supporting the Mackie-HUI™ protocol. For details on the connections, please see the RS-422 wiring for your
product. Here we will deal with the configuration.

Although the 'Tree Definition' paths are named Protools, these elements can be used for any DAW
supporting the Mackie-HUI™ protocol.

Using Protools Sources

Up to eight special ProTools™ Sources can be created in order to control channel functions within the DAW
from a fader strip.

1. Insert a new Source in the usual manner, see Creating Sources.

2. Set the source Type to Protools:

3. Select the ProTools source to define its parameters:

These are a subset of the Source parameters described earlier. Most important are the Reference name which
must be unique (e.g. DAW 1), and the Pro Tools Fader field which defines the ProTools channel number.

Once the configuration has been transferred to the system, you can assign the Protools source to a fader strip in
the usual manner. The console fader will remotely control the designated ProTools fader.

The fader strip MF Keys will then provide the following remote controls:
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· MF 1a = RECORD Enable

· MF 1b = Insert

· MF 2a = AUTOMATION Status

· MF 2b = SELECT

· MF 3 = channel MUTE

· MF 4 = channel SOLO (PFL)

The fader strip’s rotary control has the same function as on the Mackie-HUI control panel. For a detailed
description of these functions, please consult your DAW manual.
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7.2 CAN Bus Addressing

The CAN bus address, also known as the Frame ID, is a unique address which defines the role of each control
surface module within the system. 
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7.2.1 ruby CAN Bus Addressing

For ruby, the following options are supported:

· Address 01 to 0F (hexadecimal) can be assigned to Fader Modules.

· Address 10 (hexadecimal) is always assigned to the first full mode Central Module. Every layout
includes this assignment.

· Address 11 (hexadecimal) is not available for assignment.

· Address 12 to 17 (hexadecimal) can be assigned to additional Central Modules:

o For a standard DSP Core, these must run in monitor mode. 

o For Power Core Max, hex address 12 to 14 can run in either full or monitor mode; hex address 15 to
17 must run in monitor mode.

Frame -> Surface: CAN Bus Addresses (hexadecimal)

Each address must be unique, so do not assign the same address to more than one module. If you do so,
this can lead to control conflicts and odd behaviour of the surface.

To mirror faders or other controls, use the programmable logic features of the DSP Core, such as "fader
mapping" or "source replication".

Single-frame Consoles

By default, each control surface frame ships with the following CAN bus addresses: the first Fader Module on
the left = hex address 01; the next Fader Module = hex address 02; and so on; the Central Module = hex
address 10. Thus, for a single-frame console there is usually no further action required, as the modules will
map correctly to the configuration.

Console: CAN Bus Addresses (hexadecimal)
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Split-frame Consoles

For a split-frame surface, you will need to adjust the CAN bus addresses on the additional frames so that they
match the configuration supplied with the system. An example is shown below. 

In this instance, the Frame -> Surface configuration does not look anything like the physical console, as it is
the CAN bus addresses which define the functionality. In our example, the surface on the left controls faders 1
to 24 (in two layers); while the surface on the right controls faders 25 to 48.

Frame -> Surface: CAN Bus Addresses (hexadecimal)

Console: CAN Bus Addresses (hexadecimal)
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Control Surface Layers (Fader Mappings)

Each Fader Module supports two layers. This means that the module set to hex address 01 controls fader strips
1 to 4 (Layer 1) and 5 to 8 (Layer 2); the module set to hex address 02 controls fader strips 9-12 and 13-16;
and so on.

Fader Mappings
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7.2.2 crystal CAN Bus Addressing

For crystal, the following options are supported:

· Address 01 to 06 (hexadecimal) are assigned to Fader Modules.

· Address 0F & 0E (hexadecimal) are assigned to the two Central Modules.

Frame -> Surface: CAN Bus Addresses (hexadecimal)

Each address must be unique, so do not assign the same address to more than one module. If you do so,
this can lead to control conflicts and odd behaviour of the surface.

Single-frame Consoles

By default, each control surface frame ships with the following CAN bus addresses: the first Fader Module on
the left = hex address 01; the next Fader Module = hex address 02; and so on; the Central Module = hex
address 10. Thus, for a single-frame console there is usually no further action required, as the modules will
map correctly to the configuration.

Split-frame Consoles

For a split-frame surface, you will need to adjust the CAN bus addresses on the extender module(s) so that they
match the configuration supplied with the system. 
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7.2.3 sapphire compact CAN Bus Addressing

 For sapphire compact, the following options are supported:

· Address 01 to 04 (hexadecimal) are assigned to Fader Modules. Each one can be a standard, self-
operated or virtual module.

· Address 10 (hexadecimal) is always assigned to the Central Module.

Frame -> Surface: CAN Bus Addresses (hexadecimal)

Each address must be unique, so do not assign the same address to more than one module. If you do so,
this can lead to control conflicts and odd behaviour of the surface.

Single-frame Consoles

By default, each control surface frame ships with the following CAN bus addresses: the first Fader Module on
the left = hex address 01; the next Fader Module = hex address 02; and so on; the Central Module = hex
address 10. Thus, for a single-frame console there is usually no further action required, as the modules will
map correctly to the configuration.

Split-frame Consoles

For a split-frame surface, you will need to adjust the CAN bus addresses on the extender module(s) so that they
match the configuration supplied with the system. 
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7.3 Matrix Numbers

When using matrix functions, the inputs and outputs within the Lawo system are addressed as shown below. Note
that the matrix address is the same as the ID number shown in the Command -> Inputs/Outputs lists, and so this
can be a useful way to determine the address for an individual signal. To control crosspoints within an external
matrix, please contact the manufacturer for details on their matrix addressing system.

Matrix Address
DSP Core

Power Core NOVA17 NOVA29 COMPACT ENGINE

1 IO CARDS
IO CARDS

MADI  1 LOCAL IO

65 MADI  2

129 MADI  1 MADI  1 MADI  3 MADI  1

193 MADI  2 MADI  2 MADI  4 MADI  2

257 MADI  3 MADI  3 MADI  5 MADI  3

321 MADI  4 MADI  4 MADI  6 MADI  4

385
MADI  SLOT 1

MADI  5 MADI  7 LOOPBACKS

449 MADI  6 MADI  8

513
MADI  SLOT 2

LOOPBACKS

MADI  9

577 MADI  10

641
MADI  SLOT 3

MADI  11

705 MADI  12

769
MADI  SLOT 4

UDP MADI  13

833 MADI  14

897
MADI  SLOT 5

MADI  15

961 GT MADI  16

1025
MADI  SLOT 6

LOOPBACK PORTS
1089

1153
MADI  SLOT 7

1217

1281
MADI  SLOT 8 DMS

1345

1409

RAVENNA

GT 1

1473 GT 2

1537

1601

1665

LOOPBACKS
1729

1793

1857

1921
GT

1985

2049 UDP



ON-AIR Designer Configuration OptionsVersion: 6.6.0_1304/325

7. Appendices

7.4 Mackie HUI Parameters

The following table lists the Mackie-HUI™ protocol Central Control functions which can be remotely controlled
from Power Core or sapphire MK2/Nova17 systems. For a detailed description of each function, please consult
your DAW manual.

Group Name Lawo System -> DAW DAW -> Lawo System

V-Pot Assign Input Yes Yes

V-Pot Assign Output Yes Yes

V-Pot Assign Pan Yes Yes

V-Pot Assign Send A Yes Yes

V-Pot Assign Send B Yes Yes

V-Pot Assign Send C Yes Yes

V-Pot Assign Send D Yes Yes

V-Pot Assign Send E Yes Yes

Global Channel < Yes Yes

Global Channel > Yes Yes

Global Bank < Yes Yes

Global Bank > Yes Yes

Global Assign Yes Yes

Global Default Yes Yes

Global Suspend Yes Yes

Global Flip Yes Yes

Global Mute Yes Yes

Global Bypass Yes Yes

Global Rec/Rdy Yes Yes

Auto Enable Plug-In Yes Yes

Auto Enable Pan Yes Yes

Auto Enable Fader Yes Yes

Auto Enable Send Mute Yes Yes

Auto Enable Send Yes Yes

Auto Enable Mute Yes Yes

Auto Mode Trim Yes Yes

Auto Mode Latch Yes Yes

Auto Mode Read Yes Yes

Auto Mode Off Yes Yes

Auto Mode Write Yes Yes

Auto Mode Touch Yes Yes

Window Mix Yes Yes

Window Edit Yes Yes

Window Transport Yes Yes

Window Mem-Loc Yes Yes

Window Status Yes Yes

Window Alt Yes Yes

Keyb. Shortcuts Ctrl/Clutch Yes Yes

Keyb. Shortcuts Shift/Add Yes Yes
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Group Name Lawo System -> DAW DAW -> Lawo System

Keyb. Shortcuts Edit Yes Yes

Keyb. Shortcuts Undo Yes Yes

Keyb. Shortcuts Alt/Fine Yes Yes

Keyb. Shortcuts Option/All Yes Yes

Keyb. Shortcuts Edit-Tool Yes Yes

Keyb. Shortcuts Save Yes Yes

Functionkeys F1 Yes Yes

Functionkeys F2 Yes Yes

Functionkeys F3 Yes Yes

Functionkeys F4 Yes Yes

Functionkeys F5 Yes Yes

Functionkeys F6 Yes Yes

Functionkeys F7 Yes Yes

Functionkeys F8/ESC Yes Yes

Status/Group Phase Yes Yes

Status/Group Monitor Yes Yes

Status/Group Auto Yes Yes

Status/Group Suspend Yes Yes

Status/Group Create Yes Yes

Status/Group Group Yes Yes

Edit Paste Yes Yes

Edit Cut Yes Yes

Edit Capture Yes Yes

Edit Delete Yes Yes

Edit Copy Yes Yes

Edit Separate Yes Yes

Transport Talkback Yes Yes

Transport Rewind Yes Yes

Transport FastFwd Yes Yes

Transport Stop Yes Yes

Transport Play Yes Yes

Transport Record Yes Yes

Transport Down Yes Yes

Transport Left Yes Yes

Transport Mode Yes Yes

Transport Right Yes Yes

Transport Up Yes Yes

Transport Scrub Yes Yes

Transport Shuttle Yes Yes

Transport RTZ Yes Yes

Transport End Yes Yes

Transport Online Yes Yes

Transport Loop Yes Yes
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Group Name Lawo System -> DAW DAW -> Lawo System

Transport Quickpunch Yes Yes

Transport Audition Yes Yes

Transport Pre Yes Yes

Transport In Yes Yes

Transport Out Yes Yes

Transport Post Yes Yes
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7.5 Ember+ Tree

Ember+ parameters are addressed as follows.

Key

M Mono

S Stereo

5.1 5.1 & 5.1+2

V VCA

J R3LAY

Mx MiniMix

P Pro Tools

r read only

rw read and write

I Integer

R Real

E Enumeration

B Boolean

U UTF8

1 Product

1 . 1..2 Sources / Sums

1 . 1..2 . 1..n Name Min Max Type Protect Sources Sums

1 . 1..2 . 1..n . 1 . Audio Type 0 4 E14 r M S 5.1 V J Mx P M S 5.1 J

1 . 1..2 . 1..n . 2 . Source Class 0 4 E15 r M S 5.1 V J Mx P M S 5.1 J

1 . 1..2 . 1..n . 3 . Fader M S 5.1 V J Mx P M S 5.1 J

1 . 1..2 . 1..n . 3 . 1 Number 0 120 I r M S 5.1 V J Mx P M S 5.1 J

1 . 1..2 . 1..n . 3 . 2 Motor db Value -191 9 R rw M S 5.1 V J Mx P M S 5.1 J

1 . 1..2 . 1..n . 3 . 3 Motor Position 0 255 I rw M S 5.1 V J Mx P M S 5.1 J

1 . 1..2 . 1..n . 3 . 4 Manual dB Value -191 9 R rw M S 5.1 V J Mx P M S 5.1 J

1 . 1..2 . 1..n . 3 . 5 Manual Position 0 255 I rw M S 5.1 V J Mx P M S 5.1 J

1 . 1..2 . 1..n . 4 DSP M S 5.1 M S 5.1 J

1 . 1..2 . 1..n . 4 . 1 Input M S 5.1

1 . 1..2 . 1..n . 4 . 1 . 1 Gain[dB] -30 18 I rw M S 5.1

1 . 1..2 . 1..n . 4 . 1 . 2 Mic Gain [dB] 0 70 I rw Mic Input

1 . 1..2 . 1..n . 4 . 1 . 3 Back Gain [dB] -120 9 I rw M S

1 . 1..2 . 1..n . 4 . 1 . 4 Rumble (powercore / sapphire) 0 3 E1S rw Mic Input

1 . 1..2 . 1..n . 4 . 1 . 4 Rumble (crystal) 0 1 E1C rw Mic Input

1 . 1..2 . 1..n . 4 . 1 . 5 Pad 0 1 B rw Mic Input

1 . 1..2 . 1..n . 4 . 1 . 6 Phantom 0 1 B rw Mic Input

1 . 1..2 . 1..n . 4 . 1 . 7 Phase 0 1 B rw M S

1 . 1..2 . 1..n . 4 . 1 . 8 LR Mode 0 6 E2 rw S

1 . 1..2 . 1..n . 4 . 1 . 9 Pan -12 12 I rw M (no 5.1 Sums

configured)

1 . 1..2 . 1..n . 4 . 1 . 10 Balance -12 12 I rw S (no 5.1 Sums

configured)

1 . 1..2 . 1..n . 4 . 1 . 11 Basis 0 10 I rw S

1 . 1..2 . 1..n . 4 . 1 . 12 Center Slope 0 1 R rw M (5.1 Sums configured)

1 . 1..2 . 1..n . 4 . 1 . 13 LFE [dB] -120 0 I rw M S 5.1 (5.1 Sums configured)

1 . 1..2 . 1..n . 4 . 1 . 14 Surr. Pan LR -12 12 I rw M S (5.1 Sums configured)

1 . 1..2 . 1..n . 4 . 1 . 15 Surr. Pan FB -12 12 I rw M S (5.1 Sums configured)

1 . 1..2 . 1..n . 4 . 1 . 16 Channel On 0 1 B rw M S 5.1

1 . 1..2 . 1..n . 4 . 1 . 16 N-1 Gain [dB] -30 18 I rw M S 5.1

1 . 1..2 . 1..n . 4 . 2 Equalizer M S 5.1 M S 5.1

1 . 1..2 . 1..n . 4 . 2 . 1 On 0 1 B rw M S 5.1 M S 5.1

1 . 1..2 . 1..n . 4 . 2 . 2 Band 1 (filter low) M S 5.1 M S 5.1

1 . 1..2 . 1..n . 4 . 2 . 2 . 1 Frequency 0 59 E3 rw M S 5.1 M S 5.1

1 . 1..2 . 1..n . 4 . 2 . 2 . 2 Gain [dB] -15 15 I rw M S 5.1 M S 5.1

1 . 1..2 . 1..n . 4 . 2 . 2 . 4 Mode 0 1 E4 rw M S 5.1 M S 5.1

1 . 1..2 . 1..n . 4 . 2 . 3-5 Band 2-4 (EQ) M S 5.1 M S 5.1

1 . 1..2 . 1..n . 4 . 2 . 3-5 . 1  Frequency 0 59 E3 rw M S 5.1 M S 5.1
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1 Product

1 . 1..2 Sources / Sums

1 . 1..2 . 1..n Name Min Max Type Protect Sources Sums

1 . 1..2 . 1..n . 4 . 2 . 3-5 . 2 Gain [dB] -15 15 I rw M S 5.1 M S 5.1

1 . 1..2 . 1..n . 4 . 2 . 3-5 . 3 Q 0 5 E5 rw M S 5.1 M S 5.1

1 . 1..2 . 1..n . 4 . 2 . 6 Band 5 (filter high) M S 5.1 M S 5.1

1 . 1..2 . 1..n . 4 . 2 . 6 . 1 Frequency 0 59 E3 rw M S 5.1 M S 5.1

1 . 1..2 . 1..n . 4 . 2 . 6 . 2 Gain [dB] -15 15 I rw M S 5.1 M S 5.1

1 . 1..2 . 1..n . 4 . 2 . 6 . 4 Mode 0 1 E6 rw M S 5.1 M S 5.1

1 . 1..2 . 1..n . 4 . 3 Dynamics M S 5.1 M S 5.1

1 . 1..2 . 1..n . 4 . 3 . 1 On 0 1 B rw M S 5.1 M S 5.1

1 . 1..2 . 1..n . 4 . 3 . 2 Corr Gain [dB] -12 0 I rw M S 5.1

1 . 1..2 . 1..n . 4 . 3 . 3 Compressor M S 5.1 M S 5.1

1 . 1..2 . 1..n . 4 . 3 . 3 . 1 On 0 1 B rw M S 5.1 M S 5.1

1 . 1..2 . 1..n . 4 . 3 . 3 . 2 Threshold [dB] -93 27 I rw M S 5.1 M S 5.1

1 . 1..2 . 1..n . 4 . 3 . 3 . 3 Ratio 0 9 E7 rw M S 5.1 M S 5.1

1 . 1..2 . 1..n . 4 . 3 . 3 . 4 Attack Time 0 9 E8 rw M S 5.1 M S 5.1

1 . 1..2 . 1..n . 4 . 3 . 3 . 5 Release Time 0 14 E9 rw M S 5.1 M S 5.1

1 . 1..2 . 1..n . 4 . 3 . 4 Expander M S 5.1 M S 5.1

1 . 1..2 . 1..n . 4 . 3 . 4 . 1 On 0 1 B rw M S 5.1 M S 5.1

1 . 1..2 . 1..n . 4 . 3 . 4 . 2 Threshold [dB] -93 27 I rw M S 5.1 M S 5.1

1 . 1..2 . 1..n . 4 . 3 . 4 . 3 Ratio 0 9 E10 rw M S 5.1 M S 5.1

1 . 1..2 . 1..n . 4 . 3 . 5 Gate M S 5.1 M S 5.1

1 . 1..2 . 1..n . 4 . 3 . 5 . 1 On 0 1 B rw M S 5.1 M S 5.1

1 . 1..2 . 1..n . 4 . 3 . 5 . 2 Threshold [dB] -93 27 I rw M S 5.1 M S 5.1

1 . 1..2 . 1..n . 4 . 3 . 5 . 3 Attack Time 0 9 E8 rw M S 5.1 M S 5.1

1 . 1..2 . 1..n . 4 . 3 . 5 . 4 Release Time 0 14 E9 rw M S 5.1 M S 5.1

1 . 1..2 . 1..n . 4 . 3 . 6 DeEsser M S

1 . 1..2 . 1..n . 4 . 3 . 6 . 1 On 0 1 B rw M S

1 . 1..2 . 1..n . 4 . 3 . 6 . 2 Mode 0 1 E11 rw M S

1 . 1..2 . 1..n . 4 . 3 . 6 . 3 Reduction 0 10 I rw M S

1 . 1..2 . 1..n . 4 . 4 AutoMix M S

1 . 1..2 . 1..n . 4 . 4 . 1 On 0 1 B rw M S

1 . 1..2 . 1..n . 4 . 4 . 2 Weight [dB] -9 9 I rw M S

1 . 1..2 . 1..n . 4 . 4 . 3 Speed 0 14 E9 rw M S

1 . 1..2 . 1..n . 4 . 4 . 4 Group (Crystal max 2) 1 4 I rw M S

1 . 1..2 . 1..n . 4 . 5 Limiter M S 5.1 M S 5.1

1 . 1..2 . 1..n . 4 . 5 . 1 On 0 1 B rw M S 5.1 M S 5.1

1 . 1..2 . 1..n . 4 . 5 . 2 Threshold [dB] -93 27 I rw M S 5.1 M S 5.1

1 . 1..2 . 1..n . 4 . 5 . 3 Release Time 0 14 E9 rw M S 5.1 M S 5.1

1 . 1..2 . 1..n . 4 . 6 Delay M S 5.1 M S 5.1

1 . 1..2 . 1..n . 4 . 6 . 1 On 0 1 B rw M S 5.1 M S 5.1

1 . 1..2 . 1..n . 4 . 6 . 2 Time (ms) (sapphire, crystal) 0 340 R rw M S 5.1 M S 5.1

1 . 1..2 . 1..n . 4 . 6 . 2 Time (ms) (powercore) 0 5300 R rw M S 5.1 M S 5.1

1 . 1..2 . 1..n . 5 Aux buses M S 5.1

1 . 1..2 . 1..n . 5 . 1..20 Aux Name M S 5.1

1 . 1..2 . 1..n . 5 . 1..20 . 1 Gain [dB] -120 9 I rw M S 5.1

1 . 1..2 . 1..n . 5 . 1..20 . 2 State 0 2 E12 rw M S 5.1

1 . 1..2 . 1..n . 6 MF Keys M S 5.1 V J Mx P M S 5.1 J

1 . 1..2 . 1..n . 6 . 1-4 MF1a- MF2b M S 5.1 V J Mx P M S 5.1 J

1 . 1..2 . 1..n . 6 . 1-4 . 1 Label U r M S 5.1 V J Mx P M S 5.1 J

1 . 1..2 . 1..n . 6 . 1-4 . 2 Key 0 1 B rw M S 5.1 V J Mx P M S 5.1 J

1 . 1..2 . 1..n . 6 . 1-4 . 3 LED State M S 5.1 V J Mx P M S 5.1 J

1 . 1..2 . 1..n . 6 . 1-4 . 3 . 1 Color 0 7 E13 r M S 5.1 V J Mx P M S 5.1 J

1 . 1..2 . 1..n . 6 . 1-4 . 3 . 2 Low 0 1 B r M S 5.1 V J Mx P M S 5.1 J

1 . 1..2 . 1..n . 6 . 1-4 . 3 . 3 Blink 0 1 B r M S 5.1 V J Mx P M S 5.1 J

1 . 1..2 . 1..n . 6 . 5-7 MF3-5 (5 powercore / sapphire only) M S 5.1 V J Mx P M S 5.1 J
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1 Product

1 . 1..2 Sources / Sums

1 . 1..2 . 1..n Name Min Max Type Protect Sources Sums

1 . 1..2 . 1..n . 6 . 5-7 . 2 Key 0 1 B rw M S 5.1 V J Mx P M S 5.1 J

1 . 1..2 . 1..n . 6 . 5-7 . 3 LED State M S 5.1 V J Mx P M S 5.1 J

1 . 1..2 . 1..n . 6 . 5-7 . 3 . 1 Color 0 7 E13 r M S 5.1 V J Mx P M S 5.1 J

1 . 1..2 . 1..n . 6 . 5-7 . 3 . 2 Low 0 1 B r M S 5.1 V J Mx P M S 5.1 J

1 . 1..2 . 1..n . 6 . 5-7 . 3 . 3 Blink 0 1 B r M S 5.1 V J Mx P M S 5.1 J

1 . 1..2 . 1..n . 6 . 8-11 MF6-9 (powercore / sapphire only) M S 5.1 V J Mx P M S 5.1 J

1 . 1..2 . 1..n . 6 . 8-11 . 1 Label U r M S 5.1 V J Mx P M S 5.1 J

1 . 1..2 . 1..n . 6 . 8-11 . 2 Key 0 1 B rw M S 5.1 V J Mx P M S 5.1 J

1 . 1..2 . 1..n . 6 . 8-11 . 3 LED State M S 5.1 V J Mx P M S 5.1 J

1 . 1..2 . 1..n . 6 . 8-11 . 3 . 1 Color 0 7 E13 r M S 5.1 V J Mx P M S 5.1 J

1 . 1..2 . 1..n . 6 . 8-11 . 3 . 2 Low 0 1 B r M S 5.1 V J Mx P M S 5.1 J

1 . 1..2 . 1..n . 6 . 8-11 . 3 . 3 Blink 0 1 B r M S 5.1 V J Mx P M S 5.1 J

1 . 1..2 . 1..n . 7 States M S 5.1 V J Mx P M S 5.1 J

1 . 1..2 . 1..n . 7 . 1 Fader Motor Start 0 1 B r M S 5.1 V J Mx P M S 5.1 J

1 . 1..2 . 1..n . 7 . 2 Fader Manual Start 0 1 B r M S 5.1 V J Mx P M S 5.1 J

1 . 1..2 . 1..n . 7 . 3 Fader Result Start 0 1 B r M S 5.1 V J Mx P M S 5.1 J

1 . 1..2 . 1..n . 7 . 4 PFL1 active 0 1 B r M S 5.1

1 . 1..2 . 1..n . 8 VCA Groups M S 5.1 V

1 . 1..2 . 1..n . 8 . 1 Assigned Group Number 0 8 I rw M S 5.1 V

1 . 1..2 . 1..n . 9 Labels M S 5.1 V J Mx P

1 . 1..2 . 1..n . 9 . 1 User Label M S 5.1 V J Mx P

1 . 1..2 . 1..n . 9 . 1 . 1 Line 1 U rw M S 5.1 V J Mx P

1 . 1..2 . 1..n . 9 . 1 . 2 Line 2 U rw M S 5.1 V J Mx P

1 . 1..2 . 1..n . 10 Insert (powercore only)

1 . 1..2 . 1..n . 10 . 1 Name (powercore only) E rw M S

1 . 1..2 . 1..n . 10 . 2 Position (powercore only) E rw M S

7.5.1 Misc

1 Product Min Max Type Protect
1 . 1 Sources Sources and

Sum table1 . 2 Sums
1 . 3 Matrices
1 . 3 . 1 System Matrix
1 . 3 . 2 . Matrix Params
1 . 3 . 2 . 1 targets
1 . 3 . 2 . 1 . 1-n Name
1 . 3 . 2 . 1 . 1-n . 1 Group U r
1 . 3 . 2 . 1 . 1-n . 2 Name U r
1 . 3 . 2 . 1 . 1-n . 3 Type 0 6 EM1 r
1 . 3 . 2 . 1 . 1-n . 4 Gain[dB] -30 9 I r
1 . 3 . 2 . 1 . 1-n . 5 Protected 0 1 B rw
1 . 3 . 2 . 2 sources
1 . 3 . 2 . 2 . 1-n Name
1 . 3 . 2 . 2 . 1-n . 1 Group U r
1 . 3 . 2 . 2 . 1-n . 2 Name U r
1 . 3 . 2 . 2 . 1-n . 3 Type 0 6 EM1 r
1 . 3 . 2 . 2 . 1-n . 4 Gain[dB] -30 9 I rw
1 . 3 . 3 Matrix Labels
1 . 3 . 3 . 1 targets
1 . 3 . 3 . 1 . 1-n L1 to Ln U r
1 . 3 . 3 . 2 sources
1 . 3 . 3 . 2 . 1-n L1 to Ln U r
1 . 4 GPIOs
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1 . 4 . 1-n Name
1 . 4 . 1-n . 1 Output Register I r
1 . 4 . 1-n . 2 Output Signals
1 . 4 . 1-n . 2 . 1-32 Name
1 . 4 . 1-n . 2 . 1-32. 1 State 0 1 B r
1 . 4 . 1-n . 3 Input Register I r/rw
1 . 4 . 1-n . 4 Input signals
1 . 4 . 1-n . 4 . 1-32 Name
1 . 4 . 1-n . 4 . 1-32. 1 State 0 1 B r/rw
1 . 5 Functions
1 . 5 . 1 ParamLoopBack

Function table1 . 5 . 2 RampMotorFader
1 . 5 . 3 SetPFLState
1 . 6 (powercore only) RAVENNA RAVENNA table
1 . 7 (powercore only) IO Cards IO Card table
1 . 7 (powercore only) GPIO Card IO Card table
1 . 29 (powercore only) System System table
1 . 29 (legacy only) System
1 . 29 . 1 (legacy only) System Type 0 3 EM2 r
1 . 29 . 2 (legacy only) M2 Mode 0 3 EM3 r
1 . 29 . 3 (legacy only) Card Position 0 1 EM4 r
1 . 29 . 4 (legacy only) Card State 0 5 EM5 r
1 . 30 identity
1 . 30 . 1 product U r
1 . 30 . 2 company U r
1 . 30 . 3 serial U r
1 . 30 . 4 version U r
1 . 30 . 5 role U r
1 . 31 Configuration
1 . 31 . 1 Timestamp U r

7.5.2 Enumerations (Misc)

EM1 Source Type

0none

1mono

2left

3right

4stereo

55.1

65.1+2

EM2S System Type

0Default

1Sapphire

2Nova17MK2

3AudioIF

EM2C System Type

0Default

EM3 System M2 Mode

0Normal

1Standalone

EM4 System Card Position

0M1

1M2

EM5 System Card State

0Active

1Inactive

2Standalone

3Isolate Active

4Isolate Inactive

5Undefined

EM6
(powercore)

System Sampling Rate

044.1 kHz

148 kHz

EM7
(powercore)

System Prio Sequence

0PTP - MADI -
WordClock

1PTP - WordClock
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EM3 System M2 Mode

2Isolate

3Unknown

EM7
(powercore)

System Prio Sequence

- MADI

2MADI - PTP -
WordClock

3MADI -
WordClock - PTP

4WordClock - PTP
- MADI

5WordClock -
MADI - PTP

7.5.3 Function Calls

ParamLoopBack

Test Function. Entered values are Looped Back.

Arguments Type allowed

Boolean Par. B 0 / 1

Integer Par. I Int

Real Par. R Real

String Par. U String

Results

Boolean Res. B

Integer Res. I

Real Res. R

String Res. U

RampMotorFader

Move a Motor Fader within an entered time

to a defined gain.

Arguments Type allowed

Source Name U existing Sources / Sums

Gain[dB] R -999 to +9

bounded to -191 to +9

Time[s] R 0 to 10 ( <0.5 = at once)

Results

Result I

0 Success

1 Incorrect number of parameters

2 Incorrect datatype

3 Input value out of range

4 Source / Sum not found
5 Source / Sum not assigned

6 Combination of values not allowed
(level difference to small / time to large)
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SetPFLState

Set a Sources PFL State.

Arguments Type allowed

Source Name U existing Sources / Sums

Status B 0 / 1

Results

Result I

0 Success

1 Incorrect number of parameters

2 Incorrect datatype

4 Source / Sum not found

5 Source / Sum not assigned

7.5.4 RAVENNA

ER1 Input Type

0none

1mono

2stereo

3surround

416-channel

532-channel

664-channel

ER2 Input Codec

0none

1L16

2L24

3L32

4AM824

1 ruby Min Max Type Protect

1 . 6 RAVENNA

1 . 6 . 1 PTP

1 . 6 . 1 . 1 Configuration + Control

1 . 6 . 1 . 1 . 1 Domain 0 9 I r

1 . 6 . 1 . 1 . 2 Prio 1 0 255 I r

1 . 6 . 1 . 1 . 3 Prio 2 0 255 I r

1 . 6 . 1 . 1 . 4 Master Announce Interval 0 4 I r

1 . 6 . 1 . 1 . 5 Master Sync Interval 0 2 I r

1 . 6 . 1 . 1 . 6 Master TTL 0 10 I r

1 . 6 . 1 . 1 . 7 Slave only 0 1 B r

1 . 6 . 1 . 1 . 8 Delay Mechanism 0 1 I r

1 . 6 . 1 . 1 . 9 DSCP 0 255 I r

1 . 6 . 1 . 1 . 10 Slave WAN Mode 0 1 B r

1 . 6 . 1 . 2 Global Data

1 . 6 . 1 . 2 . 1 PTP Mode U r

1 . 6 . 1 . 2 . 2 Active Clock IP Address U r

1 . 6 . 1 . 2 . 3 Active Clock ID U r

1 . 6 . 1 . 2 . 4 Grandmaster Clock ID U r

1 . 6 . 1 . 3 Slave-Only Engine

1 . 6 . 1 . 3 . 1 Time Difference U r

1 . 6 . 1 . 3 . 2 Clock Correction Value U r

1 . 6 . 1 . 3 . 3 Status U r

1 . 6 . 1 . 3 . 4 Stability U r

1 . 6 . 1 . 3 . 5 Sync Interval U r

1 . 6 . 1 . 3 . 6 Servo Window Size U r

1 . 6 . 1 . 4 Master-Slave Engine

1 . 6 . 1 . 4 . 1 Status U r



ON-AIR Designer Configuration Options Version: 6.6.0_1 313/325

7. Appendices

1 ruby Min Max Type Protect

1 . 6 RAVENNA

1 . 6 . 1 . 4 . 2 Own Clock ID U r

1 . 6 . 2 Devices

1 . 6 . 2 . 1..2 ra0 ..1

1 . 6 . 2 . 1..2 . 1 Parameters

1 . 6 . 2 . 1..2 . 1 . 1 Hostname U r

1 . 6 . 2 . 1..2 . 1 . 2 IP Address U r

1 . 6 . 2 . 1..2 . 1 . 3 Netmask U r

1 . 6 . 2 . 1..2 . 1 . 4 RTSP Port 0 65535 I r

1 . 6 . 2 . 1..2 . 1 . 5 Sample Rate 4410

0

48000 I r

1 . 6 . 3 Core

1 . 6 . 3 . 1 Inputs

1 . 6 . 3 . 1 . 1..n Ravenna Core Input name

1 . 6 . 3 . 1 . 1..n . 1 Type 0 6 ER1 r

1 . 6 . 3 . 1 . 1..n . 2 Devices U r

1 . 6 . 3 . 1 . 1..n . 3 mDNS Channels U r

1 . 6 . 3 . 1 . 1..n . 4 SAP Channels U r

1 . 6 . 3 . 1 . 1..n . 5 Codec 0 4 ER2 r

1 . 6 . 3 . 1 . 1..n . 6 Samples per Frame 0 128 I r

1 . 6 . 3 . 1 . 1..n . 7 Source No. 0 128 I r

1 . 6 . 3 . 1 . 1..n . 8 SDP U r

1 . 6 . 3 . 1 . 1..n . 9 RTSP URL 0 U r

1 . 6 . 3 . 1 . 1..n . 10 RTSP URL 1 U r

1 . 6 . 3 . 1 . 1..n . 11 Active 0 1 B rw

1 . 6 . 3 . 1 . 1..n . 12 Stream Name U rw

1 . 6 . 3 . 2 Outputs

1 . 6 . 3 . 2 . 1..n Ravenna Core Output name

1 . 6 . 3 . 2 . 1..n . 1 Type 0 6 ER1 r

1 . 6 . 3 . 2 . 1..n . 2 Flags U r

1 . 6 . 3 . 2 . 1..n . 3 Default Stream Name U r

1 . 6 . 3 . 2 . 1..n . 4 Assigned Stream Name U r

1 . 6 . 3 . 2 . 1..n . 5 Destination No. 0 128 I r

1 . 6 . 3 . 2 . 1..n . 6 SDP U rw

1 . 6 . 3 . 4 Stream Destinations

1 . 6 . 3 . 4 . 1..n Dst n

1 . 6 . 3 . 4 . 1..n . 1 Type 0 6 ER1 r

1 . 6 . 3 . 4 . 1..n . 2 Remote Stream No. 0 I r

1 . 6 . 3 . 4 . 1..n . 3 Remote Stream Name U r

1 . 6 . 3 . 4 . 1..n . 4 Codec 0 4 ER2 r

1 . 6 . 3 . 4 . 1..n . 5 Samples per Frame 0 128 I r

1 . 6 . 3 . 4 . 1..n . 6 Time Offset 0 32000 I rw

1 . 6 . 3 . 4 . 1..n . 7 Tracks U r

1 . 6 . 3 . 4 . 1..n . 8(9) Statistics primary (secondary) Device

1 . 6 . 3 . 2 . 1..n . 8(9) . 1 Total_packet Count 0 214748364

7

I r

1 . 6 . 3 . 2 . 1..n . 8(9) . 2 Early Packet Count 0 214748364

7

I r

1 . 6 . 3 . 2 . 1..n . 8(9) . 3 Late Packet Count 0 214748364

7

I r

1 . 6 . 3 . 2 . 1..n . 8(9) . 4 Misordered Packet Count 0 214748364

7

I r

1 . 6 . 3 . 2 . 1..n . 8(9) . 5 Buffer Margin Minumum U r

1 . 6 . 3 . 2 . 1..n . 8(9) . 6 Buffer Margin Maximum U r

1 . 6 . 3 . 2 . 1..n . 8(9) . 7 Peak Jitter 0 2048 I r

1 . 6 . 3 . 2 . 1..n . 10 Statistics Both Device

1 . 6 . 3 . 2 . 1..n . 10 . 1 Timeout Count 0 214748364 I r
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1 ruby Min Max Type Protect

1 . 6 RAVENNA

7

1 . 6 . 3 . 2 . 1..n . 10 . 2 FSM State 0 8 I r

1 . 6 . 4 Remote Nodes

1 . 6 . 4 . 1..n Node Name 

1 . 6 . 4 . 1..n . 1 IP Address U r

1 . 6 . 4 . 1..n . 2 Flags U r

1 . 6 . 4 . 1..n . 3 TTL 0 240 I r

1 . 6 . 5 . Remote Streams

1 . 6 . 5 . 1..n Stream Name

1 . 6 . 5 . 1..n . 1 Type 0 6 ER1 r

1 . 6 . 5 . 1..n . 2 Devices U r

1 . 6 . 5 . 1..n . 3 mDNS Channels U r

1 . 6 . 5 . 1..n . 4 SAP Channels U r

1 . 6 . 5 . 1..n . 5 Flags U r

1 . 6 . 5 . 1..n . 6 TTL 0 240 I r

1 . 6 . 5 . 1..n . 7 Codec 0 4 ER2 r

1 . 6 . 5 . 1..n . 8 Samples per Frame 0 128 I r

1 . 6 . 5 . 1..n . 9 RTSP Port 0 I r

1 . 6 . 5 . 1..n . 10 MCast IP Address 0 U r

1 . 6 . 5 . 1..n . 11 MCast IP Address 1 U r

1 . 6 . 5 . 1..n . 12 Destination No. 0 5000 I r

1 . 6 . 5 . 1..n . 13 Destination Name U r

1 . 6 . 5 . 1..n . 14 SDP U r

1 . 6 . 5 . 1..n . 15 RTSP URI 0 U r

1 . 6 . 5 . 1..n . 16 RTSP URI 1 U r

1 . 6 . 6 Timestamps

1 . 6 . 6 . 1 Node List Update Timestamp 0 7465596 I r

1 . 6 . 6 . 2 Stream List Update Timestamp 0 7465596 I r

1 . 6 . 7 Functions

1 . 6 . 7 . 1 Output Connect RAVENNA
Function Table1 . 6 . 7 . 2 Remote Nodes List

1 . 6 . 7 . 3 Remote Streams List

Output Connect

Connects RAVENNA Output to stream

Arguments Type allowed

Output No. I existing Output Nos

Remote Stream No. I
use No. or Name

Remote Stream Name U

Results

Result I

0 Success

1

2

3 Output not found

4
5

6
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Remote Nodes List

Lists selected Remote Nodes

Arguments Type allowed

Previous Node No. I

Name Filter U

From Timestamp I

Results

Result I

0 Success

1

2

4

5

Node Name U

Node No. I

Actual Timestamp I

Remote Stream List

Lists selected Remote Streams

Arguments Type allowed

Previous Stream No. I

Stream Name Filter U

Node Name Filter U

Stream Type Filter I

From Timestamp I

Results

Result I

0 Success

1

2

4

5

Stream Name U

Stream No. I

Node No. I

Actual Timestamp I

7.5.5 IO Cards

EIO1 Input Card Type

0none

1Mic / Line

2Line In

3Line Out

4Studio I/O

5AES3 In/Out

6MADI

7Type Mismatch

EIO3 Input Mic Gain fixed

0Off

1-20 dB

2-25 dB

3-30 dB

4-35 dB

5-40 dB

6-45 dB

7-50dB
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EIO2 Input Type

0none

1Mic

2Line In

3Line Out

4AES

EIO3 Input Mic Gain fixed

8-55 dB

9-60 dB

10-65 dB

11-70 dB

1 ruby Min Max Type Protect

1 . 7 IO Cards

1 . 7 . 1..8 Slot No.

1 . 7 . 1..8 . 1 Card Type 0 7 EIO1 r

1 . 7 . 1..8 . 2 Parameters

1 . 7 . 1..8 . 2 . 1 Product ID U r

1 . 7 . 1..8 . 2 . 2 Serial Number U r

1 . 7 . 1..8 . 2 . 3 Hardware Revision I r

1 . 7 . 1..8 . 2 . 4 Firmware Version U r

1 . 7 . 1..8 . 2 . 5 Firmware Compile Date U r

1 . 7 . 1..8 . 2 . 6 Card Temperature U

1 . 7 . 1..8 . 2 . 7 Card Temperature High Limit U

1 . 7 . 1..8 . 2 . 10 Channels

1 . 7 . 1..8 . 2 . 10 . 1..8 Channel No.

1 . 7 . 1..8 . 2 . 10 . 1..8 . 1 Type 0 4 EIO2 r

1 . 7 . 1..8 . 2 . 10 . 1..8 . 2 Core connected B r

1 . 7 . 1..8 . 2 . 10 . 1..8 . 5 Mic Parameters (read only if Core connected)

1 . 7 . 1..8 . 2 . 10 . 1..8 . 5 . 1 In Gain [dB] -30 18 I r(w)

1 . 7 . 1..8 . 2 . 10 . 1..8 . 5 . 2 Mic Gain [dB] 0 70 C r(w)

1 . 7 . 1..8 . 2 . 10 . 1..8 . 5 . 3 Mic Gain fixed 0 11 EIO2 r
1 . 7 . 1..8 . 2 . 10 . 1..8 . 5 . 4 Phantom B r(w)

1 . 7 . 1..8 . 2 . 10 . 1..8 . 5 . 5 Phantom fixed B r

1 . 7 . 1..8 . 2 . 10 . 1..8 . 5 . 6 Pad 20dB B r(w)

1 . 7 . 1..8 . 2 . 10 . 1..8 . 5 . 7 Rumble 0 3 E1S r(w)

1 . 7 . 1..8 . 2 . 10 . 1..8 . 6 Line In Parameters

1 . 7 . 1..8 . 2 . 10 . 1..8 . 6 . 1 In Gain [dB] -30 18 I rw

1 . 7 . 1..8 . 2 . 10 . 1..8 . 6 . 2 Rumble 0 3 E1S r(w)

1 . 7 . 1..8 . 2 . 10 . 1..8 . 7 Line Out Parameters

1 . 7 . 1..8 . 2 . 10 . 1..8 . 7 . 1 Out Gain [dB] -30 18 I rw

1 . 7 . 1..8 . 2 . 10 . 1..8 . 8 AES Parameters

1 . 7 . 1..8 . 2 . 10 . 1..8 . 8 . 1 In Gain [dB] -30 18 I rw

1 . 7 . 1..8 . 2 . 10 . 1..8 . 8 . 2 Out Gain [dB] -30 18 I rw

1 . 7 . 1..8 . 2 . 10 . 1..8 . 8 . 3 Disable SRC B rw

1 . 8 GPIO Card

1 . 8 . 1..8 GPIO No.

1 . 8 . 1..8 . 1 Input 0 1 I r

1 . 8 . 1..8 . 2 Output (read only if Core connected) 0 1 I r(w)

1 . 8 . 1..8 . 3 Core connected (Output) 0 1 B r

7.5.6 System

1 ruby Min Max Type Protect

1 . 29 System

1 . 29 . 1 System States ( No function for powercore)

1 . 29 . 1 . 1 System Type 0 3 EM2 r

1 . 29 . 1 2 M2 Mode 0 3 EM3 r

1 . 29 . 1 3 Card Position 0 1 EM4 r
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1 ruby Min Max Type Protect

1 . 29 System

1 . 29 . 1 4 Card State 0 5 EM5 r

1 . 29 . 2 Sampling + Levels (only adjustable for AP IO Node License)

1 . 29 . 2 . 1 Sampling Rate 0 1 EM6 r(w)

1 . 29 . 2 . 2 Analog Ref. Level [dBu] 12 24 I r(w)

1 . 29 . 2 . 3 Relative System Level [dBFS] -45 -18 I r(w)

1 . 29 . 2 . 4 Digital Ref. Level [dBFS] -27 0 I r(w)

1 . 29 . 3 Sync (only adjustable for AP IO Node License)

1 . 29 . 3 . 1  Prio Sequence 0 5 EM7 r(w)

1 . 29 . 3 . 2 PTP

1 . 29 . 3 . 2 . 1 Enabled B r(w)

1 . 29 . 3 . 2 . 2 Present B r

1 . 29 . 3 . 2 . 3 Active B r

1 . 29 . 3 . 3 MADI

1 . 29 . 3 . 3 . 1 Enabled B r(w)

1 . 29 . 3 . 3 . 2 Present B r

1 . 29 . 3 . 3 . 3 Active B r

1 . 29 . 3 . 4 WordClock

1 . 29 . 3 . 4 . 1 Enabled B r(w)

1 . 29 . 3 . 4 . 2 Present B r

1 . 29 . 3 . 4 . 3 Active B r

1 . 29 . 3 . 5 Internal

1 . 29 . 3 . 5 . 1 Enabled B r(w)

1 . 29 . 3 . 5 . 2 Present B r

1 . 29 . 3 . 5 . 3 Active B r

1 . 29 . 4 Voltages

1 . 29 . 4 . 1 Main Input Voltage (12V)

1 . 29 . 4 . 1 . 1 Actual Value U r

1 . 29 . 4 . 1 . 2 Low Limit U r

1 . 29 . 4 . 1 . 3 High Limit U r

1 . 29 . 4 . 2 Aux Input Voltage (12V)

1 . 29 . 4 . 2 . 1 Actual Value U r

1 . 29 . 4 . 2 . 2 Low Limit U r

1 . 29 . 4 . 2 . 3 High Limit U r

1 . 29 . 4 . 3 Board Voltage 1 (3.3V)

1 . 29 . 4 . 3 . 1 Actual Value U r

1 . 29 . 4 . 3 . 2 Low Limit U r

1 . 29 . 4 . 3 . 3 High Limit U r

1 . 29 . 4 . 4 Board Voltage 2 (1.8V)

1 . 29 . 4 . 4 . 1 Actual Value U r

1 . 29 . 4 . 4 . 2 Low Limit U r

1 . 29 . 4 . 4 . 3 High Limit U r

1 . 29 . 4 . 5 Board Voltage 3 (1.35V)

1 . 29 . 4 . 5 . 1 Actual Value U r

1 . 29 . 4 . 5 . 2 Low Limit U r

1 . 29 . 4 . 5 . 3 High Limit U r

1 . 29 . 5 Currents

1 . 29 . 5 . 1 DCDC 12V Input Current

1 . 29 . 5 . 1 . 1 Actual Value U r

1 . 29 . 5 . 2 DCDC 3.3V Output Current

1 . 29 . 5 . 2 . 1 Actual Value U r

1 . 29 . 5 . 3 DCDC 0.9V Output Current

1 . 29 . 5 . 3 . 1 Actual Value U r

1 . 29 . 6 Temperatures

1 . 29 . 6 . 1 FPGA Chip Temperature

1 . 29 . 6 . 1 . 1 Actual Value U r
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1 ruby Min Max Type Protect

1 . 29 System

1 . 29 . 6 . 1 . 2 High Limit U r

1 . 29 . 6 . 2 Bord Temperature

1 . 29 . 6 . 2 . 1 Actual Value U r

1 . 29 . 6 . 2 . 2 High Limit U r

1 . 29 . 6 . 3 Fan Temperature

1 . 29 . 6 . 3 . 1 Actual Value U r

1 . 29 . 6 . 3 . 2 High Limit U r

1 . 29 . 6 . 4 DCDC Temperature

1 . 29 . 6 . 4 . 1 Actual Value U r

1 . 29 . 6 . 4 . 2 High Limit U r

1 . 29 . 7 Fan Speeds

1 . 29 . 7 . 1 Fan 1 Speed

1 . 29 . 7 . 1 . 1 Actual Value U r

1 . 29 . 7 . 1 . 2 High Limit U r

1 . 29 . 7 . 2 Fan 2 Speed

1 . 29 . 7 . 2 . 1 Actual Value U r

1 . 29 . 7 . 2 . 2 High Limit U r

1 . 29 . 7 . 3 Fan 3 Speed

1 . 29 . 7 . 3 . 1 Actual Value U r

1 . 29 . 7 . 3 . 2 High Limit U r

1 . 29 . 7 . 4 Fan 4 Speed

1 . 29 . 7 . 4 . 1 Actual Value U r

1 . 29 . 7 . 4 . 2 High Limit U r

7.5.7 Enumerations (Sources & Sums)

E1S Mic Rumble

0off

140Hz

280Hz

3140Hz

E1C Mic Rumble

0off

1on

E2 Input LR Mode

0stereo

1r -> b

2side

3

4l -> b

5mono

6ms -> xy

E3 EQ Frequency

020Hz

122Hz

225Hz

328Hz

431Hz

535Hz

E3 EQ Frequency

21224Hz

22250Hz

23280Hz

24315Hz

25355Hz

26400Hz

27450Hz

28500Hz

29560Hz

30630Hz

31710Hz

32800Hz

33900Hz

341kHz

351k12Hz

361k25Hz

371k4Hz

381k6Hz

391k8Hz

402kHz

412k24Hz

422k5Hz

432k8Hz

443k15Hz
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E3 EQ Frequency

640Hz

745Hz

850Hz

956Hz

1063Hz

1171Hz

1280Hz

1390Hz

14100Hz

15112Hz

16125Hz

17140Hz

18160Hz

19180Hz

20200Hz

453k55Hz

464kHz

474k5Hz

485kHz

495k6Hz

506k3Hz

517k1Hz

528kHz

539kHz

5410kHz

5511k2Hz

5612k5Hz

5714kHz

5816kHz

5918kHz
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E4 EQ Band 1 Mode

0High Pass

1Low Shelve

E5 EQ Band 2-4  Q

00.7

11.0

22.0

33.0

44.0

55.0

E6 EQ Band 5 Mode

0Low Pass

1High Shelve

E7 Compressor Ratio

01:1

11:1.12

21:1.25

31:1.4

41:1.8

51:2.4

61:3.4

71:5

81:8

91:16

E8 Gate Attack Time

Compressor Attack Time

00.16ms

10.32ms

20.64ms

31.28ms

42.56ms

55.12ms

610.2ms

720.5ms

841ms

982ms

E9 Gate Release Time

Limiter Release Time

Compressor Release Time

Automix Speed

010ms

125ms

250ms

3100ms

4200ms

5300ms

6400ms

7500ms

8600ms

9700ms

10800ms

11900ms

121000ms

132500ms

145000ms

E10 Expander Ratio

01:1

11:0.9

21:0.8

31:0.7

41:0.6

51:0.5

61:0.4

71:0.3

81:0.2

91:0.1

E11 DeEsser Mode

0female

1male

E12 Aux State

0off

1pre fader

2post fader
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E13 LED color

0black

1red

2green

3yellow

4white

5blue

6magenta

7cyan

E14 Audio Type

0None

1Mono

2Stereo

3Surr. 5.1

4Surr. 5.1+2

E15 Source Class

0Audio

1ProTools

2VCA Group

3MiniMix

4R3LAY
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8.     Glossary

48kHz or 44.1kHz See Sample Rate.

Access On Lawo consoles, much of the source parameter operation is performed by
selecting a fader strip. This is otherwise known as putting a source ‘in access’. 

Attack Time In the context of dynamics processing (compressor, limiter, gate or expander), the
attack time defines the duration over which an input signal is measured. The longer
the attack time, the slower the processor will react. For example, when using a gate, a
fast attack time causes the gate to open quickly when signal exceeds the gate
threshold.

Aux Auxiliary

An Aux is a general purpose mono, stereo or multi-channel summing bus which can
be used for a variety of applications such as sending to outboard effects devices.

Aux Send Auxiliary Send

Source channels feed onto each aux via their Aux Send. The aux send from each
channel can be either pre or post fader and has variable level control.

Aux Master Auxiliary Master

The Aux Master is a master source channel used to control the level and processing
of the Aux output. The direct output of the Aux Master is the signal routed to the
outboard effects send.

Aux Return Auxiliary Return

The Aux Return is the name given to the return channel from the outboard effects
device. This channel controls the level and processing of the effect as it is summed
into the rest of the mix. 

Band Pass Filter See Filters.

Balance Balance is applied to the input of a stereo channel and is the ratio between the left
and right input levels. When Balance is set to its default value, the level of left and
right inputs are equally weighted.

Bargraph An optical display instrument in the shape of a LED bar for displaying signal level.

Clean Feed See Mix Minus.

Compressor A dynamics processor used to smooth out uneven signal levels. For example, when a
presenter shouts and then whispers, they are producing sound which has a wide
dynamic range; one moment it is very loud and the next very quiet. This can mean
that if we listened to this signal on our radio without compression, we would forever be
turning the level up and down! A compressor smooths the signal such very loud audio
is reduced in level and very quiet audio is increased in level. This results in smaller
dynamic range ideal for radio transmission. 

Configuration The system configuration is a file created by the Configuration Tool software. This file
is then transferred to the console’s system unit where it is then loaded every time the
console powers on. The configuration defines key elements of the system such as
sources, summing busses, signal processing, MF Key functions.

DALLIS Lawo’s modular IO interfacing system based on 19” frames using plug-in cards for
different interfaces.

dB deciBel 

A unit of transmission giving the ratio of two powers. 

The number of bels is the logarithm to the base 10 of the ratio of the two powers. One
decibel equals one tenth of a bel.

dBu dBu is used to describe levels within the analogue domain, and is a measure of
absolute voltage level based on 0dBu = 0.775 Volts (RMS). dBu is often used to
indicate nominal broadcast operating levels. For example, in the EBU normal
broadcasting level = +6dBu. 
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dBFS dB Full Scale

dBFS is used to describe levels within the digital domain. 0dBFS describes the
system’s internal clipping point; this is the maximum level which may be handled by
the system without signal distortion. For example, your system may be set for +18dBu
= 0dBFS. If your normal broadcast level is +6dBu then this leaves an operating
headroom of 12dB.

Delay The signal output from a delay module is x ms behind the signal input to the module.
Delay is often applied to audio sources whose video has undergone digital video
processing; delay is required such the audio remains in sync with the video.

Direct Out Direct Output

The direct output of a source channel is the output of the individual source. Direct
Outputs are often used to provide a record or ‘snoop’ feed of a single source, and
may be taken from various points within signal flow: pre fader, post fader, etc.

DSP Digital Signal Processing

Digital signal processing (DSP) is the study of signals in a digital representation and
the processing methods of these signals.

Within ON-AIR Designer, DSP is also used as the collective name given to the
processing chips, within the system unit’s Master Board, which provide audio signal
processing such as equalization, dynamics and delay. 

Dynamics Dynamics is the collective terms given to audio processing which responds to
changes in signal level. For example, a Compressor, Limiter, Gate or Expander.

EQ Equaliser.

An equaliser is a processor which changes the frequency characteristics of a signal,
for example to increase the amount of treble or bass components in the signal.

Expander A dynamics processor used to magnify changes in the dynamic range of the input
signal. For example, to reduce noise in speech pauses. See also Compressor. 

Fader A potentiometer used to adjust the gain of a signal.

Filters Filters are equaliser sections which are used to cut out or reduce specific frequency
bands within the signal. For example, a Low Pass Filter cuts out high frequencies so
will result in less treble to the sound. A High Pass Filter cuts out low frequencies, for
example you may use this to remove unwanted low frequencies like hum or rumble. A
Band Pass Filter cuts out both high and low frequencies allowing frequency
components within the band to pass through the signal; for example, you may use this
type of filter to create a telephone effect on a normal voice.

Gain Adjusting the gain of a signal results in a change in the perceived level or amplitude.
An increase in gain (positive values) results in amplification and a reduction in gain
(negative values) in attenuation.

Gate A dynamics processor used to remove unwanted signals below a certain threshold
level. For example, if a gate is applied to a presenter’s microphone source, then when
they speak signal level exceeds the gate threshold and the gate opens, while if they
make a low level sound, like shuffling in their seat, the gate remains closed. The result
is that only the signal we want to hear is output from the source channel!

GPI General Purpose Interface (IEEE488) is a standardised platform independent short-
range digital interface, to allow switching connections between broadcast equipment
from different manufacturers.

Headroom The amount of operating level which is in reserve between normal operating level and
0dBFS.

High Pass Filter See Filters.

Insert Point A connection point within the source channel which interrupts the signal flow and
routes out to a piece of external equipment and returns back to the source channel. 

Insert send = route out from the source channel to the external device.

Insert return = input to the source channel from the external device.
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Limiter A dynamics processor used to stop signals exceeding a certain threshold level. For
example, you may place a limiter across the main output of the programme to prevent
a sudden increase in level exceeding the clipping point of your transmission feed and
causing signal distortion.

Low Pass Filter See Filters.

Mix Minus Mix Minus, Clean Feed and N-1 are all terms used to describe a feed which is created
from a number of channels minus a particular channel or channels. For example, to
provide telephone hybrids with a feed of the programme minus the incoming phone
call.

MF Key Multi Function Key

Programmable keys which can be used for a variety of functions as set in the
console’s configuration.

Module On Lawo's radio on-air consoles, this term can be used to refer to the control surface
modules or the different sections of signal processing (EQ, Dynamics, etc.)

Monitor Term used to describe the outputs and functionality of feeds to loudspeakers or
headphones for the purpose of listening to a mix.

ms milliseconds

Unit of time measurement.

M-S Middle and Side Stereo

Used to describe an arrangement of two coincident microphones, one pointing to the
front (Middle) and the other (bidirectional) at right angles providing a Side signal.
crystal and sapphire provide M-S to X-Y decoding to turn the Middle and Side signal
into normal Left and Right stereo.

Nova17 A stand alone routing matrix with networking capabilities; the name given to the
sapphire system unit without a control surface.

Nova29 A stand alone routing matrix with networking capabilities; the name given to the
Compact Engine without a control surface.

Nova73 A stand alone routing matrix with networking capabilities; this is a large matrix related

to the mc2 series of Lawo consoles.

N-1 See Mix Minus.

On-Air Term used to indicate that a radio or TV programme is being broadcast.

Overload Occurs when the signal level is too large for the system, resulting in signal distortion.

Panning Used to control the left/right position of a mono source when routed to a stereo or
multi-channel output. For example, if a source is panned left, the entire signal from the
source is routed to the left side of the summing bus. If a source is panned centre,
equal levels are applied to the left and right sides of the summing bus, etc.

PFL Pre Fade Listen

Used to listen to signals before the application of fader level. Provides a way of
listening to a source when the fader is closed to check its signal before the fader is
opened to route it onto the programme output.

Phantom Power This is the power supply required when working with condenser microphones. The
console supplies 48V to the microphone via the audio connector.

Programme The main output of a live broadcast console. This is the mix which feeds the
transmission chain.

RAS Radio Automation System control protocol is Lawo’s universal protocol for
communication between a mixing console (MIXER) and a radio automation system
(RAS).

Ratio In the context of a compressor or expander, the ratio defines how much compression
or expansion is applied. For example, the high the compressor ratio, the more signal
levels above the compressor threshold will be compressed.
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Release Time In the context of dynamics processing (compressor, limiter, gate or expander), the
release time defines the time taken for the action of the processor to subside. For
example, when using a gate, a short release time will cause the gate to close quickly
after signal falls below the gate threshold.

Remote MNOPL The remote control protocol RemoteMNOPL is a LAN based client-server network byte
order protocol to enable third party systems to control Lawo’s digital mixing consoles
or standalone routers.

Roll-off Frequency See Shelving EQ.

Routing Signal Routing

Term used to describe the connection made between an input and output.

RS422  A type of serial interface used for communication with external devices such as radio
automation systems.

Rumble Filter Name given to the High Pass Filter which can be inserted in the analogue microphone
preamplifier. Used to cut out or reduce unwanted low frequencies, such as rumble,
before analogue-to-digital conversion.

Sample Rate The speed at which the internal processing of the system takes samples respective to
values from a continuous, analogue audio signal to make a discrete, digital one. For
example, when running at 48kHz, incoming analogue audio is sampled at a rate of
48000 values per second.

Shelving EQ A shelving equaliser band is used to increase or decrease high or low frequency
components of a signal. The slope of the shelf defines how steeply the gain
increase/decrease is applied. The roll-off frequency defines the frequency at which
signal level is reduced by 3dB. 

Slope See Shelving EQ.

Source In Lawo's radio on-air consoles, this term describes a channel with input signal
assignment, DSP and other attributes (MF Keys, control triggers, etc.) A source
becomes active once it is assigned to a fader channel.

Different to “Input” - the term for an audio input signal (i.e. the physical interface).

Sum Summing Bus

The result of several audio signals mixed together within the console. 

Telephone Hybrid Device which deals with bi-directional signals to/from a 2-wire phone line. One line
provides an incoming feed from the phone line (e.g. the guests voice), and the other
sends signal back to the receiver (e.g. the mix minus feed).

Threshold In the context of dynamics processing (compressor, limiter, gate or expander), the
threshold defines the signal level at which the processor starts to act. For example, the
gate threshold sets the level at which the gate will open and then close.
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