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This user manual describes SoP Explorer, Lawo's firmware update tool for on-air systems.

The following products are updated using SoP Explorer.

diamond
ruby
crystal
Power Core

https://confluence.lawo.com/display/PKD/diamond
https://confluence.lawo.com/display/PKD/ruby
https://confluence.lawo.com/display/PKD/crystal
https://confluence.lawo.com/display/PKD/Power+Core
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1 SoP Explorer - Getting Started
SoP Explorer is the firmware update tool for Lawo on-air systems. It can be used to check and update the firmware versions 
on the Core, expansion I/O cards and, where applicable, the control surface and key panels.

You will need to run SoP Explorer whenever you update to a new version of software. The latest firmware files are copied 
onto the PC by the software installer. When SoP Explorer connects to the Lawo system, it compares the versions. If updates 
are required, data is transferred firstly to the Core, and then onto the other components.

1.1 Prerequisites
SoP Explorer must be installed onto the configuration PC using the onair-designer.exe installer (as described here). Both 
the configuration PC and the Lawo device must be connected to the control network.

1.2 First Steps
Before you begin, check that the expansion I/O cards are installed and that any surface components, including key panels, 
are connected.

1.    Start the software.

SoP Explorer starts automatically at the end of the ON-AIR Designer software installation procedure. It can also be started 
from the desktop icon or Windows START menu.

If this is the first time you have launched SoP Explorer, then the "Unit Properties" window opens automatically. Alternatively, 
select Unit → New... (from the main menus).

2.    Edit the 'Unit Properties' to define the system you wish to connect to.

Usually it is enough to enter the IP address of the Core and leave the other fields at their default values. In a larger network 
with multiple devices, it can be useful to edit the Name field (to help identify the device in the system tree).

Select OK  - the unit is added to the OnAir  device group in the system tree. SoP Explorer connects to the device and 
analyses the current firmware revisions.

Important: You should never update system while it is operational! The hardware will reset several times during the 
update process, causing interruption to the operation and audio.



https://confluence.lawo.com/display/PKD/Power+Core+-+Configuration+Tools
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If a white cross on a red background  appears beside the unit name, then SoP Explorer cannot connect to the device. 
Check that the IP address (entered in the "Unit Properties") matches that of the remote device. Then check the IP settings 
of the configuration PC and the network cabling.

3.    Once a connection is established, you can use the + and - signs (in the system tree) to reveal the components. 

For a Power Core system, you will see up to three components: System (for internal components), IOs (for expansion I/O 
cards) and Surface  (for control surface modules and/or key panels). If the Surface  branch is missing, then the surface 
components are not connected.

1.3 Editing the 'Unit Properties'
Once a unit is defined, you can re-open the 'Unit Properties' by selecting Unit → Properties...  (from the main menus) or 

clicking on the  button (from the toolbar).

If more than one device has been added to SoP Explorer, then you can use the Unit drop-down menu to select a different 
system.

The remaining fields can be edited as follows.

Ip  - defines the IP address of the Lawo control system. This must be entered correctly, otherwise network 
communication cannot be established.
Name - identifies the system within SoP Explorer. A default name of OnAir Device is given to each new unit. It is a good 
idea to edit the name so that systems can be easily identified.
Group - is reserved for future implementation; the default group is always OnAir.
Sample Freq  - this field is used to select the sample frequency for sapphire  or Nova17. It has no function for other 
systems.
Configuration - this field is optional. It can be used to enter the file path for the system configuration. You do not have 
to enter a configuration, but if you do, you will able to open the ON-AIR Designer configuration by selecting Run → 
Configuration (from the main menus) or clicking on the  button (from the toolbar).
Comment - this field is optional. It can be used to enter notes about the system.
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1.4 Checking the Current Revisions
Once the unit is defined, select a component (e.g. System) to interrogate its software modules.

Several columns of information are provided: "Status", "Slot", "Hardware", etc. These are described in more detail later.

For now, use the "Status" column to check the firmware revisions. The table below describes all possible states.

Status Meaning Actions

Software is up to date. No action required.

Software requires an update. Update the module using one of the update 
methods.

Software is newer than the SoP Explorer release. SoP Explorer cannot be used to downdate the 
software. Please contact the Lawo Support 
Department for assistance. 

Software cannot be updated by the SoP Explorer 
release.

Please contact the Lawo Support Department
for assistance. 

Software cannot be identified. This may occur if 
you have not updated the system for a while.

Please update the module and then refresh the 
connection.

Repeat to interrogate each component as applicable: System, IOs and Surface.

If all modules on all components are up to date, then you can close SoP Explorer. Alternatively, use the 'Software Update 
Wizard' to update the components.

https://lawo.com/support/customer-center/
https://lawo.com/support/customer-center/
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2 SoP Explorer - Software Update Wizard
SoP Explorer support three software update methods: Selected, Wizard and Force. Unless otherwise advised, it is 
recommended to use the 'Update Wizard'.

1.    Start by opening the 'Software Update Wizard', either from the main menus (Run → Software Update → Wizard...) or 
toolbar.

2.    Check that the correct unit is selected (in the drop-down Unit menu).

3.    Then use the Type, Status and Software options to prepare the update as follows.

Start by selecting System (in the Type column) + UPD (in the Status column) + All (in the Software modules list).

4.    Select OK - a confirmation window appears.

5.    Select Continue to start the update.

Software updates can take several minutes. The progress is shown in the status bar at the bottom of the SoP Explorer 
window. Once the update is complete, the system cold starts.

6.    Wait for the system to reboot and then click on the refresh button on the toolbar .

7.    Now check the status of the System modules.

All modules should be equalized  indicating that their software is up to date.

8.    Repeat the process but this time select IOs (in the Type column) to update the expansion I/O cards fitted to the Core.

9.    If a control surface is connected, repeat the process again but this time select Surfaces (in the Type column).

Once all software modules on all components are equalized, the firmware updates are complete and you can close SoP 
Explorer.

Important: While it is possible to update all components at once, it is strongly recommended that you update the 
components individually in the following order: System, IOs and then Surface.
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In the unlikely event that the 'Software Update Wizard' fails, you can try one of the alternative update methods.
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3 SoP Explorer - Other Update Methods
This topic covers the other two update methods: Selected and Force. You can use the first method to update a specific 
component. The second method can be used if both the Software Update Wizard and Selected Update fail. 

3.1 'Selected' Software Update
This method updates the software on a specific component.

1.    Using the system tree (on the left), select the component (e.g. IOs).

2.    Then select the module(s) you wish to update.

3.    Open the 'Software Update' dialog box, either from the main menus (Run → Software Update → Selected) or toolbar (

).

3.   Check the actions and click on Continue to start the update.

Software updates can take several minutes. The progress is shown in the status bar at the bottom of the SoP Explorer 
window. Once the update is complete, the system cold starts.

4.    Wait for the system to reboot and then click on the refresh button on the toolbar .

5.    Now check the status of the updated modules.

If they are equalized  , then the update is successful.

•
•
•

You can select multiple modules by using the SHIFT or CTRL buttons on your keyboard.

To select a range: click on the first entry, press and hold SHIFT, and then click on the last entry.
Once a range is selected, press and hold SHIFT and click to increase (or decrease) the selected range.
Alternatively, press and hold CTRL and click to select (or deselect) individual modules.
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3.2 'Force' Software Update
This method can be used to transfer a specific set of software to a component. 

1.    As before, use the system tree to select a component (e.g. IOs).

2.    Then select the module you wish to update.

3.    Open the 'Force Software Update' dialog box by selecting Run → Software Update → Force from the main menus.

4.    From the drop-down Type menu, select the device type.

5.    From the Hardware list, select the type of component.

6.    In the Slot box, enter the slot position where the software modules should be loaded to. (This box is only active for 
IOs.)

7.    From the drop-down Software menu, define the software module.

8.    Check the settings and click on OK to start the update.

Software updates can take several minutes. The progress is shown in the status bar at the bottom of the SoP Explorer 
window. Once the update is complete, the system cold starts.

9.    Wait for the system to reboot and then click on the refresh button on the toolbar .

10.    Now check the status of the updated modules.

If they are equalized, then the update is successful.

If you need further assistance, the Lawo Support Department can be contacted by email at support@lawo.com, or by 
telephone during normal working hours - please visit the Support area of the Lawo website for the most up-to-date contact 
details.

Important: It is recommended to use this function with caution and only if all other update methods have failed.

A forced update does not check the hardware status of the component before performing an update. Thus, it is 
possible to transfer the wrong software to a module in error and, potentially, leave the system inoperative!



mailto:support@lawo.com
https://lawo.com/support/customer-center/
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4 SoP Explorer - Software Module Interrogation
The columns on the right of the SoP Explorer window show information about the selected component's software modules.

Most important is the Status  column as this shows the current revision status of the firmware (compared to the version 
included with SoP Explorer). The remaining columns provide further information about the component or its firmware.

Status - the current revision status of the firmware. All possible states are described in the table below.
Slot - the hardware address of the component:

For System, this is always 031 (the control system).
For IOs, this is the expansion I/O slot number of the I/O card.
For Surface, this is the CAN bus address of the module or panel.

Hardware - the part number of the component.
Rev - the hardware revision of the component.
Software - the name of the software module.
Version - the current version running on the module.
Timestamp - the date and time when the current version was created (if available).
Version (SoP) - the version included in the SoP release.
Timestamp (SoP) - the date and time when the SoP version was created.
Rev - the hardware revision required to perform an update.
SoP - the filename included in the SoP release.

Status Meaning Actions

Software is up to date. No action required.

Software requires an update. Update the module using one of the update 
methods.

Software is newer than the SoP Explorer release. SoP Explorer cannot be used to downdate the 
software. Please contact the Lawo Support 
Department for assistance. 

Software cannot be updated by the SoP Explorer 
release.

Please contact the Lawo Support Department
for assistance. 

Software cannot be identified. This may occur if 
you have not updated the system for a while.

Please update the module and then refresh the 
connection.

https://lawo.com/support/customer-center/
https://lawo.com/support/customer-center/
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5 SoP Explorer - Set System Time
SoP Explorer can be used to transfer the date and time from your configuration PC to the Lawo device. The transfer is done 
as a one-shot snapshot, so start by checking the current settings on your PC before you begin.

1.    If SoP Explorer is not already open, start the application from either its desktop icon or Windows START menu.

All units that have been previously defined appear in the system tree (on the left).

If the unit you wish to configure is not listed, then select Unit → New... (from the main menus), enter the IP address of the 
Core and select OK - the unit is added to the "OnAir" device group in the system tree. SoP Explorer connects to the device 
and analyses the current firmware revisions.

If a white cross on a red background  appears beside the unit name, then SoP Explorer cannot connect to the device. 
Check that the IP address (entered in the "Unit Properties") matches that of the remote device. Then check the IP settings 
of the configuration PC and the network cabling.

2.    Right-click on the unit and select Set System Time. Confirm by selecting OK.

The software now sets the system date and time to match that of the configuration PC. The success (or failure) of the reset 
is shown in the SoP Explorer status bar area.



SoP Explorer

Version: 8.0.0/1 Exported on: 24 October, 2023 14 /  16

•
•

•

•
•

•
•
•

•

•
•

•

6 SoP Explorer - Main Menus
This topic describes all possible operations from the main menus.

6.1 Unit

Use the Unit menu to...

New - add a new unit to SoP Explorer.
Delete - delete a unit from Sop Explorer. The unit must be selected (in the system tree); then choose Unit -> Delete and 
select Yes to confirm.
Properties  - show or edit the 'Unit Properties' of an existing system. The unit must be selected (in the system tree); 
then choose Unit -> Properties.
Refresh on Startup - enable/disable the refresh on startup option.
Exit - close SoP Explorer.

6.2 Run

Use the Run menu to...

Software Update – access the three methods of updating software: the Update Wizard and Selected/Force.
Factory Reset – reset the units defined in SoP Explorer and reload the complete software set to the system.
Switch Mode – switch the mode of a Compact Engine (from crystal to sapphire compact or vice versa). This option is 
only available for Compact Engine systems.
Transfer Config – access the Unit to File… and File to Unit… transfer options. From here you can make a binary copy of 
the system configuration stored on the unit OR transfer a new binary file to the system.
Erase Config – transfer an empty system configuration to the unit.
Configuration – open the ON-AIR Designer configuration for the selected unit. The configuration file path is defined in 
the 'Unit Properties'. This option becomes available once a configuration file is defined.
Web – open a Web UI session for the selected unit.

You can also right-click on a unit or component (in the system tree) to access the most common operations.
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Telnet – open a Telnet session for the selected unit.
Set System Time - set the date and time of the selected unit to the current clock settings of the configuration PC.
Save Logs as – save the SoP Explorer logs area into a log file (for diagnostic purposes).
Cancel – cancel all operations. For example, to cancel a software update.

6.3 View

Use the View menu to...

Toolbar – show or hide the toolbar.
Statusbar – show or hide the status area.
Logs – show or hide the logs area.
Fixed Modules – show or hide the fixed software modules (for the selected component).
Refresh – refresh the status of the selected unit. For example after performing an update.
Refresh All – refresh the status of all units in SoP Explorer.

6.4 Help

Use the Help menu to...

Support → Export Hardware Info - export information about the units defined in SoP Explorer (for diagnostic purposes).
Info - view information about the SoP Explorer release.
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7 SoP Explorer - Toolbar
This topic describes all possible operations from the Toolbar.

If the toolbar is not visible, then check the show/hide option in the View menu.

1 create new unit Add a new unit to SoP Explorer.

2 show/edit current 
unit's properties

Open the 'Unit Properties' dialog box for the selected system.

3 cancel all 
operations

Cancel all operations. For example, to cancel a software update.

4 refresh all units Refresh the status of all units. For example, after performing an update.

5 software update 
wizard

Start the 'Software Update Wizard'.

6 update selected 
software module

Open the 'Software Update' dialog box for the selected software module. This option becomes 
available once a module is selected.

7 run configuration 
tool

Open the ON-AIR Designer configuration for the selected unit. The configuration file path is 
defined in the 'Unit Properties'. This option becomes available once a configuration file is 
defined.

8 run web browser Open a Web UI session for the selected unit.

9 run telnet 
application

Open a Telnet session for the selected unit.
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